DSL Circuits

Discussion in 'Cisco' started by Steve Ray, Nov 6, 2007.

  1. Steve Ray

    Steve Ray Guest

    Guys

    We have to set up a new DSL circuit for one of our customers. We've
    deployed a C1800 onsite.

    I'm having problems finding out how to set the interface up as well as
    encapsulation needed

    Does anyone have a worked exampled that they would be happy to share to help
    me understand how I setup the ATM0 interface along with all other settings

    Many thanks
    Steve Ray, Nov 6, 2007
    #1
    1. Advertising

  2. Steve Ray

    Zub Guest

    On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    > Guys
    >
    > We have to set up a new DSL circuit for one of our customers. We've
    > deployed a C1800 onsite.
    >
    > I'm having problems finding out how to set the interface up as well as
    > encapsulation needed
    >
    > Does anyone have a worked exampled that they would be happy to share to help
    > me understand how I setup the ATM0 interface along with all other settings
    >
    > Many thanks


    Steve,

    I've been sending out 800 routers for home usage in many different
    countries and the first thing i'd recommend is to do a 'sh ip int br'
    and see if the atm0 interface has come up up.

    First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    the vci/vpi id be more than happy to help with an example config
    Zub, Nov 6, 2007
    #2
    1. Advertising

  3. Steve Ray

    Steve Ray Guest

    Hi

    I need to reply in chunks as I don't have the 1800 on site with me. its at a
    remote site

    I did notice the when I forced the ATM0 interface up from "Admin down" it
    stayed as "Down/Down"

    We are using ADSL2 (here in the UK)

    VCI/VPI ID - No idea sorry

    Steve


    "Zub" <> wrote in message
    news:...
    > On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    >> Guys
    >>
    >> We have to set up a new DSL circuit for one of our customers. We've
    >> deployed a C1800 onsite.
    >>
    >> I'm having problems finding out how to set the interface up as well as
    >> encapsulation needed
    >>
    >> Does anyone have a worked exampled that they would be happy to share to
    >> help
    >> me understand how I setup the ATM0 interface along with all other
    >> settings
    >>
    >> Many thanks

    >
    > Steve,
    >
    > I've been sending out 800 routers for home usage in many different
    > countries and the first thing i'd recommend is to do a 'sh ip int br'
    > and see if the atm0 interface has come up up.
    >
    > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    > the vci/vpi id be more than happy to help with an example config
    >
    Steve Ray, Nov 6, 2007
    #3
  4. Steve Ray

    Zub Guest

    On Nov 6, 2:00 pm, "Steve Ray" <> wrote:
    > Hi
    >
    > I need to reply in chunks as I don't have the 1800 on site with me. its at a
    > remote site
    >
    > I did notice the when I forced the ATM0 interface up from "Admin down" it
    > stayed as "Down/Down"
    >
    > We are using ADSL2 (here in the UK)
    >
    > VCI/VPI ID - No idea sorry
    >
    > Steve
    >
    > "Zub" <> wrote in message
    >
    > news:...
    >
    > > On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    > >> Guys

    >
    > >> We have to set up a new DSL circuit for one of our customers. We've
    > >> deployed a C1800 onsite.

    >
    > >> I'm having problems finding out how to set the interface up as well as
    > >> encapsulation needed

    >
    > >> Does anyone have a worked exampled that they would be happy to share to
    > >> help
    > >> me understand how I setup the ATM0 interface along with all other
    > >> settings

    >
    > >> Many thanks

    >
    > > Steve,

    >
    > > I've been sending out 800 routers for home usage in many different
    > > countries and the first thing i'd recommend is to do a 'sh ip int br'
    > > and see if the atm0 interface has come up up.

    >
    > > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    > > the vci/vpi id be more than happy to help with an example config


    I would advise you have a look at
    http://www.cisco.com/en/US/products/hw/routers/ps380/products_tech_note09186a0080093e48.shtml

    If the ATM0 interface isnt coming up we have a lower level problem. It
    could be that the device you are using cannot work with ADSL2. FYI UK
    is usually VPI=0 VCI=38.
    Zub, Nov 6, 2007
    #4
  5. Steve Ray

    Darren Green Guest

    On 6 Nov, 14:00, "Steve Ray" <> wrote:
    > Hi
    >
    > I need to reply in chunks as I don't have the 1800 on site with me. its at a
    > remote site
    >
    > I did notice the when I forced the ATM0 interface up from "Admin down" it
    > stayed as "Down/Down"
    >
    > We are using ADSL2 (here in the UK)
    >
    > VCI/VPI ID - No idea sorry
    >
    > Steve
    >
    > "Zub" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    > >> Guys

    >
    > >> We have to set up a new DSL circuit for one of our customers. We've
    > >> deployed a C1800 onsite.

    >
    > >> I'm having problems finding out how to set the interface up as well as
    > >> encapsulation needed

    >
    > >> Does anyone have a worked exampled that they would be happy to share to
    > >> help
    > >> me understand how I setup the ATM0 interface along with all other
    > >> settings

    >
    > >> Many thanks

    >
    > > Steve,

    >
    > > I've been sending out 800 routers for home usage in many different
    > > countries and the first thing i'd recommend is to do a 'sh ip int br'
    > > and see if the atm0 interface has come up up.

    >
    > > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    > > the vci/vpi id be more than happy to help with an example config- Hide quoted text -

    >
    > - Show quoted text -


    Hi Steve,

    Did you ge this sorted.

    Sounds like a physical issue to me but having installed hundreds of
    ASDL boxes in the UK I would:

    Swap out the microfilter (you get the odd faulty one)

    Change the ADSL RJ11 cable (as above)

    Plug an analogue phone into the ADSL microfilter, do you have a
    dialtone. NB This won't indicate that there is DSL on the line but I
    have attended loads of installations where the PSTN line wasn't
    working. This being the case you won't be going anywere until the
    Telco sort the line error.

    If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
    WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
    card

    The PVC is 0/38 unless it's Kingston Comms.

    Typical Config:

    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname XYZ@Your-ISP
    ppp chap password
    !

    Regards

    Darren
    Darren Green, Nov 9, 2007
    #5
  6. Steve Ray

    Steve Ray Guest

    Hi

    I'm hoping to get this sorted in the next few days. The ISP that put the
    circuits in has not been overly helpful so I sent them a slightly disgrutled
    email today. I have a sample config from Cisco but need the user ID's as
    per the config below

    I'll keep you updated. Thanks for the help

    Steve

    "Darren Green" <> wrote in message
    news:...
    > On 6 Nov, 14:00, "Steve Ray" <> wrote:
    >> Hi
    >>
    >> I need to reply in chunks as I don't have the 1800 on site with me. its
    >> at a
    >> remote site
    >>
    >> I did notice the when I forced the ATM0 interface up from "Admin down" it
    >> stayed as "Down/Down"
    >>
    >> We are using ADSL2 (here in the UK)
    >>
    >> VCI/VPI ID - No idea sorry
    >>
    >> Steve
    >>
    >> "Zub" <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >> > On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    >> >> Guys

    >>
    >> >> We have to set up a new DSL circuit for one of our customers. We've
    >> >> deployed a C1800 onsite.

    >>
    >> >> I'm having problems finding out how to set the interface up as well as
    >> >> encapsulation needed

    >>
    >> >> Does anyone have a worked exampled that they would be happy to share
    >> >> to
    >> >> help
    >> >> me understand how I setup the ATM0 interface along with all other
    >> >> settings

    >>
    >> >> Many thanks

    >>
    >> > Steve,

    >>
    >> > I've been sending out 800 routers for home usage in many different
    >> > countries and the first thing i'd recommend is to do a 'sh ip int br'
    >> > and see if the atm0 interface has come up up.

    >>
    >> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    >> > the vci/vpi id be more than happy to help with an example config- Hide
    >> > quoted text -

    >>
    >> - Show quoted text -

    >
    > Hi Steve,
    >
    > Did you ge this sorted.
    >
    > Sounds like a physical issue to me but having installed hundreds of
    > ASDL boxes in the UK I would:
    >
    > Swap out the microfilter (you get the odd faulty one)
    >
    > Change the ADSL RJ11 cable (as above)
    >
    > Plug an analogue phone into the ADSL microfilter, do you have a
    > dialtone. NB This won't indicate that there is DSL on the line but I
    > have attended loads of installations where the PSTN line wasn't
    > working. This being the case you won't be going anywere until the
    > Telco sort the line error.
    >
    > If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
    > WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
    > card
    >
    > The PVC is 0/38 unless it's Kingston Comms.
    >
    > Typical Config:
    >
    > !
    > interface ATM0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > interface Dialer0
    > ip address negotiated
    > encapsulation ppp
    > dialer pool 1
    > no cdp enable
    > ppp authentication chap callin
    > ppp chap hostname XYZ@Your-ISP
    > ppp chap password
    > !
    >
    > Regards
    >
    > Darren
    >
    Steve Ray, Nov 13, 2007
    #6
  7. Steve Ray

    Steve Ray Guest

    Guys

    I could really do with some help over this issue please. I'm obviously way
    out of my depth and am totally unable to see what I'm doing wrong

    I've pasted the config below

    At the minute I cannot get the unit to connect to the ISP/internet

    Any help would be seriously appreciated


    --START OF CONFIG

    hostname 1831_Customer
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    interface FastEthernet0
    no ip address
    speed 100
    full-duplex
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface FastEthernet1
    description *** Connection into Internal LAN
    !
    interface ATM0
    bandwidth inherit
    no ip address
    ip mtu 1500
    ip nat outside
    atm bandwidth dynamic
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    pvc 8/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface Vlan1
    description *** Internal LAN
    ip address 10.10.10.5 255.255.255.0
    ip nat inside
    !
    interface Vlan2
    no ip address
    !
    interface Dialer0
    ip address ISP-GRANTED-IP-ADDRESS 255.255.255.252
    ip mtu 128
    encapsulation ppp
    dialer pool 1
    dialer string 5551234567 class User@ISP
    dialer-group 1
    ppp authentication chap User@ISP
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route ISP-GRANTED-IP-ADDRESS 255.255.255.252 Dialer0
    !
    no ip http server
    !
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    end
    --END OF CONFIG

    Steve

    "Steve Ray" <> wrote in message
    news:fhcii3$piq$...
    > Hi
    >
    > I'm hoping to get this sorted in the next few days. The ISP that put the
    > circuits in has not been overly helpful so I sent them a slightly
    > disgrutled email today. I have a sample config from Cisco but need the
    > user ID's as per the config below
    >
    > I'll keep you updated. Thanks for the help
    >
    > Steve
    >
    > "Darren Green" <> wrote in message
    > news:...
    >> On 6 Nov, 14:00, "Steve Ray" <> wrote:
    >>> Hi
    >>>
    >>> I need to reply in chunks as I don't have the 1800 on site with me. its
    >>> at a
    >>> remote site
    >>>
    >>> I did notice the when I forced the ATM0 interface up from "Admin down"
    >>> it
    >>> stayed as "Down/Down"
    >>>
    >>> We are using ADSL2 (here in the UK)
    >>>
    >>> VCI/VPI ID - No idea sorry
    >>>
    >>> Steve
    >>>
    >>> "Zub" <> wrote in message
    >>>
    >>> news:...
    >>>
    >>>
    >>>
    >>> > On Nov 6, 9:10 am, "Steve Ray" <> wrote:
    >>> >> Guys
    >>>
    >>> >> We have to set up a new DSL circuit for one of our customers. We've
    >>> >> deployed a C1800 onsite.
    >>>
    >>> >> I'm having problems finding out how to set the interface up as well
    >>> >> as
    >>> >> encapsulation needed
    >>>
    >>> >> Does anyone have a worked exampled that they would be happy to share
    >>> >> to
    >>> >> help
    >>> >> me understand how I setup the ATM0 interface along with all other
    >>> >> settings
    >>>
    >>> >> Many thanks
    >>>
    >>> > Steve,
    >>>
    >>> > I've been sending out 800 routers for home usage in many different
    >>> > countries and the first thing i'd recommend is to do a 'sh ip int br'
    >>> > and see if the atm0 interface has come up up.
    >>>
    >>> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
    >>> > the vci/vpi id be more than happy to help with an example config- Hide
    >>> > quoted text -
    >>>
    >>> - Show quoted text -

    >>
    >> Hi Steve,
    >>
    >> Did you ge this sorted.
    >>
    >> Sounds like a physical issue to me but having installed hundreds of
    >> ASDL boxes in the UK I would:
    >>
    >> Swap out the microfilter (you get the odd faulty one)
    >>
    >> Change the ADSL RJ11 cable (as above)
    >>
    >> Plug an analogue phone into the ADSL microfilter, do you have a
    >> dialtone. NB This won't indicate that there is DSL on the line but I
    >> have attended loads of installations where the PSTN line wasn't
    >> working. This being the case you won't be going anywere until the
    >> Telco sort the line error.
    >>
    >> If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
    >> WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
    >> card
    >>
    >> The PVC is 0/38 unless it's Kingston Comms.
    >>
    >> Typical Config:
    >>
    >> !
    >> interface ATM0
    >> no ip address
    >> no atm ilmi-keepalive
    >> dsl operating-mode auto
    >> pvc 0/38
    >> encapsulation aal5mux ppp dialer
    >> dialer pool-member 1
    >> !
    >> interface Dialer0
    >> ip address negotiated
    >> encapsulation ppp
    >> dialer pool 1
    >> no cdp enable
    >> ppp authentication chap callin
    >> ppp chap hostname XYZ@Your-ISP
    >> ppp chap password
    >> !
    >>
    >> Regards
    >>
    >> Darren
    >>

    >
    Steve Ray, Nov 20, 2007
    #7
  8. Steve Ray

    Merv Guest

    Do you have the DSL setup infomation that is normally provided by ISP
    -
    PVC, PPP authentication method, usernmae, password, etc, etc


    You need to troubleshoot each of the layers used for the DSL
    connection.

    Layer 1 - DSL physical connectivity to the Digital Subscriber Line
    Access Multiplexer (DSLAM) of your ISP

    Layer 2 - ATM connectivity and Point-to-Point Protocol over ATM
    (PPPoA)

    Layer 3 - IP


    The normal config for PPP CHAP is

    int dialer 1
    ppp chap hostname <username>
    ppp chap password <password>



    Post the output of the following commands:


    sh version


    ! check the status of the DSL interface

    sh int atm 0


    ! test if PVC 0/38 is the one in use by sending OAM echo packets to
    the ISP's DSLAM

    ping atm interface atm 0 0 38 seg-loopback


    show atm int atm0


    debug atm errors

    debug atm events

    debug ppp negotiation

    debug ppp authentication



    ! unplug and replug cable to phone jack



    ! after testing is completed

    undebug all
    Merv, Nov 20, 2007
    #8
  9. Steve Ray

    alexd Guest

    Steve Ray wrote:

    > !
    > interface ATM0
    > bandwidth inherit
    > no ip address
    > ip mtu 1500
    > ip nat outside
    > atm bandwidth dynamic
    > no atm ilmi-keepalive
    > pvc 8/35
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > pvc 8/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > dsl operating-mode auto
    > !


    I would expect a 'no shutdown' somewhere in there. For example, the 'CD'
    light won't start flashing on an 877 until you put 'no shutdown' on the ATM
    interface. Look at the "Layer 1 Issues" section of this document:

    http://www.cisco.com/warp/public/794/adslguide_rtng_ts.shtml#task1

    The other thing is, who is the ISP for the DSL circuit? Are they a BT
    Wholesale reseller [the majority are]? If that is the case, then your pvc
    statements are wrong.

    --
    <http://ale.cx/> (AIM:troffasky) ()
    10:10:07 up 10 days, 22:48, 2 users, load average: 0.10, 0.20, 0.23
    50,000 watts of funking power
    alexd, Nov 22, 2007
    #9
  10. Steve Ray

    alexd Guest

    alexd wrote:

    > The other thing is, who is the ISP for the DSL circuit? Are they a BT
    > Wholesale reseller [the majority are]? If that is the case, then your pvc
    > statements are wrong.


    This is taken from a router connected to a Griffin/BT IPStream circuit:

    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    ! Note that for whatever reason ["you know nothing about Cisco"]
    ! 'show run' doesn't show a 'no shutdown' here, but without it
    ! it just won't work!
    !
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !

    interface Dialer0
    description $FW_OUTSIDE$
    ip address outside_IP 255.255.255.240
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    ip inspect cdp-inspect out
    ip ips sdm_ips_rule in
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname username@domain
    ppp chap password 7 crypted_password
    ppp pap sent-username username@domain password 7 crypted_password
    crypto map SDM_CMAP_1
    !

    Good luck!

    --
    <http://ale.cx/> (AIM:troffasky) ()
    15:22:05 up 11 days, 4:00, 2 users, load average: 0.63, 0.56, 0.35
    50,000 watts of funking power
    alexd, Nov 22, 2007
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Cpt_Cam
    Replies:
    7
    Views:
    2,718
    Hansang Bae
    Oct 5, 2004
  2. A. Bronson
    Replies:
    5
    Views:
    550
  3. Replies:
    4
    Views:
    1,381
  4. Replies:
    1
    Views:
    436
    BradReeseCom
    Feb 23, 2005
  5. Adam
    Replies:
    2
    Views:
    961
Loading...

Share This Page