DNS /Suse

Discussion in 'Computer Support' started by Tom Eggleston, Sep 7, 2004.

  1. Hi

    I am running Suse 9.1 at home behind a BT adsl connection.

    I having odd DNS problems.

    For example I cannot resolve www.google.co.uk. I get the following:

    tom@uhuru:~/software> dig www.google.co.uk
    ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53

    ; <<>> DiG 9.2.3 <<>> www.google.co.uk
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached


    WHen I run windows on the same hardware I can resolve www.google.co.uk no
    problems.

    The result of this is extremely slow browsing, and some pages will not come
    up at all.

    Any ideas / suggestions??

    Cheers

    Tom
    Tom Eggleston, Sep 7, 2004
    #1
    1. Advertising

  2. T'was upon Tue, 07 Sep 2004 22:48:34 +0000, that Tom Eggleston did write
    the following missive:

    > Hi
    >
    > I am running Suse 9.1 at home behind a BT adsl connection.


    Are you using a modem or router?
    Do you connect with a static IP or is it dynamically assigned (via
    dhcp)? Are you using pppoe? Are you connected by ether card to the
    modem/router? What exactly did you set up with yast?

    > I having odd DNS problems.
    >
    > For example I cannot resolve www.google.co.uk. I get the following:
    >
    > tom@uhuru:~/software> dig www.google.co.uk ;; reply from unexpected
    > source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from unexpected
    > source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from unexpected
    > source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from unexpected
    > source: 213.120.62.98#53, expected 192.168.1.1#53
    >
    > ; <<>> DiG 9.2.3 <<>> www.google.co.uk ;; global options: printcmd
    > ;; connection timed out; no servers could be reached
    >
    >
    > WHen I run windows on the same hardware I can resolve www.google.co.uk no
    > problems.
    >
    > The result of this is extremely slow browsing, and some pages will not
    > come up at all.
    >
    > Any ideas / suggestions??
    >
    > Cheers
    >
    > Tom





    --
    SuSE 9.1 Pro 64bit
    linux 2.6.5-7.104 i686 athlon
    Reclaim your computer!
    http://linuxnotjustforgeeks.org/
    Perce P. Cassidy, Sep 8, 2004
    #2
    1. Advertising

  3. Tom Eggleston

    Jim Berwick Guest

    Tom Eggleston <> wrote in news:chlds2$ge2$1
    @hercules.btinternet.com:

    > Any ideas / suggestions??


    What is in your /etc/resolv.conf file? Should have the addresses of your
    nameservers, probably 192.168.1.1.
    Jim Berwick, Sep 8, 2004
    #3
  4. Perce P. Cassidy wrote:

    > T'was upon Tue, 07 Sep 2004 22:48:34 +0000, that Tom Eggleston did write
    > the following missive:
    >
    >> Hi
    >>
    >> I am running Suse 9.1 at home behind a BT adsl connection.

    >
    > Are you using a modem or router?
    > Do you connect with a static IP or is it dynamically assigned (via
    > dhcp)? Are you using pppoe? Are you connected by ether card to the
    > modem/router? What exactly did you set up with yast?
    >
    >> I having odd DNS problems.
    >>
    >> For example I cannot resolve www.google.co.uk. I get the following:
    >>
    >> tom@uhuru:~/software> dig www.google.co.uk ;; reply from unexpected
    >> source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from
    >> unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply
    >> from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;;
    >> reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    >>
    >> ; <<>> DiG 9.2.3 <<>> www.google.co.uk ;; global options: printcmd
    >> ;; connection timed out; no servers could be reached
    >>
    >>
    >> WHen I run windows on the same hardware I can resolve www.google.co.uk no
    >> problems.
    >>
    >> The result of this is extremely slow browsing, and some pages will not
    >> come up at all.
    >>
    >> Any ideas / suggestions??
    >>
    >> Cheers
    >>
    >> Tom

    >
    >
    >
    >


    Hi and thanks for the replys.

    My /etc/resov.conf file is:

    ....a lot of remmed out stuff then:
    nameserver 192.168.1.1
    nameserver 192.168.1.1

    I am using a Draytek Vigor 2600 router. The router allocates IP adresses via
    DHCP. I don't know whether I'm using pppoe - what is it? I connect via
    ethernet to the router (it doubles as a four port switch).

    I have set up very little in Yast - I mainly took the defaults. I did edit
    my /etc/hosts file however to include a refernce to my host name - it
    previously only had an entry for localhost and this was causing a problem
    with KDE running very slowly.

    CHeers

    Tom
    Tom Eggleston, Sep 8, 2004
    #4
  5. Twas upon Wed, 08 Sep 2004 09:18:17 +0000, that Tom Eggleston did write
    the following missive:

    > Perce P. Cassidy wrote:
    >
    >> T'was upon Tue, 07 Sep 2004 22:48:34 +0000, that Tom Eggleston did write
    >> the following missive:
    >>
    >>> Hi
    >>>
    >>> I am running Suse 9.1 at home behind a BT adsl connection.

    >>
    >> Are you using a modem or router?
    >> Do you connect with a static IP or is it dynamically assigned (via
    >> dhcp)? Are you using pppoe? Are you connected by ether card to the
    >> modem/router? What exactly did you set up with yast?
    >>
    >>> I having odd DNS problems.
    >>>
    >>> For example I cannot resolve www.google.co.uk. I get the following:
    >>>
    >>> tom@uhuru:~/software> dig www.google.co.uk ;; reply from unexpected
    >>> source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from
    >>> unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply
    >>> from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;;
    >>> reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    >>>
    >>> ; <<>> DiG 9.2.3 <<>> www.google.co.uk ;; global options: printcmd ;;
    >>> connection timed out; no servers could be reached
    >>>
    >>>
    >>> WHen I run windows on the same hardware I can resolve www.google.co.uk
    >>> no problems.
    >>>
    >>> The result of this is extremely slow browsing, and some pages will not
    >>> come up at all.
    >>>
    >>> Any ideas / suggestions??
    >>>
    >>> Cheers
    >>>
    >>> Tom

    >>
    >>
    >>
    >>
    >>

    > Hi and thanks for the replys.
    >
    > My /etc/resov.conf file is:
    >
    > ...a lot of remmed out stuff then:
    > nameserver 192.168.1.1
    > nameserver 192.168.1.1


    That seems ok...

    > I am using a Draytek Vigor 2600 router. The router allocates IP adresses
    > via DHCP. I don't know whether I'm using pppoe - what is it? I connect
    > via ethernet to the router (it doubles as a four port switch).


    What are the ping results like to www.google.com?
    Mine are -
    64 bytes from 66.102.11.104: icmp_seq=1 ttl=246 time=29.1 ms
    64 bytes from 66.102.11.104: icmp_seq=2 ttl=246 time=28.8 ms
    64 bytes from 66.102.11.104: icmp_seq=3 ttl=246 time=28.8 ms
    64 bytes from 66.102.11.104: icmp_seq=4 ttl=246 time=29.3 ms

    I'm sitting behind an ACEEX AR41 ADSL router with a NAT running on full
    duplex, & I've not had to change anything on any of the 3 machines I run.
    (All running SuSE 9.1)

    > I have set up very little in Yast - I mainly took the defaults.


    YaST should have detected everything & set it up. I've found it best to
    accept the defaults. However a not (or wrong) configured network card
    could slow down a system enormously. On this machine, it's a Realtek
    8139, & runs fine.

    > I did edit my /etc/hosts file however to include a reference to my host name - it
    > previously only had an entry for localhost and this was causing a problem
    > with KDE running very slowly.


    Oh..odd, I've never had that happen.

    You could also try this. Open up a terminal, and type free -m, and it will
    tell you how much memory is available to linux, & if it is misrepresented,

    --
    "Hit any button to continue...
    Heeey? Where's "Any" button?"
    - Homer Simpson -
    Perce P. Cassidy, Sep 8, 2004
    #5
  6. Tom Eggleston

    psion Guest

    my guess is that your hosts file is screwed up. try going in there, making
    a backup first, and edit it to only say:
    localhost 127.0.0.1

    psion


    On Tue, 07 Sep 2004 22:48:34 +0000, Tom Eggleston wrote:

    > Hi
    >
    > I am running Suse 9.1 at home behind a BT adsl connection.
    >
    > I having odd DNS problems.
    >
    > For example I cannot resolve www.google.co.uk. I get the following:
    >
    > tom@uhuru:~/software> dig www.google.co.uk
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    >
    > ; <<>> DiG 9.2.3 <<>> www.google.co.uk
    > ;; global options: printcmd
    > ;; connection timed out; no servers could be reached
    >
    >
    > WHen I run windows on the same hardware I can resolve www.google.co.uk no
    > problems.
    >
    > The result of this is extremely slow browsing, and some pages will not come
    > up at all.
    >
    > Any ideas / suggestions??
    >
    > Cheers
    >
    > Tom
    psion, Sep 8, 2004
    #6
  7. Tom Eggleston

    Dave Guest

    remove Suse 9.1



    "Tom Eggleston" <> wrote in message
    news:chlds2$ge2$...
    > Hi
    >
    > I am running Suse 9.1 at home behind a BT adsl connection.
    >
    > I having odd DNS problems.
    >
    > For example I cannot resolve www.google.co.uk. I get the following:
    >
    > tom@uhuru:~/software> dig www.google.co.uk
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    > ;; reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    >
    > ; <<>> DiG 9.2.3 <<>> www.google.co.uk
    > ;; global options: printcmd
    > ;; connection timed out; no servers could be reached
    >
    >
    > WHen I run windows on the same hardware I can resolve www.google.co.uk no
    > problems.
    >
    > The result of this is extremely slow browsing, and some pages will not

    come
    > up at all.
    >
    > Any ideas / suggestions??
    >
    > Cheers
    >
    > Tom
    >
    Dave, Sep 9, 2004
    #7
  8. begin T'was upon Wed, 08 Sep 2004 18:54:08 -0500, that Dave did write the
    following missive:

    begin It is alleged that sometime during Wed, 08 Sep 2004 18:54:08 -0500,
    Dave wrote this:

    > remove Suse 9.1


    Idiot.

    --
    "Hit any button to continue...
    Heeey? Where's "Any" button?"
    - Homer Simpson -
    Perce P. Cassidy, Sep 9, 2004
    #8
  9. Perce P. Cassidy wrote:

    > Twas upon Wed, 08 Sep 2004 09:18:17 +0000, that Tom Eggleston did write
    > the following missive:
    >
    >> Perce P. Cassidy wrote:
    >>
    >>> T'was upon Tue, 07 Sep 2004 22:48:34 +0000, that Tom Eggleston did write
    >>> the following missive:
    >>>
    >>>> Hi
    >>>>
    >>>> I am running Suse 9.1 at home behind a BT adsl connection.
    >>>
    >>> Are you using a modem or router?
    >>> Do you connect with a static IP or is it dynamically assigned (via
    >>> dhcp)? Are you using pppoe? Are you connected by ether card to the
    >>> modem/router? What exactly did you set up with yast?
    >>>
    >>>> I having odd DNS problems.
    >>>>
    >>>> For example I cannot resolve www.google.co.uk. I get the following:
    >>>>
    >>>> tom@uhuru:~/software> dig www.google.co.uk ;; reply from unexpected
    >>>> source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply from
    >>>> unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;; reply
    >>>> from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53 ;;
    >>>> reply from unexpected source: 213.120.62.98#53, expected 192.168.1.1#53
    >>>>
    >>>> ; <<>> DiG 9.2.3 <<>> www.google.co.uk ;; global options: printcmd ;;
    >>>> connection timed out; no servers could be reached
    >>>>
    >>>>
    >>>> WHen I run windows on the same hardware I can resolve www.google.co.uk
    >>>> no problems.
    >>>>
    >>>> The result of this is extremely slow browsing, and some pages will not
    >>>> come up at all.
    >>>>
    >>>> Any ideas / suggestions??
    >>>>
    >>>> Cheers
    >>>>
    >>>> Tom
    >>>
    >>>
    >>>
    >>>
    >>>

    >> Hi and thanks for the replys.
    >>
    >> My /etc/resov.conf file is:
    >>
    >> ...a lot of remmed out stuff then:
    >> nameserver 192.168.1.1
    >> nameserver 192.168.1.1

    >
    > That seems ok...
    >
    >> I am using a Draytek Vigor 2600 router. The router allocates IP adresses
    >> via DHCP. I don't know whether I'm using pppoe - what is it? I connect
    >> via ethernet to the router (it doubles as a four port switch).

    >
    > What are the ping results like to www.google.com?
    > Mine are -
    > 64 bytes from 66.102.11.104: icmp_seq=1 ttl=246 time=29.1 ms
    > 64 bytes from 66.102.11.104: icmp_seq=2 ttl=246 time=28.8 ms
    > 64 bytes from 66.102.11.104: icmp_seq=3 ttl=246 time=28.8 ms
    > 64 bytes from 66.102.11.104: icmp_seq=4 ttl=246 time=29.3 ms
    >
    > I'm sitting behind an ACEEX AR41 ADSL router with a NAT running on full
    > duplex, & I've not had to change anything on any of the 3 machines I run.
    > (All running SuSE 9.1)
    >
    >> I have set up very little in Yast - I mainly took the defaults.

    >
    > YaST should have detected everything & set it up. I've found it best to
    > accept the defaults. However a not (or wrong) configured network card
    > could slow down a system enormously. On this machine, it's a Realtek
    > 8139, & runs fine.
    >
    >> I did edit my /etc/hosts file however to include a reference to my host
    >> name - it previously only had an entry for localhost and this was causing
    >> a problem with KDE running very slowly.

    >
    > Oh..odd, I've never had that happen.
    >
    > You could also try this. Open up a terminal, and type free -m, and it will
    > tell you how much memory is available to linux, & if it is misrepresented,
    >


    Hi and thanks for your continuing assistance.

    To answer your questions in order:

    1) Ping results to www.google.com

    tom@uhuru:~> ping www.google.com
    PING www.google.akadns.net (66.102.11.104) 56(84) bytes of data.
    64 bytes from www.google.com (66.102.11.104): icmp_seq=1 ttl=241 time=42.6
    ms
    64 bytes from www.google.com (66.102.11.104): icmp_seq=2 ttl=241 time=41.3
    ms
    64 bytes from www.google.com (66.102.11.104): icmp_seq=3 ttl=241 time=39.7
    ms
    64 bytes from www.google.com (66.102.11.104): icmp_seq=4 ttl=241 time=40.1
    ms

    and results to www.google.co.uk:

    tom@uhuru:~> ping www.google.co.uk
    ping: unknown host www.google.co.uk

    So I am not having problems with all addresses. And it is not all .co.uk
    addresses, for example www.novell.co.uk responds perfectly.

    2) Network Card - this is an Intel EtherExpress PRO/100B and seems to be
    functioning fine in all other respects (i.e. once DNS resolves file
    transfers and so on are quick.) Also an Ethereal trace reveals no errors.
    Is there any further testing I can do on Linux to verify this?

    3) The odd KDE problem - you can find out more here if you are interested:
    http://dot.kde.org/1016696443/1016814177/1017438702/1044829946/
    This was my exact problem and fix.

    4) Output from free -m:

    uhuru:/home/tom # free -m
    total used free shared buffers cached
    Mem: 504 383 120 0 56 180
    -/+ buffers/cache: 146 357
    Swap: 504 0 504


    Looks OK to me, but I'm no expert on this OS.


    I am leaning to this being a problem with my ISP, and I have emailed them
    about this. However that does not explain why it works fine under Windows?

    On another note I am slightly disappointed with this release of Suse, the
    amount of timkering I have had to do to make it useable has been excessive.
    But then you don't seem to have had any of these problems so maybe its just
    me! Are you using personal or professional by the way? I am using personal,
    maybe they behave slightly differently during install.

    I really want to get to grips with this distro and not change to Red Hat or
    whatever, as I am a Novell engineer by profession so I think learning Suse
    is important for my future!

    Anyway, thanks again for all your help.

    Cheers

    Tom
    Tom Eggleston, Sep 9, 2004
    #9
  10. Tom Eggleston

    sqool Guest

    It is alleged that sometime during Thu, 09 Sep 2004 16:57:58 +0000, Tom
    Eggleston wrote this:

    Hello, Tom :)

    <snip>
    > To answer your questions in order:
    >
    > 1) Ping results to www.google.com
    >
    > tom@uhuru:~> ping www.google.com
    > PING www.google.akadns.net (66.102.11.104) 56(84) bytes of data. 64 bytes
    > from www.google.com (66.102.11.104): icmp_seq=1 ttl=241 time=42.6 ms
    > 64 bytes from www.google.com (66.102.11.104): icmp_seq=2 ttl=241 time=41.3
    > ms
    > 64 bytes from www.google.com (66.102.11.104): icmp_seq=3 ttl=241 time=39.7
    > ms
    > 64 bytes from www.google.com (66.102.11.104): icmp_seq=4 ttl=241 time=40.1
    > ms


    That's slow, IMHO.

    > and results to www.google.co.uk:
    >
    > tom@uhuru:~> ping www.google.co.uk
    > ping: unknown host www.google.co.uk



    > So I am not having problems with all addresses. And it is not all .co.uk
    > addresses, for example www.novell.co.uk responds perfectly.


    This is an odd one. Is SuSE firewall2 activated? You can check it in:
    Control Center > YaST2 modules > System > Runlevel Editor. You'll have to
    log in as root, by hitting the "Administrator Mode" button at the bottom.

    > 2) Network Card - this is an Intel EtherExpress PRO/100B and seems to be
    > functioning fine in all other respects (i.e. once DNS resolves file
    > transfers and so on are quick.) Also an Ethereal trace reveals no errors.
    > Is there any further testing I can do on Linux to verify this?


    Have you run 'ifconfig' at a terminal prompt? You should get somthing like:

    Bash# ifconfig
    Bash# eth0 Link encap:Ethernet HWaddr 00:50:FC:A1:BA:48
    inet addr:xxx.xxx.x.x Bcast:xxx.xxx.x.xxx Mask:xxx.xxx.xxx.0
    inet6 addr: fe80::250:fcff:fea1:ba48/64 Scope:Link
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:11276 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13976 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:6046262 (5.7 Mb) TX bytes:2190640 (2.0 Mb)
    Interrupt:11 Base address:0x4f00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1016 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1016 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:79830 (77.9 Kb) TX bytes:79830 (77.9 Kb)


    > 3) The odd KDE problem - you can find out more here if you are interested:
    > http://dot.kde.org/1016696443/1016814177/1017438702/1044829946/ This was
    > my exact problem and fix.


    I got a Zope error - Down for maintenance.

    > 4) Output from free -m:
    >
    > uhuru:/home/tom # free -m
    > total used free shared buffers cached
    > Mem: 504 383 120 0 56 180
    > -/+ buffers/cache: 146 357
    > Swap: 504 0 504


    > Looks OK to me, but I'm no expert on this OS.


    Did you let YaST setup the partitions?
    If YaST set it like that on installation, then I'd leave it.

    I note from my 'free -m' output, that my swap file is twice the RAM size.
    total used free shared buffers cached
    Mem: 1012 483 529 0 56 282
    -/+ buffers/cache: 144 867
    Swap: 2048 0 2048

    However, linux uses RAM in a different way from Windows. It needs only
    one-third to one-half the memory Windows requires. UNIX/Linux sees memory
    as a seamless block (sort of) and is not interested in vagaries such as
    himem, extended etc etc. It uses memory in a number of ways. It caches
    disk sectors, buffers read/write activity, and swaps out processes that
    are never active. The net effect of all that means if you let the system
    run for a few days, any program that is in memory but never becomes active
    will be put into swap to free up the RAM it uses. It can then be paged
    (meaning only the parts of it that actually are needed will ever be in
    RAM) back into memory if it becomes active. Examples are getty programs
    running on virtual consoles that are never accessed.
    Basicly, linux will use all the RAM first, \before/ it will use the swap
    file. If you want to see the difference try this at a terminal:-
    ls -R /usr/include

    Note about how long it takes, and then do it again. The second time it's
    run, it'll probably take \significantly/ less time, in fact you may not
    even realise it's reprinted.

    > I am leaning to this being a problem with my ISP, and I have emailed
    > them about this. However that does not explain why it works fine under
    > Windows?


    It's possible, though I don't see why.

    > On another note I am slightly disappointed with this release of Suse,
    > the amount of timkering I have had to do to make it useable has been
    > excessive.


    I think that SuSE released it a little to soon. Ok if you know what
    you're doing, you can get things up without much trouble. I've used
    SuSE since 1998, & I had ver9.0 before this. That installed & ran very
    well. I had a little fixing to do with this on all of my machines,
    but nothing significant.

    > But then you don't seem to have had any of these problems so
    > maybe its just me! Are you using personal or professional by the way? I
    > am using personal, maybe they behave slightly differently during
    > install.


    I'm using SuSE 9.1 Pro, & perhaps they do behave differently, I don't know.

    > I really want to get to grips with this distro and not change to Red Hat
    > or whatever, as I am a Novell engineer by profession so I think learning
    > Suse is important for my future!


    Oh, a Novell engineer! Yes, it \could/ be very useful to you to know
    about it!

    BTW, this is a Novell/SuSE newsgroup -
    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&group=novell.support.suse.linux.professional

    And there are some SuSE forums here -
    http://forums.suselinuxsupport.de/
    http://support.novell.com/forums/2su.html


    --
    Rimmer : Step up to Red Alert!
    Kryten : Sir, are you absolutely sure?
    It does mean changing the bulb.
    - Red Dwarf -
    sqool, Sep 9, 2004
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lars Bonnesen
    Replies:
    9
    Views:
    7,182
    chris
    Apr 8, 2006
  2. none
    Replies:
    5
    Views:
    3,162
  3. Jose Padilla

    DNS question - reverse DNS getting cluttered

    Jose Padilla, Jan 21, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    570
    Jose Padilla
    Jan 21, 2004
  4. Replies:
    1
    Views:
    1,058
    Rohan
    Nov 18, 2006
  5. juska
    Replies:
    1
    Views:
    1,521
    hdeboo
    Nov 12, 2007
Loading...

Share This Page