dns relay(through dhcp)...

Discussion in 'Cisco' started by Captain, Jul 26, 2006.

  1. Captain

    Captain Guest

    I have a cisco806 with 2 ethernet ports,
    (Ethernet1 is connected to the internet,
    Ethernet0 is connected to my LAN).

    The router picks up everthing using DHCP,
    and passes everthing internally using DHCP.

    But no-one,(not even the router itself),
    can connect to,(or even ping), either of
    the dns without adding the following 2
    lines of code,(y.y.y.y is the ISP gateway):

    ip route x.x.x.a 255.255.255.255 y.y.y.y
    ip route x.x.x.b 255.255.255.255 y.y.y.y

    Why would this be?

    fyi: I don't want to leave the ISP gateway
    in the configuration if possible.

    Partial configuration follows:
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !
    version 12.2
    !
    ip name-server x.x.x.a
    ip name-server x.x.x.b
    ip dhcp excluded-address 192.168.0.1 192.168.0.200
    !
    ip dhcp pool main
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server x.x.x.a
    !
    no ip dhcp-client network-discovery
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    ip nat inside
    no cdp enable
    !
    interface Ethernet1
    ip address dhcp
    no ip unreachables
    ip nat outside
    no cdp enable
    !
    ip nat inside source list 101 interface Ethernet1 overload
    ip classless
    ip route x.x.x.a 255.255.255.255 y.y.y.y
    ip route x.x.x.b 255.255.255.255 y.y.y.y
    !
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    no cdp run
    !
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    ----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----
    Captain, Jul 26, 2006
    #1
    1. Advertising

  2. Captain

    Merv Guest

    Default route ???

    ip route 0.0.0.0 0.0.0.0 dhcp

    or

    ip route 0.0.0.0 0.0.0.0 y.y.y.y
    Merv, Jul 27, 2006
    #2
    1. Advertising

  3. Captain

    Captain Guest

    I don't have one.

    fyi: Everything seems to work without one, and this way the dhcp
    seems to get the default route WITHOUT having to hard code
    it in.

    However, the 2 dns IPs,(which again the dhcp picks up), seem to
    not route?!?!?!




    On 27 Jul 2006 03:10:08 -0700, "Merv" <> wrote:
    >Default route ???
    >
    >ip route 0.0.0.0 0.0.0.0 dhcp
    >
    >or
    >
    >ip route 0.0.0.0 0.0.0.0 y.y.y.y
    >



    ----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----
    Captain, Jul 28, 2006
    #3
  4. Captain

    Merv Guest

    Captain wrote:
    > I don't have one.
    >
    > fyi: Everything seems to work without one, and this way the dhcp
    > seems to get the default route WITHOUT having to hard code
    > it in.
    >




    You want to have a default route !!!

    The dns servers IP addresses could change at any point in time.

    IMHO configuring static routes for the current dns servers is not a
    good idea

    So configure a default route. remove the current static and confirm
    that you have connectivity by name...
    Merv, Jul 28, 2006
    #4
  5. On Fri, 28 Jul 2006 20:39:29 +0000, Captain wrote:

    > I don't have one.
    >
    > fyi: Everything seems to work without one, and this way the dhcp
    > seems to get the default route WITHOUT having to hard code
    > it in.
    >
    > However, the 2 dns IPs,(which again the dhcp picks up), seem to
    > not route?!?!?!
    >


    So post "show ip route" then. Do you perhaps have "no ip classless"
    configured?

    --
    Rgds,
    Martin
    Martin Gallagher, Jul 30, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    4
    Views:
    3,016
    chris
    Mar 23, 2006
  2. Replies:
    10
    Views:
    21,356
    brokentwig
    Jun 14, 2007
  3. Vimokh
    Replies:
    3
    Views:
    5,595
    Vimokh
    Sep 6, 2006
  4. inf2700

    DHCP Relay through VPN

    inf2700, Sep 27, 2006, in forum: Cisco
    Replies:
    0
    Views:
    1,248
    inf2700
    Sep 27, 2006
  5. Replies:
    1
    Views:
    1,034
    Rohan
    Nov 18, 2006
Loading...

Share This Page