dlink adsl router

Discussion in 'NZ Computing' started by Andrew, Feb 26, 2006.

  1. Andrew

    Andrew Guest

    Ive gone and broken something...

    I have a webserver running at home. To go to it i just have to go to
    http://mary and it loads the page
    From outside the network i go to my ip address.

    From inside the network if i go to my ip address it directs me to my
    modems login page, Same as if i went to 10.1.1.1

    I was looking at the modems admin page and it had an option for me to
    change the port of the http access to the admin... So i did, I changed
    it from 80 to 62000

    I figured that i would then be able to go to 10.1.1.1:62000 to get to
    the admin page and then 10.1.1.1 would go to the webpage thats hosted

    However that didnt work and now i cant get to the modems admin page..


    Does anyone know what i need to do?

    Im hoping to not have to reset the modem to defaults with the magic
    button (if it has one that is)
     
    Andrew, Feb 26, 2006
    #1
    1. Advertising

  2. Andrew

    Fred Dagg Guest

    On Mon, 27 Feb 2006 12:42:38 +1300, Andrew
    <> exclaimed:

    >Ive gone and broken something...
    >
    >I have a webserver running at home. To go to it i just have to go to
    >http://mary and it loads the page
    > From outside the network i go to my ip address.
    >
    > From inside the network if i go to my ip address it directs me to my
    >modems login page, Same as if i went to 10.1.1.1
    >
    >I was looking at the modems admin page and it had an option for me to
    >change the port of the http access to the admin... So i did, I changed
    >it from 80 to 62000
    >
    >I figured that i would then be able to go to 10.1.1.1:62000 to get to
    >the admin page and then 10.1.1.1 would go to the webpage thats hosted
    >
    >However that didnt work and now i cant get to the modems admin page..
    >
    >
    >Does anyone know what i need to do?
    >
    >Im hoping to not have to reset the modem to defaults with the magic
    >button (if it has one that is)
    >

    Hmm, can you not access it on port 80 or 62000?

    You could try telneting into it, and changing the port that way.
     
    Fred Dagg, Feb 26, 2006
    #2
    1. Advertising

  3. Andrew

    Shane Guest

    Andrew wrote:

    > Ive gone and broken something...
    >
    > I have a webserver running at home. To go to it i just have to go to
    > http://mary and it loads the page
    > From outside the network i go to my ip address.
    >
    > From inside the network if i go to my ip address it directs me to my
    > modems login page, Same as if i went to 10.1.1.1
    >
    > I was looking at the modems admin page and it had an option for me to
    > change the port of the http access to the admin... So i did, I changed
    > it from 80 to 62000
    >
    > I figured that i would then be able to go to 10.1.1.1:62000 to get to
    > the admin page and then 10.1.1.1 would go to the webpage thats hosted
    >
    > However that didnt work and now i cant get to the modems admin page..
    >
    >
    > Does anyone know what i need to do?
    >
    > Im hoping to not have to reset the modem to defaults with the magic
    > button (if it has one that is)


    For internal access
    On a windows box, put a hosts file in.. system32??
    On a linux box put a hosts file in /etc
    <my ip address> <my host name>
    127.0.0.1 mary
    10.1.1.1 router

    HTH
     
    Shane, Feb 27, 2006
    #3
  4. Andrew

    El Penguino Guest

    On Mon, 27 Feb 2006 12:42:38 +1300, Andrew
    <> wrote:

    >Ive gone and broken something...
    >
    >I have a webserver running at home. To go to it i just have to go to
    >http://mary and it loads the page
    > From outside the network i go to my ip address.
    >
    > From inside the network if i go to my ip address it directs me to my
    >modems login page, Same as if i went to 10.1.1.1
    >
    >I was looking at the modems admin page and it had an option for me to
    >change the port of the http access to the admin... So i did, I changed
    >it from 80 to 62000
    >
    >I figured that i would then be able to go to 10.1.1.1:62000 to get to
    >the admin page and then 10.1.1.1 would go to the webpage thats hosted
    >
    >However that didnt work and now i cant get to the modems admin page..
    >
    >
    >Does anyone know what i need to do?
    >
    >Im hoping to not have to reset the modem to defaults with the magic
    >button (if it has one that is)


    I had the same situation.
    As another poster said, a host entry will redirect your own requests
    to the webserver. The host file has no extension and is simply
    "hosts", no quotes. look in: C:/windows/system32/drives/etc

    Add an entry for your server. e.g.
    10.1.1.1 mywebserver

    and save it.
    Your PC, when making a DNS lookup for a name runs through the hosts
    file first and viola, your webserver comes up.
    You dont have to reset your modem to port 80 but the next time you
    need to log in and cant you may wish you had reset it to default.

    You can also use a dynamic DNS service to track your changing IP and
    reference it to a host name, making it easier to give out to people.

    HTH
    Chris
     
    El Penguino, Feb 27, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    41,881
  2. Helpneeded

    Configuring a Dlink 604+ ADSL router

    Helpneeded, Aug 5, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    1,482
    Helpneeded
    Aug 5, 2004
  3. LincolnShep
    Replies:
    3
    Views:
    2,886
    Jack \(MVP-Networking\).
    Nov 8, 2006
  4. Replies:
    15
    Views:
    973
    Gordon
    Jun 27, 2006
  5. czar

    adsl router to adsl router

    czar, May 1, 2007, in forum: Cisco
    Replies:
    2
    Views:
    474
    Doug McIntyre
    May 1, 2007
Loading...

Share This Page