Disallow a wireless network

Discussion in 'Wireless Networking' started by =?Utf-8?B?Vmlja3lT?=, Sep 24, 2007.

  1. Is there a way to disallow a wireless network connection? We've got a case
    where we have two wireless networks on campus - one is using WPA2 and we and
    the notebooks are setup to automatically connect - we aren't broadcasting the
    SSID. However - there is also an unsecured public wireless and the notebooks
    are connecting to that first and they never authenticate then against the
    other. If you reboot, and login again, then you can see the private network,
    disconnect the public and connect to the private, but needless to say this
    isn't a good option for the students. I'd like to set the notebooks to NEVER
    connect to the public wireless. is this possible? The notebooks are running
    XP w/sp2.
    =?Utf-8?B?Vmlja3lT?=, Sep 24, 2007
    #1
    1. Advertising

  2. =?Utf-8?B?Vmlja3lT?=

    Lem Guest

    VickyS wrote:
    > Is there a way to disallow a wireless network connection? We've got a case
    > where we have two wireless networks on campus - one is using WPA2 and we and
    > the notebooks are setup to automatically connect - we aren't broadcasting the
    > SSID. However - there is also an unsecured public wireless and the notebooks
    > are connecting to that first and they never authenticate then against the
    > other. If you reboot, and login again, then you can see the private network,
    > disconnect the public and connect to the private, but needless to say this
    > isn't a good option for the students. I'd like to set the notebooks to NEVER
    > connect to the public wireless. is this possible? The notebooks are running
    > XP w/sp2.


    Make sure that the "Automatically connect to non-preferred networks" box
    is not checked (from the "advanced" button -- not "advanced" tab -- of
    the "wireless network" tab of wireless network connection properties
    dialog). This is the default setting, and you are probably running into
    the problem that if a user EVER connects to this public network, Windows
    automatically adds it to the top of the list of preferred networks.

    Alternatively (I think this will work), configure the SSID of the public
    network with an encryption key. Because the network itself is
    unsecured, the configuration will not match and the users will therefore
    not connect to the public network. WZC should then find the
    non-broadcast secured network and connect to that.

    --
    Lem MS MVP -- Networking

    To the moon and back with 64 Kbits of RAM and 512 Kbits of ROM.
    http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    Lem, Sep 24, 2007
    #2
    1. Advertising

  3. Automatically connect to non-preferred is not checked and it is set to
    connect to access point (infrastructure) networks only, but I'll give your
    idea w/the SSIS a try.

    "Lem" wrote:

    > VickyS wrote:
    > > Is there a way to disallow a wireless network connection? We've got a case
    > > where we have two wireless networks on campus - one is using WPA2 and we and
    > > the notebooks are setup to automatically connect - we aren't broadcasting the
    > > SSID. However - there is also an unsecured public wireless and the notebooks
    > > are connecting to that first and they never authenticate then against the
    > > other. If you reboot, and login again, then you can see the private network,
    > > disconnect the public and connect to the private, but needless to say this
    > > isn't a good option for the students. I'd like to set the notebooks to NEVER
    > > connect to the public wireless. is this possible? The notebooks are running
    > > XP w/sp2.

    >
    > Make sure that the "Automatically connect to non-preferred networks" box
    > is not checked (from the "advanced" button -- not "advanced" tab -- of
    > the "wireless network" tab of wireless network connection properties
    > dialog). This is the default setting, and you are probably running into
    > the problem that if a user EVER connects to this public network, Windows
    > automatically adds it to the top of the list of preferred networks.
    >
    > Alternatively (I think this will work), configure the SSID of the public
    > network with an encryption key. Because the network itself is
    > unsecured, the configuration will not match and the users will therefore
    > not connect to the public network. WZC should then find the
    > non-broadcast secured network and connect to that.
    >
    > --
    > Lem MS MVP -- Networking
    >
    > To the moon and back with 64 Kbits of RAM and 512 Kbits of ROM.
    > http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    >
    =?Utf-8?B?Vmlja3lT?=, Sep 24, 2007
    #3
  4. I'd encourage you to re-enable SSID broadcast of the WPA2 network. SSIDs
    aren't passwords, they're network names--so don't try to keep them secret.
    The XP client doesn't really like hidden SSIDs.

    http://www.microsoft.com/technet/technetmag/issues/2005/11/SecurityWatch/default.aspx
    describes why hiding an SSID does not make that network any more secure.

    http://technet.microsoft.com/en-us/library/bb726942.aspx describes the
    general behavior of the XP and Vista clients.

    http://support.microsoft.com/kb/907405/ describes a hotfix you can get to
    work around a specific situation regarding reconnecting after manually
    disconnecting. But you're better off re-enabling SSID broadcast.

    --
    Steve Riley

    http://blogs.technet.com/steriley
    http://www.protectyourwindowsnetwork.com


    "VickyS" <> wrote in message
    news:...
    > Automatically connect to non-preferred is not checked and it is set to
    > connect to access point (infrastructure) networks only, but I'll give your
    > idea w/the SSIS a try.
    >
    > "Lem" wrote:
    >
    >> VickyS wrote:
    >> > Is there a way to disallow a wireless network connection? We've got a
    >> > case
    >> > where we have two wireless networks on campus - one is using WPA2 and
    >> > we and
    >> > the notebooks are setup to automatically connect - we aren't
    >> > broadcasting the
    >> > SSID. However - there is also an unsecured public wireless and the
    >> > notebooks
    >> > are connecting to that first and they never authenticate then against
    >> > the
    >> > other. If you reboot, and login again, then you can see the private
    >> > network,
    >> > disconnect the public and connect to the private, but needless to say
    >> > this
    >> > isn't a good option for the students. I'd like to set the notebooks to
    >> > NEVER
    >> > connect to the public wireless. is this possible? The notebooks are
    >> > running
    >> > XP w/sp2.

    >>
    >> Make sure that the "Automatically connect to non-preferred networks" box
    >> is not checked (from the "advanced" button -- not "advanced" tab -- of
    >> the "wireless network" tab of wireless network connection properties
    >> dialog). This is the default setting, and you are probably running into
    >> the problem that if a user EVER connects to this public network, Windows
    >> automatically adds it to the top of the list of preferred networks.
    >>
    >> Alternatively (I think this will work), configure the SSID of the public
    >> network with an encryption key. Because the network itself is
    >> unsecured, the configuration will not match and the users will therefore
    >> not connect to the public network. WZC should then find the
    >> non-broadcast secured network and connect to that.
    >>
    >> --
    >> Lem MS MVP -- Networking
    >>
    >> To the moon and back with 64 Kbits of RAM and 512 Kbits of ROM.
    >> http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    >>
    Steve Riley [MSFT], Sep 24, 2007
    #4
  5. Hi
    By Not broadcasting the SSID you actually create a preference to the Network
    that does broadcast the SSID.
    Jack (MVP-Networking).

    "VickyS" <> wrote in message
    news:...
    > Automatically connect to non-preferred is not checked and it is set to
    > connect to access point (infrastructure) networks only, but I'll give your
    > idea w/the SSIS a try.
    >
    > "Lem" wrote:
    >
    >> VickyS wrote:
    >> > Is there a way to disallow a wireless network connection? We've got a
    >> > case
    >> > where we have two wireless networks on campus - one is using WPA2 and
    >> > we and
    >> > the notebooks are setup to automatically connect - we aren't
    >> > broadcasting the
    >> > SSID. However - there is also an unsecured public wireless and the
    >> > notebooks
    >> > are connecting to that first and they never authenticate then against
    >> > the
    >> > other. If you reboot, and login again, then you can see the private
    >> > network,
    >> > disconnect the public and connect to the private, but needless to say
    >> > this
    >> > isn't a good option for the students. I'd like to set the notebooks to
    >> > NEVER
    >> > connect to the public wireless. is this possible? The notebooks are
    >> > running
    >> > XP w/sp2.

    >>
    >> Make sure that the "Automatically connect to non-preferred networks" box
    >> is not checked (from the "advanced" button -- not "advanced" tab -- of
    >> the "wireless network" tab of wireless network connection properties
    >> dialog). This is the default setting, and you are probably running into
    >> the problem that if a user EVER connects to this public network, Windows
    >> automatically adds it to the top of the list of preferred networks.
    >>
    >> Alternatively (I think this will work), configure the SSID of the public
    >> network with an encryption key. Because the network itself is
    >> unsecured, the configuration will not match and the users will therefore
    >> not connect to the public network. WZC should then find the
    >> non-broadcast secured network and connect to that.
    >>
    >> --
    >> Lem MS MVP -- Networking
    >>
    >> To the moon and back with 64 Kbits of RAM and 512 Kbits of ROM.
    >> http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
    >>
    Jack \(MVP-Networking\)., Sep 25, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SmFtZXM=?=

    Deleting a "Wireless network" created with the wireless network wi

    =?Utf-8?B?SmFtZXM=?=, Dec 13, 2005, in forum: Wireless Networking
    Replies:
    2
    Views:
    4,262
    =?Utf-8?B?S2V2aW5S?=
    Feb 3, 2006
  2. Mike Cohen
    Replies:
    7
    Views:
    3,178
    John Simonetti
    Jul 10, 2004
  3. Franc Zabkar
    Replies:
    3
    Views:
    576
    Franc Zabkar
    Feb 28, 2005
  4. Jordan
    Replies:
    1
    Views:
    843
    Pavel A.
    Nov 3, 2007
  5. PL
    Replies:
    1
    Views:
    595
    Todd H.
    Nov 15, 2007
Loading...

Share This Page