Disabeling internal pointing device on laptop

Discussion in 'Computer Support' started by Jack B. Pollack, Jun 17, 2006.

  1. I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track pad
    has been working erratically so I have plugged in a nice little travel
    mouse. The problem is that the internal track pad still is sending erratic
    clicks and mouse movement and I cant find any to disable it.

    - There is nothing in the BIOS pertaining in to the pointing device

    - In Device Manager (WinXP Pro) I can disable the external pointing device,
    but there is no option to disable the internal one.

    - If I uninstall the Glide-Point driver the pointing device still works and
    it reinstalls anyway on the next boot.

    Any ideas on how to disable the internal pointing device short of opening
    the laptop?

    Thanks
     
    Jack B. Pollack, Jun 17, 2006
    #1
    1. Advertising

  2. Jack B. Pollack

    Toolman Tim Guest

    In news:AzWkg.9860$-nyc.rr.com,
    Jack B. Pollack spewed forth:
    > I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track
    > pad has been working erratically so I have plugged in a nice little
    > travel mouse. The problem is that the internal track pad still is
    > sending erratic clicks and mouse movement and I cant find any to
    > disable it.
    >
    > - There is nothing in the BIOS pertaining in to the pointing device
    >
    > - In Device Manager (WinXP Pro) I can disable the external pointing
    > device, but there is no option to disable the internal one.
    >
    > - If I uninstall the Glide-Point driver the pointing device still
    > works and it reinstalls anyway on the next boot.
    >
    > Any ideas on how to disable the internal pointing device short of
    > opening the laptop?
    >
    > Thanks



    It's disabled in the BIOS. I don't remember if it's the Del key or the F2 or
    what when you start the laptop, but you gotta go into the BIOS to turn off
    the internal pointing device.

    --
    I have CDO. It's like Obsessive Compulsive Disorder, only in
    alphabetical order, just like it should be.
     
    Toolman Tim, Jun 17, 2006
    #2
    1. Advertising

  3. Jack B. Pollack

    SgtMinor Guest

    Jack B. Pollack wrote:

    > I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track pad
    > has been working erratically so I have plugged in a nice little travel
    > mouse. The problem is that the internal track pad still is sending erratic
    > clicks and mouse movement and I cant find any to disable it.
    >
    > - There is nothing in the BIOS pertaining in to the pointing device
    >
    > - In Device Manager (WinXP Pro) I can disable the external pointing device,
    > but there is no option to disable the internal one.
    >
    > - If I uninstall the Glide-Point driver the pointing device still works and
    > it reinstalls anyway on the next boot.
    >
    > Any ideas on how to disable the internal pointing device short of opening
    > the laptop?
    >
    > Thanks
    >
    >
    >


    In Control Panel is there a "Sony Notebook Setup" option? See if
    under the Device tab you can disable it.
     
    SgtMinor, Jun 17, 2006
    #3
  4. I don't have a Sony icon in CP. I did a fresh non-OEM install of XP at one
    point.

    I did reinstall most of the drivers from here (at least the devices that
    were drive-less):
    http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    ng

    Do you see the "Sony Notebook Setup" CP applet on this page, or know where I
    can DL from?
    Thanks



    "SgtMinor" <> wrote in message
    news:p...
    > Jack B. Pollack wrote:
    >
    > > I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track

    pad
    > > has been working erratically so I have plugged in a nice little travel
    > > mouse. The problem is that the internal track pad still is sending

    erratic
    > > clicks and mouse movement and I cant find any to disable it.
    > >
    > > - There is nothing in the BIOS pertaining in to the pointing device
    > >
    > > - In Device Manager (WinXP Pro) I can disable the external pointing

    device,
    > > but there is no option to disable the internal one.
    > >
    > > - If I uninstall the Glide-Point driver the pointing device still works

    and
    > > it reinstalls anyway on the next boot.
    > >
    > > Any ideas on how to disable the internal pointing device short of

    opening
    > > the laptop?
    > >
    > > Thanks
    > >
    > >
    > >

    >
    > In Control Panel is there a "Sony Notebook Setup" option? See if
    > under the Device tab you can disable it.
     
    Jack B. Pollack, Jun 17, 2006
    #4
  5. Jack B. Pollack

    Toolman Tim Guest

    In news:fiZkg.9538$%-nyc.rr.com,
    Jack B. Pollack spewed forth:
    > I don't have a Sony icon in CP. I did a fresh non-OEM install of XP
    > at one point.
    >
    > I did reinstall most of the drivers from here (at least the devices
    > that were drive-less):
    > http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    > ng
    >
    > Do you see the "Sony Notebook Setup" CP applet on this page, or know
    > where I can DL from?
    > Thanks
    >
    >

    There isn't one. Go into the CMOS setup when the computer boots, like I told
    you earlier. Disable the touchpad there. That's what I did on MY Sony Vaio.



    >
    > "SgtMinor" <> wrote in message
    > news:p...
    >> Jack B. Pollack wrote:
    >>
    >>> I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point"
    >>> track pad has been working erratically so I have plugged in a nice
    >>> little travel mouse. The problem is that the internal track pad
    >>> still is sending erratic clicks and mouse movement and I cant find
    >>> any to disable it.
    >>>
    >>> - There is nothing in the BIOS pertaining in to the pointing device
    >>>
    >>> - In Device Manager (WinXP Pro) I can disable the external pointing
    >>> device, but there is no option to disable the internal one.
    >>>
    >>> - If I uninstall the Glide-Point driver the pointing device still
    >>> works and it reinstalls anyway on the next boot.
    >>>
    >>> Any ideas on how to disable the internal pointing device short of
    >>> opening the laptop?
    >>>
    >>> Thanks
    >>>
    >>>
    >>>

    >>
    >> In Control Panel is there a "Sony Notebook Setup" option? See if
    >> under the Device tab you can disable it.


    --
    I have CDO. It's like Obsessive Compulsive Disorder, only in
    alphabetical order, just like it should be.
     
    Toolman Tim, Jun 17, 2006
    #5
  6. As I mentioned, this was the first place I looked. Nothing having to do with
    pointing device. Only Boot order, screen stretching, password etc.

    "Toolman Tim" <> wrote in message
    news:atZkg.67$...
    > In news:fiZkg.9538$%-nyc.rr.com,
    > Jack B. Pollack spewed forth:
    > > I don't have a Sony icon in CP. I did a fresh non-OEM install of XP
    > > at one point.
    > >
    > > I did reinstall most of the drivers from here (at least the devices
    > > that were drive-less):
    > >

    http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    > > ng
    > >
    > > Do you see the "Sony Notebook Setup" CP applet on this page, or know
    > > where I can DL from?
    > > Thanks
    > >
    > >

    > There isn't one. Go into the CMOS setup when the computer boots, like I

    told
    > you earlier. Disable the touchpad there. That's what I did on MY Sony

    Vaio.
    >
    >
    >
    > >
    > > "SgtMinor" <> wrote in message
    > > news:p...
    > >> Jack B. Pollack wrote:
    > >>
    > >>> I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point"
    > >>> track pad has been working erratically so I have plugged in a nice
    > >>> little travel mouse. The problem is that the internal track pad
    > >>> still is sending erratic clicks and mouse movement and I cant find
    > >>> any to disable it.
    > >>>
    > >>> - There is nothing in the BIOS pertaining in to the pointing device
    > >>>
    > >>> - In Device Manager (WinXP Pro) I can disable the external pointing
    > >>> device, but there is no option to disable the internal one.
    > >>>
    > >>> - If I uninstall the Glide-Point driver the pointing device still
    > >>> works and it reinstalls anyway on the next boot.
    > >>>
    > >>> Any ideas on how to disable the internal pointing device short of
    > >>> opening the laptop?
    > >>>
    > >>> Thanks
    > >>>
    > >>>
    > >>>
    > >>
    > >> In Control Panel is there a "Sony Notebook Setup" option? See if
    > >> under the Device tab you can disable it.

    >
    > --
    > I have CDO. It's like Obsessive Compulsive Disorder, only in
    > alphabetical order, just like it should be.
    >
    >
     
    Jack B. Pollack, Jun 17, 2006
    #6
  7. Jack B. Pollack

    SgtMinor Guest

    Jack B. Pollack wrote:

    > I don't have a Sony icon in CP. I did a fresh non-OEM install of XP at one
    > point.
    >
    > I did reinstall most of the drivers from here (at least the devices that
    > were drive-less):
    > http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    > ng
    >
    > Do you see the "Sony Notebook Setup" CP applet on this page, or know where I
    > can DL from?
    > Thanks
    >
    >
    >
    > "SgtMinor" <> wrote in message
    > news:p...
    >
    >>Jack B. Pollack wrote:
    >>
    >>
    >>>I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track

    >
    > pad
    >
    >>>has been working erratically so I have plugged in a nice little travel
    >>>mouse. The problem is that the internal track pad still is sending

    >
    > erratic
    >
    >>>clicks and mouse movement and I cant find any to disable it.
    >>>
    >>>- There is nothing in the BIOS pertaining in to the pointing device
    >>>
    >>>- In Device Manager (WinXP Pro) I can disable the external pointing

    >
    > device,
    >
    >>>but there is no option to disable the internal one.
    >>>
    >>>- If I uninstall the Glide-Point driver the pointing device still works

    >
    > and
    >
    >>>it reinstalls anyway on the next boot.
    >>>
    >>>Any ideas on how to disable the internal pointing device short of

    >
    > opening
    >
    >>>the laptop?
    >>>
    >>>Thanks
    >>>
    >>>
    >>>

    >>
    >>In Control Panel is there a "Sony Notebook Setup" option? See if
    >>under the Device tab you can disable it.

    >
    >
    >


    If you can't or won't do as Toolman Tim suggested, here's the
    approach suggested by Sony:


    Knowledge Article C135399

    How to remove the touchpad device from Device Manager in the
    Microsoft® Windows® XP operating system.

    Follow this procedure to remove the touchpad drivers from Device
    Manager.

    IMPORTANT: This procedure must be performed while logged in as
    Administrator or to an account with Administrator rights.

    1. Press the WINDOWS key.
    2. Press the C key until Control Panel is selected.
    3. Press the ENTER key.
    4. In the Control Panel window, press the TAB key until the
    Performance and Maintenance icon is selected.
    5. Press the ENTER key.
    6. In the Performance and Maintenance window, under the Or
    pick a Control Panel icon heading, press the TAB key until the
    System icon is selected and press the ENTER key.
    7. In the System Properties window, press the RIGHT ARROW key
    until the Hardware tab is selected.
    8. On the Hardware tab, in the Device Manager box, press the
    TAB key until Device Manager is selected and press the ENTER key.
    9. In the Device Manager window, press the TAB key until the
    Computer Name is selected.
    10. Press the DOWN ARROW key until Mice and other pointing
    devices is selected.
    11. Press the RIGHT ARROW key until the Mouse device is selected.
    12. Press the ALT+A keys to open the Action menu.
    13. Press the DOWN ARROW key until Uninstall is selected and
    press the ENTER key.
    14. In the Confirm Device Removal window, press the TAB key
    until the OK button is selected.
    15. Press the ENTER key.
    16. In the System Settings Change window, press the TAB key
    until the Yes button is selected.
    17. Press the ENTER key to restart the computer.
     
    SgtMinor, Jun 17, 2006
    #7
  8. Jack B. Pollack

    Toolman Tim Guest

    In news:D,
    SgtMinor spewed forth:
    > Jack B. Pollack wrote:
    >
    >> I don't have a Sony icon in CP. I did a fresh non-OEM install of XP
    >> at one point.
    >>
    >> I did reinstall most of the drivers from here (at least the devices
    >> that were drive-less):
    >> http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    >> ng
    >>
    >> Do you see the "Sony Notebook Setup" CP applet on this page, or know
    >> where I can DL from?
    >> Thanks
    >>
    >>
    >>
    >> "SgtMinor" <> wrote in message
    >> news:p...
    >>
    >>> Jack B. Pollack wrote:
    >>>
    >>>
    >>>> I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point"
    >>>> track

    >>
    >> pad
    >>
    >>>> has been working erratically so I have plugged in a nice little
    >>>> travel mouse. The problem is that the internal track pad still is
    >>>> sending

    >>
    >> erratic
    >>
    >>>> clicks and mouse movement and I cant find any to disable it.
    >>>>
    >>>> - There is nothing in the BIOS pertaining in to the pointing device
    >>>>
    >>>> - In Device Manager (WinXP Pro) I can disable the external pointing

    >>
    >> device,
    >>
    >>>> but there is no option to disable the internal one.
    >>>>
    >>>> - If I uninstall the Glide-Point driver the pointing device still
    >>>> works

    >>
    >> and
    >>
    >>>> it reinstalls anyway on the next boot.
    >>>>
    >>>> Any ideas on how to disable the internal pointing device short of

    >>
    >> opening
    >>
    >>>> the laptop?
    >>>>
    >>>> Thanks
    >>>>
    >>>>
    >>>>
    >>>
    >>> In Control Panel is there a "Sony Notebook Setup" option? See if
    >>> under the Device tab you can disable it.

    >>
    >>
    >>

    >
    > If you can't or won't do as Toolman Tim suggested, here's the
    > approach suggested by Sony:
    >
    >
    > Knowledge Article C135399
    >
    > How to remove the touchpad device from Device Manager in the
    > Microsoft® Windows® XP operating system.
    >
    > Follow this procedure to remove the touchpad drivers from Device
    > Manager.
    >
    > IMPORTANT: This procedure must be performed while logged in as
    > Administrator or to an account with Administrator rights.
    >
    > 1. Press the WINDOWS key.
    > 2. Press the C key until Control Panel is selected.
    > 3. Press the ENTER key.
    > 4. In the Control Panel window, press the TAB key until the
    > Performance and Maintenance icon is selected.
    > 5. Press the ENTER key.
    > 6. In the Performance and Maintenance window, under the Or
    > pick a Control Panel icon heading, press the TAB key until the
    > System icon is selected and press the ENTER key.
    > 7. In the System Properties window, press the RIGHT ARROW key
    > until the Hardware tab is selected.
    > 8. On the Hardware tab, in the Device Manager box, press the
    > TAB key until Device Manager is selected and press the ENTER key.
    > 9. In the Device Manager window, press the TAB key until the
    > Computer Name is selected.
    > 10. Press the DOWN ARROW key until Mice and other pointing
    > devices is selected.
    > 11. Press the RIGHT ARROW key until the Mouse device is selected.
    > 12. Press the ALT+A keys to open the Action menu.
    > 13. Press the DOWN ARROW key until Uninstall is selected and
    > press the ENTER key.
    > 14. In the Confirm Device Removal window, press the TAB key
    > until the OK button is selected.
    > 15. Press the ENTER key.
    > 16. In the System Settings Change window, press the TAB key
    > until the Yes button is selected.
    > 17. Press the ENTER key to restart the computer.


    Since he added an external mouse, he has to be careful not to mess with the
    wrong one.

    --
    I have CDO. It's like Obsessive Compulsive Disorder, only in
    alphabetical order, just like it should be.
     
    Toolman Tim, Jun 17, 2006
    #8
  9. "SgtMinor" <> wrote in message
    news:D...
    > Jack B. Pollack wrote:
    >
    > > I don't have a Sony icon in CP. I did a fresh non-OEM install of XP at

    one
    > > point.
    > >
    > > I did reinstall most of the drivers from here (at least the devices that
    > > were drive-less):
    > >

    http://esupport.sony.com/perl/swu-list.pl?mdl=PCGV505BXP&UpdateType=Everythi
    > > ng
    > >
    > > Do you see the "Sony Notebook Setup" CP applet on this page, or know

    where I
    > > can DL from?
    > > Thanks
    > >
    > >
    > >
    > > "SgtMinor" <> wrote in message
    > > news:p...
    > >
    > >>Jack B. Pollack wrote:
    > >>
    > >>
    > >>>I have a Sony Vaio PCG505BXP Laptop. The internal "Glide-point" track

    > >
    > > pad
    > >
    > >>>has been working erratically so I have plugged in a nice little travel
    > >>>mouse. The problem is that the internal track pad still is sending

    > >
    > > erratic
    > >
    > >>>clicks and mouse movement and I cant find any to disable it.
    > >>>
    > >>>- There is nothing in the BIOS pertaining in to the pointing device
    > >>>
    > >>>- In Device Manager (WinXP Pro) I can disable the external pointing

    > >
    > > device,
    > >
    > >>>but there is no option to disable the internal one.
    > >>>
    > >>>- If I uninstall the Glide-Point driver the pointing device still works

    > >
    > > and
    > >
    > >>>it reinstalls anyway on the next boot.
    > >>>
    > >>>Any ideas on how to disable the internal pointing device short of

    > >
    > > opening
    > >
    > >>>the laptop?
    > >>>
    > >>>Thanks
    > >>>
    > >>>
    > >>>
    > >>
    > >>In Control Panel is there a "Sony Notebook Setup" option? See if
    > >>under the Device tab you can disable it.

    > >
    > >
    > >

    >
    > If you can't or won't do as Toolman Tim suggested, here's the
    > approach suggested by Sony:
    >
    >
    > Knowledge Article C135399
    >
    > How to remove the touchpad device from Device Manager in the
    > Microsoft® Windows® XP operating system.
    >
    > Follow this procedure to remove the touchpad drivers from Device
    > Manager.
    >
    > IMPORTANT: This procedure must be performed while logged in as
    > Administrator or to an account with Administrator rights.
    >
    > 1. Press the WINDOWS key.
    > 2. Press the C key until Control Panel is selected.
    > 3. Press the ENTER key.
    > 4. In the Control Panel window, press the TAB key until the
    > Performance and Maintenance icon is selected.
    > 5. Press the ENTER key.
    > 6. In the Performance and Maintenance window, under the Or
    > pick a Control Panel icon heading, press the TAB key until the
    > System icon is selected and press the ENTER key.
    > 7. In the System Properties window, press the RIGHT ARROW key
    > until the Hardware tab is selected.
    > 8. On the Hardware tab, in the Device Manager box, press the
    > TAB key until Device Manager is selected and press the ENTER key.
    > 9. In the Device Manager window, press the TAB key until the
    > Computer Name is selected.
    > 10. Press the DOWN ARROW key until Mice and other pointing
    > devices is selected.
    > 11. Press the RIGHT ARROW key until the Mouse device is selected.
    > 12. Press the ALT+A keys to open the Action menu.
    > 13. Press the DOWN ARROW key until Uninstall is selected and
    > press the ENTER key.
    > 14. In the Confirm Device Removal window, press the TAB key
    > until the OK button is selected.
    > 15. Press the ENTER key.
    > 16. In the System Settings Change window, press the TAB key
    > until the Yes button is selected.
    > 17. Press the ENTER key to restart the computer.
    >




    As I posted in my original message: If I delete the Glide-point (as
    described above) it still functions. Deleting the driver just deletes the
    "extended" features such as the tap to click feature. After rebooting the
    enhanced features reload automatically.
     
    Jack B. Pollack, Jun 17, 2006
    #9
  10. Jack B. Pollack

    SgtMinor Guest

    Toolman Tim wrote:

    <snip>

    >
    > Since he added an external mouse, he has to be careful not to mess with the
    > wrong one.
    >


    I hate touchpads. On my Satellite, Ctrl F9 turns it off.
     
    SgtMinor, Jun 17, 2006
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. LRatley104

    Pointing Devices

    LRatley104, Jan 20, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    522
    LRatley104
    Jan 20, 2004
  2. Edge

    Touch Pad vs Pointing Stick for Laptop

    Edge, Feb 15, 2006, in forum: Computer Information
    Replies:
    1
    Views:
    526
  3. JW
    Replies:
    8
    Views:
    829
  4. Jack B. Pollack
    Replies:
    0
    Views:
    961
    Jack B. Pollack
    Nov 16, 2006
  5. Juergen Kluth

    ICS disabeling dhcp service possible ?

    Juergen Kluth, Mar 14, 2007, in forum: Windows 64bit
    Replies:
    2
    Views:
    445
    Juergen Kluth
    Mar 15, 2007
Loading...

Share This Page