Dialer Idle Timeout Not Working

Discussion in 'Cisco' started by Patt, Jun 16, 2007.

  1. Patt

    Patt Guest

    Hi,

    Can someone assist.

    I'm trying to get a idle timeout working on interesting traffic port
    27890 only.
    I can see Idle timeout dropping when user sending on this port and
    eventually will drop the line after 600 seconds. I only want the line
    to drop when not sending on 27890

    is the below correct ? any help appreciated.




    interface BRI0/0
    ip address 10.10.2.50 255.255.255.0
    ip access-group 101 in
    encapsulation ppp
    dialer idle-timeout 600 inbound
    dialer-group 1
    isdn switch-type basic-net3
    peer default ip address pool isdnpool
    ppp authentication chap ms-chap
    !

    access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 192.168.0.84 eq
    27890
    access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 10.10.0.84 eq
    27890
    dialer-list 1 protocol ip list 101
    no cdp run
    !
     
    Patt, Jun 16, 2007
    #1
    1. Advertising

  2. On Sat, 16 Jun 2007 09:06:16 -0700, Patt wrote:

    >
    > I'm trying to get a idle timeout working on interesting traffic port
    > 27890 only.
    > I can see Idle timeout dropping when user sending on this port and
    > eventually will drop the line after 600 seconds. I only want the line
    > to drop when not sending on 27890
    >
    > is the below correct ? any help appreciated.
    >
    > interface BRI0/0
    > ip address 10.10.2.50 255.255.255.0
    > ip access-group 101 in
    > encapsulation ppp
    > dialer idle-timeout 600 inbound
    > dialer-group 1
    > isdn switch-type basic-net3
    > peer default ip address pool isdnpool
    > ppp authentication chap ms-chap
    > !
    >
    > access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 192.168.0.84 eq
    > 27890
    > access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 10.10.0.84 eq
    > 27890
    > dialer-list 1 protocol ip list 101
    > no cdp run
    > !


    It might be correct, depending on your network topology. You don't
    give enough information to tell.

    You can use debug dialer packet to see if your traffic is
    considered interesting or not. If it isn't, your configuration is wrong.
    If it is, something else is.

    --
    Rgds,
    Martin
     
    Martin Gallagher, Jun 17, 2007
    #2
    1. Advertising

  3. Patt

    Patt Guest

    On 17 Jun, 04:14, Martin Gallagher <> wrote:
    > On Sat, 16 Jun 2007 09:06:16 -0700, Patt wrote:
    >
    > > I'm trying to get aidletimeoutworking on interesting traffic port
    > > 27890 only.
    > > I can seeIdletimeoutdropping when user sending on this port and
    > > eventually will drop the line after 600 seconds. I only want the line
    > > to drop when not sending on 27890

    >
    > > is the below correct ? any help appreciated.

    >
    > > interface BRI0/0
    > > ip address 10.10.2.50 255.255.255.0
    > > ip access-group 101 in
    > > encapsulation ppp
    > > dialeridle-timeout600 inbound
    > > dialer-group 1
    > > isdn switch-type basic-net3
    > > peer default ip address pool isdnpool
    > > ppp authentication chap ms-chap
    > > !

    >
    > > access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 192.168.0.84 eq
    > > 27890
    > > access-list 101 permit tcp 10.10.0.0 0.0.255.255 host 10.10.0.84 eq
    > > 27890
    > > dialer-list 1 protocol ip list 101
    > > no cdp run
    > > !

    >
    > It might be correct, depending on your network topology. You don't
    > give enough information to tell.
    >
    > You can use debug dialer packet to see if your traffic is
    > considered interesting or not. If it isn't, your configuration is wrong.
    > If it is, something else is.
    >
    > --
    > Rgds,
    > Martin- Hide quoted text -
    >
    > - Show quoted text -


    Hi Martin

    Thanks for the reply.

    will try the debug dialer.

    The network is a simple.

    One ethernet , One Bri port connected .


    Pc is connected on Ethernet on 10.10.0.84 and listens on 27890.

    Everything works and clients connect ok using ppp dialup. Just the
    IDLE timeout kicks them off after 600 seconds. Even during transfer of
    data on 27880/.

    I suspect it could be old IOS causing this..
     
    Patt, Jun 18, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rob
    Replies:
    1
    Views:
    4,179
    Walter Roberson
    Nov 17, 2004
  2. Loren Amelang
    Replies:
    3
    Views:
    2,352
  3. Reinhard
    Replies:
    0
    Views:
    810
    Reinhard
    Mar 7, 2005
  4. Matt
    Replies:
    10
    Views:
    1,426
    Aaron Leonard
    Dec 6, 2005
  5. Dan Lanciani
    Replies:
    0
    Views:
    1,088
    Dan Lanciani
    Jul 28, 2008
Loading...

Share This Page