Dialer caller does not match

Discussion in 'Cisco' started by Dirk, May 24, 2005.

  1. Dirk

    Dirk Guest

    Hi,

    I have "dialer caller" commands in my Cisco ISDN PRI configuration that
    are
    supposed to assign IP addresses depending on the caller id. If no
    dialer caller matches, there is a general profile ("dialer caller x")
    which shall be used in that case.

    The problem is that always the general profile is used, even though the
    caller id is being transmitted. But when removing the "dialer caller x"
    profile, the correct dialer is selected by the acess router.

    The config:

    ....
    interface Dialer8
    description "xxx"
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 130
    dialer caller 01234567890
    dialer-group 1
    peer default ip address pool dialin_pool_8
    ppp authentication chap pap callin
    !
    interface Dialer9
    description "zzz"
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 130
    dialer caller 98765432321
    dialer-group 1
    peer default ip address pool dialin_pool_9
    ppp authentication chap pap callin
    !
    interface Dialer99
    description "Dial-in unknown number"
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 130
    dialer caller x
    dialer-group 1
    peer default ip address pool dialin_pool
    ppp authentication chap pap callin
    !

    Does anyone has an idea why the first two dialers are not used?

    Thank you very much!!

    Dirk
     
    Dirk, May 24, 2005
    #1
    1. Advertising

  2. Dirk schrieb:

    > Hi,
    >
    > I have "dialer caller" commands in my Cisco ISDN PRI configuration that
    > are
    > supposed to assign IP addresses depending on the caller id. If no
    > dialer caller matches, there is a general profile ("dialer caller x")
    > which shall be used in that case.
    >
    > The problem is that always the general profile is used, even though the
    > caller id is being transmitted. But when removing the "dialer caller x"
    > profile, the correct dialer is selected by the acess router.
    >
    > The config:
    >
    > ...
    > interface Dialer8
    > description "xxx"
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 130
    > dialer caller 01234567890
    > dialer-group 1
    > peer default ip address pool dialin_pool_8
    > ppp authentication chap pap callin
    > !
    > interface Dialer9
    > description "zzz"
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 130
    > dialer caller 98765432321
    > dialer-group 1
    > peer default ip address pool dialin_pool_9
    > ppp authentication chap pap callin
    > !
    > interface Dialer99
    > description "Dial-in unknown number"
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 130
    > dialer caller x
    > dialer-group 1
    > peer default ip address pool dialin_pool
    > ppp authentication chap pap callin
    > !
    >
    > Does anyone has an idea why the first two dialers are not used?
    >
    > Thank you very much!!
    >
    > Dirk
    >


    Hi Dirk,

    the decision is based on the first match. If only one X is in the
    command the match is reached after on check. So it is necesary to use
    more x's as the count of digets in your logest number.

    dialer caller 01234567890
    dialer caller 98765432321
    =>
    dialer caller xxxxxxxxxxxx
     
    Helmut Ulrich, May 25, 2005
    #2
    1. Advertising

  3. Dirk

    Dirk Guest

    Hi Helmut,

    I used 22 x's in the last dialer profile, but it still does not
    work:

    --------------------
    May 31 06:43:20: ISDN Se3/0:15: RX <- SETUP pd = 8 callref = 0x0027
    May 31 06:43:20: Bearer Capability i = 0x8890
    May 31 06:43:20: Channel ID i = 0xA98381
    May 31 06:43:20: Calling Party Number i = 0x21, 0x81,
    '1234182303', Plan:ISDN, Type:National
    May 31 06:43:20: Called Party Number i = 0xC1, '8170',
    Plan:ISDN, Type:Subscriber(local)
    May 31 06:43:20: Se3/0:0 DDR: Caller id 1234182303 matched to profile
    May 31 06:43:20: %DIALER-6-BIND: Interface Se3/0:0 bound to profile
    Di99
    May 31 06:43:20: %LINK-3-UPDOWN: Interface Serial3/0:0, changed state
    to up
    May 31 06:43:20: Se3/0:0 PPP: Using dialer call direction
    May 31 06:43:20: Se3/0:0 PPP: Treating connection as a callin
    ----------------------

    The call is bound to dialer 99, though the calling party number
    exactly matches dialer 2 (which contains no x's).

    Here is the config (excerpt):

    isdn switch-type primary-net5
    !
    controller E1 3/0
    pri-group timeslots 1-31
    !
    !
    !
    interface Loopback1
    ip address 172.16.150.129 255.255.255.224
    !
    interface FastEthernet1/0
    ip address 172.16.47.171 255.255.255.192
    duplex auto
    speed auto
    !
    interface Serial3/0:15
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type primary-net5
    isdn incoming-voice modem
    no peer default ip address
    no fair-queue
    !
    interface Dialer2
    description "Dialin test"
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 130
    dialer caller 1234182303
    dialer-group 1
    peer default ip address pool dialin_pool_2
    ppp authentication chap
    !
    interface Dialer99
    description "Dialin - unknown"
    ip unnumbered Loopback1
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 130
    dialer mult-map-same-name
    dialer caller xxxxxxxxxxxxxxxxxxxxxx
    dialer-group 1
    peer default ip address pool dialin_pool
    ppp authentication chap pap callin
    ppp ipcp ignore-map
    !
    ip local pool dialin_pool_1 172.16.150.130
    ip local pool dialin_pool_2 172.16.150.131
    ip local pool dialin_pool_3 172.16.150.132
    ip local pool dialin_pool_4 172.16.150.133
    ip local pool dialin_pool_7 172.16.150.136
    ip local pool dialin_pool_5 172.16.150.134
    ip local pool dialin_pool_6 172.16.150.135
    ip local pool dialin_pool_8 172.16.150.137 172.16.150.140
    ip local pool dialin_pool_9 172.16.150.141 172.16.150.142
    ip local pool dialin_pool 172.16.150.143 172.16.150.158
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.16.47.131
    no ip http server


    Any idea what still could be wrong?

    Best regards
    Dirk


    Helmut Ulrich wrote:
    > Dirk schrieb:
    >
    > > Hi,
    > >
    > > I have "dialer caller" commands in my Cisco ISDN PRI configuration that
    > > are
    > > supposed to assign IP addresses depending on the caller id. If no
    > > dialer caller matches, there is a general profile ("dialer caller x")
    > > which shall be used in that case.
    > >
    > > The problem is that always the general profile is used, even though the
    > > caller id is being transmitted. But when removing the "dialer caller x"
    > > profile, the correct dialer is selected by the acess router.
    > >
    > > The config:
    > >
    > > ...
    > > interface Dialer8
    > > description "xxx"
    > > ip unnumbered Loopback1
    > > encapsulation ppp
    > > dialer pool 1
    > > dialer idle-timeout 130
    > > dialer caller 01234567890
    > > dialer-group 1
    > > peer default ip address pool dialin_pool_8
    > > ppp authentication chap pap callin
    > > !
    > > interface Dialer9
    > > description "zzz"
    > > ip unnumbered Loopback1
    > > encapsulation ppp
    > > dialer pool 1
    > > dialer idle-timeout 130
    > > dialer caller 98765432321
    > > dialer-group 1
    > > peer default ip address pool dialin_pool_9
    > > ppp authentication chap pap callin
    > > !
    > > interface Dialer99
    > > description "Dial-in unknown number"
    > > ip unnumbered Loopback1
    > > encapsulation ppp
    > > dialer pool 1
    > > dialer idle-timeout 130
    > > dialer caller x
    > > dialer-group 1
    > > peer default ip address pool dialin_pool
    > > ppp authentication chap pap callin
    > > !
    > >
    > > Does anyone has an idea why the first two dialers are not used?
    > >
    > > Thank you very much!!
    > >
    > > Dirk
    > >

    >
    > Hi Dirk,
    >
    > the decision is based on the first match. If only one X is in the
    > command the match is reached after on check. So it is necesary to use
    > more x's as the count of digets in your logest number.
    >
    > dialer caller 01234567890
    > dialer caller 98765432321
    > =>
    > dialer caller xxxxxxxxxxxx
     
    Dirk, May 31, 2005
    #3
  4. Dirk schrieb:
    > Hi Helmut,
    >
    > I used 22 x's in the last dialer profile, but it still does not
    > work:
    >
    > --------------------
    > May 31 06:43:20: ISDN Se3/0:15: RX <- SETUP pd = 8 callref = 0x0027
    > May 31 06:43:20: Bearer Capability i = 0x8890
    > May 31 06:43:20: Channel ID i = 0xA98381
    > May 31 06:43:20: Calling Party Number i = 0x21, 0x81,
    > '1234182303', Plan:ISDN, Type:National
    > May 31 06:43:20: Called Party Number i = 0xC1, '8170',
    > Plan:ISDN, Type:Subscriber(local)
    > May 31 06:43:20: Se3/0:0 DDR: Caller id 1234182303 matched to profile
    > May 31 06:43:20: %DIALER-6-BIND: Interface Se3/0:0 bound to profile
    > Di99
    > May 31 06:43:20: %LINK-3-UPDOWN: Interface Serial3/0:0, changed state
    > to up
    > May 31 06:43:20: Se3/0:0 PPP: Using dialer call direction
    > May 31 06:43:20: Se3/0:0 PPP: Treating connection as a callin
    > ----------------------
    >
    > The call is bound to dialer 99, though the calling party number
    > exactly matches dialer 2 (which contains no x's).
    >
    > Here is the config (excerpt):
    >
    > isdn switch-type primary-net5
    > !
    > controller E1 3/0
    > pri-group timeslots 1-31
    > !
    > !
    > !
    > interface Loopback1
    > ip address 172.16.150.129 255.255.255.224
    > !
    > interface FastEthernet1/0
    > ip address 172.16.47.171 255.255.255.192
    > duplex auto
    > speed auto
    > !
    > interface Serial3/0:15
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool-member 1
    > isdn switch-type primary-net5
    > isdn incoming-voice modem
    > no peer default ip address
    > no fair-queue
    > !
    > interface Dialer2
    > description "Dialin test"
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 130
    > dialer caller 1234182303
    > dialer-group 1
    > peer default ip address pool dialin_pool_2
    > ppp authentication chap
    > !
    > interface Dialer99
    > description "Dialin - unknown"
    > ip unnumbered Loopback1
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 130
    > dialer mult-map-same-name
    > dialer caller xxxxxxxxxxxxxxxxxxxxxx
    > dialer-group 1
    > peer default ip address pool dialin_pool
    > ppp authentication chap pap callin
    > ppp ipcp ignore-map
    > !
    > ip local pool dialin_pool_1 172.16.150.130
    > ip local pool dialin_pool_2 172.16.150.131
    > ip local pool dialin_pool_3 172.16.150.132
    > ip local pool dialin_pool_4 172.16.150.133
    > ip local pool dialin_pool_7 172.16.150.136
    > ip local pool dialin_pool_5 172.16.150.134
    > ip local pool dialin_pool_6 172.16.150.135
    > ip local pool dialin_pool_8 172.16.150.137 172.16.150.140
    > ip local pool dialin_pool_9 172.16.150.141 172.16.150.142
    > ip local pool dialin_pool 172.16.150.143 172.16.150.158
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 172.16.47.131
    > no ip http server
    >
    >
    > Any idea what still could be wrong?
    >
    > Best regards
    > Dirk
    >
    >


    Ok here is a new theory:
    The dialer interface are checked against the dialer caller number in
    order that the highest interface is checked first. If a interface caller
    configuration matches this interface is used.
    So change the configuration for dialer 2 and dialer 99 and it should work.
     
    Helmut Ulrich, May 31, 2005
    #4
  5. Dirk

    Dirk Guest

    Sorry, it still does not work. I removed dialer 99 and added a dialer 0
    interface and now the call is bound to dialer 0. I tried "dialer caller
    x" as well as "dialer caller xxxxxxxxxxxxxxxxxx" on that dialer
    interface, but without success. Somehow the router likes x's more than
    numbers....

    Best regards
    Dirk
     
    Dirk, Jun 1, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Arjan
    Replies:
    0
    Views:
    694
    Arjan
    Apr 2, 2004
  2. John
    Replies:
    0
    Views:
    653
  3. John
    Replies:
    0
    Views:
    722
  4. DenisJ
    Replies:
    1
    Views:
    4,536
    mgasparr
    Aug 31, 2006
  5. Dan Lanciani
    Replies:
    0
    Views:
    1,090
    Dan Lanciani
    Jul 28, 2008
Loading...

Share This Page