DHCP relay problem

Discussion in 'Cisco' started by Iggy, Feb 10, 2005.

  1. Iggy

    Iggy Guest

    My Windows XP SP2 client is unable to acquire IP address from Windows 2003
    DHCP server. I configured ip helper-address on SVI... ip forward-protocol
    udp has been entered. I tried this on Catalyst3750 and 2811 router and there
    is no success...please help...
    My windows client always acquire address from dhcp server when they are both
    in the same VLAN. Of course, interVLAN routing works properly...

    Is there something else to be configured?

    B.R.
    Igor
    Iggy, Feb 10, 2005
    #1
    1. Advertising

  2. Iggy

    Guest

    post the config without passwords
    , Feb 10, 2005
    #2
    1. Advertising

  3. Iggy

    Iggy Guest

    Here is my show run output:

    ------------------ show running-config ------------------


    Building configuration...

    Current configuration : 6301 bytes
    !
    ! Last configuration change at 10:06:48 CET Fri Feb 11 2005 by manager
    ! NVRAM config last updated at 17:47:56 CET Wed Feb 9 2005 by manager
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log datetime localtime
    service password-encryption
    no service dhcp
    !
    hostname INEM_c3750
    !
    logging buffered informational
    enable secret ********
    !
    username ******* password *******
    clock timezone CET 1
    ip subnet-zero
    ip routing
    !
    !
    policy-map test
    !
    cluster enable Koncar 0
    cluster member 2 mac-address 0011.21f7.0b40
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    spanning-tree vlan 1 priority 24576
    !
    ! <irrelevant ports for the case removed for brevity>
    !

    interface GigabitEthernet1/0/15
    description This is where DHCP client connects
    switchport access vlan 3
    no mdix auto
    no cdp enable
    spanning-tree portfast
    spanning-tree guard root

    interface Vlan1
    description This is SVI for DHCP Server's VLAN
    ip address 192.168.73.2 255.255.255.0
    !

    !
    interface Vlan3
    description SVI for DHCP client's VLAN
    ip address 192.168.74.1
    ip helper-address 192.168.73.6
    !
    router eigrp 1
    redistribute static metric 1000000 20 255 1 1500
    network 192.168.6.0
    network 192.168.34.0
    network 192.168.71.0
    network 192.168.73.0
    auto-summary
    no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.71.1
    ip route 192.168.70.0 255.255.255.0 192.168.71.1
    ip http server
    !
    ip access-list extended CMP-NAT-ACL
    dynamic Cluster-HSRP deny ip any any
    dynamic Cluster-NAT permit ip any any
    !
    logging 192.168.73.13
    snmp-server community <removed> RO
    snmp-server community <removed> RO

    !
    line con 0
    line vty 0 4
    exec-timeout 0 0
    login local
    line vty 5 15
    exec-timeout 0 0
    login local
    !
    ntp clock-period 36028942
    ntp server 192.168.73.68
    end

    ------------------------------------------
    B.R.
    Igor


    <> wrote in message
    news:...
    >
    > post the config without passwords
    >
    Iggy, Feb 11, 2005
    #3
  4. Iggy

    Guest

    The command "no service dhcp" maybe disabling the DHCP relay agent.

    Try removing that command to see if the router will perform the
    required DHCP realy agent function.

    Please post outccome.
    , Feb 11, 2005
    #4
  5. Iggy

    Iggy Guest

    I tried to enable DHCP service, but there is still nothing... I checked
    what's happening using 'debug ip dhcp server packets' and discovered that my
    switch actually do dhcp bootp messages forwarding to the ip helper
    address... So, it seems that there is a problem with DHCP server config.

    I suppose that the following is happening:
    - switch forwards bootp message and rewrites 'giaddr ' field (with value of
    client's SVI ip address)
    - DHCP server receives this message and reads that according to 'giaddr'
    field' client is not on the subnet for which server has a range (this is my
    production DHCP server, so it has a range on single subnet and VLAN for
    client is testing environment).
    - DHCP server refuses to send DHCP offer.

    If this is a cause of my problem then it's obvious that I'm expecting the
    impossible:) I hoped that my DHCP server will issue a production range (just
    to test if my dhcp relay is working), but I overlooked 'giaddr' field...

    Next week I will create an additional scope on my DHCP server and then try
    again...

    Of course, I'll post outcome

    B.R.
    Igor

    <> wrote in message
    news:...
    > The command "no service dhcp" maybe disabling the DHCP relay agent.
    >
    > Try removing that command to see if the router will perform the
    > required DHCP realy agent function.
    >
    > Please post outccome.
    >
    Iggy, Feb 11, 2005
    #5
  6. Iggy wrote:

    > If this is a cause of my problem then it's obvious that I'm expecting the
    > impossible:)


    Yep. That's your problem.

    > Next week I will create an additional scope on my DHCP server and then try
    > again...


    That'll work.

    Regards,

    Marco.
    M.C. van den Bovenkamp, Feb 11, 2005
    #6
  7. Iggy

    Iggy Guest

    Hi,

    As I thought today I created additional scope on my DHCP server and dhcp
    relay is now functioning.

    Thanks everyone for support...

    B.R.
    Igor

    "Iggy" <> wrote in message
    news:cug5i4$nss$...
    > My Windows XP SP2 client is unable to acquire IP address from Windows 2003
    > DHCP server. I configured ip helper-address on SVI... ip forward-protocol
    > udp has been entered. I tried this on Catalyst3750 and 2811 router and
    > there is no success...please help...
    > My windows client always acquire address from dhcp server when they are
    > both in the same VLAN. Of course, interVLAN routing works properly...
    >
    > Is there something else to be configured?
    >
    > B.R.
    > Igor
    >
    >
    Iggy, Feb 16, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. tgot
    Replies:
    2
    Views:
    4,051
    Martin Gallagher
    Feb 13, 2004
  2. Javier
    Replies:
    8
    Views:
    1,132
  3. Rutger Blom

    Cisco VPN 3005 and DHCP relay

    Rutger Blom, May 25, 2004, in forum: Cisco
    Replies:
    0
    Views:
    1,650
    Rutger Blom
    May 25, 2004
  4. John Smith

    aironet 1200 dhcp relay problem

    John Smith, Jan 26, 2005, in forum: Cisco
    Replies:
    2
    Views:
    10,080
    John Smith
    Jan 26, 2005
  5. Vimokh
    Replies:
    3
    Views:
    5,589
    Vimokh
    Sep 6, 2006
Loading...

Share This Page