DHCP on a per-vlan basis?

Discussion in 'Cisco' started by brut, Jan 6, 2006.

  1. brut

    brut Guest

    Hi everyone -

    Here's a questions thats probably easy and I'm glancing over the
    answer: is it possible to configure multiple DHCP pools on a router and
    have them had out addresses to clients on different VLANS without
    leaving the router?

    I've read that you can accomplish this by putting in a seperate DHCP
    server (either *nix or Windows based) and use helper-addresses to
    forward to a particular interface on the server, but I was looking to
    see if its possible to do this on the router (one would assume so with
    the ability to create multiple pools and sub-interfaces for VLANS).

    Any comments/feedback is greatly appreciated. Thanks for your time.

    brut-
     
    brut, Jan 6, 2006
    #1
    1. Advertising

  2. On Fri, 06 Jan 2006 05:35:37 -0800, brut wrote:

    > Here's a questions thats probably easy and I'm glancing over the answer:
    > is it possible to configure multiple DHCP pools on a router and have them
    > had out addresses to clients on different VLANS without leaving the
    > router?
    >


    Like this, do you mean?

    !
    ip dhcp pool net-1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    !
    ip dhcp pool net-2
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.254
    !
    interface vlan1
    ip address 192.168.1.254
    !
    interface vlan2
    ip address 192.168.2.254
    !

    --
    rgds,
    Martin
     
    Martin Gallagher, Jan 7, 2006
    #2
    1. Advertising

  3. brut

    brut Guest

    Aha! That makes sense. I wish the cisco docs explained it a little
    simpler, but that does make perfect sense.

    In order for a router to hand out DHCP for a network, it obviously
    needs an IP address in that same network to receive the broadcast, and
    the router would match the network the broadcast was received on with
    the dhcp pool's "network" statement.

    Thanks for making the totally obvious appear before my eyes. Thanks a
    mil' mate.:)

    brut
     
    brut, Jan 8, 2006
    #3
  4. brut

    Guest

    Not clear. Can you elaborate what you mean?

    if i understand you correctly,...

    >is it possible to configure multiple >DHCP pools on a router

    yes

    >have them had out addresses to clients >on different VLANS without
    >leaving the router?

    router doesn't forward broadcast by default unless you allow them to.
    That is why ip helper-address is needed to be configured on the
    interface.
    If dhcp request was received by the router and the router has a pool it
    can give, then it reply to the client without needing to relay. It will
    know which pool of address to give based on gi add.

    Cheers,
    Jeff
     
    , Jan 9, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Eugis

    DHCP on NT per vlan

    Eugis, Dec 27, 2005, in forum: Cisco
    Replies:
    2
    Views:
    685
  2. Replies:
    25
    Views:
    3,972
    Wolfgang S. Rupprecht
    Mar 2, 2005
  3. Capturing data on a scheduled basis

    , May 1, 2006, in forum: Computer Information
    Replies:
    0
    Views:
    320
  4. Replies:
    2
    Views:
    1,594
    john sumner
    Jun 8, 2007
  5. co0pp3r
    Replies:
    0
    Views:
    525
    co0pp3r
    Sep 14, 2008
Loading...

Share This Page