DHCP on a 2621 through a trunk to a 2950

Discussion in 'Cisco' started by J, Feb 7, 2006.

  1. J

    J Guest

    Greetings. In preparing to work on the policy-based routing for the
    question that was answered earlier today I decided I needed to work out
    some underlying routing problems first. I'm using my home lab for what
    should be a simple proof of concept. I have a 2621XM connect to a 2950
    via a 1Q trunk. I have 2 sub-interfaces created on the 2621 for 2
    different providers (Cox cable and SBC DSL). I have both in my lab.
    Both sub-ifs are set for DHCP. I haven't created any of the network
    behind the border router yet.

    interface FastEthernet0/0
    no ip address
    speed 100
    full-duplex
    !
    interface FastEthernet0/0.10
    description TO SBC DSL
    encapsulation dot1Q 10
    ip address dhcp
    no snmp trap link-status
    !
    interface FastEthernet0/0.20
    description TO Cox Cable
    encapsulation dot1Q 20
    ip address dhcp
    no snmp trap link-status

    The 2950 has 1 trunk interface with vlans 10 and 20 allowed and 2 other
    interfaces in vlan 10 and 20 respectively. Other than that it is
    basically blank a blank config. I did however create vlan 10 and 20
    interfaces with no IPs and unshut them, though I'm not sure if I
    technically needed to.

    interface FastEthernet0/1
    description TO 2621 Fa0/0
    switchport trunk allowed vlan 10,20,30
    switchport mode trunk
    speed 100
    duplex full
    spanning-tree portfast
    spanning-tree bpduguard enable
    !
    interface FastEthernet0/2
    description TO SBC DSL modem
    switchport access vlan 10
    no cdp enable
    spanning-tree portfast
    spanning-tree bpduguard enable
    !
    interface FastEthernet0/3
    description TO Cox cable modem
    switchport access vlan 20
    no cdp enable
    spanning-tree portfast
    spanning-tree bpduguard enable
    !
    interface Vlan10
    no ip address
    no ip route-cache
    !
    interface Vlan20
    no ip address
    no ip route-cache
    !
    vlan 10
    !
    vlan 20

    Fa0/1 TO 2621 Fa0/0 connected trunk full 100
    10/100BaseTX
    Fa0/2 TO SBC DSL modem notconnect 10 auto auto
    10/100BaseTX
    Fa0/3 TO Cox cable modem connected 20 a-full a-100
    10/100BaseTX

    Vlan1 unassigned YES NVRAM administratively
    down down
    Vlan10 unassigned YES unset administratively
    down down
    Vlan20 1.1.1.1 YES manual up
    up
    FastEthernet0/1 unassigned YES unset up
    up
    FastEthernet0/2 unassigned YES unset down
    down
    FastEthernet0/3 unassigned YES unset up
    up

    The problem I'm running into is that the 2621 is not picking up an IP
    address via DHCP. I have confirmed that my 1Q tunnel is working by
    statically assigning Fa0/0.20 on the 2621 an IP as well as vlan 20 on
    the 2950 and pinging between them. CDP is also working. Why wouldn't
    the 2621 pick up an IP through the cable modem? I don't have the DSL
    service hooked up to the 2950 at the moment because I'm using it to
    research solutions (and write this message).

    Any ideas or suggestions? I don't have enough Ethernet interfaces in
    the router to do 2 providers and an inside LAN connection so I'm using
    a switch for interconnection purposes. This should in theory work just
    fine.

    Thanks
    J
    J, Feb 7, 2006
    #1
    1. Advertising

  2. J

    jcottingim Guest

    Your setup is almost identical to mine with the exception of the model
    of switch (and cable provider). There were two things that would stop
    my router from getting DHCP...
    1.) The incomming ACL on the interface - you apparently have not ACL's
    at all
    2.) The switches BPDU's - you are filtering them already.

    With that said, it should be working. However, here's some suggestions.
    You didn't have to create the VLAN interfaces on the switch.

    You should probably remove the IP address from interface VLAN 20. Your
    config doesn't show the IP address, but your interface list does. -
    (They don't match.) Did you modify the listing of your configuration
    before posting?? You said you havn't created the network behind the
    router - Put the switch on that VLAN after you've created it.

    J.Cottingim
    jcottingim, Feb 7, 2006
    #2
    1. Advertising

  3. J

    J Guest

    Thanks for the reply. I had a 3548 to play with as well as lots of
    Cabletron gear but I figured I'd stick with something simple and save
    the better hardware for something else. I may have to span the ports
    and see if my DHCP request is getting through the switch. I'm sure
    though that the trunk is ok. The IP information is old, from previous
    testing. I can't see any errors but that doesn't mean there aren't
    any. I'll see what a sniff turns up. Thanks for the info.

    J
    J, Feb 7, 2006
    #3
  4. J

    J Guest

    The problem is now resolved. After sniffing and finding nothing out of
    the ordinary I reconnected the cable modem directly to the remaining
    unused port on the router and configured that port for dhcp. It pulled
    an IP within seconds. This got me thinking. We're doing MAC filtering
    at our own ISP on all cable modem customers. We allow only 1 MAC
    behind the cable modem unless the customer is a business-class customer
    or if they''ve purchased multiple IPs. I called Cox to inquire if they
    were filtering on the number of IPs as well. Both the 2950 and the
    2621 MACs would both count towards the total. Cox was also doing this
    kind of filtering. The tech was very helpful and made a few changes
    necessary to address the problem. I reconnected the cable modem to the
    switch and voila! It worked. Now my only problem is trying to get the
    2600 to act as a PPPoE client... Thanks for your assistance.

    J
    J, Feb 8, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Weiguang Shi

    Help: 2621 DHCP server problem

    Weiguang Shi, Oct 16, 2003, in forum: Cisco
    Replies:
    10
    Views:
    10,267
    Aaron Leonard
    Oct 27, 2003
  2. Stephan Walter

    DHCP in a vlan over trunk on C2950

    Stephan Walter, Mar 16, 2006, in forum: Cisco
    Replies:
    1
    Views:
    942
  3. filouchke
    Replies:
    0
    Views:
    712
    filouchke
    Nov 15, 2006
  4. John Tressle

    2950 trunk

    John Tressle, Apr 2, 2007, in forum: Cisco
    Replies:
    14
    Views:
    857
    linkwood
    Apr 4, 2007
  5. nbywater

    2950 to 7200 trunk

    nbywater, Jul 3, 2007, in forum: Cisco
    Replies:
    0
    Views:
    439
    nbywater
    Jul 3, 2007
Loading...

Share This Page