DHCP Client problem

Discussion in 'Cisco' started by PecK, Apr 28, 2005.

  1. PecK

    PecK Guest

    Hello all,

    I think Cisco IOS has got a problem with DHCP renewal : my ISP renew my
    public adress every 24 hours and my Cisco 1721 doesn't care about this
    renewal.

    I tested several IOS without success and it works with others routers
    (Zyxel...).

    In fact, my Cisco 1721 doesn't send broadcast when it needs to renew its
    adress, it still uses its unicast adress to renew dhcp lease.

    Here's my log and conf :
    24331: 023865: Apr 28 00:35:34.777 UTCS: Temp IP addr: 82.65.249.243 for
    peer on Interface: Ethernet0
    24332: 023866: Apr 28 00:35:34.777 UTCS: Temp sub net mask: 255.255.255.0
    24333: 023867: Apr 28 00:35:34.777 UTCS: DHCP Lease server:
    82.65.249.254, state: 7 Releasing
    24334: 023868: Apr 28 00:35:34.781 UTCS: DHCP transaction id: 1C54
    24335: 023869: Apr 28 00:35:34.781 UTCS: Lease: 600 secs, Renewal: 60
    secs, Rebind: 600 secs
    24336: 023870: Apr 28 00:35:34.781 UTCS: Temp default-gateway addr:
    82.65.249.254
    24337: 023871: Apr 28 00:35:34.781 UTCS: Next timer fires after: 00:00:00
    24338: 023872: Apr 28 00:35:34.781 UTCS: Retry count: 1 Client-ID:
    0004.dd0c.ea06
    24339: 023873: Apr 28 00:35:34.781 UTCS: Hostname: Tower
    24340: 023874: Apr 28 00:35:34.781 UTCS: DHCP: SRelease placed Server ID
    option: 82.65.249.254
    24341: 023875: Apr 28 00:35:34.781 UTCS: DHCP: SRelease: 259 bytes
    24342: 023876: Apr 28 00:35:34.845 UTCS: DHCP: SRelease attempt # 2 for
    entry:
    24343: 023877: Apr 28 00:35:34.845 UTCS: Temp IP addr: 82.65.249.243 for
    peer on Interface: Ethernet0
    24344: 023878: Apr 28 00:35:34.845 UTCS: Temp sub net mask: 255.255.255.0
    24345: 023879: Apr 28 00:35:34.845 UTCS: DHCP Lease server:
    82.65.249.254, state: 7 Releasing
    24346: 023880: Apr 28 00:35:34.845 UTCS: DHCP transaction id: 1C54
    24347: 023881: Apr 28 00:35:34.845 UTCS: Lease: 600 secs, Renewal: 60
    secs, Rebind: 600 secs
    24348: 023882: Apr 28 00:35:34.845 UTCS: Temp default-gateway addr:
    82.65.249.254
    24349: 023883: Apr 28 00:35:34.845 UTCS: Next timer fires after: 00:00:00
    24350: 023884: Apr 28 00:35:34.845 UTCS: Retry count: 2 Client-ID:
    0004.dd0c.ea06
    24351: 023885: Apr 28 00:35:34.845 UTCS: Hostname: Tower
    24352: 023886: Apr 28 00:35:34.845 UTCS: DHCP: SRelease placed Server ID
    option: 82.65.249.254
    24353: 023887: Apr 28 00:35:34.849 UTCS: DHCP: SRelease: 259 bytes
    24354: 023888: Apr 28 00:35:34.849 UTCS: DHCP: Releasing ipl options:
    24355: 023889: Apr 28 00:35:34.849 UTCS: Clearing default gateway and
    route to 82.65.249.254
    24356: 023890: Apr 28 00:35:34.853 UTCS: Clearing DNS address
    212.27.32.177
    24357: 023891: Apr 28 00:35:34.857 UTCS: Clearing DNS address
    213.228.0.212
    24358: 023892: Apr 28 00:35:35.777 UTCS: DHCP: SRelease attempt # 3 for
    entry:
    24359: 023893: Apr 28 00:35:35.777 UTCS: Temp IP addr: 82.65.249.243 for
    peer on Interface: Ethernet0
    24360: 023894: Apr 28 00:35:35.777 UTCS: Temp sub net mask: 255.255.255.0
    24361: 023895: Apr 28 00:35:35.777 UTCS: DHCP Lease server:
    82.65.249.254, state: 7 Releasing
    24362: 023896: Apr 28 00:35:35.777 UTCS: DHCP transaction id: 1C54
    24363: 023897: Apr 28 00:35:35.777 UTCS: Lease: 600 secs, Renewal: 60
    secs, Rebind: 600 secs
    24364: 023898: Apr 28 00:35:35.777 UTCS: Next timer fires after: 00:00:01
    24365: 023899: Apr 28 00:35:35.777 UTCS: Retry count: 3 Client-ID:
    0004.dd0c.ea06
    24366: 023900: Apr 28 00:35:35.777 UTCS: Hostname: Tower
    24367: 023901: Apr 28 00:35:35.777 UTCS: DHCP: SRelease placed Server ID
    option: 82.65.249.254
    24368: 023902: Apr 28 00:35:35.781 UTCS: DHCP: SRelease: 259 bytes

    version 12.2
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname Tower
    !
    logging buffered 4096 debugging
    no logging console
    !
    clock timezone UTC 1
    clock summer-time UTCS recurring
    aaa new-model
    !
    !
    aaa authentication login local_auth local
    aaa session-id common
    ip subnet-zero
    no ip source-route
    no ip gratuitous-arps
    !
    !
    !
    no ip bootp server
    ip inspect audit-trail
    ip inspect udp idle-time 1800
    ip inspect dns-timeout 7
    ip inspect tcp idle-time 14400
    ip inspect name autosec_inspect cuseeme timeout 3600
    ip inspect name autosec_inspect ftp timeout 3600
    ip inspect name autosec_inspect http timeout 3600
    ip inspect name autosec_inspect rcmd timeout 3600
    ip inspect name autosec_inspect realaudio timeout 3600
    ip inspect name autosec_inspect smtp timeout 3600
    ip inspect name autosec_inspect udp timeout 15
    ip inspect name autosec_inspect tcp timeout 3600
    ip audit notify log
    ip audit po max-events 100
    ip cef
    ip ssh time-out 60
    ip ssh authentication-retries 2
    ip dhcp-client network-discovery informs 2 discovers 2 period 10
    !
    !
    !
    interface Ethernet0
    description Connected to Internet
    ip address dhcp client-id Ethernet0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip inspect autosec_inspect out
    half-duplex
    !
    interface FastEthernet0
    description Connected to LAN
    ip address 192.168.1.206 255.255.255.248
    ip access-group 1 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    speed auto
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip nat inside source static tcp 192.168.1.205 49996 interface Ethernet0
    49996
    ip classless
    no ip http server
    !
    !
    !
    logging trap debugging
    logging facility syslog
    logging 192.168.1.205
    access-list 1 permit 192.168.1.200 0.0.0.7
    no cdp run


    I turned of f my ACL on the interface facing the Internet...

    Has anyone's got the same problem or any idea ?

    Thanks
     
    PecK, Apr 28, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SGVpbkQ=?=

    Wireless DHCP clients cannot obtain an IP address from the DHCP se

    =?Utf-8?B?SGVpbkQ=?=, Jan 8, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    2,847
    =?Utf-8?B?SGVpbkQ=?=
    Jan 8, 2006
  2. Replies:
    4
    Views:
    3,495
  3. PecK

    Cisco DHCP client problem

    PecK, Apr 28, 2005, in forum: Cisco
    Replies:
    0
    Views:
    711
  4. Ingo Hauf

    if Active Directory no DHCP? or: Where ist my DHCP

    Ingo Hauf, Oct 17, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    525
    Ralph Wade Phillips
    Oct 18, 2003
  5. Fayza
    Replies:
    3
    Views:
    12,764
    Dan Shea
    May 12, 2004
Loading...

Share This Page