dhcp cisco806 basic setup question/problem...

Discussion in 'Cisco' started by Captain, Jul 23, 2006.

  1. Captain

    Captain Guest

    I have a cisco 806 router.

    Two(2) ethernet ports on the router.

    Ethernet1 is connected to the internet,
    (receiving it's ip from an external dhcp
    server).

    Ethernet0 is connected to my LAN,(static
    routing is working fine).


    I want the router to assign IP's to internal
    machines,(which don't have static IPs assigned),
    using dhcp. The IP's it is to assign are the
    range: 192.168.0.129<-->192.168.0.254.

    It wont assign anything! What am I missing?


    Partial config follows:
    ///////////////////////////////////////////
    !
    version 12.2
    !
    ip dhcp pool main
    import all
    network 192.168.0.128 255.255.255.128
    default-router 192.168.0.1
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    ip nat inside
    no cdp enable
    hold-queue 32 in
    hold-queue 100 out
    !
    interface Ethernet1
    ip address dhcp
    no ip unreachables
    ip nat outside
    no cdp enable
    !
    ip nat inside source list 101 interface Ethernet1 overload
    !
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    !
    ///////////////////////////////////////////


    ----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----
     
    Captain, Jul 23, 2006
    #1
    1. Advertising

  2. Captain

    Merv Guest

    1. Please post izOS version in use


    2. Suggested config change


    ! configure default route

    ip route 0.0.0.0 0.0.0.0 dhcp



    3. debug DHCP

    conf t
    logging buffer 10000 debug
    no logging console
    end

    wri mem


    clear log
    debug ip dhcp server events
    debug ip dhcp server packets

    Post debug output
     
    Merv, Jul 23, 2006
    #2
    1. Advertising

  3. Captain

    Captain Guest

    On 22 Jul 2006 17:02:10 -0700, "Merv" <> wrote:

    >
    >
    >1. Please post izOS version in use
    >


    Version 12.2(2)
    "flash:c806-sy6-mz.122-2.XI.bin"

    >
    >2. Suggested config change
    >
    >
    >! configure default route
    >
    >ip route 0.0.0.0 0.0.0.0 dhcp
    >
    >


    dhcp is not an option here.




    ----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----
     
    Captain, Jul 23, 2006
    #3
  4. Captain

    Guest

    Captain wrote:
    > Ethernet1 is connected to the internet,
    > (receiving it's ip from an external dhcp
    > server).
    > Ethernet0 is connected to my LAN,(static
    > routing is working fine).
    > I want the router to assign IP's to internal
    > machines,(which don't have static IPs assigned),
    > using dhcp. The IP's it is to assign are the
    > range: 192.168.0.129<-->192.168.0.254.
    > ip dhcp pool main
    > import all
    > network 192.168.0.128 255.255.255.128
    > default-router 192.168.0.1
    > !
    > interface Ethernet0
    > ip address 192.168.0.1 255.255.255.0


    I do this a lot and it works.

    I have no idea if this is the issue however
    your DHCP pool and your LAN address have
    inconsistent netmasks.

    ip dhcp excluded-address 192.168.0.1 192.168.0.127
    ip dhcp pool main
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1

    Is what I use.

    Merv said:-
    ip route 0.0.0.0 0.0.0.0 dhcp

    Thanks. Not seen that one, in the UK
    ADSL is usually PPPoA.
     
    , Jul 23, 2006
    #4
  5. Captain

    Captain Guest

    Thanks, that did the job!


    ////////////////////////////////////////////////////////////
    On 23 Jul 2006 09:39:49 -0700, wrote:
    >
    >Captain wrote:
    >> Ethernet1 is connected to the internet,
    >> (receiving it's ip from an external dhcp
    >> server).
    >> Ethernet0 is connected to my LAN,(static
    >> routing is working fine).
    >> I want the router to assign IP's to internal
    >> machines,(which don't have static IPs assigned),
    >> using dhcp. The IP's it is to assign are the
    >> range: 192.168.0.129<-->192.168.0.254.
    >> ip dhcp pool main
    >> import all
    >> network 192.168.0.128 255.255.255.128
    >> default-router 192.168.0.1
    >> !
    >> interface Ethernet0
    >> ip address 192.168.0.1 255.255.255.0

    >
    >I do this a lot and it works.
    >
    >I have no idea if this is the issue however
    >your DHCP pool and your LAN address have
    >inconsistent netmasks.
    >
    >ip dhcp excluded-address 192.168.0.1 192.168.0.127
    >ip dhcp pool main
    > import all
    > network 192.168.0.0 255.255.255.0
    > default-router 192.168.0.1
    >
    >Is what I use.
    >


    ----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
    ----= East and West-Coast Server Farms - Total Privacy via Encryption =----
     
    Captain, Jul 26, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. haka

    ios for cisco806

    haka, Oct 29, 2003, in forum: Cisco
    Replies:
    3
    Views:
    373
    Rod Dorman
    Oct 31, 2003
  2. Jaime
    Replies:
    2
    Views:
    570
    Jaime
    Sep 20, 2003
  3. Jimmy Dean
    Replies:
    3
    Views:
    1,154
    Duane Arnold
    Jul 25, 2005
  4. Joseph O'Brien

    Basic 1760 setup question

    Joseph O'Brien, Aug 4, 2006, in forum: Cisco
    Replies:
    2
    Views:
    519
  5. Sharp Dressed Man

    TurboTax Basic vs. Taxcut Basic?

    Sharp Dressed Man, Jan 10, 2009, in forum: Computer Support
    Replies:
    1
    Views:
    684
    Sharp Dressed Man
    Jan 12, 2009
Loading...

Share This Page