Default Gateway Problems

Discussion in 'Cisco' started by Darren Green, Oct 2, 2006.

  1. Darren Green

    Darren Green Guest

    I am trying to workout why a router swap at my HQ out is causing me so many
    problems.

    I have an Ethernet network of which the default gateway in 10.0.0.1 /8. To
    this I introduced 2 x new Cisco routers, 10.0.0.2 & 10.0.0.3

    The default gateway, a Cisco 3640, has a small number of static routes these
    are:

    0.0.0.0 pointing to a PIX (10.0.0.99).
    172.22.0.0 /24 pointing at another router 10.0.0.5
    172.16.0.0 /16 pointing to another router 10.0.0.6

    The PIX terminates some remote VPN's with LAN IP's 192.168.X.X /24.

    All I did was move the default gateway address to the 2 x new Cisco routers
    (using HSRP) & renumber the 3640 with a new IP address 10.0.0.4. I
    replicated the static routes off the 3640 on the 2 x new Cisco routers. I
    can ping from a remote site to my Head Office E-Mail Server & Intranet
    Server but I cannot access the E-Mail itself, nor HTTP to the Intranet
    server.

    The 3640 and 2 x new Cisco routers don't route any traffic over the WAN.
    They simply route on the Ethernet segment to either the PIX or next hop
    routers.

    I guess that the old 3640 router probably sent IP redirects to the LAN hosts
    as the HQ Servers using a 'route print' seem to have learnt the PIX / other
    router addresses as their next hop.

    But why oh why do some of the applications stop to work when I swap the
    10.0.0.1 gateway IP to my new boxes ?

    When I reversed the change everything started to work again.

    3640 Ethernet Config:

    interface FastEthernet0/0
    ip address 10.0.0.1 255.0.0.0 (IP address changed to 10.0.0.4 after
    migration)
    speed auto
    half-duplex

    New Router 1 (Cisco 2801)

    Fa0/0 (after moving default gateway address over)

    interface FastEthernet0/0
    ip address 10.0.0.2 255.0.0.0
    no ip redirects
    speed auto
    duplex auto
    standby 1 ip 10.0.0.1
    standby 1 priority 105
    standby 1 preempt

    New Router 2 (878)

    interface vlan 1
    ip address 10.0.0.3 255.0.0.0
    no ip redirects
    speed auto
    duplex auto
    standby 1 ip 10.0.0.1
    standby 1 preempt
     
    Darren Green, Oct 2, 2006
    #1
    1. Advertising

  2. Have you see if the

    - which is the mac address of the vip 10.0.0.1

    - cef is enabled on the router


    http://www.cisco.com/en/US/tech/tk648/tk362/technologies_configuration_example09186a0080093f93.shtml



    "Darren Green" <> wrote in message
    news:...
    >I am trying to workout why a router swap at my HQ out is causing me so many
    >problems.
    >
    > I have an Ethernet network of which the default gateway in 10.0.0.1 /8. To
    > this I introduced 2 x new Cisco routers, 10.0.0.2 & 10.0.0.3
    >
    > The default gateway, a Cisco 3640, has a small number of static routes
    > these are:
    >
    > 0.0.0.0 pointing to a PIX (10.0.0.99).
    > 172.22.0.0 /24 pointing at another router 10.0.0.5
    > 172.16.0.0 /16 pointing to another router 10.0.0.6
    >
    > The PIX terminates some remote VPN's with LAN IP's 192.168.X.X /24.
    >
    > All I did was move the default gateway address to the 2 x new Cisco
    > routers (using HSRP) & renumber the 3640 with a new IP address 10.0.0.4. I
    > replicated the static routes off the 3640 on the 2 x new Cisco routers. I
    > can ping from a remote site to my Head Office E-Mail Server & Intranet
    > Server but I cannot access the E-Mail itself, nor HTTP to the Intranet
    > server.
    >
    > The 3640 and 2 x new Cisco routers don't route any traffic over the WAN.
    > They simply route on the Ethernet segment to either the PIX or next hop
    > routers.
    >
    > I guess that the old 3640 router probably sent IP redirects to the LAN
    > hosts as the HQ Servers using a 'route print' seem to have learnt the PIX
    > / other router addresses as their next hop.
    >
    > But why oh why do some of the applications stop to work when I swap the
    > 10.0.0.1 gateway IP to my new boxes ?
    >
    > When I reversed the change everything started to work again.
    >
    > 3640 Ethernet Config:
    >
    > interface FastEthernet0/0
    > ip address 10.0.0.1 255.0.0.0 (IP address changed to 10.0.0.4 after
    > migration)
    > speed auto
    > half-duplex
    >
    > New Router 1 (Cisco 2801)
    >
    > Fa0/0 (after moving default gateway address over)
    >
    > interface FastEthernet0/0
    > ip address 10.0.0.2 255.0.0.0
    > no ip redirects
    > speed auto
    > duplex auto
    > standby 1 ip 10.0.0.1
    > standby 1 priority 105
    > standby 1 preempt
    >
    > New Router 2 (878)
    >
    > interface vlan 1
    > ip address 10.0.0.3 255.0.0.0
    > no ip redirects
    > speed auto
    > duplex auto
    > standby 1 ip 10.0.0.1
    > standby 1 preempt
    >
    >
    >
     
    Roberto Taccon, Oct 2, 2006
    #2
    1. Advertising

  3. Darren Green

    jj19 Guest

    What happens when you only leave one of the new routers active, same
    problem?

    Would you have a chance to run some debug ip commands to see what is
    happening on the 3600 and compare that to what's running on the new
    routers.

    Juan.
    Darren Green wrote:
    > I am trying to workout why a router swap at my HQ out is causing me so many
    > problems.
    >
    > I have an Ethernet network of which the default gateway in 10.0.0.1 /8. To
    > this I introduced 2 x new Cisco routers, 10.0.0.2 & 10.0.0.3
    >
    > The default gateway, a Cisco 3640, has a small number of static routes these
    > are:
    >
    > 0.0.0.0 pointing to a PIX (10.0.0.99).
    > 172.22.0.0 /24 pointing at another router 10.0.0.5
    > 172.16.0.0 /16 pointing to another router 10.0.0.6
    >
    > The PIX terminates some remote VPN's with LAN IP's 192.168.X.X /24.
    >
    > All I did was move the default gateway address to the 2 x new Cisco routers
    > (using HSRP) & renumber the 3640 with a new IP address 10.0.0.4. I
    > replicated the static routes off the 3640 on the 2 x new Cisco routers. I
    > can ping from a remote site to my Head Office E-Mail Server & Intranet
    > Server but I cannot access the E-Mail itself, nor HTTP to the Intranet
    > server.
    >
    > The 3640 and 2 x new Cisco routers don't route any traffic over the WAN.
    > They simply route on the Ethernet segment to either the PIX or next hop
    > routers.
    >
    > I guess that the old 3640 router probably sent IP redirects to the LAN hosts
    > as the HQ Servers using a 'route print' seem to have learnt the PIX / other
    > router addresses as their next hop.
    >
    > But why oh why do some of the applications stop to work when I swap the
    > 10.0.0.1 gateway IP to my new boxes ?
    >
    > When I reversed the change everything started to work again.
    >
    > 3640 Ethernet Config:
    >
    > interface FastEthernet0/0
    > ip address 10.0.0.1 255.0.0.0 (IP address changed to 10.0.0.4 after
    > migration)
    > speed auto
    > half-duplex
    >
    > New Router 1 (Cisco 2801)
    >
    > Fa0/0 (after moving default gateway address over)
    >
    > interface FastEthernet0/0
    > ip address 10.0.0.2 255.0.0.0
    > no ip redirects
    > speed auto
    > duplex auto
    > standby 1 ip 10.0.0.1
    > standby 1 priority 105
    > standby 1 preempt
    >
    > New Router 2 (878)
    >
    > interface vlan 1
    > ip address 10.0.0.3 255.0.0.0
    > no ip redirects
    > speed auto
    > duplex auto
    > standby 1 ip 10.0.0.1
    > standby 1 preempt
     
    jj19, Oct 2, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mohamad Eslami
    Replies:
    1
    Views:
    755
    Andrew Zhilenko
    May 25, 2004
  2. Frank
    Replies:
    3
    Views:
    4,973
    Andre Wisniewski
    Sep 30, 2004
  3. Rebeccaliu
    Replies:
    0
    Views:
    2,494
    Rebeccaliu
    Nov 1, 2006
  4. John
    Replies:
    0
    Views:
    1,250
  5. mercilessmike

    Gateway to Gateway Tunnel

    mercilessmike, Oct 11, 2007, in forum: Cisco
    Replies:
    0
    Views:
    571
    mercilessmike
    Oct 11, 2007
Loading...

Share This Page