debug command to show adsl traffic

Discussion in 'Cisco' started by tg, Nov 6, 2011.

  1. tg

    tg Guest

    cisco 2561xm router with wic1-adsl card

    trying to find the correct debug command that will show ip info for traffic
    on the adsl line. I want to capture source and destination ip's (much like a
    wireshark readout). I tried debug atm events and debug atm packet and these
    created a lot of output in the syslog but it didn't contain the info I was
    after. I also messed with debug ppp, debug ppatm and debug pppoe but these
    didn't create any info. What is the command I need?
    tg, Nov 6, 2011
    #1
    1. Advertising

  2. tg

    Rob Guest

    tg <> wrote:
    > cisco 2561xm router with wic1-adsl card
    >
    > trying to find the correct debug command that will show ip info for traffic
    > on the adsl line. I want to capture source and destination ip's (much like a
    > wireshark readout). I tried debug atm events and debug atm packet and these
    > created a lot of output in the syslog but it didn't contain the info I was
    > after. I also messed with debug ppp, debug ppatm and debug pppoe but these
    > didn't create any info. What is the command I need?


    It depends on the actual configuration of your ADSL connection.
    Rob, Nov 6, 2011
    #2
    1. Advertising

  3. tg

    tg Guest

    "Rob" <> wrote in message
    news:4all.nl...
    > tg <> wrote:
    >> cisco 2561xm router with wic1-adsl card
    >>
    >> trying to find the correct debug command that will show ip info for
    >> traffic
    >> on the adsl line. I want to capture source and destination ip's (much
    >> like a
    >> wireshark readout). I tried debug atm events and debug atm packet and
    >> these
    >> created a lot of output in the syslog but it didn't contain the info I
    >> was
    >> after. I also messed with debug ppp, debug ppatm and debug pppoe but
    >> these
    >> didn't create any info. What is the command I need?

    >
    > It depends on the actual configuration of your ADSL connection.


    ok, does this help?

    interface ATM0/0
    mtu 1430
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1

    interface Dialer0
    ip address negotiated previous
    ip access-group 10 in
    no ip redirects
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname my-user-name
    ppp chap password 0 mypassword
    tg, Nov 6, 2011
    #3
  4. tg

    Rob Guest

    tg <> wrote:
    >
    >
    > "Rob" <> wrote in message
    > news:4all.nl...
    >> tg <> wrote:
    >>> cisco 2561xm router with wic1-adsl card
    >>>
    >>> trying to find the correct debug command that will show ip info for
    >>> traffic
    >>> on the adsl line. I want to capture source and destination ip's (much
    >>> like a
    >>> wireshark readout). I tried debug atm events and debug atm packet and
    >>> these
    >>> created a lot of output in the syslog but it didn't contain the info I
    >>> was
    >>> after. I also messed with debug ppp, debug ppatm and debug pppoe but
    >>> these
    >>> didn't create any info. What is the command I need?

    >>
    >> It depends on the actual configuration of your ADSL connection.

    >
    > ok, does this help?
    >
    > interface ATM0/0
    > mtu 1430
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    >
    > interface Dialer0
    > ip address negotiated previous
    > ip access-group 10 in
    > no ip redirects
    > no ip proxy-arp
    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > dialer pool 1
    > dialer idle-timeout 0
    > dialer persistent
    > dialer-group 1
    > no cdp enable
    > ppp authentication chap callin
    > ppp chap hostname my-user-name
    > ppp chap password 0 mypassword


    Ok so you have PPPoA (PPP over ATM) on your ADSL line.
    You can use debug ppp packet.
    (or debug ip packet, of course)

    Remember that this will usually kill your router when done without
    an access list.
    Rob, Nov 6, 2011
    #4
  5. tg

    tg Guest


    > Ok so you have PPPoA (PPP over ATM) on your ADSL line.
    > You can use debug ppp packet.
    > (or debug ip packet, of course)
    >
    > Remember that this will usually kill your router when done without
    > an access list.


    debug ppp packet produces nothing from my router but debug ip packet seems
    to hit the nail on the head, thanks for your input Rob.
    tg, Nov 7, 2011
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter Jonas
    Replies:
    3
    Views:
    832
    Walter Roberson
    Jan 5, 2004
  2. Mariano Herrero

    Debug Command for CISCO Routers

    Mariano Herrero, Apr 20, 2004, in forum: Cisco
    Replies:
    7
    Views:
    7,036
    Mariano Herrero
    Apr 29, 2004
  3. arme35
    Replies:
    3
    Views:
    1,663
  4. Mike Rahl
    Replies:
    6
    Views:
    2,318
    Walter Roberson
    Dec 12, 2006
  5. Replies:
    1
    Views:
    3,424
    Martin Gallagher
    Jun 5, 2007
Loading...

Share This Page