D70s wont power up memory led will stay blinking

Discussion in 'Digital Photography' started by scuba@uaimail.com.br, Jul 18, 2005.

  1. Guest

    Does anybody had this problem with the D70s. Tried the reset button
    with no luck. The top display shows nothing with the battery in place
    and the memory green led will blink constantly when the memory is in
    place. I am able to briefly see a picture taken when pressing the play
    button but will shut off straight after. Any comments apreciated.

    Thanks...
    , Jul 18, 2005
    #1
    1. Advertising

  2. Owamanga Guest

    On 17 Jul 2005 18:43:25 -0700, wrote:

    >Does anybody had this problem with the D70s. Tried the reset button
    >with no luck. The top display shows nothing with the battery in place
    >and the memory green led will blink constantly when the memory is in
    >place. I am able to briefly see a picture taken when pressing the play
    >button but will shut off straight after. Any comments apreciated.


    Never seen that before. Have you tried taking the lens off in case
    there is a faulty connection screwing up the camera?

    ....fully charged the battery ?


    --
    Owamanga!
    http://www.pbase.com/owamanga
    Owamanga, Jul 18, 2005
    #2
    1. Advertising

  3. JR Guest

    This was a problem with the D70....You will have to send it in to Nikon
    service...

    JR



    In article <>,
    wrote:

    > Does anybody had this problem with the D70s. Tried the reset button
    > with no luck. The top display shows nothing with the battery in place
    > and the memory green led will blink constantly when the memory is in
    > place. I am able to briefly see a picture taken when pressing the play
    > button but will shut off straight after. Any comments apreciated.
    >
    > Thanks...
    JR, Jul 18, 2005
    #3
  4. [BnH] Guest

    You sure is a D70s ? keep us updated and if possible mail me your serial.
    A friend in Nikon is interested on the development of your unit.

    thx

    <> wrote in message
    news:...
    > Does anybody had this problem with the D70s. Tried the reset button
    > with no luck. The top display shows nothing with the battery in place
    > and the memory green led will blink constantly when the memory is in
    > place. I am able to briefly see a picture taken when pressing the play
    > button but will shut off straight after. Any comments apreciated.
    >
    > Thanks...
    >
    [BnH], Jul 18, 2005
    #4
  5. Jim Guest

    <> wrote in message
    news:...
    > Does anybody had this problem with the D70s. Tried the reset button
    > with no luck. The top display shows nothing with the battery in place
    > and the memory green led will blink constantly when the memory is in
    > place. I am able to briefly see a picture taken when pressing the play
    > button but will shut off straight after. Any comments apreciated.
    >
    > Thanks...
    >

    I had this problem with a D70. I bought it in March of 2004, and it
    developed this problem in May of 2005. Nikon repaired it under warranty
    even though it was more than a year old. The fix involved replacing two PC
    boards...
    Jim
    Jim, Jul 18, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Michael Neumann

    2950T-24 dead with blinking sys led

    Michael Neumann, Sep 7, 2004, in forum: Cisco
    Replies:
    3
    Views:
    752
    Doug McIntyre
    Sep 8, 2004
  2. AM
    Replies:
    0
    Views:
    444
  3. Harrison

    Power and HDD LED's blinking

    Harrison, Sep 13, 2005, in forum: Computer Support
    Replies:
    2
    Views:
    3,758
    Harrison
    Sep 13, 2005
  4. E Pericoloso Sporgersi

    LED there be Light, a D.I.Y. LED ringlight

    E Pericoloso Sporgersi, Aug 10, 2003, in forum: Digital Photography
    Replies:
    18
    Views:
    9,528
    Tim Brown
    Aug 19, 2003
  5. Jack B. Pollack

    Netgear WGR614 wireless LED blinking

    Jack B. Pollack, Jan 4, 2007, in forum: Computer Support
    Replies:
    5
    Views:
    5,466
    Jack B. Pollack
    Jan 5, 2007
Loading...

Share This Page