? corrupted JPG files

Discussion in 'Digital Photography' started by JRS, Feb 23, 2006.

  1. JRS

    JRS Guest

    I know this is touched on regularly but I'm not sure if my case is different
    as the thumbs in windows explorer look perfect. However, when opening the
    file in a variety of applications (PSE4, PI10, ACDsee, Irfan, etc) the image
    is all there but seems to be divided into 4 or 5 large blocks with a
    different colour cast. one block has the correct tones though. does anyone
    know how i might fix this? This is how the image was stored on the CF card
    and the picture taken with a dimage s414. sods law its one of the best
    pictures.

    i have tried various image recovery programmes but they just recover the
    same image off the CF

    Thanks

    jon
     
    JRS, Feb 23, 2006
    #1
    1. Advertising

  2. JRS

    Pat Guest

    Can you post one somewhere so we can see it. It might help. Also it
    would allow other people to open it with other software.
     
    Pat, Feb 23, 2006
    #2
    1. Advertising

  3. JRS

    Hunt Guest

    In article <43fd99f7$0$3623$>, something@f
    9.co.uk says...
    >
    >I know this is touched on regularly but I'm not sure if my case is different
    >as the thumbs in windows explorer look perfect. However, when opening the
    >file in a variety of applications (PSE4, PI10, ACDsee, Irfan, etc) the image
    >is all there but seems to be divided into 4 or 5 large blocks with a
    >different colour cast. one block has the correct tones though. does anyone
    >know how i might fix this? This is how the image was stored on the CF card
    >and the picture taken with a dimage s414. sods law its one of the best
    >pictures.
    >
    >i have tried various image recovery programmes but they just recover the
    >same image off the CF
    >
    >Thanks
    >
    >jon


    Yes, the file(s) has become corrupted. In most cases, it will be beyond
    repair, other than manually cutting apart the image, placing the parts on
    separate Layers (PS, and maybe PSE, or similar), making corrections to the
    color/density and maybe contrast, then Flatteneing the resulting image.

    First thing I would do, however, is copy all of the files to a backup
    direcctory, and run a file checker program on the "originals," like Norton
    Utilities, DiskDr. There are others out there, and some may be much better.
    See if this finds any problems. If not, look into file recovery programs (
    Google should yield 1,000+ hits), and try some. Again, some will be better
    than others, and many should have "trial" versions. If one does a great job of
    recovering your files, buy it. I know you have tried some, but again, some are
    better than others. I'd go for quite a few, just to see the results. Maybe ALL
    will just yield the corrupt file.

    Lastly, grab your BU CD, or DVD and just restore the files, providing that you
    made one.

    There is probably a problem developing with your HDD. Check it out well, and
    have a backup handy, as you are likely to need it sooner, rather than later.
    Either that, or you have a piece of software (editing, maybe) that is Saving
    corrupted files. Is there a common thread in these files? Maybe all were
    editied in PSE vX? If nothing is common, the HDD is the likely suspect.

    I doubt that you will find an image viewing/editing program that will "fix"
    the files, other than manually doing it.

    Hunt
     
    Hunt, Feb 23, 2006
    #3
  4. JRS

    JRS Guest

    Thanks,

    I have extensive backups of all of my files and no HD probs. this one just
    came off the CF card like it. Not sure if camera id developing fault or
    battery died whilst writing - might have done. Will continue to look and
    learn. I guess I would learn a lot about PShop trying to chop it up and even
    out the colour!

    Jon

    "Hunt" <> wrote in message
    news:...
    > In article <43fd99f7$0$3623$>,
    > something@f
    > 9.co.uk says...
    >>
    >>I know this is touched on regularly but I'm not sure if my case is
    >>different
    >>as the thumbs in windows explorer look perfect. However, when opening the
    >>file in a variety of applications (PSE4, PI10, ACDsee, Irfan, etc) the
    >>image
    >>is all there but seems to be divided into 4 or 5 large blocks with a
    >>different colour cast. one block has the correct tones though. does
    >>anyone
    >>know how i might fix this? This is how the image was stored on the CF card
    >>and the picture taken with a dimage s414. sods law its one of the best
    >>pictures.
    >>
    >>i have tried various image recovery programmes but they just recover the
    >>same image off the CF
    >>
    >>Thanks
    >>
    >>jon

    >
    > Yes, the file(s) has become corrupted. In most cases, it will be beyond
    > repair, other than manually cutting apart the image, placing the parts on
    > separate Layers (PS, and maybe PSE, or similar), making corrections to the
    > color/density and maybe contrast, then Flatteneing the resulting image.
    >
    > First thing I would do, however, is copy all of the files to a backup
    > direcctory, and run a file checker program on the "originals," like Norton
    > Utilities, DiskDr. There are others out there, and some may be much
    > better.
    > See if this finds any problems. If not, look into file recovery programs (
    > Google should yield 1,000+ hits), and try some. Again, some will be better
    > than others, and many should have "trial" versions. If one does a great
    > job of
    > recovering your files, buy it. I know you have tried some, but again, some
    > are
    > better than others. I'd go for quite a few, just to see the results. Maybe
    > ALL
    > will just yield the corrupt file.
    >
    > Lastly, grab your BU CD, or DVD and just restore the files, providing that
    > you
    > made one.
    >
    > There is probably a problem developing with your HDD. Check it out well,
    > and
    > have a backup handy, as you are likely to need it sooner, rather than
    > later.
    > Either that, or you have a piece of software (editing, maybe) that is
    > Saving
    > corrupted files. Is there a common thread in these files? Maybe all were
    > editied in PSE vX? If nothing is common, the HDD is the likely suspect.
    >
    > I doubt that you will find an image viewing/editing program that will
    > "fix"
    > the files, other than manually doing it.
    >
    > Hunt
    >
     
    JRS, Feb 23, 2006
    #4
  5. JRS

    JRS Guest

    "Pat" <> wrote in message
    news:...
    > Can you post one somewhere so we can see it. It might help. Also it
    > would allow other people to open it with other software.
    >

    http://tinyurl.com/rszup

    I've not compressed or reduced it so as not to interfere with the data. No
    masterpiece but of sentimental value.

    Jon
     
    JRS, Feb 23, 2006
    #5
  6. JRS

    ASAAR Guest

    On Thu, 23 Feb 2006 16:00:53 -0000, JRS wrote:

    > I have extensive backups of all of my files and no HD probs. this one just
    > came off the CF card like it. Not sure if camera id developing fault or
    > battery died whilst writing - might have done. Will continue to look and
    > learn. I guess I would learn a lot about PShop trying to chop it up and
    > even out the colour!


    Is there any chance that you used a computer to format the CF card
    in a card reader prior to taking the pictures? Are the pictures
    still on the card, and if so, does the camera display them properly?
     
    ASAAR, Feb 23, 2006
    #6
  7. JRS

    JRS Guest

    "ASAAR" <> wrote in message
    news:...
    > On Thu, 23 Feb 2006 16:00:53 -0000, JRS wrote:
    >
    >> I have extensive backups of all of my files and no HD probs. this one
    >> just
    >> came off the CF card like it. Not sure if camera id developing fault or
    >> battery died whilst writing - might have done. Will continue to look and
    >> learn. I guess I would learn a lot about PShop trying to chop it up and
    >> even out the colour!

    >
    > Is there any chance that you used a computer to format the CF card
    > in a card reader prior to taking the pictures? Are the pictures
    > still on the card, and if so, does the camera display them properly?
    >


    they are no longer on the card. I believe the camera read them ok before I
    transferred them to my PC

    Jon
     
    JRS, Feb 23, 2006
    #7
  8. JRS

    ASAAR Guest

    On Thu, 23 Feb 2006 17:09:10 -0000, JRS wrote:

    > they are no longer on the card. I believe the camera read them ok before I
    > transferred them to my PC


    What I had in mind was that if formatted using the computer, the
    card may now have a FAT32 file system on it, with the camera
    assuming that it was formatted as FAT16. If this is what caused the
    problem you probably could have used a USB cable to transfer good
    copies of the pictures to the computer, whereas using a card reader
    for the transfer would result in bad copies. It's best to always
    format cards using the camera at least once before they're used, but
    before doing this now, it might be wise to take a bunch of test
    shots to test this theory. If you get bad copies of your pictures
    even if they're transferred using the USB then the problem has a
    different cause. But if they come across OK using USB but not if
    using the card reader, then you probably can assume that the camera
    is not defective, and formatting the card in the camera might well
    solve the problem.

    If only a few of the pictures had the bad blocks with unusual
    color casts, you may have to make a large number of test shots to
    have confidence in the test. But if most or all were corrupted,
    then it should only take a few pictures. If all of the pictures
    transfer OK using the USB, it only takes one bad copy using the card
    reader to "prove" the theory.
     
    ASAAR, Feb 23, 2006
    #8
  9. JRS

    JRS Guest

    "ASAAR" <> wrote in message
    news:...
    > On Thu, 23 Feb 2006 17:09:10 -0000, JRS wrote:
    >
    >> they are no longer on the card. I believe the camera read them ok before
    >> I
    >> transferred them to my PC

    >
    > What I had in mind was that if formatted using the computer, the
    > card may now have a FAT32 file system on it, with the camera
    > assuming that it was formatted as FAT16. If this is what caused the
    > problem you probably could have used a USB cable to transfer good
    > copies of the pictures to the computer, whereas using a card reader
    > for the transfer would result in bad copies. It's best to always
    > format cards using the camera at least once before they're used, but
    > before doing this now, it might be wise to take a bunch of test
    > shots to test this theory. If you get bad copies of your pictures
    > even if they're transferred using the USB then the problem has a
    > different cause. But if they come across OK using USB but not if
    > using the card reader, then you probably can assume that the camera
    > is not defective, and formatting the card in the camera might well
    > solve the problem.
    >
    > If only a few of the pictures had the bad blocks with unusual
    > color casts, you may have to make a large number of test shots to
    > have confidence in the test. But if most or all were corrupted,
    > then it should only take a few pictures. If all of the pictures
    > transfer OK using the USB, it only takes one bad copy using the card
    > reader to "prove" the theory.


    Thanks, I only ever format my cards in the device they are intended for.

    Jon

    >
     
    JRS, Feb 23, 2006
    #9
  10. JRS

    Bill Funk Guest

    On Thu, 23 Feb 2006 12:35:18 -0500, ASAAR <> wrote:

    >On Thu, 23 Feb 2006 17:09:10 -0000, JRS wrote:
    >
    >> they are no longer on the card. I believe the camera read them ok before I
    >> transferred them to my PC

    >
    > What I had in mind was that if formatted using the computer, the
    >card may now have a FAT32 file system on it, with the camera
    >assuming that it was formatted as FAT16. If this is what caused the
    >problem you probably could have used a USB cable to transfer good
    >copies of the pictures to the computer, whereas using a card reader
    >for the transfer would result in bad copies. It's best to always
    >format cards using the camera at least once before they're used, but
    >before doing this now, it might be wise to take a bunch of test
    >shots to test this theory. If you get bad copies of your pictures
    >even if they're transferred using the USB then the problem has a
    >different cause. But if they come across OK using USB but not if
    >using the card reader, then you probably can assume that the camera
    >is not defective, and formatting the card in the camera might well
    >solve the problem.


    If the card was formatted to FAT32, while the camera didn't recognize
    FAT32, would the camera be able to put any image files on the card at
    all?
    I think the camera would come up with an error, either not recognizing
    the card, or offering to format the card, wouldn't it?

    For JRS: that sort of corruption happens, sometimes, for reasons
    unknown. A single incident, all by itself, with no other corrupted
    images, can be caused by something as unfortunate as a cosmic ray
    (alpha particle? Beta particle? Someone help me...) or a power glitch.
    If it doesn't happen regularly, there's not much to fix with the
    camera/card.
    Fixing the image is possible with time; as has been sugested, working
    on each individual part of the corrupted image can bring it back.
    Good luck!
    --
    Bill Funk
    replace "g" with "a"
     
    Bill Funk, Feb 23, 2006
    #10
  11. JRS

    socrtwo Guest

    I don't exactly know how to use it, but you can try this Dutch program.
    I had the instructions translated into English, but I still can't
    follow them, maybe you will have better luck:

    http://www.s2services.com/hosted-freeware/jpg-repair.zip

    It deals with the problems you are having which seems to be the gain or
    loss of a few bytes.
     
    socrtwo, Feb 24, 2006
    #11
  12. JRS

    ASAAR Guest

    On Thu, 23 Feb 2006 12:17:22 -0700, Bill Funk wrote:

    > If the card was formatted to FAT32, while the camera didn't recognize
    > FAT32, would the camera be able to put any image files on the card at
    > all?
    > I think the camera would come up with an error, either not recognizing
    > the card, or offering to format the card, wouldn't it?


    There's no telling what would happen, because it depends on how
    the code (in the camera) was written to handle card file I/O. Some
    cameras might see an incompatible card and display an error message,
    others might have poor error checking and slog on, interpreting the
    FAT and its pointers and block sizes in a manner consistent with its
    own mis-assumptions, but sure to cause problems by a computer using
    the correct assumptions used by the formatting program.


    > For JRS: that sort of corruption happens, sometimes, for reasons
    > unknown. A single incident, all by itself, with no other corrupted
    > images, can be caused by something as unfortunate as a cosmic ray
    > (alpha particle? Beta particle? Someone help me...) or a power glitch.
    > If it doesn't happen regularly, there's not much to fix with the
    > camera/card.


    Maybe beta particles. I don't know the makeup of cosmic rays;
    they might consist primarily of very energetic gamma rays and a
    photon torpedo or two. :) Alphas are much shorter range and more
    easily blocked by the inner package coatings that became fairly
    common in mid 80's to early 90's, I think. The worst offenders were
    the expensive mil-spec ceramic packages, because the ceramic
    material contained lots of unsuspected alpha emitters.

    Unfortunately, JRS didn't detail how widespread the problem was,
    which I alluded to in the testing method, ie, corruption in all
    files, just a few, or something in between. As you say, a single
    incident might corrupt a file or two, or if in the right place, wipe
    out the entire card. But corruption to more than a tiny number of
    files probably indicates some other type of problem.


    > Fixing the image is possible with time; as has been sugested, working
    > on each individual part of the corrupted image can bring it back.
    > Good luck!


    I saw a few corrupted images about a year ago on a card in a
    supposedly "new" camera. It was quickly returned, as I had no clue
    as to whether the camera was in any way responsible. A description
    of the bad images (about half were good) would have sounded similar
    to what JRS described, and I wouldn't have been able to reconstruct
    them without extensive image loss. A custom program designed to
    look for and clean up damaged jpg structures might have helped, but
    I'm not familiar with any software like that, and the damaged files
    meant nothing to me anyway . . .
     
    ASAAR, Feb 24, 2006
    #12
  13. JRS

    socrtwo Guest

    There is a commercial program put out by Recoveronix called
    PixRecovery, which is supposed to restore damaged jpgs. It's here:
    http://www.officerecovery.com/pixrecovery/index.htm. I tried using the
    full version and it did not work on the image from the tinyurl link.
    Perhaps someone can try the demo and see if it works (grasping at
    straws).
     
    socrtwo, Feb 24, 2006
    #13
  14. JRS

    socrtwo Guest

    Scratch that, I fixed the file. It did work with the software when I
    deleted all the header information and a little of the jpg image data
    itself with a hex editor. There also appeared to be some blank
    nonsense at the end before the typical jpg ending character. I don't
    know if I really got rid of it all, or I really knoew what I was doing
    bout it worked. PixRecovery saved the image as a 640 X 480 BMP which I
    doubled in size to 1280 X 960 and saved as a JPG.

    The image is here:

    http://www.s2services.com/images/CONVAR38Fixed.jpg

    My site at www.s2services.com has about 250 links to freeware (and
    nonemphasized commercial links too) data recovery products.
     
    socrtwo, Feb 24, 2006
    #14
  15. JRS

    Hunt Guest

    In article <43fddc36$0$82640$>,
    says...
    >
    >Thanks,
    >
    >I have extensive backups of all of my files and no HD probs. this one just
    >came off the CF card like it. Not sure if camera id developing fault or
    >battery died whilst writing - might have done. Will continue to look and
    >learn. I guess I would learn a lot about PShop trying to chop it up and even
    >out the colour!
    >
    >Jon


    [SNIP]

    Good to hear that you have the BUs. If you happen to track down the problem,
    please let us know. One never knows when they can benefit, down the road, from
    another's misfortune.

    If you ever do need to try and reconstruct one of these damaged JPGs in PS,
    let me know, and I can step you through the process. It's not difficult, but
    does require a bit of work, and getting the masks just right at the junctions
    can take some time and trial-n-error.

    Hunt
     
    Hunt, Feb 24, 2006
    #15
  16. JRS

    Bill Funk Guest

    On 23 Feb 2006 18:22:56 -0800, "socrtwo" <> wrote:

    >Scratch that, I fixed the file. It did work with the software when I
    >deleted all the header information and a little of the jpg image data
    >itself with a hex editor. There also appeared to be some blank
    >nonsense at the end before the typical jpg ending character. I don't
    >know if I really got rid of it all, or I really knoew what I was doing
    >bout it worked. PixRecovery saved the image as a 640 X 480 BMP which I
    >doubled in size to 1280 X 960 and saved as a JPG.
    >
    >The image is here:
    >
    >http://www.s2services.com/images/CONVAR38Fixed.jpg
    >
    >My site at www.s2services.com has about 250 links to freeware (and
    >nonemphasized commercial links too) data recovery products.


    That is impressive!
    I wonder how it does that.

    --
    Bill Funk
    replace "g" with "a"
     
    Bill Funk, Feb 24, 2006
    #16
  17. JRS

    socrtwo Guest

    No idea except there is another free app in my website that I mentioned
    before (http://www.s2services.com/hosted-freeware/jpg-repair.zip) that
    allows you to add bytes to jpg images and fix them. It is kind of
    primitive and I haven't figure it out or used it successfully. There
    is a nice Word file readme with sample image illustrations and I had a
    native speaker translate it from the Dutch, but I still can't figure it
    out.

    Please note with PixRecovery, I deleted 10 % of the beginning of the
    file before it worked. Before I did this, the program gave me an error
    of "There's no data to recover," which I had seen before with the app.
     
    socrtwo, Feb 24, 2006
    #17
  18. JRS

    Martin Brown Guest

    JRS wrote:

    > I know this is touched on regularly but I'm not sure if my case is different
    > as the thumbs in windows explorer look perfect.


    The thumbnails almost always do. It is only when you try to decode the
    main JPEG stream that you encounter any corruption in the bulk data.

    Your corruption is somewhat different to the normal kind though. It is a
    much rarer situation where the JPEG encoder has done something very
    strange. Much more common is a block of the file missing or overwritten.

    > However, when opening the
    > file in a variety of applications (PSE4, PI10, ACDsee, Irfan, etc) the image
    > is all there but seems to be divided into 4 or 5 large blocks with a
    > different colour cast. one block has the correct tones though. does anyone
    > know how i might fix this? This is how the image was stored on the CF card
    > and the picture taken with a dimage s414. sods law its one of the best
    > pictures.
    >
    > i have tried various image recovery programmes but they just recover the
    > same image off the CF


    To my amazement that is exactly what the camera appears to have
    recorded. There are identical JPEG coefficients for the same chunk of
    sky, tree and bush repeated twice in a block about 130000 bytes long
    starting at around offest 580000 in the file. If you look carefully at
    the original shot you can see the same branches repeated again in the
    sideslipped band.

    The really odd thing is that they are wrong in the JPEG bitstream and
    not byte alligned. And unlike normal corruption not in multiples of
    filesystem blocksize. It may be worth showing this image to Minolta as
    it was clearly the result of an in camera firmware glitch. Your image
    broke their encoder!

    All I could do with the main image 2272x1704 was to recover the parts
    that were there with no effort made to fill in the missing data. The
    tree looks a bit stunted and the bush flat topped as a result.

    http://www.nezumi.demon.co.uk/temp/

    As conv38fix.jpg (full resolution but with some missing data) 2230465
    bytes. I leave it there for a few days.

    The explanation of the other recovery program that found a 640x480 JPEG
    image is even weirder. It seems Minolta in their infinite wisdom have
    bolted a large thumnail onto the end of the file beyond the final EOI
    marker with a bit of random junk to keep it company. This isn't a
    feature of your damaged file - I checked a couple of sample review
    images too. They have the same quirky structure!

    This means if you cut a fair bit off the front you can obtain a 640x480
    JPEG by using any recovery program that recognises partial JPEG headers.

    Quite a few high MP cameras now add a secondary thumbnail of 640x480 to
    the application specific marker (presumably for faster in camera LCD
    review).

    Regards,
    Martin Brown
     
    Martin Brown, Feb 28, 2006
    #18
  19. JRS

    Martin Brown Guest

    Bill Funk wrote:

    > On 23 Feb 2006 18:22:56 -0800, "socrtwo" <> wrote:
    >
    >>Scratch that, I fixed the file. It did work with the software when I
    >>deleted all the header information and a little of the jpg image data
    >>itself with a hex editor. There also appeared to be some blank
    >>nonsense at the end before the typical jpg ending character. I don't
    >>know if I really got rid of it all, or I really knoew what I was doing
    >>bout it worked. PixRecovery saved the image as a 640 X 480 BMP


    Pixrecovery found an unencapsulated JPEG image 640x480 at the end of the
    main data - certainly better than nothing but it didn't fix the file.

    > That is impressive!
    > I wonder how it does that.


    It recognised the orphanned JPEG header information near the end of the
    file and turned it into a valid decodable file.

    Regards,
    Martin Brown
     
    Martin Brown, Feb 28, 2006
    #19
  20. JRS

    Bill Funk Guest

    On Tue, 28 Feb 2006 15:52:13 +0000, Martin Brown
    <|||newspam|||@nezumi.demon.co.uk> wrote:

    >Bill Funk wrote:
    >
    >> On 23 Feb 2006 18:22:56 -0800, "socrtwo" <> wrote:
    >>
    >>>Scratch that, I fixed the file. It did work with the software when I
    >>>deleted all the header information and a little of the jpg image data
    >>>itself with a hex editor. There also appeared to be some blank
    >>>nonsense at the end before the typical jpg ending character. I don't
    >>>know if I really got rid of it all, or I really knoew what I was doing
    >>>bout it worked. PixRecovery saved the image as a 640 X 480 BMP

    >
    >Pixrecovery found an unencapsulated JPEG image 640x480 at the end of the
    >main data - certainly better than nothing but it didn't fix the file.
    >
    >> That is impressive!
    >> I wonder how it does that.

    >
    >It recognised the orphanned JPEG header information near the end of the
    >file and turned it into a valid decodable file.


    So the header missing will make the image show farkled as the OP's?
    Interesting.
    >
    >Regards,
    >Martin Brown


    --
    Bill Funk
    replace "g" with "a"
     
    Bill Funk, Feb 28, 2006
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. english patient

    PAR2 Files and Corrupted Files

    english patient, Jun 10, 2004, in forum: Computer Support
    Replies:
    3
    Views:
    4,273
    Jeroen Wijnands
    Jun 11, 2004
  2. bb

    software to repair corrupted JPG

    bb, Jan 25, 2005, in forum: Digital Photography
    Replies:
    0
    Views:
    494
  3. DigitalWok

    HELP: Fix corrupted JPG after import

    DigitalWok, Apr 18, 2005, in forum: Digital Photography
    Replies:
    3
    Views:
    1,349
  4. MarcusLeach311

    Corrupted JPG File

    MarcusLeach311, Nov 10, 2007, in forum: Digital Photography
    Replies:
    3
    Views:
    499
  5. SS

    Corrupted .JPG files

    SS, Dec 27, 2007, in forum: Computer Support
    Replies:
    15
    Views:
    1,479
    Plato
    Dec 31, 2007
Loading...

Share This Page