Connecting 2 Cisco Routers (back to back)

Discussion in 'Cisco' started by ANON, Aug 11, 2004.

  1. ANON

    ANON Guest

    Hi everyone,

    This is probably a real novice question but I'm trying to connect two
    routers (2600's) back to back. Unfortunately I can't get them to see
    each other. I've set them up each serial interface with an ip address
    of:

    10.50.0.1
    10.50.0.2

    I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    type: CISCO.

    The problem is that when I run: SHOW INT S0/0

    I keep getting SERIAL UP, LINE PROTOCOL DOWN

    I've notice when I do a SHOW FRAME-RELAY LMI it shows enquiries being
    sent but not received.

    Can anyone help me with this, i'm starting to get really frustrated
    and any help would be much appreciated.

    I can wipe the configs so if anyone can give me all the commands to
    get these two routers to talk to each other that would be fantastic.

    Many thanks,


    Giles
    ANON, Aug 11, 2004
    #1
    1. Advertising

  2. I'm also a novice, could it be you have not used a crossover cable?

    Dave

    "ANON" <> wrote in message
    news:...
    > Hi everyone,
    >
    > This is probably a real novice question but I'm trying to connect two
    > routers (2600's) back to back. Unfortunately I can't get them to see
    > each other. I've set them up each serial interface with an ip address
    > of:
    >
    > 10.50.0.1
    > 10.50.0.2
    >
    > I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    > type: CISCO.
    >
    > The problem is that when I run: SHOW INT S0/0
    >
    > I keep getting SERIAL UP, LINE PROTOCOL DOWN
    >
    > I've notice when I do a SHOW FRAME-RELAY LMI it shows enquiries being
    > sent but not received.
    >
    > Can anyone help me with this, i'm starting to get really frustrated
    > and any help would be much appreciated.
    >
    > I can wipe the configs so if anyone can give me all the commands to
    > get these two routers to talk to each other that would be fantastic.
    >
    > Many thanks,
    >
    >
    > Giles
    David Hodgson, Aug 11, 2004
    #2
    1. Advertising

  3. ANON wrote:

    > Hi everyone,
    >
    > This is probably a real novice question but I'm trying to connect two
    > routers (2600's) back to back. Unfortunately I can't get them to see
    > each other. I've set them up each serial interface with an ip address
    > of:
    >
    > 10.50.0.1
    > 10.50.0.2
    >
    > I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    > type: CISCO.
    >
    > The problem is that when I run: SHOW INT S0/0
    >
    > I keep getting SERIAL UP, LINE PROTOCOL DOWN
    >
    > I've notice when I do a SHOW FRAME-RELAY LMI it shows enquiries being
    > sent but not received.
    >
    > Can anyone help me with this, i'm starting to get really frustrated
    > and any help would be much appreciated.
    >
    > I can wipe the configs so if anyone can give me all the commands to
    > get these two routers to talk to each other that would be fantastic.
    >
    > Many thanks,
    >



    Have you set the clockrate on the DCE router? If not then there's no line
    clock and no way for the routers to sync.

    P.
    Paul S. Brown, Aug 11, 2004
    #3
  4. ANON wrote:

    > This is probably a real novice question but I'm trying to connect two
    > routers (2600's) back to back. Unfortunately I can't get them to see
    > each other. I've set them up each serial interface with an ip address
    > of:
    >
    > 10.50.0.1
    > 10.50.0.2
    >
    > I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    > type: CISCO.
    >
    > The problem is that when I run: SHOW INT S0/0
    >
    > I keep getting SERIAL UP, LINE PROTOCOL DOWN


    You should configure frame-relay switching and provide clocking on the
    box with DCE cable (I assume You're using V.35 DTE and V.35 DCE cables).

    Here's configuration snippet, unfortunately descriptions are in Polish,
    but the config is self-explanatory. It'll set 2Mbit/s FR connection
    between two routers, first config is from the clocking/DCE unit, second
    is from DTE unit.

    --
    this space was intentionally left blank | £ukasz Bromirski
    you can insert your favourite quote here | lukasz:bromirski,net
    =?ISO-8859-2?Q?=A3ukasz_Bromirski?=, Aug 11, 2004
    #4
  5. forget I said anything, should've realized you needed a serial cable, duh!

    "David Hodgson" <> wrote in message
    news:cfcpa7$fmm$1$...
    > I'm also a novice, could it be you have not used a crossover cable?
    >
    > Dave
    >
    > "ANON" <> wrote in message
    > news:...
    > > Hi everyone,
    > >
    > > This is probably a real novice question but I'm trying to connect two
    > > routers (2600's) back to back. Unfortunately I can't get them to see
    > > each other. I've set them up each serial interface with an ip address
    > > of:
    > >
    > > 10.50.0.1
    > > 10.50.0.2
    > >
    > > I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    > > type: CISCO.
    > >
    > > The problem is that when I run: SHOW INT S0/0
    > >
    > > I keep getting SERIAL UP, LINE PROTOCOL DOWN
    > >
    > > I've notice when I do a SHOW FRAME-RELAY LMI it shows enquiries being
    > > sent but not received.
    > >
    > > Can anyone help me with this, i'm starting to get really frustrated
    > > and any help would be much appreciated.
    > >
    > > I can wipe the configs so if anyone can give me all the commands to
    > > get these two routers to talk to each other that would be fantastic.
    > >
    > > Many thanks,
    > >
    > >
    > > Giles

    >
    >
    David Hodgson, Aug 11, 2004
    #5
  6. £ukasz Bromirski wrote:

    > Here's configuration snippet, unfortunately descriptions are in Polish,
    > but the config is self-explanatory. It'll set 2Mbit/s FR connection
    > between two routers, first config is from the clocking/DCE unit, second
    > is from DTE unit.


    Uh, sorry, here it is:
    http://lukasz.bromirski.net/docs/cisco/cisco_faq_pl.html#AEN1182

    --
    this space was intentionally left blank | £ukasz Bromirski
    you can insert your favourite quote here | lukasz:bromirski,net
    =?ISO-8859-2?Q?=A3ukasz_Bromirski?=, Aug 11, 2004
    #6
  7. ANON

    ANON Guest

    Hi,

    Yep, I've set the clock rate on the DCE. I'm using X.21 DTE cable.

    Is there anything specific to configure when using IP with frame
    relay? I can't even ping the interface (despite trying loopback
    too)???

    Thanks for your help.

    Any other suggestions
    ANON, Aug 11, 2004
    #7
  8. ANON

    Steinar Haug Guest

    [ANON]

    | Yep, I've set the clock rate on the DCE. I'm using X.21 DTE cable.
    |
    | Is there anything specific to configure when using IP with frame
    | relay?

    Yes. You need "frame-relay switching" (global command) and "frame-relay
    intf-type dce" under the appropriate interface.

    Steinar Haug, Nethelp consulting,
    Steinar Haug, Aug 11, 2004
    #8
  9. ANON

    hktco Guest

    http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a0080094a3b.shtml

    http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a0080094a3c.shtml

    hktco

    (ANON) wrote in message news:<>...
    > Hi everyone,
    >
    > This is probably a real novice question but I'm trying to connect two
    > routers (2600's) back to back. Unfortunately I can't get them to see
    > each other. I've set them up each serial interface with an ip address
    > of:
    >
    > 10.50.0.1
    > 10.50.0.2
    >
    > I've enabled the serial ports, set encapsulation to FRAME RELAY, lmi
    > type: CISCO.
    >
    > The problem is that when I run: SHOW INT S0/0
    >
    > I keep getting SERIAL UP, LINE PROTOCOL DOWN
    >
    > I've notice when I do a SHOW FRAME-RELAY LMI it shows enquiries being
    > sent but not received.
    >
    > Can anyone help me with this, i'm starting to get really frustrated
    > and any help would be much appreciated.
    >
    > I can wipe the configs so if anyone can give me all the commands to
    > get these two routers to talk to each other that would be fantastic.
    >
    > Many thanks,
    >
    >
    > Giles
    hktco, Aug 11, 2004
    #9
  10. ANON

    ANON Guest

    Hi,

    Just want to say a big thank you for all your help, the routers are
    now up and running fine.

    Those links to Cisco's site were great.

    Cheers!!!
    ANON, Aug 12, 2004
    #10
  11. ANON

    cisconovice

    Joined:
    Oct 13, 2006
    Messages:
    2
    Connecting 2 2600 routers using the 2 wic t1 csu/dsu

    Hi! i was wondering if anyone can help me configure 2 2600 routers back to back using 2 wic t1 csu/dsu's.. i already have a t1 crossover cable. but i dont know how to configure them to talk using frame relay... thanks in advance!
    cisconovice, Oct 13, 2006
    #11
  12. ANON

    katberts

    Joined:
    Apr 2, 2011
    Messages:
    1
    Connect 2 2600 routers using WIC1 DSU

    Hi there,
    I wish I found this site when I was having my hair pulling issues when I tried to connect my two 2600 routers with integrated CSU/DSU (WIC1DSU). I had found plenty of sites with bits of information, but none that had all the information for what I wanted. I wanted to connect my 2 routers using frame relay sub interfaces.

    Things I knew:
    I needed a T1 crossover cable
    Because each router has a T1 WIC1-DSU, I needed to verify/configure the service-module
    I knew I needed to set the clocking on one of the routers to be the master
    .

    Things I thought I knew:
    I assumed each router would need its own DLCI (since in the real world that's how you would do it to get them to talk)
    One of the routers to be DCE since, by default, routers are DTE (but HOW to do it - ah, that was a bit of challenge for my addled pated mind!)

    I got the crossover cable made and validated it. Then I configured the service module (most of these are defaults and do not show up under the serial interface). Note: The clocking need only be modified on the router you want to be the master.

    service-module T1 line b8zs (default)
    service-module T1 framing ESF (default)
    service-module T1 timeslots 1-24 speed 64
    service-module T1 clock source internal (one router only)

    Then I went to the serial interface s0/0 and configured the following:

    encapsulation frame-relay

    I created a sub interface s0/0.100 and configured the following:

    ip address 10.1.12.1 255.255.255.252
    frame-relay interface-dlci 100

    On the 2nd router, I mimicked the configs from serial interface s0/0 above as noted then on the sub interface, I assigned the ip address 10.1.12.2 and then assigned a DLCI of 200.

    The interfaces came up in an up/down state and I could not get them to work. I eventually found out that when you put the 2 routers back to back, you must have each router's sub interfaces assigned with the SAME DLCI.

    So I modified the configs of each sub interface so each router had the same DLCI.

    Still didn't work.

    Somewhere in the recess of my mind, I knew I needed to change one of the routers to be DCE but I could not find how (I did find a fancy youtube video where this guy has a GUI lab and when he clicks on the serial interface of his router picture, this little thing pops up and asks him if he wants this interface to be a DTE or a DCE. Nifty, but not helpful for my situation). I finally found a website which indicated the config I needed:

    frame-relay intf-type dce

    I added that to the serial s0/0 of one router only ( I put it on the router I was using as the master)

    Still did not come up (well, it would come up for about 1 minute then go back into the up/down state).

    I was getting somewhat frustrated by this point. I finally, out of desperation, added a config to my master router that I had seen in a few posts (but didn't think it applied to my situation). Viola, both sides came up and I was able to ping and send traffic across my links.

    In global mode:

    frame-relay switching

    That little command I didn't think applied to me because I only was using 2 routers. In all the scenarios I found on the internet, there were at least 3 or 4 routers and one of the routers was acting like a cloud router. It never occurred to me that, even with 2 routers, using frame relay DLCI, one of them needs to still needs to be a cloud router.

    Here are the complete configs I ended up using:

    R1
    config t
    frame-relay switching

    interface s0/0
    encapsulation frame-relay
    service-module T1 linecode b8zs
    service-module T1 framing esf
    service-module T1 clock source internal
    service-module T1 timeslots 1-24 speed 64
    frame-relay intf-type dce

    interface s0/0.100 point-to-point
    ip address 10.1.12.1 255.255.255.252
    frame-relay interface-dlci 100

    router eigrp 1
    network 10.0.0.0
    no auto-summary


    R2

    interface s0/0
    encapsulation frame-relay
    service-module T1 linecode b8zs
    service-module T1 framing esf
    service-module T1 timeslots 1-24 speed 64

    interface s0/0.100 point-to-point
    ip address 10.1.12.2 255.255.255.252
    frame-relay interface-dlci 100

    router eigrp 1
    network 10.0.0.0
    no auto-summary

    Thanks to sites like these, I was finally able to get all the pieces together to get my lab up and running.
    katberts, Apr 2, 2011
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Melbourne

    Back-to-back G.SHDSL Routers

    Matthew Melbourne, Feb 25, 2004, in forum: Cisco
    Replies:
    0
    Views:
    565
    Matthew Melbourne
    Feb 25, 2004
  2. adam

    back to back routers

    adam, Aug 28, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,763
  3. Jon L. Miller

    cisco routers and netgear routers

    Jon L. Miller, Feb 4, 2005, in forum: Cisco
    Replies:
    2
    Views:
    1,211
    SysAdm
    Feb 5, 2005
  4. Gordon Montgomery

    Connect routers back to back with WIC-1DSU-T1

    Gordon Montgomery, Apr 16, 2005, in forum: Cisco
    Replies:
    4
    Views:
    5,301
    BradReeseCom
    Apr 16, 2005
  5. Replies:
    6
    Views:
    604
Loading...

Share This Page