connect routers via console ports ???

Discussion in 'Cisco' started by J Bard, Dec 27, 2003.

  1. J Bard

    J Bard Guest

    My 2524 came without a serial WAN port ( no doubt I can buy it too on
    ebay) , and I want to play connection and routing games between it and my
    1600.
    I 'm on both routers with console cables from 2 different PC's. With a
    cross over cable I can ping one router from another via their ethernet ports
    , and I suppose I can next try pinging a computer on the LAN (from this
    console connection to the 1600 to a PC on the hub ) but I was wondering
    ....Can one use console ports to connect routers ? Get on one router via
    ethernet and then just use this cross over cable between console ports ?
     
    J Bard, Dec 27, 2003
    #1
    1. Advertising

  2. J Bard

    Ivan Guest

    "J Bard" <> wrote in message
    news:H75Hb.2168$...
    > My 2524 came without a serial WAN port ( no doubt I can buy it too

    on
    > ebay) , and I want to play connection and routing games between it and my
    > 1600.
    > I 'm on both routers with console cables from 2 different PC's. With a
    > cross over cable I can ping one router from another via their ethernet

    ports
    > , and I suppose I can next try pinging a computer on the LAN (from this
    > console connection to the 1600 to a PC on the hub ) but I was wondering
    > ...Can one use console ports to connect routers ? Get on one router via
    > ethernet and then just use this cross over cable between console ports ?
    >


    Theoretically yes, because they are more or less serial connector. There's
    an issue about flow control (you can not expect decent speed).

    Ivan
     
    Ivan, Dec 27, 2003
    #2
    1. Advertising

  3. J Bard

    News Account Guest

    I haven't tried this yet but found it on the web...

    Below is working config for AUX-to-AUX dialup using rollover cable. R1 can
    call R3 using these configs This came from: Brian Dennis, CCIE #2210
    (R&S)(ISP/Dial) CCSI #98640 of 5G Networks, Inc. He posted it on
    Groupstudy.

    Take a rollover cable and run it from the AUX port of one router to the AUX
    port of another. This script simulates DDR over the PSTN and gives you a
    chance to study DDR, backup connections, and routing protocols over DDR
    without having to buy a simulator or an extra line.




    R1#wr t
    Building configuration...
    Current configuration:
    !
    version 12.0
    hostname R1
    !
    username R3 password 0 cisco
    chat-script virtualmodem " "
    !
    interface Async1
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer in-band
    dialer pool-member 1
    async default routing
    async dynamic routing
    async mode dedicated
    no peer default ip address
    no fair-queue
    ppp authentication chap
    !
    interface Dialer0
    ip address 172.16.1.1 255.255.255.0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name R3
    dialer string 5551212
    dialer pool 1
    dialer-group 1
    ppp authentication chap
    !
    ip route 0.0.0.0 0.0.0.0 172.16.1.254
    !
    dialer-list 1 protocol ip permit
    !
    line aux 0
    exec-timeout 0 0
    script dialer virtualmodem
    modem Host
    transport input all
    speed 38400
    flowcontrol hardware
    !
    end



    R3#wr t
    Building configuration...
    Current configuration:
    !
    version 12.0
    !
    hostname R3
    !
    username R1 password 0 cisco
    chat-script virtualmodem " "
    !
    interface Dialer0
    ip address 172.16.1.3 255.255.255.0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name R1
    dialer string 5551212
    dialer pool 1
    dialer-group 1
    ppp authentication chap
    !
    ip classless
    !
    dialer-list 1 protocol ip permit
    !
    line aux 0
    exec-timeout 0 0
    script dialer virtualmodem
    modem Dialin
    transport input all
    speed 38400
    flowcontrol hardware
    !
    end
    R3#

    "J Bard" <> wrote in message
    news:H75Hb.2168$...
    > My 2524 came without a serial WAN port ( no doubt I can buy it too

    on
    > ebay) , and I want to play connection and routing games between it and my
    > 1600.
    > I 'm on both routers with console cables from 2 different PC's. With a
    > cross over cable I can ping one router from another via their ethernet

    ports
    > , and I suppose I can next try pinging a computer on the LAN (from this
    > console connection to the 1600 to a PC on the hub ) but I was wondering
    > ...Can one use console ports to connect routers ? Get on one router via
    > ethernet and then just use this cross over cable between console ports ?
    >
    >
     
    News Account, Dec 27, 2003
    #3
  4. In article <J8oHb.2$hj4.0@fe01>, News Account <> wrote:
    :I haven't tried this yet but found it on the web...

    :Below is working config for AUX-to-AUX dialup using rollover cable. R1 can
    :call R3 using these configs This came from: Brian Dennis, CCIE #2210
    :(R&S)(ISP/Dial) CCSI #98640 of 5G Networks, Inc. He posted it on
    :Groupstudy.

    Yeah, but that's the AUX ports. I would be quite surprised if you
    were able to set up the console ports to route. Sure, they are
    serial connections, but I don't think IOS allows it to be
    configured that way.
    --
    Cannot open .signature: Permission denied
     
    Walter Roberson, Dec 27, 2003
    #4
  5. J Bard

    News Account Guest

    Worth a try!

    "Walter Roberson" <-cnrc.gc.ca> wrote in message
    news:bsl4s6$kk9$...
    > In article <J8oHb.2$hj4.0@fe01>, News Account <> wrote:
    > :I haven't tried this yet but found it on the web...
    >
    > :Below is working config for AUX-to-AUX dialup using rollover cable. R1

    can
    > :call R3 using these configs This came from: Brian Dennis, CCIE #2210
    > :(R&S)(ISP/Dial) CCSI #98640 of 5G Networks, Inc. He posted it on
    > :Groupstudy.
    >
    > Yeah, but that's the AUX ports. I would be quite surprised if you
    > were able to set up the console ports to route. Sure, they are
    > serial connections, but I don't think IOS allows it to be
    > configured that way.
    > --
    > Cannot open .signature: Permission denied
     
    News Account, Dec 28, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dineyar Buhariwala

    Connect 2 routers (wireless and regular routers)

    Dineyar Buhariwala, Nov 22, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    2,594
  2. Kirill Ponazdyr

    How to repair the Cisco console ports.

    Kirill Ponazdyr, Nov 30, 2003, in forum: Cisco
    Replies:
    5
    Views:
    1,652
  3. J Bard
    Replies:
    6
    Views:
    2,629
    Rod Dorman
    Dec 9, 2003
  4. virgilv

    Modem access via console port

    virgilv, Feb 27, 2004, in forum: Cisco
    Replies:
    1
    Views:
    663
    Aaron Leonard
    Feb 27, 2004
  5. Newbie72
    Replies:
    7
    Views:
    2,515
    ArtGle
    Jan 5, 2009
Loading...

Share This Page