connect Router 1841 to DSL modem

Discussion in 'Cisco' started by cisco_crazy, Oct 3, 2009.

  1. cisco_crazy

    cisco_crazy Guest

    hi all,
    if any body has solution to my problem please help me

    i wanted to connect my router to dsl modem so i can connect to the
    internet from that router.

    thats what i did:
    1- i connected port f0/0 to modem
    2- i connect other pcs to F0/0/0 till f0/0/3 (switch modular)
    3- i made f0/0 get ip through dhcp from modem.
    4- i made f0/0 nat outside
    interface FastEthernet0/0
    ip address dhcp
    ip nat outside

    5- i made this nat
    ip nat inside source list salem interface FastEthernet0/0 overload
    !
    ip access-list extended salem
    permit ip 192.168.99.0 0.0.0.255 any

    6- i made int vlan 1 ip address 192.168.99.1 /24
    7- i assign F0/0/0 till f0/0/3 to vlan 1

    so the problem, when i ping from PC to dsl modem i can ping but i can
    not reach the internet ??????????????
     
    cisco_crazy, Oct 3, 2009
    #1
    1. Advertising

  2. cisco_crazy

    Brian V Guest

    "cisco_crazy" <> wrote in message
    news:...
    > hi all,
    > if any body has solution to my problem please help me
    >
    > i wanted to connect my router to dsl modem so i can connect to the
    > internet from that router.
    >
    > thats what i did:
    > 1- i connected port f0/0 to modem
    > 2- i connect other pcs to F0/0/0 till f0/0/3 (switch modular)
    > 3- i made f0/0 get ip through dhcp from modem.
    > 4- i made f0/0 nat outside
    > interface FastEthernet0/0
    > ip address dhcp
    > ip nat outside
    >
    > 5- i made this nat
    > ip nat inside source list salem interface FastEthernet0/0 overload
    > !
    > ip access-list extended salem
    > permit ip 192.168.99.0 0.0.0.255 any
    >
    > 6- i made int vlan 1 ip address 192.168.99.1 /24
    > 7- i assign F0/0/0 till f0/0/3 to vlan 1
    >
    > so the problem, when i ping from PC to dsl modem i can ping but i can
    > not reach the internet ??????????????


    int vlan 1
    ip nat inside
     
    Brian V, Oct 3, 2009
    #2
    1. Advertising

  3. cisco_crazy

    tweety Guest

    On Oct 3, 11:09 pm, "Brian V" <> wrote:
    > "cisco_crazy" <> wrote in message
    >
    > news:...
    >
    >
    >
    >
    >
    > > hi all,
    > > if any body has solution to my problem please help me

    >
    > > i wanted to connect my router to dsl modem so i can connect to the
    > > internet from that router.

    >
    > > thats what i did:
    > > 1- i connected port f0/0 to modem
    > > 2- i connect other pcs to F0/0/0 till f0/0/3 (switch modular)
    > > 3- i made f0/0 get ip through dhcp from modem.
    > > 4- i made f0/0 nat outside
    > > interface FastEthernet0/0
    > > ip address dhcp
    > > ip nat outside

    >
    > > 5- i made this nat
    > > ip nat inside source list salem interface FastEthernet0/0 overload
    > > !
    > > ip access-list extended salem
    > > permit ip 192.168.99.0 0.0.0.255 any

    >
    > > 6- i made int vlan 1 ip address 192.168.99.1 /24
    > > 7- i assign F0/0/0 till f0/0/3 to vlan 1

    >
    > > so the problem, when i ping from PC to dsl modem i can ping but i can
    > > not reach the internet ??????????????

    >
    > int vlan 1
    > ip nat inside- Hide quoted text -
    >
    > - Show quoted text -


    Hi,

    Also through in a default route 0.0.0.0 0.0.0.0 int Fa0/0
     
    tweety, Oct 4, 2009
    #3
  4. cisco_crazy

    cisco_crazy Guest

    On Oct 3, 9:46 pm, cisco_crazy <> wrote:
    > hi all,
    > if any body has solution to my problem please help me
    >
    > i wanted to connect my router to dsl modem so i can connect to the
    > internet from that router.
    >
    > thats what i did:
    > 1- i connected port f0/0 to modem
    > 2- i connect other pcs to F0/0/0 till f0/0/3 (switch modular)
    > 3- i made f0/0 get ip through dhcp from modem.
    > 4- i made f0/0 nat outside
    > interface FastEthernet0/0
    >  ip address dhcp
    >  ip nat outside
    >
    > 5- i made this nat
    > ip nat inside source list salem interface FastEthernet0/0 overload
    > !
    > ip access-list extended salem
    >  permit ip 192.168.99.0 0.0.0.255 any
    >
    > 6- i made int vlan 1 ip address 192.168.99.1 /24
    > 7- i assign F0/0/0 till f0/0/3 to vlan 1
    >
    > so the problem, when i ping from PC to dsl modem i can ping but i can
    > not reach the internet ??????????????


    hi all,
    i tried all suggestions but still not working
     
    cisco_crazy, Oct 5, 2009
    #4
  5. cisco_crazy

    Morph Guest

    Morph, Oct 5, 2009
    #5
  6. cisco_crazy

    Brian V Guest

    "cisco_crazy" <> wrote in message
    news:...
    > On Oct 3, 9:46 pm, cisco_crazy <> wrote:
    >> hi all,
    >> if any body has solution to my problem please help me
    >>
    >> i wanted to connect my router to dsl modem so i can connect to the
    >> internet from that router.
    >>
    >> thats what i did:
    >> 1- i connected port f0/0 to modem
    >> 2- i connect other pcs to F0/0/0 till f0/0/3 (switch modular)
    >> 3- i made f0/0 get ip through dhcp from modem.
    >> 4- i made f0/0 nat outside
    >> interface FastEthernet0/0
    >> ip address dhcp
    >> ip nat outside
    >>
    >> 5- i made this nat
    >> ip nat inside source list salem interface FastEthernet0/0 overload
    >> !
    >> ip access-list extended salem
    >> permit ip 192.168.99.0 0.0.0.255 any
    >>
    >> 6- i made int vlan 1 ip address 192.168.99.1 /24
    >> 7- i assign F0/0/0 till f0/0/3 to vlan 1
    >>
    >> so the problem, when i ping from PC to dsl modem i can ping but i can
    >> not reach the internet ??????????????

    >
    > hi all,
    > i tried all suggestions but still not working


    Post the latest full config.
     
    Brian V, Oct 5, 2009
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Scooter
    Replies:
    0
    Views:
    498
    Scooter
    Feb 26, 2005
  2. Mephesto
    Replies:
    0
    Views:
    1,066
    Mephesto
    Jun 29, 2005
  3. roberthob

    an Intel PRO/DSL 2100 or Intel PRO/DSL 2200 Modem

    roberthob, Sep 25, 2005, in forum: Computer Support
    Replies:
    0
    Views:
    1,719
    roberthob
    Sep 25, 2005
  4. LincolnShep
    Replies:
    3
    Views:
    2,751
    Jack \(MVP-Networking\).
    Nov 8, 2006
  5. sync
    Replies:
    0
    Views:
    592
Loading...

Share This Page