Configuring InterVLAN Routing and ISL Trunking on 2621 Router

Discussion in 'Cisco' started by Peter, Jan 6, 2004.

  1. Peter

    Peter Guest

    I followed the document - 'Cisco - Configuring InterVLAN Routing and
    ISL/802.1Q Trunking on Catalyst 2900XL/3500XL2490/2950/2970' Switches
    Using an External Router'. Everything was fine until I tried to
    configure ISL encapsulation on the router's Fastethernet
    sub-interfaces. The command 'encapsulate' didn't exist when in
    subinterface mode.

    The Catalyst is a 3524 and is running the following IOS:
    Cisco Internetwork Operating System Software
    IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC7,
    RELEASE SOFTWAR
    E (fc1)-+

    And the Router is a 2621 and is runing:
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-I-M), Version 12.0(3)T3, RELEASE
    SOFTWARE (fc1)

    Question(s):

    1. Does the IOS version of my router support ISL encapsulation? If
    so, can you tell me how to configure it.


    Additional Information:

    I have defined three VLANs on the switch. They are as follows:
    VLAN1 192.168.1.35
    VLAN10 192.168.10.0
    VLAN20 192.168.20.0

    ? Does VLAN1 have to exist?

    ? I want traffic to be routed between VLAN10 and VLAN20. What is the
    best way to accomplish this?

    ? The router has two FastEthernet ports and one Ethernet port. Do I
    have to place one FastEthernet port in each VLAN and connect the
    Ethernet port to the exterior router?

    I realize that it may sound a bit confusing, but any assistance would
    be appreciated.
     
    Peter, Jan 6, 2004
    #1
    1. Advertising

  2. Peter

    Jeroen Guest

    "Peter" <> schreef in bericht
    news:...
    > I followed the document - 'Cisco - Configuring InterVLAN Routing and
    > ISL/802.1Q Trunking on Catalyst 2900XL/3500XL2490/2950/2970' Switches
    > Using an External Router'. Everything was fine until I tried to
    > configure ISL encapsulation on the router's Fastethernet
    > sub-interfaces. The command 'encapsulate' didn't exist when in
    > subinterface mode.
    >
    > The Catalyst is a 3524 and is running the following IOS:
    > Cisco Internetwork Operating System Software
    > IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC7,
    > RELEASE SOFTWAR
    > E (fc1)-+
    >
    > And the Router is a 2621 and is runing:
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2600 Software (C2600-I-M), Version 12.0(3)T3, RELEASE
    > SOFTWARE (fc1)
    >
    > Question(s):
    >
    > 1. Does the IOS version of my router support ISL encapsulation? If
    > so, can you tell me how to configure it.
    >
    >
    > Additional Information:
    >
    > I have defined three VLANs on the switch. They are as follows:
    > VLAN1 192.168.1.35
    > VLAN10 192.168.10.0
    > VLAN20 192.168.20.0
    >
    > ? Does VLAN1 have to exist?
    >
    > ? I want traffic to be routed between VLAN10 and VLAN20. What is the
    > best way to accomplish this?
    >
    > ? The router has two FastEthernet ports and one Ethernet port. Do I
    > have to place one FastEthernet port in each VLAN and connect the
    > Ethernet port to the exterior router?
    >
    > I realize that it may sound a bit confusing, but any assistance would
    > be appreciated.


    I've this configuration, you probaly do not hav ethe right IOS, IP-Plus, I
    think you nedd.
    Routing between VLan, like my configuration, is default because both
    IP-ranges (172.16.81 and 172.16.81) are directly connected. (show ip route)

    Connect your switch to your router and configure your switch port in
    switchport mode trunking
    and your router- fa-port like this:

    (I've used dot1Q encapsulation, nbut you can use isl if your switch (and
    router) supports it
    interface FastEthernet0/0
    no ip address
    speed 100
    full-duplex
    !
    interface FastEthernet0/0.1
    desc vlan 81
    encapsulation dot1Q 81
    ip address 172.16.81.1 255.255.255.0

    interface FastEthernet0/0.2
    desc vlan 82
    encapsulation dot1Q 82
    ip address 172.16.82.1 255.255.255.0

    Gtx,

    Jeroen
     
    Jeroen, Jan 6, 2004
    #2
    1. Advertising

  3. In article <>,
    Peter <> wrote:
    :I have defined three VLANs on the switch. They are as follows:
    :VLAN1 192.168.1.35
    :VLAN10 192.168.10.0
    :VLAN20 192.168.20.0

    :? Does VLAN1 have to exist?

    Yes. You cannot delete VLAN1 -- but you don't need to have
    assigned it an IP address, and you don't need to use it as
    the management VLAN.
    --
    "Infinity is like a stuffed walrus I can hold in the palm of my hand.
    Don't do anything with infinity you wouldn't do with a stuffed walrus."
    -- Dr. Fletcher, Va. Polytechnic Inst. and St. Univ.
     
    Walter Roberson, Jan 6, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bvlmv

    IOS FOR TRUNKING (ISL/dot1q)

    bvlmv, May 1, 2004, in forum: Cisco
    Replies:
    6
    Views:
    2,918
    Erik Tamminga
    May 2, 2004
  2. xlr8
    Replies:
    1
    Views:
    598
    Russell Lusignan
    Aug 19, 2004
  3. Replies:
    2
    Views:
    961
  4. Sied@r
    Replies:
    3
    Views:
    8,546
    Sied@r
    Oct 20, 2005
  5. Omadon
    Replies:
    0
    Views:
    517
    Omadon
    Nov 6, 2005
Loading...

Share This Page