Configuring a Cisco 828 for multiple IPs

Discussion in 'Cisco' started by need_help, Mar 25, 2005.

  1. need_help

    need_help Guest

    Having a bit of a nightmare at the moment with our new Cisco 828. Hav
    spent many hours on the phone to Cisco and have the followin
    configuration but I think it is setup for when an ISP provides
    static IP and not a range which we have


    interface Ethernet
    no shu
    ip address 10.10.10.1 255.0.0.
    ip nat insid
    no ip directed-broadcas

    interface ATM
    no shu
    no ip addres
    no ip directed-broadcas
    no atm ilmi-keepaliv
    bundle-enabl

    interface ATM0.1 point-to-poin
    no ip directed-broadcas
    pvc 0/3
    encapsulation aal5mux ppp diale
    dialer pool-member


    interface Dialer
    ip address negotiate
    no ip directed-broadcas
    ip nat outsid
    encapsulation pp
    dialer pool
    ppp chap hostname ***@sdsl-provider.co
    ppp chap password ******
    ppp pap sent-username ***@sdsl-provider.com password ******

    ip nat inside source list 1 interface Dialer1 overloa

    ip route 0.0.0.0 0.0.0.0 dialer
    access-list 1 permit 10.10.10.1 255.0.0.

    Now basically we have an IP range provided to us by our SDSL provide
    which I have provided below (have changed the IPs from the rea
    ones!)

    Static IP Range: 200.150.90.32/4
    Subnet: 255.255.255.24

    I am under the impression that the second IP should be assigned to th
    router (200.150.90.33) and that we can then have traffic passe
    through to web servers ie 200.150.90.34 etc. Now I understand Cisco'
    CRWS interface has a fit if you change it's IP so I am happy to kee
    the local LAN in the 10.10.10.1 255.0.0.0 range but have no idea ho
    to tell the router about all this info while keeping our SDSL line u
    and running

    Hopefully you can help me find a solution to a problem that is no
    written about anywhere

    Many thanks
    Brun
     
    need_help, Mar 25, 2005
    #1
    1. Advertising

  2. need_help

    d Guest

    Not sure what CRWS is?

    Anyway I think you are trying to do this.

    ip nat inside source static tcp 10.10.10.10 200.150.90.34 eq 80

    This will take any traffic from 200.150.90.34 destined to port 80 and send
    it to port 80 on 10.10.10.10.

    Is this what your after?

    D

    On Fri, 25 Mar 2005 02:10:43 -0600, need_help wrote:

    > Having a bit of a nightmare at the moment with our new Cisco 828. Have
    > spent many hours on the phone to Cisco and have the following
    > configuration but I think it is setup for when an ISP provides 1
    > static IP and not a range which we have:
    >
    > !
    > interface Ethernet0
    > no shut
    > ip address 10.10.10.1 255.0.0.0
    > ip nat inside
    > no ip directed-broadcast
    > !
    > interface ATM0
    > no shut
    > no ip address
    > no ip directed-broadcast
    > no atm ilmi-keepalive
    > bundle-enable
    > !
    > interface ATM0.1 point-to-point
    > no ip directed-broadcast
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > !
    > interface Dialer1
    > ip address negotiated
    > no ip directed-broadcast
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > ppp chap hostname ***@sdsl-provider.com
    > ppp chap password *******
    > ppp pap sent-username ***@sdsl-provider.com password *******
    > !
    > ip nat inside source list 1 interface Dialer1 overload
    > !
    > ip route 0.0.0.0 0.0.0.0 dialer1
    > access-list 1 permit 10.10.10.1 255.0.0.0
    >
    >
    > Now basically we have an IP range provided to us by our SDSL provider
    > which I have provided below (have changed the IPs from the real
    > ones!):
    >
    > Static IP Range: 200.150.90.32/47
    > Subnet: 255.255.255.240
    >
    > I am under the impression that the second IP should be assigned to the
    > router (200.150.90.33) and that we can then have traffic passed
    > through to web servers ie 200.150.90.34 etc. Now I understand Cisco's
    > CRWS interface has a fit if you change it's IP so I am happy to keep
    > the local LAN in the 10.10.10.1 255.0.0.0 range but have no idea how
    > to tell the router about all this info while keeping our SDSL line up
    > and running.
    >
    > Hopefully you can help me find a solution to a problem that is not
    > written about anywhere!
    >
    > Many thanks!
    > Bruno
     
    d, Mar 31, 2005
    #2
    1. Advertising

  3. On Thu, 31 Mar 2005 21:06:19 +0800, d wrote:

    >> Static IP Range: 200.150.90.32/47
    >> Subnet: 255.255.255.240
    >>
    >> I am under the impression that the second IP should be assigned to the
    >> router (200.150.90.33) and that we can then have traffic passed through
    >> to web servers ie 200.150.90.34 etc. Now I understand Cisco's CRWS
    >> interface has a fit if you change it's IP so I am happy to keep the
    >> local LAN in the 10.10.10.1 255.0.0.0 range but have no idea how to tell
    >> the router about all this info while keeping our SDSL line up and
    >> running.
    >>
    >> Hopefully you can help me find a solution to a problem that is not
    >> written about anywhere!


    Just telnet or make a console connection to the router, get into enable
    mode and then do:

    router#configure terminal
    ....
    router(config)#interface Ethernet0
    router(config-if)#ip address <your top secret address> 255.255.255.240 secondary
    router(config-if)#end
    router#copy running-config startup-config
    ....
    router#

    Now you can use addreses 34 to 46 for your local hosts.

    --
    Rgds,
    Martin
     
    Martin Gallagher, Apr 1, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lars L. Christensen

    G.SHDSL 828-to-828

    Lars L. Christensen, Dec 16, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,353
    Igor Mamuziæ
    Dec 17, 2004
  2. Tristan
    Replies:
    2
    Views:
    10,011
    Hansang Bae
    Mar 10, 2005
  3. Replies:
    1
    Views:
    1,699
  4. Giuen
    Replies:
    0
    Views:
    1,154
    Giuen
    Sep 12, 2008
  5. Martijn Lievaart

    HSRP: virtual IPs without real IPs?

    Martijn Lievaart, Feb 9, 2012, in forum: Cisco
    Replies:
    4
    Views:
    1,154
    Martijn Lievaart
    Feb 15, 2012
Loading...

Share This Page