Configure 1800 Router with ethernet connection

Discussion in 'Cisco' started by Ciscohater, Oct 25, 2007.

  1. Ciscohater

    Ciscohater Guest

    We no longer will be using our T1 connection we now have a dedicated
    lan connecting to the web. I am new to Cisco routers. How do i
    configure this Router with my settings.

    Internet Provider gave me the following info and I am not sure how i
    can configure it. So i am a bit confused.


    Example......
    External IP Address 10.1.111.34
    Subnet 255.255.255.252
    Gateway 10.1.111.33
    DNS 127.0.0.1

    Internal IP Address 10.1.55.161
    Subnet 255.255.255.224


    Thanks
    Ciscohater, Oct 25, 2007
    #1
    1. Advertising

  2. Ciscohater

    Trendkill Guest

    On Oct 25, 12:11 pm, Ciscohater <> wrote:
    > We no longer will be using our T1 connection we now have a dedicated
    > lan connecting to the web. I am new to Cisco routers. How do i
    > configure this Router with my settings.
    >
    > Internet Provider gave me the following info and I am not sure how i
    > can configure it. So i am a bit confused.
    >
    > Example......
    > External IP Address 10.1.111.34
    > Subnet 255.255.255.252
    > Gateway 10.1.111.33
    > DNS 127.0.0.1
    >
    > Internal IP Address 10.1.55.161
    > Subnet 255.255.255.224
    >
    > Thanks


    configuration terminal
    interface fastethernet<mod/port> (example, 1/0, you can get this from
    show ip interface brief)
    ip address 10.1.111.34 255.255.255.252
    description External
    no shut
    !
    interface fastethernet<mod/port>
    ip address 10.1.55.161 255.255.255.224
    description internal
    no shut
    !

    Your clients will need to be configured with the gateway, and your
    default route (presuming this network does not have any other segments
    that need to exchange routes, is:

    ip aroute 0.0.0.0 0.0.0.0 10.1.111.33
    Trendkill, Oct 25, 2007
    #2
    1. Advertising

  3. Ciscohater

    Trendkill Guest

    On Oct 25, 12:43 pm, Trendkill <> wrote:
    > On Oct 25, 12:11 pm, Ciscohater <> wrote:
    >
    >
    >
    > > We no longer will be using our T1 connection we now have a dedicated
    > > lan connecting to the web. I am new to Cisco routers. How do i
    > > configure this Router with my settings.

    >
    > > Internet Provider gave me the following info and I am not sure how i
    > > can configure it. So i am a bit confused.

    >
    > > Example......
    > > External IP Address 10.1.111.34
    > > Subnet 255.255.255.252
    > > Gateway 10.1.111.33
    > > DNS 127.0.0.1

    >
    > > Internal IP Address 10.1.55.161
    > > Subnet 255.255.255.224

    >
    > > Thanks

    >
    > configuration terminal
    > interface fastethernet<mod/port> (example, 1/0, you can get this from
    > show ip interface brief)
    > ip address 10.1.111.34 255.255.255.252
    > description External
    > no shut
    > !
    > interface fastethernet<mod/port>
    > ip address 10.1.55.161 255.255.255.224
    > description internal
    > no shut
    > !
    >
    > Your clients will need to be configured with the gateway, and your
    > default route (presuming this network does not have any other segments
    > that need to exchange routes, is:
    >
    > ip aroute 0.0.0.0 0.0.0.0 10.1.111.33


    Oops - ip route (not ip aroute)
    Trendkill, Oct 25, 2007
    #3
  4. Ciscohater

    Ciscohater Guest

    Thanks so much.
    Ciscohater, Oct 26, 2007
    #4
  5. Ciscohater

    Ciscohater Guest

    My Provider did not give me all the information and now i am confused.
    This is what they sent me today.

    Example:
    Serial Block 10.1.11132 /30
    TelCove Serial: 10.1.111..33
    Customer Prem Serial: 10.1.111.34
    Subnet Mask: 255.255.255.252

    IP Address Block: 10.1.55.160 /27
    Subnet Mask: 255.255.255.224
    Network IP Address: 10.1.55.160
    Broadcast IP Address: 10.1.55.191

    Thanks so much.
    Ciscohater, Oct 26, 2007
    #5
  6. Ciscohater

    Chris Guest

    On Fri, 26 Oct 2007 17:39:34 -0000, Ciscohater wrote:

    > My Provider did not give me all the information and now i am confused.
    > This is what they sent me today.
    >
    > Example:
    > Serial Block 10.1.11132 /30
    > TelCove Serial: 10.1.111..33
    > Customer Prem Serial: 10.1.111.34
    > Subnet Mask: 255.255.255.252
    >
    > IP Address Block: 10.1.55.160 /27
    > Subnet Mask: 255.255.255.224
    > Network IP Address: 10.1.55.160
    > Broadcast IP Address: 10.1.55.191
    >
    > Thanks so much.



    Which bit of that confuses you? There is a /30 WAN between the providers
    core router and the serial interface of your router. Your side is
    10.1.111.34 and the providers interface (your default gateway) is
    10.1.111.33.

    The other address block is what has been assigned to you for your LAN.

    Chris.
    Chris, Oct 26, 2007
    #6
  7. Ciscohater

    Ciscohater Guest

    I configured the router with the above instructions and i am unable to
    connect to the internet. I also used the web interface to test the wan
    connection and it errors out with user defined route.
    Ciscohater, Oct 26, 2007
    #7
  8. Ciscohater

    Steven Carr Guest

    Ciscohater wrote:
    > I configured the router with the above instructions and i am unable to
    > connect to the internet. I also used the web interface to test the wan
    > connection and it errors out with user defined route.


    If you are completely brand new to Cisco then you are going to have to
    do some research and learning in order to gain the knowledge of how they
    work. Having your name set to "Ciscohater" wont do you much good on a
    Cisco forum either.

    Cisco equipment is not just a drop in replacement for cheap
    netgear/linksys/dlink kit. It is complex equipment that needs to be
    properly configured.

    The 1800 series come with the SDM which is a software based configurator
    using wizards etc. to configure the device. Personally I do not like
    this and would rather configure it from the CLI. But if you do not have
    the time to learn the CLI then I would advise that you use the SDM to
    restore the box to factory defaults and then go through the various
    wizards on the SDM for setting up the device.

    Steve

    --
    Steve Carr
    http://gpf.me.uk


    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.7 (Darwin)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFHIta9g6K71gPSyTARAsk4AJwJtPZ59dYzMv2eyRW2QiInYCEzvACaAndV
    RKrVtv36ZGeG8GK0jTtehe8=
    =qp2Q
    -----END PGP SIGNATURE-----
    Steven Carr, Oct 27, 2007
    #8
  9. Ciscohater

    Merv Guest

    Can you ping 10.1.111.33

    Network 10.x.x.x is not a routable address with respect to reaching
    Internet. Does your ISP provide Network Address Translation (NAT) as
    part of its service ?
    Merv, Oct 27, 2007
    #9
  10. Ciscohater

    Ciscoserver Guest

    Able reading up on some Cisco stuff i ran the following commands and I
    was able to connect but the problem is my connection is very slow. I
    have a 10 meg line but I am only getting 786 speed.

    Ip address's are examples.


    Router>
    Router>enable
    Router#show running-config
    Router#configure terminal
    Router(config)#ip routing
    Router(config)#config-register 0x2102
    interface fastethernet0/0
    ip address 10.1.111.34 255.255.255.252
    description External
    no shutdown
    exit

    interface fastethernet0/1
    ip address 10.1.55.161 255.255.255.224
    description internal
    no shutdown

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.111.33
    Router(config)#end
    Router#copy running-config startup-config
    Ciscoserver, Oct 30, 2007
    #10
  11. Ciscohater

    Merv Guest

    1. Check for errors on the external fastEthernet interface - show
    interface fa 0/0

    2. Call your ISP and report problem
    Merv, Oct 30, 2007
    #11
  12. Ciscohater

    Ciscoserver Guest

    We had a server setup to run with the ip seetings for testing and
    worked fine. But we did set the network connections for 10 meg speed
    not auto. Is there a setting for that is cisco.
    Ciscoserver, Oct 30, 2007
    #12
  13. Ciscohater

    Merv Guest

    On Oct 30, 2:22 pm, Ciscoserver <> wrote:
    > We had a server setup to run with the ip seetings for testing and
    > worked fine. But we did set the network connections for 10 meg speed
    > not auto. Is there a setting for that is cisco.


    If the question is how to configure the router FastEthernet interface
    for a fixed speed, the interface commands are


    int fa 0/0
    speed xx
    duplex < half or full>


    Make sure you do not have a duplex mismatch by doing a show interface
    and checking for error ( runts, crc errors, etc)
    Merv, Oct 30, 2007
    #13
  14. Ciscohater

    Ciscoserver Guest

    Ok so i switched the interfaces to 10 meg / full duplex. I am getting
    much better speed right now but still not the whole speed. I get about
    7900k via the Cisco and 7400 using a server directly connected. I have
    included the int fa log.

    FastEthernet0/0 is up, line protocol is up
    Hardware is Gt96k FE, address is 001c.f6ff.8c2c (bia 001c.f6ff.8c2c)
    Description: External$ETH-WAN$
    Internet address is xx.x.xx.34/30
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 10Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:51, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 9000 bits/sec, 3 packets/sec
    5 minute output rate 8000 bits/sec, 5 packets/sec
    45213 packets input, 29420416 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    37246 packets output, 11195047 bytes, 0 underruns
    0 output errors, 0 collisions, 4 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Ciscoserver, Oct 31, 2007
    #14
  15. Ciscohater

    Merv Guest


    > FastEthernet0/0


    the fa 0/0 is running error free

    BTW you can clear the interface counters using the enable mode command
    " clear counters

    Also you change change the interval for the interface traffic avergae
    to 30 seconds

    config t
    int fa 0/0
    load-interval 30
    end

    wri mem
    Merv, Oct 31, 2007
    #15
  16. Ciscohater

    Ciscoserver Guest

    Here is the internal connection. It shows show errors.

    FastEthernet0/1 is up, line protocol is up
    Hardware is Gt96k FE, address is 001c.f6ff.8c2d (bia 001c.f6ff.8c2d)
    Description: internal$ETH-LAN$
    Internet address is xx.x.xx.161/27
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 6/255, rxload 3/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 10Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:33, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 153000 bits/sec, 69 packets/sec
    5 minute output rate 255000 bits/sec, 70 packets/sec
    213024 packets input, 53083357 bytes
    Received 1816 broadcasts, 0 runts, 0 giants, 0 throttles
    150 input errors, 150 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    286766 packets output, 238925786 bytes, 0 underruns
    0 output errors, 0 collisions, 4 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out

    FYI I have a few people using the DHCP option of this and they are
    VPNing into a client site and get kicked off every 10 mins.


    Thanks for your help. At least I am learning a little bit in the
    process.
    Ciscoserver, Oct 31, 2007
    #16
  17. Ciscohater

    Ciscoserver Guest

    I set those users who are testing the VPN connection to use dhcp from
    the router.
    Ciscoserver, Oct 31, 2007
    #17
  18. Ciscohater

    Merv Guest

    Here is the internal connection. It shows show errors.

    FastEthernet0/1 is up, line protocol is up
    Hardware is Gt96k FE, address is 001c.f6ff.8c2d (bia 001c.f6ff.8c2d)
    Description: internal$ETH-LAN$
    Internet address is xx.x.xx.161/27
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 6/255, rxload 3/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 10Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:33, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 153000 bits/sec, 69 packets/sec
    5 minute output rate 255000 bits/sec, 70 packets/sec
    213024 packets input, 53083357 bytes
    Received 1816 broadcasts, 0 runts, 0 giants, 0 throttles
    150 input errors, 150 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    286766 packets output, 238925786 bytes, 0 underruns
    0 output errors, 0 collisions, 4 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out


    clear counters

    monitor for errors on inside fa interface

    If errors persist replace cabling to router - make sure cable is Cat5E
    or better
    Merv, Oct 31, 2007
    #18
  19. Ciscohater

    Ciscoserver Guest

    I replaced all the cabling and the connection is still slow.

    Any idea.
    Ciscoserver, Nov 1, 2007
    #19
  20. Ciscohater

    Merv Guest

    Given that you have eliminated all the interface error issues, then
    you need to define what you mean by slow.

    You will not for a single TCP connection be able to get 10 Megs given
    that in fact that is what the ISP is delivering to you.

    If you search this newsgroup for TCP performance articles you will
    have tons of hits.

    What type of test are you performing to make the throughput
    performance assessment ?

    Things like end system TCP windows size have a big impact on TCP
    performance for example.

    Anotehr big factor is network latency, etc, etc.
    Merv, Nov 1, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter
    Replies:
    2
    Views:
    1,017
  2. Kai
    Replies:
    1
    Views:
    1,025
    Ivan OstreŇ°
    Dec 13, 2004
  3. andyr
    Replies:
    4
    Views:
    1,997
  4. RobMarsh
    Replies:
    1
    Views:
    4,804
    RobMarsh
    Sep 18, 2006
  5. s
    Replies:
    4
    Views:
    1,195
Loading...

Share This Page