Computer Clock Problems

Discussion in 'NZ Computing' started by ybakiwi, Jan 1, 2006.

  1. ybakiwi

    ybakiwi Guest

    The clock on my computer keeps gaining about 1 hour in 24 hours.
    Is this a sigh of a problem and can it be fixwed
    Ciao
    Kevin
    ybakiwi, Jan 1, 2006
    #1
    1. Advertising

  2. On Sun, 01 Jan 2006 17:57:46 +1300, ybakiwi <> wrote
    in <news:>:

    > The clock on my computer keeps gaining about 1 hour in 24 hours.
    > Is this a sigh of a problem and can it be fixwed
    > Ciao
    > Kevin


    Look at repacing your CMOS battery as a starting point.

    --
    Regards,
    Nicolaas.


    .... Those who know, know who knows.
    Nicolaas Hawkins, Jan 1, 2006
    #2
    1. Advertising

  3. ybakiwi

    Jerry Guest

    ybakiwi wrote:
    > The clock on my computer keeps gaining about 1 hour in 24 hours.
    > Is this a sigh of a problem and can it be fixwed
    > Ciao
    > Kevin


    Mine was doing that a while ago, actually I've had that problem twice
    now. It isn't likely to bbe the CMOS battery, no matter how many people
    tell you to change it. A CMOS battery failure doesn't make your clock
    run slow, it makes the settings go away altogether, and only when the
    computer is powered off.

    I don't know what caused it, but both times I fixed it by deleting all
    the internet history, temp files, and all that crap. As I recall the
    windows time was gaining, but the CMOS time was correct when it happened
    to me.
    Jerry, Jan 1, 2006
    #3
  4. ybakiwi

    Murray Symon Guest

    On Sun, 01 Jan 2006 17:57:46 +1300, ybakiwi wrote:

    > The clock on my computer keeps gaining about 1 hour in 24 hours. Is this a
    > sigh of a problem and can it be fixed? Ciao
    > Kevin


    It depends if it is gaining while the computer is off, or when it is
    running. Is it mostly off or mostly on?

    As far as I know, the CMOS RTC (real time clock chip) is usually only
    read on boot-up and then it is up to software to keep the time up to date.

    You can check the time in the CMOS RTC chip before you boot, in your BIOS
    configuration menu - usually accessed by pressing a key such as DELETE
    when prompted to.
    Murray Symon, Jan 1, 2006
    #4
  5. ybakiwi wrote:
    > The clock on my computer keeps gaining about 1 hour in 24 hours.
    > Is this a sigh of a problem and can it be fixwed


    Check that your timezone and daylight savings settings are correct. On
    Windows XP, you can use the "Internet time" feature on the date/time
    setting window to automatically synchronize your clock, or there are
    many third-party tools to do this for any operating system (Google: NTP).

    Cheers,
    Nicholas Sherlock
    Nicholas Sherlock, Jan 1, 2006
    #5
  6. ybakiwi

    Jerry Guest

    Nicholas Sherlock wrote:
    > ybakiwi wrote:
    >
    >> The clock on my computer keeps gaining about 1 hour in 24 hours.
    >> Is this a sigh of a problem and can it be fixwed

    >
    >
    > Check that your timezone and daylight savings settings are correct. On
    > Windows XP, you can use the "Internet time" feature on the date/time
    > setting window to automatically synchronize your clock, or there are
    > many third-party tools to do this for any operating system (Google: NTP).


    None of this is going to help his problem. Between synchs his computer
    will still gain time. I've been there recently
    Jerry, Jan 1, 2006
    #6
  7. Jerry wrote:
    > ybakiwi wrote:
    >> The clock on my computer keeps gaining about 1 hour in 24 hours.
    >> Is this a sigh of a problem and can it be fixwed

    >
    > Mine was doing that a while ago, actually I've had that problem twice
    > now. It isn't likely to bbe the CMOS battery, no matter how many people
    > tell you to change it. A CMOS battery failure doesn't make your clock
    > run slow, it makes the settings go away altogether, and only when the
    > computer is powered off.


    I'll attest that a flat CMOS battery can make RTCs do strange things.
    Mark Robinson, Jan 1, 2006
    #7
  8. Jerry wrote:
    > Nicholas Sherlock wrote:
    >> ybakiwi wrote:
    >>
    >>> The clock on my computer keeps gaining about 1 hour in 24 hours.
    >>> Is this a sigh of a problem and can it be fixwed

    >>
    >>
    >> Check that your timezone and daylight savings settings are correct. On
    >> Windows XP, you can use the "Internet time" feature on the date/time
    >> setting window to automatically synchronize your clock, or there are
    >> many third-party tools to do this for any operating system (Google: NTP).

    >
    > None of this is going to help his problem. Between synchs his computer
    > will still gain time. I've been there recently


    If the OP is using Linux, there is a time-sync program available which
    also corrects for clock drift /between/ syncs (It measures how fast/slow
    your computer's clock is). Perhaps something like this is also available
    for Windows, but I wasn't able to find a package which claimed this feature.

    Cheers,
    Nicholas Sherlock
    Nicholas Sherlock, Jan 1, 2006
    #8
  9. ybakiwi

    Sharktyymbfj Guest

    If it isn't the CMOS, I remember some time ago that some Norton products
    caused this.



    --
    Sharktyymbfj

    Newsgroups - For those who can't afford vanity publishing.
    "ybakiwi" <> wrote in message
    news:...
    > The clock on my computer keeps gaining about 1 hour in 24 hours.
    > Is this a sigh of a problem and can it be fixwed
    > Ciao
    > Kevin
    Sharktyymbfj, Jan 1, 2006
    #9
  10. T'was the Sun, 01 Jan 2006 20:02:29 +1300 when I remembered Jerry
    <> saying something like this:

    >Mine was doing that a while ago, actually I've had that problem twice
    >now. It isn't likely to bbe the CMOS battery, no matter how many people
    >tell you to change it. A CMOS battery failure doesn't make your clock
    >run slow, it makes the settings go away altogether, and only when the
    >computer is powered off.


    Mine started playing up after a nearby lightning storm. Would slowly
    gain time, meaning I thought I was late for everything, but quietly
    surprised when instead I was massively early. Makes a change from
    normal...

    I guess it's the motherboard. You can get programs to update your time
    automatically from the internet.
    --
    Cheers,

    Waylon Kenning.
    Waylon Kenning, Jan 5, 2006
    #10
  11. ybakiwi

    Shane Guest

    On Thu, 05 Jan 2006 13:52:45 +1300, Waylon Kenning wrote:

    > T'was the Sun, 01 Jan 2006 20:02:29 +1300 when I remembered Jerry
    > <> saying something like this:
    >
    >>Mine was doing that a while ago, actually I've had that problem twice
    >>now. It isn't likely to bbe the CMOS battery, no matter how many people
    >>tell you to change it. A CMOS battery failure doesn't make your clock
    >>run slow, it makes the settings go away altogether, and only when the
    >>computer is powered off.

    >
    > Mine started playing up after a nearby lightning storm. Would slowly gain
    > time, meaning I thought I was late for everything, but quietly surprised
    > when instead I was massively early. Makes a change from normal...
    >
    > I guess it's the motherboard. You can get programs to update your time
    > automatically from the internet.




    http://www.cs.utah.edu/support/faq/ntp/faq-ntp.html

    Windows Users
    For Windows XP go to your Control Panel and start up the "Date and Time" panel.
    Select the "Internet Time" tab and enter timemaster.cs.utah.edu.

    If you wish to install an NTP client on an older Windows machine, one of
    the most useful and free programs out there is NetTime. You can find it on
    many Windows resource sites. It possesses a simple interface for
    configuration. It runs on all Windows platforms, but as an added bonus it
    runs as a resource under Windows NT/2000. Simply add our time server to
    the software's configuration and you're done.


    Unix Users
    Implementing clients that sync their time off of timemaster.cs.utah.edu is rather
    straight forward:

    * Two executables must be present: ntpd and ntpdate. These should exist in
    /usr/local/sbin.
    * The file /etc/ntp.conf must exist, and be configured for our environment.
    * There should also be a startup file, in /etc/init.d and linked to the various
    rcX.d directories, although this will depend on your computer OS
    version.
    Files for for Irix, HPUX and Solaris are available here.

    Once these files are in place, all you have to do is run the startup file
    to run ntpdate (which sets the clock explicitly), and then starts up ntpd
    (the daemon that keeps the time in sync with the server). When starting
    ntpd, please make sure that other time-keeping utilities, such as AFS and
    timed, are turned off, or other you'll start a war over time control.
    (This is something to be avoided!) That's it. Once ntpd is running, you
    should be set.

    --
    Dammit Jim, I'm an actor, not a doctor.
    Shane, Jan 5, 2006
    #11
  12. ybakiwi

    Mark C Guest

    Shane <-a-geek.net> wrote in
    news:p-a-geek.net:

    > http://www.cs.utah.edu/support/faq/ntp/faq-ntp.html
    >
    > Windows Users
    > For Windows XP go to your Control Panel and start up the "Date
    > and Time" panel. Select the "Internet Time" tab and enter
    > timemaster.cs.utah.edu.


    Or to be a better internet citizen (and use a local server with
    better ping), use:
    nz.pool.ntp.org
    .... or if you need a list of (random nz) servers for fallback:
    0.nz.pool.ntp.org;1.nz.pool.ntp.org;2.nz.pool.ntp.org

    > If you wish to install an NTP client on an older Windows
    > machine, one of the most useful and free programs out there is
    > NetTime. You can find it on many Windows resource sites. It
    > possesses a simple interface for configuration. It runs on all
    > Windows platforms, but as an added bonus it runs as a resource
    > under Windows NT/2000. Simply add our time server to the
    > software's configuration and you're done.


    Also, the W32Time service is available for Windows NT
    ftp://ftp.microsoft.com/reskit/y2kfix/x86/w32time/
    http://support.microsoft.com/kb/246145

    .... However, I don't think that the XP or 2000 or NT (link above)
    W32Time service can correct for skew.

    More info here:
    http://www.ntp.org/ntpfaq/NTP-s-def-impl.htm

    > Unix Users
    > Implementing clients that sync their time off of
    > timemaster.cs.utah.edu is rather straight forward:
    >
    > * Two executables must be present: ntpd and ntpdate. These
    > should exist in
    > /usr/local/sbin.
    > * The file /etc/ntp.conf must exist, and be configured for
    > our environment. * There should also be a startup file, in
    > /etc/init.d and linked to the various
    > rcX.d directories, although this will depend on your
    > computer OS version.
    > Files for for Irix, HPUX and Solaris are available here.
    >
    > Once these files are in place, all you have to do is run the
    > startup file to run ntpdate (which sets the clock explicitly),
    > and then starts up ntpd (the daemon that keeps the time in sync
    > with the server). When starting ntpd, please make sure that
    > other time-keeping utilities, such as AFS and timed, are turned
    > off, or other you'll start a war over time control. (This is
    > something to be avoided!) That's it. Once ntpd is running, you
    > should be set.
    Mark C, Jan 5, 2006
    #12
  13. ybakiwi

    Jerry Guest

    Shane wrote:
    > On Thu, 05 Jan 2006 13:52:45 +1300, Waylon Kenning wrote:
    >
    >
    >>T'was the Sun, 01 Jan 2006 20:02:29 +1300 when I remembered Jerry
    >><> saying something like this:
    >>
    >>
    >>>Mine was doing that a while ago, actually I've had that problem twice
    >>>now. It isn't likely to bbe the CMOS battery, no matter how many people
    >>>tell you to change it. A CMOS battery failure doesn't make your clock
    >>>run slow, it makes the settings go away altogether, and only when the
    >>>computer is powered off.

    >>
    >>Mine started playing up after a nearby lightning storm. Would slowly gain
    >>time, meaning I thought I was late for everything, but quietly surprised
    >>when instead I was massively early. Makes a change from normal...
    >>
    >>I guess it's the motherboard. You can get programs to update your time
    >>automatically from the internet.

    >
    >
    >
    >
    > http://www.cs.utah.edu/support/faq/ntp/faq-ntp.html
    >
    > Windows Users
    > For Windows XP go to your Control Panel and start up the "Date and Time" panel.
    > Select the "Internet Time" tab and enter timemaster.cs.utah.edu.
    >
    > If you wish to install an NTP client on an older Windows machine, one of
    > the most useful and free programs out there is NetTime. You can find it on
    > many Windows resource sites. It possesses a simple interface for
    > configuration. It runs on all Windows platforms, but as an added bonus it
    > runs as a resource under Windows NT/2000. Simply add our time server to
    > the software's configuration and you're done.
    >
    >
    > Unix Users
    > Implementing clients that sync their time off of timemaster.cs.utah.edu is rather
    > straight forward:
    >
    > * Two executables must be present: ntpd and ntpdate. These should exist in
    > /usr/local/sbin.
    > * The file /etc/ntp.conf must exist, and be configured for our environment.
    > * There should also be a startup file, in /etc/init.d and linked to the various
    > rcX.d directories, although this will depend on your computer OS
    > version.
    > Files for for Irix, HPUX and Solaris are available here.
    >
    > Once these files are in place, all you have to do is run the startup file
    > to run ntpdate (which sets the clock explicitly), and then starts up ntpd
    > (the daemon that keeps the time in sync with the server). When starting
    > ntpd, please make sure that other time-keeping utilities, such as AFS and
    > timed, are turned off, or other you'll start a war over time control.
    > (This is something to be avoided!) That's it. Once ntpd is running, you
    > should be set.
    >

    Synching the time doesn't fix the problem though. The OP here never
    came back, if we knew if it was bios or windows losing time we would
    know what he should be working on, hardware or windows. When I had the
    problem the bios clock was right, the windows clock was gaining time.
    Jerry, Jan 5, 2006
    #13
  14. On Thu, 05 Jan 2006 14:00:28 +1300, Shane wrote:

    > Windows Users
    > For Windows XP go to your Control Panel and start up the "Date and Time" panel.
    > Select the "Internet Time" tab and enter timemaster.cs.utah.edu.


    or you could try tk1.ihug.co.nz


    --
    Red Dwarf Future Echoes
    I am Holly, the ships computer, with an IQ of 6000, the same IQ as 6000 PE
    teachers.
    Holly
    Robin Halligan, Jan 5, 2006
    #14
  15. ybakiwi

    Shane Guest

    On Thu, 05 Jan 2006 04:34:03 +0000, Mark C wrote:


    > Or to be a better internet citizen (and use a local server with better
    > ping), use:
    > nz.pool.ntp.org
    > ... or if you need a list of (random nz) servers for fallback:
    > 0.nz.pool.ntp.org;1.nz.pool.ntp.org;2.nz.pool.ntp.org


    I should be more judicious with my copy and pastes :\
    --
    Unix weanies are as bad at this as anyone.
    -- Larry Wall in <>
    Shane, Jan 5, 2006
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. paul s

    Re: computer clock slow

    paul s, Jul 7, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    626
    paul s
    Jul 7, 2003
  2. John

    Re: computer clock slow

    John, Jul 8, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    1,163
    Shep©
    Jul 8, 2003
  3. John

    Slow computer clock

    John, Dec 23, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    788
  4. PS

    Sync for PC clock and server clock

    PS, May 12, 2005, in forum: Computer Support
    Replies:
    3
    Views:
    749
    Dave Lear
    May 13, 2005
  5. The Buzz

    computer clock problems

    The Buzz, Oct 30, 2007, in forum: Computer Support
    Replies:
    7
    Views:
    851
    chuckcar
    Oct 31, 2007
Loading...

Share This Page