CMS problem with ftp

Discussion in 'Cisco' started by marcelo@there.com, May 25, 2005.

  1. Guest

    Hi,
    I have the CMS module on my 6509 with sup1/msfc2. My problem is easy:
    all works (http, smtp, pop3, ...), except ftp.

    a easy example:

    I have a server on ipA. And I want to load balance ipB to ipA.

    I connect to ipA to ftp service (ftp works):
    # ncftp ipA
    ncftp / > ls -al
    [...]
    ncftp / > pas
    passive off
    ncftp / > ls -al
    [...]
    ncftp / > pas
    passive on
    ncftp / > ls -al
    [...]

    So, it works.

    Now I want to use CMS to load balance ipB to ipA:
    # ssh root@ipA
    # ifconfig lo:0 ipB netmask 255.255.255.255

    then:
    # conf t
    module ContentSwitchingModule 3
    vlan XXX client
    ip address ipC 255.255.255.0
    vlan YYY server
    ip address ipD 255.255.255.0
    probe ICMP icmp
    interval 30
    retries 2
    failed 60
    receive 20
    serverfarm TEST_WWW
    no nat server
    no nat client
    real ipA
    inservice
    probe ICMP
    vserver TEST_WWW
    virtual ipB any
    serverfarm TEST_WWW
    persistent rebalance
    inservice
    end

    I can ping ipB, I can use http, smtp, pop3 on ipB but:
    # ncftp ipB
    ncftp / > pas
    passive on
    ncftp / > ls -al
    [...]
    ncftp / > pas
    passive off
    ncftp / > ls
    List failed.

    I have no firewall.

    Worst:

    conf t
    mod con 3
    vserver TEST_WWW
    no in
    virtual ipB tcp ftp service ftp
    in

    and now, nothing works !

    # ncftp ipB
    NcFTP 3.1.5 (Oct 13, 2002) by Mike Gleason ().
    Connecting to ipB...
    # telnet ipB 21
    Trying ipB...
    Connected to ipB.
    Escape character is '^]'.
    ^]
    telnet> q
    Connection closed.
    #

    Any idea ?

    Thanks in advance
    Marcelo


    #sh mod
    Mod Ports Card Type Model Serial No.
    --- ----- -------------------------------------- ------------------ -----------
    1 2 Cat 6k sup 1 Enhanced QoS (Active) WS-X6K-SUP1A-2GE XXXXXXXXXXX
    2 8 8 port 1000mb ethernet WS-X6408-GBIC XXXXXXXXXXX
    3 0 SLB Application Processor Complex WS-X6066-SLB-APC XXXXXXXXXXX

    Mod MAC addresses Hw Fw Sw Status
    --- ---------------------------------- ------ ------------ ------------ -------
    1 0002.fcbc.8f78 to 0002.fcbc.8f79 7.0 5.3(1) 12.1(22)E2 Ok
    2 0030.a338.a638 to 0030.a338.a63f 2.3 4.2(0.24)VAI 8.3(0.111)TF Ok
    3 0011.5ceb.5e5a to 0011.5ceb.5e61 1.7 4.1(1) Ok

    Mod Sub-Module Model Serial Hw Status
    --- --------------------------- --------------- --------------- ------- -------
    1 Policy Feature Card WS-F6K-PFC SAD05050906 1.1 Ok
    1 Cat6k MSFC 2 daughterboard WS-F6K-MSFC2 SAD05050KLM 1.2 Ok

    Mod Online Diag Status
    --- -------------------
    , May 25, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. JohnNews

    CMS on Cat 3550

    JohnNews, Nov 20, 2003, in forum: Cisco
    Replies:
    1
    Views:
    597
    Walter Roberson
    Nov 20, 2003
  2. JohnNews

    CMS deployment

    JohnNews, Nov 25, 2003, in forum: Cisco
    Replies:
    0
    Views:
    490
    JohnNews
    Nov 25, 2003
  3. UnH0Ly
    Replies:
    1
    Views:
    740
    news.optonline.net
    Jul 13, 2005
  4. Ben Fellows

    Important CMS Information

    Ben Fellows, Nov 23, 2005, in forum: Computer Support
    Replies:
    0
    Views:
    539
    Ben Fellows
    Nov 23, 2005
  5. Ben Jones

    CMS recommendations

    Ben Jones, Sep 13, 2006, in forum: Computer Support
    Replies:
    2
    Views:
    401
Loading...

Share This Page