clients from vlan do not get a dhcp lease?! (using access router 1721 and 4-port wic switch)

Discussion in 'Cisco' started by Tom, Jun 10, 2004.

  1. Tom

    Tom Guest

    Hi,
    I've a cisco 1700 router with 4port wic switch.
    For 4port wic switch see:
    http://www.cisco.com/en/US/products/hw/routers/ps221/products_data_sheet09186a00801c749d.html

    The clients connected to the cisco 4port wic switch "should" get an ip
    adress (lease) from the dhcp server,
    which is also running on this same 1721 router.

    The dhcp server works well as it is delivering to my private-lan) see config
    below.
    The private lan is connected via (buildin) fastethernet0 to a third-party
    switch. No vlan is used on this segment! This segment uses the "ip dhcp pool
    private-lan" see config below.

    The client from wifi-lan do not get a lease ?

    I can not see that something is blocked. So, what do you think might be the
    problem?!

    Here are the dhcp server settings:

    no ip dhcp conflict logging
    ip dhcp excluded-address 172.16.43.1 172.16.43.10
    ip dhcp excluded-address 172.16.43.50 172.16.43.254
    ip dhcp excluded-address 192.168.0.1 192.168.0.10
    ip dhcp pool private-lan
    network 172.16.43.0 255.255.255.0
    default-router 172.16.43.1
    netbios-node-type p-node
    domain-name private.local
    lease 3
    ip dhcp pool wifi-lan
    network 192.168.0.0 255.255.255.0
    domain-name wifi.local
    netbios-node-type p-node
    default-router 192.168.0.1
    lease 0 1

    Here is the fastethernet port (binded to vlan20) where a client is
    connected:

    interface FastEthernet2
    description wifi-lan-laptop
    switchport access vlan 20
    no ip address
    no cdp enable
    end


    interface Vlan20
    ip address 192.168.0.1 255.255.255.0
    ip access-group 11 in
    no ip proxy-arp
    ip nat inside
    end

    Standard IP access list 11
    10 permit 192.168.0.0, wildcard bits 0.0.0.255 (1032 matches)

    May be you can give me hint and tell me what I can try?

    In advance, many thanks!
    Tom, Jun 10, 2004
    #1
    1. Advertising

  2. On Thu, 10 Jun 2004 20:11:51 +0200, Tom wrote:

    [Snip]

    >
    > Standard IP access list 11
    > 10 permit 192.168.0.0, wildcard bits 0.0.0.255 (1032 matches)
    >


    DHCP clients use source address 0.0.0.0 in their broadcasts. After all,
    they don't know what their address is. You need to allow them in the acl.

    !
    access-list 11 permit 0.0.0.0 0.0.0.0
    !

    Or something like that.

    --
    Rgds,
    Martin
    Martin Gallagher, Jun 11, 2004
    #2
    1. Advertising

  3. Tom

    Tosh Guest

    > access-list 11 permit 0.0.0.0 0.0.0.0
    >

    A more granular one could be:
    access-list 111 permit udp any any eq bootps
    Bye,
    Tosh
    Tosh, Jun 11, 2004
    #3
  4. Yep, thanks a lot, you were right!!

    "Tosh" <> wrote in message
    news:...
    > > access-list 11 permit 0.0.0.0 0.0.0.0
    > >

    > A more granular one could be:
    > access-list 111 permit udp any any eq bootps
    > Bye,
    > Tosh
    >
    >
    No Spam Sorry, Jun 11, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John White
    Replies:
    2
    Views:
    619
    S. Gione
    Nov 7, 2003
  2. Replies:
    5
    Views:
    1,092
    Phillip Remaker
    Dec 30, 2004
  3. JohnH.
    Replies:
    4
    Views:
    25,541
    JohnH.
    Feb 8, 2006
  4. ITCOM
    Replies:
    0
    Views:
    751
    ITCOM
    Mar 13, 2007
  5. rsjimmy
    Replies:
    3
    Views:
    2,663
    rsjimmy
    Jan 8, 2009
Loading...

Share This Page