cisco wic-1adsl wan card connect to ISP

Discussion in 'Cisco' started by tg, Jul 30, 2008.

  1. tg

    tg Guest

    Cisco 2651XM router
    fitted with WIC-1ADSL interface card

    1) the cisco doc for the wic-adsl card says that when the CD light is flashing this means
    it's training with DSLAMs, but the light flashes in two different ways, there's a few
    seconds of fast flashing, followed by a few seconds of slow flashing. What do these two
    different flashing speeds signify?

    2) as a newbie I've been unsuccessful in connecting to my ISP with the wic-adsl card.
    Before coming here I've been trawling through cisco documents but I can't work out what
    the correct commands are for a successful connection. I confess I also don't know the
    command to verify if I have a successful connection or not.
    My wic card is present in the cli as interface ATM0/0.
    Here are the details for connecting to my isp, who happens to be a very bog standard UK
    isp on a BT phone line.
    Connection type: PPPoA
    VPI value: 0
    VCI Value: 38
    Encapsulation type: VC-MUX (or VC based)
    Modulation: G.DMT (or DMT)
    Authentication type: CHAP (may be listed as "PAP or CHAP")
    ADSL Username: username
    ADSL Password: password

    Thanks for any pointers.
     
    tg, Jul 30, 2008
    #1
    1. Advertising

  2. "tg" <> writes:
    >Cisco 2651XM router
    >fitted with WIC-1ADSL interface card


    >1) the cisco doc for the wic-adsl card says that when the CD light is flashing this means
    >it's training with DSLAMs, but the light flashes in two different ways, there's a few
    >seconds of fast flashing, followed by a few seconds of slow flashing. What do these two
    >different flashing speeds signify?



    Different phases of the DSL training up.
    You can watch the card with the 'show dsl int atm 0/0' command..


    >2) as a newbie I've been unsuccessful in connecting to my ISP with the wic-adsl card.
    >Before coming here I've been trawling through cisco documents but I can't work out what
    >the correct commands are for a successful connection. I confess I also don't know the
    >command to verify if I have a successful connection or not.
    >My wic card is present in the cli as interface ATM0/0.
    >Here are the details for connecting to my isp, who happens to be a very bog standard UK
    >isp on a BT phone line.
    >Connection type: PPPoA
    >VPI value: 0
    >VCI Value: 38
    >Encapsulation type: VC-MUX (or VC based)
    >Modulation: G.DMT (or DMT)
    >Authentication type: CHAP (may be listed as "PAP or CHAP")
    >ADSL Username: username
    >ADSL Password: password


    Probably PAP and not CHAP...

    interface ATM0
    no shutdown
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    interface Dialer1
    description PPPoA Dialer
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    ppp authentication chap pap callin
    ppp pap sent-username username password password

    Should be straight out of the Cisco docs for doing PPPoA on a cisco router..
     
    Doug McIntyre, Jul 31, 2008
    #2
    1. Advertising

  3. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:4890f4c7$0$90339$...
    > "tg" <> writes:
    >>Cisco 2651XM router
    >>fitted with WIC-1ADSL interface card


    > Probably PAP and not CHAP...
    >
    > interface ATM0
    > no shutdown
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > interface Dialer1
    > description PPPoA Dialer
    > ip address negotiated
    > encapsulation ppp
    > dialer pool 1
    > ppp authentication chap pap callin
    > ppp pap sent-username username password password
    >
    > Should be straight out of the Cisco docs for doing PPPoA on a cisco router..
    >

    thanks for your response Doug, those commands are making the adsl lights behave the way I
    think they should. Do you know if there's a way to test for certain if the adsl card is
    connected to the isp? Is there a command one can run? I think my lan-routing-nat-config is
    a mess and will need sorting out but I'd like to be certain about the adsl connection
    before proceeding with that. Thanks for any further advice.
     
    tg, Jul 31, 2008
    #3
  4. "tg" <> writes:
    >"Doug McIntyre" <> wrote in message
    >news:4890f4c7$0$90339$...
    >> "tg" <> writes:
    >>>Cisco 2651XM router
    >>>fitted with WIC-1ADSL interface card


    >> Probably PAP and not CHAP...
    >>
    >> interface ATM0
    >> no shutdown
    >> pvc 0/38
    >> encapsulation aal5mux ppp dialer
    >> dialer pool-member 1
    >> interface Dialer1
    >> description PPPoA Dialer
    >> ip address negotiated
    >> encapsulation ppp
    >> dialer pool 1
    >> ppp authentication chap pap callin
    >> ppp pap sent-username username password password
    >>
    >> Should be straight out of the Cisco docs for doing PPPoA on a cisco router..


    >thanks for your response Doug, those commands are making the adsl
    >lights behave the way I think they should. Do you know if there's a
    >way to test for certain if the adsl card is connected to the isp? Is
    >there a command one can run? I think my lan-routing-nat-config is a
    >mess and will need sorting out but I'd like to be certain about the
    >adsl connection before proceeding with that. Thanks for any further advice.



    There's really two actions.

    There's training up to the DSLAM. Then there's logging into the ISP's
    LNS or whatever they use internally.

    You can check on the DSL line training up to the DSLAM with the
    'show dsl int atm 0/0'

    command. Check status to make sure it says Showtime. Then you are trained.

    You can do a 'who' to see a PPPoA link connected to the ISP. You can
    also look at the 'show int dialer 1' to see if it obtained an IP address.
    Likely there'll be an 'interface is bound to Vix' and you should be
    able to see info on that virtual-interface.

    If neither are there, then you probably have to 'debug ppp packet' and
    the like to see what is going on.
     
    Doug McIntyre, Jul 31, 2008
    #4
  5. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:4891147d$0$90348$...

    > There's really two actions.
    >
    > There's training up to the DSLAM. Then there's logging into the ISP's
    > LNS or whatever they use internally.
    >
    > You can check on the DSL line training up to the DSLAM with the
    > 'show dsl int atm 0/0'
    >
    > command. Check status to make sure it says Showtime. Then you are trained.
    >
    > You can do a 'who' to see a PPPoA link connected to the ISP. You can
    > also look at the 'show int dialer 1' to see if it obtained an IP address.
    > Likely there'll be an 'interface is bound to Vix' and you should be
    > able to see info on that virtual-interface.
    >
    > If neither are there, then you probably have to 'debug ppp packet' and
    > the like to see what is going on.


    thanks for your further help Doug.
    I did 'show dsl int atm 0/0' and I did see 'Modem Status: Showtime (DMTDSL_SHOWTIME)'
    so I know the line has trained.
    I don't know the command to do a 'who', can you help me on that one?
    I did 'show int dialer 1' but there was no ip address in the router response so I think
    I'm still doing something wrong. Here is what the router said:
    ------------------
    router#show int dialer1
    Dialer1 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Description: PPP0A dialer
    Internet address will be negotiated using IPCP
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 1 seconds on reset
    Interface is bound to Vi2
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 00:04:49
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes
    0 packets output, 0 bytes
    Bound to:
    Virtual-Access2 is up, line protocol is down
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 448 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Listen
    PPPoATM vaccess, cloned from Dialer1
    Vaccess status 0x44
    Bound to ATM0/0 VCD: 1, VPI: 0, VCI: 38, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di1 (Encapsulation PPP)
    Last input 00:00:34, output never, output hang never
    Last clearing of "show interface" counters 00:05:14
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    40 packets input, 703 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    100 packets output, 1207 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
     
    tg, Jul 31, 2008
    #5
  6. tg

    tg Guest

    "Gabriele Beltrame" <> wrote in message
    news:4891c714$0$41661$...

    > Hi,
    >
    > the command 'who' is just that... (who) (should give you something like the following:
    > Interface User Mode Idle Peer Address
    > Vi2 PPPoATM 00:00:00 192.168.100.1
    > Anyway since your PPP is in state LCP Listen (should be LCP Open and IPCP Open) you're
    > not connected.
    > As already suggested try a 'debug ppp <something>' (i.e. debug ppp packet, debug ppp
    > events, debug ppp negotiation, debug ppp authentication) to find out the root cause


    thanks for your feedback Gabrielle. The lights on the adsl card appear to be doing the
    right thing and I've been trying to connect all day, so I rang my isp who said their end
    showed I hadn't even tried to log on (all day) so my router isn't even trying to connect,
    which I find puzzling. How does one get the adsl card to initiate a connection? I tried
    what you said and my cli responded thus: thanks for any further tips btw.
    -----------------------------

    router#debug ppp negotiation
    PPP protocol negotiation debugging is on
    router#debug ppp authentication
    PPP authentication debugging is on
    router#debug ppp events
    ^
    % Invalid input detected at '^' marker.

    router#debug ppp packet
    PPP packet display debugging is on

    router#who
    Line User Host(s) Idle Location
    * 0 con 0 idle 00:00:00

    Interface User Mode Idle Peer Address

    router#
     
    tg, Jul 31, 2008
    #6
  7. "tg" <> writes:
    >thanks for your feedback Gabrielle. The lights on the adsl card
    >appear to be doing the right thing and I've been trying to connect
    >all day, so I rang my isp who said their end showed I hadn't even
    >tried to log on (all day) so my router isn't even trying to connect,
    >which I find puzzling. How does one get the adsl card to initiate a
    >connection? I tried what you said and my cli responded thus: thanks
    >for any further tips btw.


    Double check the ATM PVC value given.

    If they aren't seeing something, most likely the PVC you stated was incorrect.

    IOS tries to pretty much dial PPPoA connections all the time, so you
    don't have to initiate anything.
     
    Doug McIntyre, Jul 31, 2008
    #7
  8. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:48923d14$0$90337$...
    > "tg" <> writes:
    >>thanks for your feedback Gabrielle. The lights on the adsl card
    >>appear to be doing the right thing and I've been trying to connect
    >>all day, so I rang my isp who said their end showed I hadn't even
    >>tried to log on (all day) so my router isn't even trying to connect,
    >>which I find puzzling. How does one get the adsl card to initiate a
    >>connection? I tried what you said and my cli responded thus: thanks
    >>for any further tips btw.

    >
    > Double check the ATM PVC value given.
    >
    > If they aren't seeing something, most likely the PVC you stated was incorrect.
    >
    > IOS tries to pretty much dial PPPoA connections all the time, so you
    > don't have to initiate anything.



    thanks for your reply Doug.
    the only thing I could find in the config regarding atm pvc value was:
    Bound to ATM0/0 VCD: 1, VPI: 0, VCI: 38, loopback not set

    The connection details my isp gives out to all customers is:
    Connection type: PPPoA
    VPI value: 0
    VCI Value: 38

    thus I've been entering:
    router(config-if)#pvc 0/38
    that's right isn't it?
     
    tg, Aug 1, 2008
    #8
  9. "tg" <> writes:
    >"Doug McIntyre" <> wrote in message
    >news:48923d14$0$90337$...
    >> "tg" <> writes:
    >>>thanks for your feedback Gabrielle. The lights on the adsl card
    >>>appear to be doing the right thing and I've been trying to connect
    >>>all day, so I rang my isp who said their end showed I hadn't even
    >>>tried to log on (all day) so my router isn't even trying to connect,
    >>>which I find puzzling. How does one get the adsl card to initiate a
    >>>connection? I tried what you said and my cli responded thus: thanks
    >>>for any further tips btw.

    >>
    >> Double check the ATM PVC value given.
    >>
    >> If they aren't seeing something, most likely the PVC you stated was incorrect.
    >>
    >> IOS tries to pretty much dial PPPoA connections all the time, so you
    >> don't have to initiate anything.



    >thanks for your reply Doug.
    >the only thing I could find in the config regarding atm pvc value was:
    >Bound to ATM0/0 VCD: 1, VPI: 0, VCI: 38, loopback not set


    >The connection details my isp gives out to all customers is:
    >Connection type: PPPoA
    > VPI value: 0
    > VCI Value: 38


    >thus I've been entering:
    >router(config-if)#pvc 0/38
    >that's right isn't it?


    pvc 0/38 enters pvc editing mode, it doesn't necessarily state that
    this is the PVC to use, but the commands underneath (ie. notice they
    are indented a space in the 'show conf' listing) define that things
    should talk o the PVC they are defined on.

    I'm just saying that typically, if your ISP isn't seeing you talking,
    then likely the PVC is wrong. The DSLAM will discard any cells they
    get on a PVC that doesn't match up (ie. they are configured for 8/38,
    and you talk on 0/38, the DSLAM is going to toss all those cells).

    If you do the 'debug ppp packet' and see your PPP packets going out,
    and not getting anything back, and the ISP isn't seeing anything from
    you, then there's something wrong in the middle. Either the PVC is
    wrong, or the circuit is broken, or something..
     
    Doug McIntyre, Aug 1, 2008
    #9
  10. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:48924ac5$0$90339$...

    thanks for your help along the way Doug, I'm finally on the internet with this adsl card.
    what a relief.
    There is one strange thing though, maybe you can shed some light.
    My lan is on 172.16.1.xx and goes into fastethernet port 0/0. There is nothing happening
    on fe0/1 and in the running config for it says:
    FastEthernet0/1 unassigned YES NVRAM administratively down
    and the little green lights for the f0/1 port are all off.
    But the adsl training won't sync without f0/1 being connected to something. I have a
    little plastic dinky router and if I switch it on and connect f0/1 to it the dsl sync
    eventually succeeds and the CD light goes solid and the internet connection comes on. But
    if I pull the cable out of the f0/1 port the CD light starts blinking. This is weird. Any
    idea why the router behaves this way?
     
    tg, Aug 1, 2008
    #10
  11. "tg" <> writes:
    >"Doug McIntyre" <> wrote in message
    >news:48924ac5$0$90339$...


    >thanks for your help along the way Doug, I'm finally on the internet with this adsl card.
    >what a relief.
    >There is one strange thing though, maybe you can shed some light.
    >My lan is on 172.16.1.xx and goes into fastethernet port 0/0. There is nothing happening
    >on fe0/1 and in the running config for it says:
    >FastEthernet0/1 unassigned YES NVRAM administratively down
    >and the little green lights for the f0/1 port are all off.
    >But the adsl training won't sync without f0/1 being connected to something. I have a
    >little plastic dinky router and if I switch it on and connect f0/1 to it the dsl sync
    >eventually succeeds and the CD light goes solid and the internet connection comes on. But
    >if I pull the cable out of the f0/1 port the CD light starts blinking. This is weird. Any
    >idea why the router behaves this way?



    Thats very odd. I've never seen it on dozens of 26xx class routers.

    This is all legit cisco gear? No gray-market stuff?

    Some of my resellers tell me weird & strange things can happen with
    gray-market stuff, like two knock-off WIC-1DSU-T1 cards in a 26xx
    router won't work at the same time and the like..

    Otherwise, try a different IOS rev.
     
    Doug McIntyre, Aug 2, 2008
    #11
  12. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:4893eda1$0$60066$...
    > "tg" <> writes:

    <snip>
    > Some of my resellers tell me weird & strange things can happen with
    > gray-market stuff, like two knock-off WIC-1DSU-T1 cards in a 26xx
    > router won't work at the same time and the like..
    >
    > Otherwise, try a different IOS rev.


    I bought the router and adsl card from the same guy off ebay - I don't know what
    gray-market stuff means and and don't know if my router is a gray market item. Is there a
    way to tell?
    Since my earlier post things have gone from bad to worse. Now I can't get any adsl sync at
    all. I'm stuck with a blinking CD light regardless of what wires are plugged in or not.
    I've contacted my isp to get them to check it but I'm still waiting for a reply from them.
    I've also done the swapping modem lead and filter etc but no joy.
    Which brings me to the question...
    if I can't get the dsl to train could this in any way be attributed to config errors?
    or is it purely a hardware issue?
    thanks for any advice you can give on this Doug and in the meantime I will certainly try a
    different IOS.
     
    tg, Aug 2, 2008
    #12
  13. tg

    tg Guest

    "tg" <> wrote in message news:g71hp6$vva$...
    >
    > "Doug McIntyre" <> wrote in message
    > news:4893eda1$0$60066$...
    >> "tg" <> writes:

    > <snip>
    > Since my earlier post things have gone from bad to worse. Now I can't get any adsl sync
    > at
    > all. I'm stuck with a blinking CD light regardless of what wires are plugged in or not.
    > I've contacted my isp to get them to check it but I'm still waiting for a reply from
    > them.
    > I've also done the swapping modem lead and filter etc but no joy.
    > Which brings me to the question...
    > if I can't get the dsl to train could this in any way be attributed to config errors?
    > or is it purely a hardware issue?
    > thanks for any advice you can give on this Doug and in the meantime I will certainly try
    > a
    > different IOS.


    before you respond Doug I found the problem. As a last desperate resort to this problem I
    took the adsl card out of the router and put it under a strong light and got out my
    magnifying glass and began to inspect the card. There's a silver capacitor that sticks up
    from the board and bugger me I could rock it backwards and forwards with my finger. So I
    got out the soldering iron, repaired the contacts, put the card back in and wham,
    perfecto. Thinking about it this is exactly the kind of fault that would happen from
    transit handling and I only unpacked it a few days ago.
     
    tg, Aug 2, 2008
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bobby

    Cisco WIC-1ADSL - No LEDs

    Bobby, Oct 21, 2003, in forum: Cisco
    Replies:
    1
    Views:
    859
    Chris
    Oct 21, 2003
  2. Andrew Brown

    Cisco WIC-1ADSL and SBC Yahoo DSL

    Andrew Brown, Oct 30, 2003, in forum: Cisco
    Replies:
    0
    Views:
    743
    Andrew Brown
    Oct 30, 2003
  3. Replies:
    4
    Views:
    2,068
  4. Roel Koops
    Replies:
    2
    Views:
    937
    Roel Koops
    Sep 8, 2006
  5. BlueMonkeyFish
    Replies:
    8
    Views:
    1,024
    BlueMonkeyFish
    Feb 24, 2007
Loading...

Share This Page