Cisco VPN with Site to Site and Remote Access

Discussion in 'Cisco' started by rustysyate, May 3, 2012.

  1. rustysyate

    rustysyate

    Joined:
    May 3, 2012
    Messages:
    1
    This is the first time for me to work with Cisco Router.
    The below mentioned is my configuration where
    Cisco Srv is Cisco 7200 Series Router XYZ is one VPN Server running on Linux. RAC is the Remote Access VPN Client
    | RAC |-----> | XYZ | ===== | Cisco Srv |

    HTML:
    The configuration for the Cisco Srv: no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service internal
    !
    hostname Cisco7200
    !
    aaa new-model
    !
    !
    aaa authorization network hw-client-groupname local
    aaa session-id common
    enable password cisco
    !
    memory-size iomem 16
    clock timezone - 0 6
    ip subnet-zero
    no ip source-route
    !
    !
    ip domain-name cisco.com
    !
    ip audit notify log
    ip audit po max-events 100
    !
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp client configuration address-pool local dynpool
    !
    crypto isakmp client configuration group hw-client-groupname
    key hw-client-password
    dns 30.30.30.10 30.30.30.11
    wins 30.30.30.12 30.30.30.13
    domain cisco.com
    pool dynpool
    
    crypto isakm profile VPNclient
    description VPN clients profile
    match identity group hw-client-groupname
    isakmp authorization list hw-client-groupname
    client configuration address respond
    
    crypto ipsec transform-set transform-1 esp-3des esp-sha-hmac
    crypto dynamic-map vpnclient 1
    set transform-set transform-1
    set isakmp-profile VPNclient
    reverse-route
    !
    crypto isakmp policy 10
    encr aes 256
    hash sha
    authentication pre-share
    group 2
    
    crypto isakmp key somestrongkey address 0.0.0.0 0.0.0.0
    
    crypto ipsec transform-set ts esp-aes 256 esp-sha-hmac
    
    ip access-list extended vpn
    deny ip 192.168.1.22 255.255.255.255 20.1.1.0 255.255.255.0
    permit ip 192.168.1.22 255.255.255.225 any
    crypto dynamic-map vpndynamic 10
    set transform-set ts
    match address vpn
    reverse-route 
    
    crypto map dynmap 1 ipsec-isakmp dynamic vpnclient
    crypto map dynmap 10 ipsec-isakmp dynamic vpndynamic
    
    interface FastEthernet1/0
    ip addr 192.168.1.22 255.255.255.0
    no shutdown
    crypto map dynmap
    no cdp enable
    !
    interface f1/1
    description connected to HQ LAN
    ip address 30.30.30.1 255.255.255.0
    no shutdown
    speed auto
    no cdp enable
    !
    ip local pool dynpool 30.30.30.20 30.30.30.30
    ip classless
    ip route 20.1.1.0 255.255.255.0 192.168.1.2 
    no ip http server
    ip pim bidir-enable
    !
    !
    no cdp run
    !
    line con 0
    line aux 0
    line vty 0 4
    password cisco
    !
    end
    I can individually create a tunnel between Cisco Srv and RAC also between Cisco Srv and XYZ. But when the tunnel between Cisco Srv and XYZ is established, i can't create a tunnel with RAC from Cisco Srv. If anyone can shed some light it would be a great help for me.
    rustysyate, May 3, 2012
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Vigarv
    Replies:
    1
    Views:
    1,500
    Walter Roberson
    Aug 7, 2006
  2. steviebee_uk

    Remote Access And Site To Site VPN

    steviebee_uk, Nov 15, 2006, in forum: Cisco
    Replies:
    0
    Views:
    934
    steviebee_uk
    Nov 15, 2006
  3. drhopkins@cox.net

    PIX 501 Site-to-Site VPN and Remote Access VPN

    drhopkins@cox.net, Nov 14, 2006, in forum: Cisco
    Replies:
    1
    Views:
    627
    Walter Roberson
    Nov 14, 2006
  4. pasatealinux
    Replies:
    1
    Views:
    2,001
    pasatealinux
    Dec 17, 2007
  5. BF
    Replies:
    2
    Views:
    737
Loading...

Share This Page