Cisco Switch/Router configuration help.

Discussion in 'Cisco' started by Jimsu, Nov 12, 2007.

  1. Jimsu

    Jimsu Guest

    Hello,

    I've done some cisco configurations in the past without much issue.
    Usually, between books and the internet, I can figure just about any
    of them out.. but this one is stumping me. Perhaps there's an IOS
    issue (like I have the wrong one), or perhaps it's pebkac.

    I am trying to setup a sample network, or networks. I'm trying to
    configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    24). On each of the subinterfaces I've added the router ip addresses.

    On the switch (cisco 2950) I've put the port into trunk mode (same
    with the main interface on the router). i've added the ports to the
    appropriate vlans, but I'm getting no connectivity.

    If anyone can please advise, and/or provide a link to further
    resources, I would appreciate it. Here are the devices and configs:

    Cisco 2950:

    eanut_sw1#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    SOFTWARE (fc1)
    Copyright (c) 1986-2005 by cisco Systems, Inc.
    Compiled Wed 23-Mar-05 15:33 by yenanh
    Image text-base: 0x80010000, data-base: 0x80562000

    ROM: Bootstrap program is C2950 boot loader

    eanut_sw1 uptime is 22 minutes
    System returned to ROM by power-on
    System restarted at 07:43:26 CDT Mon Nov 12 2007
    System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    bytes of memory.
    Processor board ID FOC0937Z6KN
    Last reset from system-reset
    Running Enhanced Image
    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)

    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:15:63:73:1B:40
    Motherboard assembly number: 73-7280-05
    Power supply part number: 34-0965-01
    Motherboard serial number: FOC09371F6S
    Power supply serial number: PHI0931C2MW
    Model revision number: L0
    Motherboard revision number: A0
    Model number: WS-C2950G-24-EI
    System serial number: FOC0937Z6KN
    Configuration register is 0xF

    Cisco 2610:

    #sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    SOFTWARE (fc3)
    Copyright (c) 1986-2004 by cisco Systems, Inc.
    Compiled Tue 17-Aug-04 05:11 by kellythw
    Image text-base: 0x80008098, data-base: 0x819E9FE4

    ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    uptime is 54 minutes
    System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are
    unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be
    found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email
    to
    .

    cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    of memory.
    Processor board ID JAD041007W7 (1350106988)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    1 Ethernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102

    Now onto the applicable configs:

    2950 (the port Im plugging the switch into is fa0/1, so I stopped
    there):

    Current configuration : 2055 bytes
    !
    ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    !
    version 12.1
    no service pad
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    !
    hostname eanut_sw1
    !
    clock timezone CDT -6
    ip subnet-zero
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    !

    Cisco 2510 config:

    !
    interface Ethernet0/0
    no ip address
    no ip unreachables
    no ip proxy-arp
    full-duplex
    no cdp enable
    !
    interface Ethernet0/0.1
    encapsulation dot1Q 1 native
    ip address 192.168.2.99 255.255.255.0
    no cdp enable
    !
    interface Ethernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.248.99 255.255.255.0
    no cdp enable
    !

    with this setup, I cannot ping any devices on either network, and the
    network cannot ping the .99 addresses assigned on the router. Please
    advise. Hopefully, I'm just missing something obvious.

    Thank you,

    Jim Surles
    Jimsu, Nov 12, 2007
    #1
    1. Advertising

  2. Jimsu

    Trendkill Guest

    On Nov 12, 9:36 am, Jimsu <> wrote:
    > Hello,
    >
    > I've done some cisco configurations in the past without much issue.
    > Usually, between books and the internet, I can figure just about any
    > of them out.. but this one is stumping me. Perhaps there's an IOS
    > issue (like I have the wrong one), or perhaps it's pebkac.
    >
    > I am trying to setup a sample network, or networks. I'm trying to
    > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > 24). On each of the subinterfaces I've added the router ip addresses.
    >
    > On the switch (cisco 2950) I've put the port into trunk mode (same
    > with the main interface on the router). i've added the ports to the
    > appropriate vlans, but I'm getting no connectivity.
    >
    > If anyone can please advise, and/or provide a link to further
    > resources, I would appreciate it. Here are the devices and configs:
    >
    > Cisco 2950:
    >
    > eanut_sw1#sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > SOFTWARE (fc1)
    > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > Compiled Wed 23-Mar-05 15:33 by yenanh
    > Image text-base: 0x80010000, data-base: 0x80562000
    >
    > ROM: Bootstrap program is C2950 boot loader
    >
    > eanut_sw1 uptime is 22 minutes
    > System returned to ROM by power-on
    > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"
    >
    > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > bytes of memory.
    > Processor board ID FOC0937Z6KN
    > Last reset from system-reset
    > Running Enhanced Image
    > 24 FastEthernet/IEEE 802.3 interface(s)
    > 2 Gigabit Ethernet/IEEE 802.3 interface(s)
    >
    > 32K bytes of flash-simulated non-volatile configuration memory.
    > Base ethernet MAC Address: 00:15:63:73:1B:40
    > Motherboard assembly number: 73-7280-05
    > Power supply part number: 34-0965-01
    > Motherboard serial number: FOC09371F6S
    > Power supply serial number: PHI0931C2MW
    > Model revision number: L0
    > Motherboard revision number: A0
    > Model number: WS-C2950G-24-EI
    > System serial number: FOC0937Z6KN
    > Configuration register is 0xF
    >
    > Cisco 2610:
    >
    > #sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > SOFTWARE (fc3)
    > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > Compiled Tue 17-Aug-04 05:11 by kellythw
    > Image text-base: 0x80008098, data-base: 0x819E9FE4
    >
    > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
    >
    > uptime is 54 minutes
    > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"
    >
    > This product contains cryptographic features and is subject to United
    > States and local country laws governing import, export, transfer and
    > use. Delivery of Cisco cryptographic products does not imply
    > third-party authority to import, export, distribute or use encryption.
    > Importers, exporters, distributors and users are responsible for
    > compliance with U.S. and local country laws. By using this product you
    > agree to comply with applicable laws and regulations. If you are
    > unable
    > to comply with U.S. and local laws, return this product immediately.
    >
    > A summary of U.S. laws governing Cisco cryptographic products may be
    > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >
    > If you require further assistance please contact us by sending email
    > to
    > .
    >
    > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > of memory.
    > Processor board ID JAD041007W7 (1350106988)
    > M860 processor: part number 0, mask 49
    > Bridging software.
    > X.25 software, Version 3.0.0.
    > 1 Ethernet/IEEE 802.3 interface(s)
    > 1 Serial network interface(s)
    > 32K bytes of non-volatile configuration memory.
    > 16384K bytes of processor board System flash (Read/Write)
    >
    > Configuration register is 0x2102
    >
    > Now onto the applicable configs:
    >
    > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > there):
    >
    > Current configuration : 2055 bytes
    > !
    > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > !
    > version 12.1
    > no service pad
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > !
    > hostname eanut_sw1
    > !
    > clock timezone CDT -6
    > ip subnet-zero
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > !
    >
    > Cisco 2510 config:
    >
    > !
    > interface Ethernet0/0
    > no ip address
    > no ip unreachables
    > no ip proxy-arp
    > full-duplex
    > no cdp enable
    > !
    > interface Ethernet0/0.1
    > encapsulation dot1Q 1 native
    > ip address 192.168.2.99 255.255.255.0
    > no cdp enable
    > !
    > interface Ethernet0/0.2
    > encapsulation dot1Q 2
    > ip address 192.168.248.99 255.255.255.0
    > no cdp enable
    > !
    >
    > with this setup, I cannot ping any devices on either network, and the
    > network cannot ping the .99 addresses assigned on the router. Please
    > advise. Hopefully, I'm just missing something obvious.
    >
    > Thank you,
    >
    > Jim Surles


    Have you checked the encapsulation type on the 2950? I see you have
    configured the trunk, but I am not sure of the default trunking encap
    on the 2950. May want ot make sure you have the same on both sides.
    Additionally, are you going to put your management interface on the
    2950 in one of the vlans so you can test from switch to router before
    you test from node in switch to router? May help you...
    Trendkill, Nov 12, 2007
    #2
    1. Advertising

  3. Jimsu

    Jimsu Guest

    On Nov 12, 9:19 am, Trendkill <> wrote:
    > On Nov 12, 9:36 am, Jimsu <> wrote:
    >
    >
    >
    > > Hello,

    >
    > > I've done some cisco configurations in the past without much issue.
    > > Usually, between books and the internet, I can figure just about any
    > > of them out.. but this one is stumping me. Perhaps there's an IOS
    > > issue (like I have the wrong one), or perhaps it's pebkac.

    >
    > > I am trying to setup a sample network, or networks. I'm trying to
    > > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > > 24). On each of the subinterfaces I've added the router ip addresses.

    >
    > > On the switch (cisco 2950) I've put the port into trunk mode (same
    > > with the main interface on the router). i've added the ports to the
    > > appropriate vlans, but I'm getting no connectivity.

    >
    > > If anyone can please advise, and/or provide a link to further
    > > resources, I would appreciate it. Here are the devices and configs:

    >
    > > Cisco 2950:

    >
    > > eanut_sw1#sh ver
    > > Cisco Internetwork Operating System Software
    > > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > > SOFTWARE (fc1)
    > > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > > Compiled Wed 23-Mar-05 15:33 by yenanh
    > > Image text-base: 0x80010000, data-base: 0x80562000

    >
    > > ROM: Bootstrap program is C2950 boot loader

    >
    > > eanut_sw1 uptime is 22 minutes
    > > System returned to ROM by power-on
    > > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    >
    > > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > > bytes of memory.
    > > Processor board ID FOC0937Z6KN
    > > Last reset from system-reset
    > > Running Enhanced Image
    > > 24 FastEthernet/IEEE 802.3 interface(s)
    > > 2 Gigabit Ethernet/IEEE 802.3 interface(s)

    >
    > > 32K bytes of flash-simulated non-volatile configuration memory.
    > > Base ethernet MAC Address: 00:15:63:73:1B:40
    > > Motherboard assembly number: 73-7280-05
    > > Power supply part number: 34-0965-01
    > > Motherboard serial number: FOC09371F6S
    > > Power supply serial number: PHI0931C2MW
    > > Model revision number: L0
    > > Motherboard revision number: A0
    > > Model number: WS-C2950G-24-EI
    > > System serial number: FOC0937Z6KN
    > > Configuration register is 0xF

    >
    > > Cisco 2610:

    >
    > > #sh ver
    > > Cisco Internetwork Operating System Software
    > > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > > SOFTWARE (fc3)
    > > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > > Compiled Tue 17-Aug-04 05:11 by kellythw
    > > Image text-base: 0x80008098, data-base: 0x819E9FE4

    >
    > > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    >
    > > uptime is 54 minutes
    > > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"

    >
    > > This product contains cryptographic features and is subject to United
    > > States and local country laws governing import, export, transfer and
    > > use. Delivery of Cisco cryptographic products does not imply
    > > third-party authority to import, export, distribute or use encryption.
    > > Importers, exporters, distributors and users are responsible for
    > > compliance with U.S. and local country laws. By using this product you
    > > agree to comply with applicable laws and regulations. If you are
    > > unable
    > > to comply with U.S. and local laws, return this product immediately.

    >
    > > A summary of U.S. laws governing Cisco cryptographic products may be
    > > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    >
    > > If you require further assistance please contact us by sending email
    > > to
    > > .

    >
    > > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > > of memory.
    > > Processor board ID JAD041007W7 (1350106988)
    > > M860 processor: part number 0, mask 49
    > > Bridging software.
    > > X.25 software, Version 3.0.0.
    > > 1 Ethernet/IEEE 802.3 interface(s)
    > > 1 Serial network interface(s)
    > > 32K bytes of non-volatile configuration memory.
    > > 16384K bytes of processor board System flash (Read/Write)

    >
    > > Configuration register is 0x2102

    >
    > > Now onto the applicable configs:

    >
    > > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > > there):

    >
    > > Current configuration : 2055 bytes
    > > !
    > > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > > !
    > > version 12.1
    > > no service pad
    > > service timestamps debug datetime localtime
    > > service timestamps log datetime localtime
    > > !
    > > hostname eanut_sw1
    > > !
    > > clock timezone CDT -6
    > > ip subnet-zero
    > > !
    > > !
    > > spanning-tree mode pvst
    > > no spanning-tree optimize bpdu transmission
    > > spanning-tree extend system-id
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0/1
    > > switchport mode trunk
    > > !

    >
    > > Cisco 2510 config:

    >
    > > !
    > > interface Ethernet0/0
    > > no ip address
    > > no ip unreachables
    > > no ip proxy-arp
    > > full-duplex
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.1
    > > encapsulation dot1Q 1 native
    > > ip address 192.168.2.99 255.255.255.0
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.2
    > > encapsulation dot1Q 2
    > > ip address 192.168.248.99 255.255.255.0
    > > no cdp enable
    > > !

    >
    > > with this setup, I cannot ping any devices on either network, and the
    > > network cannot ping the .99 addresses assigned on the router. Please
    > > advise. Hopefully, I'm just missing something obvious.

    >
    > > Thank you,

    >
    > > Jim Surles

    >
    > Have you checked the encapsulation type on the 2950? I see you have
    > configured the trunk, but I am not sure of the default trunking encap
    > on the 2950. May want ot make sure you have the same on both sides.
    > Additionally, are you going to put your management interface on the
    > 2950 in one of the vlans so you can test from switch to router before
    > you test from node in switch to router? May help you...



    i currently have the switch addressed as 192.168.2.10 (192.168.2.x is
    the currently implemented network), all of the ports in use use this
    network on the default vlan 1. I have tried setting the encapsulation
    specifically on the 2950, and it wouldn't work.. ie, the command
    wasn't there (switchport trunk encapsulation dot1q). From what Ive
    read the 2950 does not support ISL, only dot1q, so it does this by
    default.

    Anything else to look into?
    Jimsu, Nov 12, 2007
    #3
  4. Jimsu

    Trendkill Guest

    On Nov 12, 10:44 am, Jimsu <> wrote:
    > On Nov 12, 9:19 am, Trendkill <> wrote:
    >
    >
    >
    > > On Nov 12, 9:36 am, Jimsu <> wrote:

    >
    > > > Hello,

    >
    > > > I've done some cisco configurations in the past without much issue.
    > > > Usually, between books and the internet, I can figure just about any
    > > > of them out.. but this one is stumping me. Perhaps there's an IOS
    > > > issue (like I have the wrong one), or perhaps it's pebkac.

    >
    > > > I am trying to setup a sample network, or networks. I'm trying to
    > > > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > > > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > > > 24). On each of the subinterfaces I've added the router ip addresses.

    >
    > > > On the switch (cisco 2950) I've put the port into trunk mode (same
    > > > with the main interface on the router). i've added the ports to the
    > > > appropriate vlans, but I'm getting no connectivity.

    >
    > > > If anyone can please advise, and/or provide a link to further
    > > > resources, I would appreciate it. Here are the devices and configs:

    >
    > > > Cisco 2950:

    >
    > > > eanut_sw1#sh ver
    > > > Cisco Internetwork Operating System Software
    > > > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > > > SOFTWARE (fc1)
    > > > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > > > Compiled Wed 23-Mar-05 15:33 by yenanh
    > > > Image text-base: 0x80010000, data-base: 0x80562000

    >
    > > > ROM: Bootstrap program is C2950 boot loader

    >
    > > > eanut_sw1 uptime is 22 minutes
    > > > System returned to ROM by power-on
    > > > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > > > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    >
    > > > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > > > bytes of memory.
    > > > Processor board ID FOC0937Z6KN
    > > > Last reset from system-reset
    > > > Running Enhanced Image
    > > > 24 FastEthernet/IEEE 802.3 interface(s)
    > > > 2 Gigabit Ethernet/IEEE 802.3 interface(s)

    >
    > > > 32K bytes of flash-simulated non-volatile configuration memory.
    > > > Base ethernet MAC Address: 00:15:63:73:1B:40
    > > > Motherboard assembly number: 73-7280-05
    > > > Power supply part number: 34-0965-01
    > > > Motherboard serial number: FOC09371F6S
    > > > Power supply serial number: PHI0931C2MW
    > > > Model revision number: L0
    > > > Motherboard revision number: A0
    > > > Model number: WS-C2950G-24-EI
    > > > System serial number: FOC0937Z6KN
    > > > Configuration register is 0xF

    >
    > > > Cisco 2610:

    >
    > > > #sh ver
    > > > Cisco Internetwork Operating System Software
    > > > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > > > SOFTWARE (fc3)
    > > > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > > > Compiled Tue 17-Aug-04 05:11 by kellythw
    > > > Image text-base: 0x80008098, data-base: 0x819E9FE4

    >
    > > > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    >
    > > > uptime is 54 minutes
    > > > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > > > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"

    >
    > > > This product contains cryptographic features and is subject to United
    > > > States and local country laws governing import, export, transfer and
    > > > use. Delivery of Cisco cryptographic products does not imply
    > > > third-party authority to import, export, distribute or use encryption.
    > > > Importers, exporters, distributors and users are responsible for
    > > > compliance with U.S. and local country laws. By using this product you
    > > > agree to comply with applicable laws and regulations. If you are
    > > > unable
    > > > to comply with U.S. and local laws, return this product immediately.

    >
    > > > A summary of U.S. laws governing Cisco cryptographic products may be
    > > > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    >
    > > > If you require further assistance please contact us by sending email
    > > > to
    > > > .

    >
    > > > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > > > of memory.
    > > > Processor board ID JAD041007W7 (1350106988)
    > > > M860 processor: part number 0, mask 49
    > > > Bridging software.
    > > > X.25 software, Version 3.0.0.
    > > > 1 Ethernet/IEEE 802.3 interface(s)
    > > > 1 Serial network interface(s)
    > > > 32K bytes of non-volatile configuration memory.
    > > > 16384K bytes of processor board System flash (Read/Write)

    >
    > > > Configuration register is 0x2102

    >
    > > > Now onto the applicable configs:

    >
    > > > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > > > there):

    >
    > > > Current configuration : 2055 bytes
    > > > !
    > > > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > > > !
    > > > version 12.1
    > > > no service pad
    > > > service timestamps debug datetime localtime
    > > > service timestamps log datetime localtime
    > > > !
    > > > hostname eanut_sw1
    > > > !
    > > > clock timezone CDT -6
    > > > ip subnet-zero
    > > > !
    > > > !
    > > > spanning-tree mode pvst
    > > > no spanning-tree optimize bpdu transmission
    > > > spanning-tree extend system-id
    > > > !
    > > > !
    > > > !
    > > > !
    > > > interface FastEthernet0/1
    > > > switchport mode trunk
    > > > !

    >
    > > > Cisco 2510 config:

    >
    > > > !
    > > > interface Ethernet0/0
    > > > no ip address
    > > > no ip unreachables
    > > > no ip proxy-arp
    > > > full-duplex
    > > > no cdp enable
    > > > !
    > > > interface Ethernet0/0.1
    > > > encapsulation dot1Q 1 native
    > > > ip address 192.168.2.99 255.255.255.0
    > > > no cdp enable
    > > > !
    > > > interface Ethernet0/0.2
    > > > encapsulation dot1Q 2
    > > > ip address 192.168.248.99 255.255.255.0
    > > > no cdp enable
    > > > !

    >
    > > > with this setup, I cannot ping any devices on either network, and the
    > > > network cannot ping the .99 addresses assigned on the router. Please
    > > > advise. Hopefully, I'm just missing something obvious.

    >
    > > > Thank you,

    >
    > > > Jim Surles

    >
    > > Have you checked the encapsulation type on the 2950? I see you have
    > > configured the trunk, but I am not sure of the default trunking encap
    > > on the 2950. May want ot make sure you have the same on both sides.
    > > Additionally, are you going to put your management interface on the
    > > 2950 in one of the vlans so you can test from switch to router before
    > > you test from node in switch to router? May help you...

    >
    > i currently have the switch addressed as 192.168.2.10 (192.168.2.x is
    > the currently implemented network), all of the ports in use use this
    > network on the default vlan 1. I have tried setting the encapsulation
    > specifically on the 2950, and it wouldn't work.. ie, the command
    > wasn't there (switchport trunk encapsulation dot1q). From what Ive
    > read the 2950 does not support ISL, only dot1q, so it does this by
    > default.
    >
    > Anything else to look into?


    Interfaces up on both devices? Speed/duplex are hard coded correct?
    Paste a show int on both devices. Have you switch it back to an
    access port on the both sides and can ping then?
    Trendkill, Nov 12, 2007
    #4
  5. Jimsu

    c0d3w12 Guest

    On Nov 12, 6:36 am, Jimsu <> wrote:
    > Hello,
    >
    > I've done some cisco configurations in the past without much issue.
    > Usually, between books and the internet, I can figure just about any
    > of them out.. but this one is stumping me. Perhaps there's an IOS
    > issue (like I have the wrong one), or perhaps it's pebkac.
    >
    > I am trying to setup a sample network, or networks. I'm trying to
    > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > 24). On each of the subinterfaces I've added the router ip addresses.
    >
    > On the switch (cisco 2950) I've put the port into trunk mode (same
    > with the main interface on the router). i've added the ports to the
    > appropriate vlans, but I'm getting no connectivity.
    >
    > If anyone can please advise, and/or provide a link to further
    > resources, I would appreciate it. Here are the devices and configs:
    >
    > Cisco 2950:
    >
    > eanut_sw1#sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > SOFTWARE (fc1)
    > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > Compiled Wed 23-Mar-05 15:33 by yenanh
    > Image text-base: 0x80010000, data-base: 0x80562000
    >
    > ROM: Bootstrap program is C2950 boot loader
    >
    > eanut_sw1 uptime is 22 minutes
    > System returned to ROM by power-on
    > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"
    >
    > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > bytes of memory.
    > Processor board ID FOC0937Z6KN
    > Last reset from system-reset
    > Running Enhanced Image
    > 24 FastEthernet/IEEE 802.3 interface(s)
    > 2 Gigabit Ethernet/IEEE 802.3 interface(s)
    >
    > 32K bytes of flash-simulated non-volatile configuration memory.
    > Base ethernet MAC Address: 00:15:63:73:1B:40
    > Motherboard assembly number: 73-7280-05
    > Power supply part number: 34-0965-01
    > Motherboard serial number: FOC09371F6S
    > Power supply serial number: PHI0931C2MW
    > Model revision number: L0
    > Motherboard revision number: A0
    > Model number: WS-C2950G-24-EI
    > System serial number: FOC0937Z6KN
    > Configuration register is 0xF
    >
    > Cisco 2610:
    >
    > #sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > SOFTWARE (fc3)
    > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > Compiled Tue 17-Aug-04 05:11 by kellythw
    > Image text-base: 0x80008098, data-base: 0x819E9FE4
    >
    > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
    >
    > uptime is 54 minutes
    > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"
    >
    > This product contains cryptographic features and is subject to United
    > States and local country laws governing import, export, transfer and
    > use. Delivery of Cisco cryptographic products does not imply
    > third-party authority to import, export, distribute or use encryption.
    > Importers, exporters, distributors and users are responsible for
    > compliance with U.S. and local country laws. By using this product you
    > agree to comply with applicable laws and regulations. If you are
    > unable
    > to comply with U.S. and local laws, return this product immediately.
    >
    > A summary of U.S. laws governing Cisco cryptographic products may be
    > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >
    > If you require further assistance please contact us by sending email
    > to
    > .
    >
    > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > of memory.
    > Processor board ID JAD041007W7 (1350106988)
    > M860 processor: part number 0, mask 49
    > Bridging software.
    > X.25 software, Version 3.0.0.
    > 1 Ethernet/IEEE 802.3 interface(s)
    > 1 Serial network interface(s)
    > 32K bytes of non-volatile configuration memory.
    > 16384K bytes of processor board System flash (Read/Write)
    >
    > Configuration register is 0x2102
    >
    > Now onto the applicable configs:
    >
    > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > there):
    >
    > Current configuration : 2055 bytes
    > !
    > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > !
    > version 12.1
    > no service pad
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > !
    > hostname eanut_sw1
    > !
    > clock timezone CDT -6
    > ip subnet-zero
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > !
    >
    > Cisco 2510 config:
    >
    > !
    > interface Ethernet0/0
    > no ip address
    > no ip unreachables
    > no ip proxy-arp
    > full-duplex
    > no cdp enable
    > !
    > interface Ethernet0/0.1
    > encapsulation dot1Q 1 native
    > ip address 192.168.2.99 255.255.255.0
    > no cdp enable
    > !
    > interface Ethernet0/0.2
    > encapsulation dot1Q 2
    > ip address 192.168.248.99 255.255.255.0
    > no cdp enable
    > !
    >
    > with this setup, I cannot ping any devices on either network, and the
    > network cannot ping the .99 addresses assigned on the router. Please
    > advise. Hopefully, I'm just missing something obvious.
    >
    > Thank you,
    >
    > Jim Surles





    Do a show run and paste up the finding.
    c0d3w12, Nov 12, 2007
    #5
  6. Jimsu

    guillermo.ralil

    Joined:
    Nov 12, 2007
    Messages:
    3
    -vlans in the 2950 are created?

    post a "show vlan" comand in your switch 2950...

    your vlans are mapped correctly with your router subinterfaces?

    encapsulation dot1Q 1 native <-- vlan 1 in 2950
    encapsulation dot1Q 2 <-- vlan 2 in 2950


    -the default gateway in the 2950 is correctly configured?
    -the ip for 2950 in the vlan 1... what is? test from switch to your router whit pings and traceroutes

    -the encapsulation not is the problem... 2950 only support dot1q and your router is operating in the same protocol..

    sorry for my english

    ;)
    Last edited: Nov 12, 2007
    guillermo.ralil, Nov 12, 2007
    #6
  7. Jimsu

    Jimsu Guest

    On Nov 12, 11:48 am, c0d3w12 <> wrote:
    > On Nov 12, 6:36 am, Jimsu <> wrote:
    >
    >
    >
    > > Hello,

    >
    > > I've done some cisco configurations in the past without much issue.
    > > Usually, between books and the internet, I can figure just about any
    > > of them out.. but this one is stumping me. Perhaps there's an IOS
    > > issue (like I have the wrong one), or perhaps it's pebkac.

    >
    > > I am trying to setup a sample network, or networks. I'm trying to
    > > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > > 24). On each of the subinterfaces I've added the router ip addresses.

    >
    > > On the switch (cisco 2950) I've put the port into trunk mode (same
    > > with the main interface on the router). i've added the ports to the
    > > appropriate vlans, but I'm getting no connectivity.

    >
    > > If anyone can please advise, and/or provide a link to further
    > > resources, I would appreciate it. Here are the devices and configs:

    >
    > > Cisco 2950:

    >
    > > eanut_sw1#sh ver
    > > Cisco Internetwork Operating System Software
    > > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > > SOFTWARE (fc1)
    > > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > > Compiled Wed 23-Mar-05 15:33 by yenanh
    > > Image text-base: 0x80010000, data-base: 0x80562000

    >
    > > ROM: Bootstrap program is C2950 boot loader

    >
    > > eanut_sw1 uptime is 22 minutes
    > > System returned to ROM by power-on
    > > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    >
    > > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > > bytes of memory.
    > > Processor board ID FOC0937Z6KN
    > > Last reset from system-reset
    > > Running Enhanced Image
    > > 24 FastEthernet/IEEE 802.3 interface(s)
    > > 2 Gigabit Ethernet/IEEE 802.3 interface(s)

    >
    > > 32K bytes of flash-simulated non-volatile configuration memory.
    > > Base ethernet MAC Address: 00:15:63:73:1B:40
    > > Motherboard assembly number: 73-7280-05
    > > Power supply part number: 34-0965-01
    > > Motherboard serial number: FOC09371F6S
    > > Power supply serial number: PHI0931C2MW
    > > Model revision number: L0
    > > Motherboard revision number: A0
    > > Model number: WS-C2950G-24-EI
    > > System serial number: FOC0937Z6KN
    > > Configuration register is 0xF

    >
    > > Cisco 2610:

    >
    > > #sh ver
    > > Cisco Internetwork Operating System Software
    > > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > > SOFTWARE (fc3)
    > > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > > Compiled Tue 17-Aug-04 05:11 by kellythw
    > > Image text-base: 0x80008098, data-base: 0x819E9FE4

    >
    > > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    >
    > > uptime is 54 minutes
    > > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"

    >
    > > This product contains cryptographic features and is subject to United
    > > States and local country laws governing import, export, transfer and
    > > use. Delivery of Cisco cryptographic products does not imply
    > > third-party authority to import, export, distribute or use encryption.
    > > Importers, exporters, distributors and users are responsible for
    > > compliance with U.S. and local country laws. By using this product you
    > > agree to comply with applicable laws and regulations. If you are
    > > unable
    > > to comply with U.S. and local laws, return this product immediately.

    >
    > > A summary of U.S. laws governing Cisco cryptographic products may be
    > > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    >
    > > If you require further assistance please contact us by sending email
    > > to
    > > .

    >
    > > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > > of memory.
    > > Processor board ID JAD041007W7 (1350106988)
    > > M860 processor: part number 0, mask 49
    > > Bridging software.
    > > X.25 software, Version 3.0.0.
    > > 1 Ethernet/IEEE 802.3 interface(s)
    > > 1 Serial network interface(s)
    > > 32K bytes of non-volatile configuration memory.
    > > 16384K bytes of processor board System flash (Read/Write)

    >
    > > Configuration register is 0x2102

    >
    > > Now onto the applicable configs:

    >
    > > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > > there):

    >
    > > Current configuration : 2055 bytes
    > > !
    > > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > > !
    > > version 12.1
    > > no service pad
    > > service timestamps debug datetime localtime
    > > service timestamps log datetime localtime
    > > !
    > > hostname eanut_sw1
    > > !
    > > clock timezone CDT -6
    > > ip subnet-zero
    > > !
    > > !
    > > spanning-tree mode pvst
    > > no spanning-tree optimize bpdu transmission
    > > spanning-tree extend system-id
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0/1
    > > switchport mode trunk
    > > !

    >
    > > Cisco 2510 config:

    >
    > > !
    > > interface Ethernet0/0
    > > no ip address
    > > no ip unreachables
    > > no ip proxy-arp
    > > full-duplex
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.1
    > > encapsulation dot1Q 1 native
    > > ip address 192.168.2.99 255.255.255.0
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.2
    > > encapsulation dot1Q 2
    > > ip address 192.168.248.99 255.255.255.0
    > > no cdp enable
    > > !

    >
    > > with this setup, I cannot ping any devices on either network, and the
    > > network cannot ping the .99 addresses assigned on the router. Please
    > > advise. Hopefully, I'm just missing something obvious.

    >
    > > Thank you,

    >
    > > Jim Surles

    >
    > Do a show run and paste up the finding.


    Yes, both interfaces are showing up/up

    here is the full switch configuration:

    my_sw1#sh run
    Building configuration...

    Current configuration : 2055 bytes
    !
    ! Last configuration change at 09:52:51 CDT Mon Nov 12 2007
    !
    version 12.1
    no service pad
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    no service password-encryption
    !
    hostname my_sw1
    !
    enable secret 5 $secretstuff
    !
    clock timezone CDT -6
    ip subnet-zero
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    shutdown
    !
    interface FastEthernet0/3
    shutdown
    !
    interface FastEthernet0/4
    shutdown
    !
    interface FastEthernet0/5
    shutdown
    !
    interface FastEthernet0/6
    shutdown
    !
    interface FastEthernet0/7
    shutdown
    !
    interface FastEthernet0/8
    shutdown
    !
    interface FastEthernet0/9
    shutdown
    !
    interface FastEthernet0/10
    shutdown
    !
    interface FastEthernet0/11
    shutdown
    !
    interface FastEthernet0/12
    shutdown
    !
    interface FastEthernet0/13
    description IP Phone
    !
    interface FastEthernet0/14
    shutdown
    !
    interface FastEthernet0/15
    description hydrogen - internet link
    bandwidth 6000
    !
    interface FastEthernet0/16
    shutdown
    !
    interface FastEthernet0/17
    description calcium link
    !
    interface FastEthernet0/18
    shutdown
    !
    interface FastEthernet0/19
    description chlorine link
    !
    interface FastEthernet0/20
    description potassium link
    !
    interface FastEthernet0/21
    description 100 mbs to helium (back house)
    !
    interface FastEthernet0/22
    description Arsenic
    speed 100
    !
    interface FastEthernet0/23
    shutdown
    speed 100
    duplex full
    !
    interface FastEthernet0/24
    shutdown
    !
    interface GigabitEthernet0/1
    shutdown
    !
    interface GigabitEthernet0/2
    shutdown
    !
    interface Vlan1
    ip address 192.168.2.10 255.255.255.0
    no ip route-cache
    !
    ip default-gateway 192.168.2.1
    ip http server
    snmp-server community public RO
    snmp-server location Garage Rack
    snmp-server contact Jim Surles
    !
    line con 0
    exec-timeout 0 0
    line vty 0 4
    password testing
    login
    line vty 5 15
    password testing
    login
    !
    ntp clock-period 17179777
    ntp server 192.168.2.19
    !
    end

    Here is the full router configuration:

    my-rtr#sh run
    Building configuration...

    Current configuration : 1281 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname my-rtr
    !
    boot-start-marker
    boot system flash
    boot-end-marker
    !
    logging buffered 4096 debugging
    enable secret 5 $secretstuff
    !
    username jsurles password 7 083643410D
    clock timezone CST -6
    clock summer-time CDT recurring
    aaa new-model
    !
    !
    aaa session-id common
    ip subnet-zero
    ip cef
    !
    !
    ip name-server 192.168.2.19
    !
    ip audit po max-events 100
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    no ip address
    no ip unreachables
    no ip proxy-arp
    full-duplex
    no cdp enable
    !
    interface Ethernet0/0.1
    encapsulation dot1Q 1 native
    ip address 192.168.2.99 255.255.255.0
    no cdp enable
    !
    interface Ethernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.248.99 255.255.255.0
    no cdp enable
    !
    interface Serial0/0
    shutdown
    !
    ip default-gateway 192.168.2.1
    no ip http server
    no ip http secure-server
    ip classless
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 15061206477E72
    !
    ntp clock-period 17208303
    ntp server 192.168.2.19
    !
    end


    Hopefully this will give people some insight, and hopefully I won't
    lose anymore hair than I already have. :p
    Jimsu, Nov 12, 2007
    #7
  8. Jimsu

    guillermo.ralil

    Joined:
    Nov 12, 2007
    Messages:
    3
    your default gateway in the 2950 is the problem...

    ip default gateway 192.168.2.99

    is the correct!!!
    test ping with this and check your vlan 2...

    Your vlan database??

    post a "show vlan" command

    note that your router no operate with default gateway... router work with default routes...

    example:
    ip route 0.0.0.0 0.0.0.0 x.x.x.x
    guillermo.ralil, Nov 12, 2007
    #8
  9. Jimsu

    c0d3w12 Guest

    On Nov 12, 10:56 am, Jimsu <> wrote:
    > On Nov 12, 11:48 am, c0d3w12 <> wrote:
    >
    >
    >
    >
    >
    > > On Nov 12, 6:36 am, Jimsu <> wrote:

    >
    > > > Hello,

    >
    > > > I've done some cisco configurations in the past without much issue.
    > > > Usually, between books and the internet, I can figure just about any
    > > > of them out.. but this one is stumping me. Perhaps there's an IOS
    > > > issue (like I have the wrong one), or perhaps it's pebkac.

    >
    > > > I am trying to setup a sample network, or networks. I'm trying to
    > > > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > > > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > > > 24). On each of the subinterfaces I've added the router ip addresses.

    >
    > > > On the switch (cisco 2950) I've put the port into trunk mode (same
    > > > with the main interface on the router). i've added the ports to the
    > > > appropriate vlans, but I'm getting no connectivity.

    >
    > > > If anyone can please advise, and/or provide a link to further
    > > > resources, I would appreciate it. Here are the devices and configs:

    >
    > > > Cisco 2950:

    >
    > > > eanut_sw1#sh ver
    > > > Cisco Internetwork Operating System Software
    > > > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > > > SOFTWARE (fc1)
    > > > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > > > Compiled Wed 23-Mar-05 15:33 by yenanh
    > > > Image text-base: 0x80010000, data-base: 0x80562000

    >
    > > > ROM: Bootstrap program is C2950 boot loader

    >
    > > > eanut_sw1 uptime is 22 minutes
    > > > System returned to ROM by power-on
    > > > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > > > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    >
    > > > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > > > bytes of memory.
    > > > Processor board ID FOC0937Z6KN
    > > > Last reset from system-reset
    > > > Running Enhanced Image
    > > > 24 FastEthernet/IEEE 802.3 interface(s)
    > > > 2 Gigabit Ethernet/IEEE 802.3 interface(s)

    >
    > > > 32K bytes of flash-simulated non-volatile configuration memory.
    > > > Base ethernet MAC Address: 00:15:63:73:1B:40
    > > > Motherboard assembly number: 73-7280-05
    > > > Power supply part number: 34-0965-01
    > > > Motherboard serial number: FOC09371F6S
    > > > Power supply serial number: PHI0931C2MW
    > > > Model revision number: L0
    > > > Motherboard revision number: A0
    > > > Model number: WS-C2950G-24-EI
    > > > System serial number: FOC0937Z6KN
    > > > Configuration register is 0xF

    >
    > > > Cisco 2610:

    >
    > > > #sh ver
    > > > Cisco Internetwork Operating System Software
    > > > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > > > SOFTWARE (fc3)
    > > > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > > > Compiled Tue 17-Aug-04 05:11 by kellythw
    > > > Image text-base: 0x80008098, data-base: 0x819E9FE4

    >
    > > > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    >
    > > > uptime is 54 minutes
    > > > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > > > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"

    >
    > > > This product contains cryptographic features and is subject to United
    > > > States and local country laws governing import, export, transfer and
    > > > use. Delivery of Cisco cryptographic products does not imply
    > > > third-party authority to import, export, distribute or use encryption.
    > > > Importers, exporters, distributors and users are responsible for
    > > > compliance with U.S. and local country laws. By using this product you
    > > > agree to comply with applicable laws and regulations. If you are
    > > > unable
    > > > to comply with U.S. and local laws, return this product immediately.

    >
    > > > A summary of U.S. laws governing Cisco cryptographic products may be
    > > > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    >
    > > > If you require further assistance please contact us by sending email
    > > > to
    > > > .

    >
    > > > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > > > of memory.
    > > > Processor board ID JAD041007W7 (1350106988)
    > > > M860 processor: part number 0, mask 49
    > > > Bridging software.
    > > > X.25 software, Version 3.0.0.
    > > > 1 Ethernet/IEEE 802.3 interface(s)
    > > > 1 Serial network interface(s)
    > > > 32K bytes of non-volatile configuration memory.
    > > > 16384K bytes of processor board System flash (Read/Write)

    >
    > > > Configuration register is 0x2102

    >
    > > > Now onto the applicable configs:

    >
    > > > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > > > there):

    >
    > > > Current configuration : 2055 bytes
    > > > !
    > > > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > > > !
    > > > version 12.1
    > > > no service pad
    > > > service timestamps debug datetime localtime
    > > > service timestamps log datetime localtime
    > > > !
    > > > hostname eanut_sw1
    > > > !
    > > > clock timezone CDT -6
    > > > ip subnet-zero
    > > > !
    > > > !
    > > > spanning-tree mode pvst
    > > > no spanning-tree optimize bpdu transmission
    > > > spanning-tree extend system-id
    > > > !
    > > > !
    > > > !
    > > > !
    > > > interface FastEthernet0/1
    > > > switchport mode trunk
    > > > !

    >
    > > > Cisco 2510 config:

    >
    > > > !
    > > > interface Ethernet0/0
    > > > no ip address
    > > > no ip unreachables
    > > > no ip proxy-arp
    > > > full-duplex
    > > > no cdp enable
    > > > !
    > > > interface Ethernet0/0.1
    > > > encapsulation dot1Q 1 native
    > > > ip address 192.168.2.99 255.255.255.0
    > > > no cdp enable
    > > > !
    > > > interface Ethernet0/0.2
    > > > encapsulation dot1Q 2
    > > > ip address 192.168.248.99 255.255.255.0
    > > > no cdp enable
    > > > !

    >
    > > > with this setup, I cannot ping any devices on either network, and the
    > > > network cannot ping the .99 addresses assigned on the router. Please
    > > > advise. Hopefully, I'm just missing something obvious.

    >
    > > > Thank you,

    >
    > > > Jim Surles

    >
    > > Do a show run and paste up the finding.

    >
    > Yes, both interfaces are showing up/up
    >
    > here is the full switch configuration:
    >
    > my_sw1#sh run
    > Building configuration...
    >
    > Current configuration : 2055 bytes
    > !
    > ! Last configuration change at 09:52:51 CDT Mon Nov 12 2007
    > !
    > version 12.1
    > no service pad
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > no service password-encryption
    > !
    > hostname my_sw1
    > !
    > enable secret 5 $secretstuff
    > !
    > clock timezone CDT -6
    > ip subnet-zero
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > !
    > interface FastEthernet0/2
    > shutdown
    > !
    > interface FastEthernet0/3
    > shutdown
    > !
    > interface FastEthernet0/4
    > shutdown
    > !
    > interface FastEthernet0/5
    > shutdown
    > !
    > interface FastEthernet0/6
    > shutdown
    > !
    > interface FastEthernet0/7
    > shutdown
    > !
    > interface FastEthernet0/8
    > shutdown
    > !
    > interface FastEthernet0/9
    > shutdown
    > !
    > interface FastEthernet0/10
    > shutdown
    > !
    > interface FastEthernet0/11
    > shutdown
    > !
    > interface FastEthernet0/12
    > shutdown
    > !
    > interface FastEthernet0/13
    > description IP Phone
    > !
    > interface FastEthernet0/14
    > shutdown
    > !
    > interface FastEthernet0/15
    > description hydrogen - internet link
    > bandwidth 6000
    > !
    > interface FastEthernet0/16
    > shutdown
    > !
    > interface FastEthernet0/17
    > description calcium link
    > !
    > interface FastEthernet0/18
    > shutdown
    > !
    > interface FastEthernet0/19
    > description chlorine link
    > !
    > interface FastEthernet0/20
    > description potassium link
    > !
    > interface FastEthernet0/21
    > description 100 mbs to helium (back house)
    > !
    > interface FastEthernet0/22
    > description Arsenic
    > speed 100
    > !
    > interface FastEthernet0/23
    > shutdown
    > speed 100
    > duplex full
    > !
    > interface FastEthernet0/24
    > shutdown
    > !
    > interface GigabitEthernet0/1
    > shutdown
    > !
    > interface GigabitEthernet0/2
    > shutdown
    > !
    > interface Vlan1
    > ip address 192.168.2.10 255.255.255.0
    > no ip route-cache
    > !
    > ip default-gateway 192.168.2.1
    > ip http server
    > snmp-server community public RO
    > snmp-server location Garage Rack
    > snmp-server contact Jim Surles
    > !
    > line con 0
    > exec-timeout 0 0
    > line vty 0 4
    > password testing
    > login
    > line vty 5 15
    > password testing
    > login
    > !
    > ntp clock-period 17179777
    > ntp server 192.168.2.19
    > !
    > end
    >
    > Here is the full router configuration:
    >
    > my-rtr#sh run
    > Building configuration...
    >
    > Current configuration : 1281 bytes
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname my-rtr
    > !
    > boot-start-marker
    > boot system flash
    > boot-end-marker
    > !
    > logging buffered 4096 debugging
    > enable secret 5 $secretstuff
    > !
    > username jsurles password 7 083643410D
    > clock timezone CST -6
    > clock summer-time CDT recurring
    > aaa new-model
    > !
    > !
    > aaa session-id common
    > ip subnet-zero
    > ip cef
    > !
    > !
    > ip name-server 192.168.2.19
    > !
    > ip audit po max-events 100
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > interface Ethernet0/0
    > no ip address
    > no ip unreachables
    > no ip proxy-arp
    > full-duplex
    > no cdp enable
    > !
    > interface Ethernet0/0.1
    > encapsulation dot1Q 1 native
    > ip address 192.168.2.99 255.255.255.0
    > no cdp enable
    > !
    > interface Ethernet0/0.2
    > encapsulation dot1Q 2
    > ip address 192.168.248.99 255.255.255.0
    > no cdp enable
    > !
    > interface Serial0/0
    > shutdown
    > !
    > ip default-gateway 192.168.2.1
    > no ip http server
    > no ip http secure-server
    > ip classless
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > password 7 15061206477E72
    > !
    > ntp clock-period 17208303
    > ntp server 192.168.2.19
    > !
    > end
    >
    > Hopefully this will give people some insight, and hopefully I won't
    > lose anymore hair than I already have. :p- Hide quoted text -
    >
    > - Show quoted text -


    I don't see an IP on interface FastEthernet0/1.
    Are the 192.x.x.x networks communicating?
    c0d3w12, Nov 12, 2007
    #9
  10. Jimsu

    Jimsu Guest

    On Nov 12, 4:49 pm, c0d3w12 <> wrote:
    > On Nov 12, 10:56 am, Jimsu <> wrote:
    >
    >
    >
    > > On Nov 12, 11:48 am, c0d3w12 <> wrote:

    >
    > > > On Nov 12, 6:36 am, Jimsu <> wrote:

    >
    > > > > Hello,

    >
    > > > > I've done some cisco configurations in the past without much issue.
    > > > > Usually, between books and the internet, I can figure just about any
    > > > > of them out.. but this one is stumping me. Perhaps there's an IOS
    > > > > issue (like I have the wrong one), or perhaps it's pebkac.

    >
    > > > > I am trying to setup a sample network, or networks. I'm trying to
    > > > > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > > > > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > > > > 24). On each of the subinterfaces I've added the router ip addresses.

    >
    > > > > On the switch (cisco 2950) I've put the port into trunk mode (same
    > > > > with the main interface on the router). i've added the ports to the
    > > > > appropriate vlans, but I'm getting no connectivity.

    >
    > > > > If anyone can please advise, and/or provide a link to further
    > > > > resources, I would appreciate it. Here are the devices and configs:

    >
    > > > > Cisco 2950:

    >
    > > > > eanut_sw1#sh ver
    > > > > Cisco Internetwork Operating System Software
    > > > > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > > > > SOFTWARE (fc1)
    > > > > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > > > > Compiled Wed 23-Mar-05 15:33 by yenanh
    > > > > Image text-base: 0x80010000, data-base: 0x80562000

    >
    > > > > ROM: Bootstrap program is C2950 boot loader

    >
    > > > > eanut_sw1 uptime is 22 minutes
    > > > > System returned to ROM by power-on
    > > > > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > > > > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

    >
    > > > > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > > > > bytes of memory.
    > > > > Processor board ID FOC0937Z6KN
    > > > > Last reset from system-reset
    > > > > Running Enhanced Image
    > > > > 24 FastEthernet/IEEE 802.3 interface(s)
    > > > > 2 Gigabit Ethernet/IEEE 802.3 interface(s)

    >
    > > > > 32K bytes of flash-simulated non-volatile configuration memory.
    > > > > Base ethernet MAC Address: 00:15:63:73:1B:40
    > > > > Motherboard assembly number: 73-7280-05
    > > > > Power supply part number: 34-0965-01
    > > > > Motherboard serial number: FOC09371F6S
    > > > > Power supply serial number: PHI0931C2MW
    > > > > Model revision number: L0
    > > > > Motherboard revision number: A0
    > > > > Model number: WS-C2950G-24-EI
    > > > > System serial number: FOC0937Z6KN
    > > > > Configuration register is 0xF

    >
    > > > > Cisco 2610:

    >
    > > > > #sh ver
    > > > > Cisco Internetwork Operating System Software
    > > > > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > > > > SOFTWARE (fc3)
    > > > > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > > > > Compiled Tue 17-Aug-04 05:11 by kellythw
    > > > > Image text-base: 0x80008098, data-base: 0x819E9FE4

    >
    > > > > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

    >
    > > > > uptime is 54 minutes
    > > > > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > > > > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"

    >
    > > > > This product contains cryptographic features and is subject to United
    > > > > States and local country laws governing import, export, transfer and
    > > > > use. Delivery of Cisco cryptographic products does not imply
    > > > > third-party authority to import, export, distribute or use encryption.
    > > > > Importers, exporters, distributors and users are responsible for
    > > > > compliance with U.S. and local country laws. By using this product you
    > > > > agree to comply with applicable laws and regulations. If you are
    > > > > unable
    > > > > to comply with U.S. and local laws, return this product immediately.

    >
    > > > > A summary of U.S. laws governing Cisco cryptographic products may be
    > > > > found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    >
    > > > > If you require further assistance please contact us by sending email
    > > > > to
    > > > > .

    >
    > > > > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > > > > of memory.
    > > > > Processor board ID JAD041007W7 (1350106988)
    > > > > M860 processor: part number 0, mask 49
    > > > > Bridging software.
    > > > > X.25 software, Version 3.0.0.
    > > > > 1 Ethernet/IEEE 802.3 interface(s)
    > > > > 1 Serial network interface(s)
    > > > > 32K bytes of non-volatile configuration memory.
    > > > > 16384K bytes of processor board System flash (Read/Write)

    >
    > > > > Configuration register is 0x2102

    >
    > > > > Now onto the applicable configs:

    >
    > > > > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > > > > there):

    >
    > > > > Current configuration : 2055 bytes
    > > > > !
    > > > > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > > > > !
    > > > > version 12.1
    > > > > no service pad
    > > > > service timestamps debug datetime localtime
    > > > > service timestamps log datetime localtime
    > > > > !
    > > > > hostname eanut_sw1
    > > > > !
    > > > > clock timezone CDT -6
    > > > > ip subnet-zero
    > > > > !
    > > > > !
    > > > > spanning-tree mode pvst
    > > > > no spanning-tree optimize bpdu transmission
    > > > > spanning-tree extend system-id
    > > > > !
    > > > > !
    > > > > !
    > > > > !
    > > > > interface FastEthernet0/1
    > > > > switchport mode trunk
    > > > > !

    >
    > > > > Cisco 2510 config:

    >
    > > > > !
    > > > > interface Ethernet0/0
    > > > > no ip address
    > > > > no ip unreachables
    > > > > no ip proxy-arp
    > > > > full-duplex
    > > > > no cdp enable
    > > > > !
    > > > > interface Ethernet0/0.1
    > > > > encapsulation dot1Q 1 native
    > > > > ip address 192.168.2.99 255.255.255.0
    > > > > no cdp enable
    > > > > !
    > > > > interface Ethernet0/0.2
    > > > > encapsulation dot1Q 2
    > > > > ip address 192.168.248.99 255.255.255.0
    > > > > no cdp enable
    > > > > !

    >
    > > > > with this setup, I cannot ping any devices on either network, and the
    > > > > network cannot ping the .99 addresses assigned on the router. Please
    > > > > advise. Hopefully, I'm just missing something obvious.

    >
    > > > > Thank you,

    >
    > > > > Jim Surles

    >
    > > > Do a show run and paste up the finding.

    >
    > > Yes, both interfaces are showing up/up

    >
    > > here is the full switch configuration:

    >
    > > my_sw1#sh run
    > > Building configuration...

    >
    > > Current configuration : 2055 bytes
    > > !
    > > ! Last configuration change at 09:52:51 CDT Mon Nov 12 2007
    > > !
    > > version 12.1
    > > no service pad
    > > service timestamps debug datetime localtime
    > > service timestamps log datetime localtime
    > > no service password-encryption
    > > !
    > > hostname my_sw1
    > > !
    > > enable secret 5 $secretstuff
    > > !
    > > clock timezone CDT -6
    > > ip subnet-zero
    > > !
    > > !
    > > spanning-tree mode pvst
    > > no spanning-tree optimize bpdu transmission
    > > spanning-tree extend system-id
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0/1
    > > switchport mode trunk
    > > !
    > > interface FastEthernet0/2
    > > shutdown
    > > !
    > > interface FastEthernet0/3
    > > shutdown
    > > !
    > > interface FastEthernet0/4
    > > shutdown
    > > !
    > > interface FastEthernet0/5
    > > shutdown
    > > !
    > > interface FastEthernet0/6
    > > shutdown
    > > !
    > > interface FastEthernet0/7
    > > shutdown
    > > !
    > > interface FastEthernet0/8
    > > shutdown
    > > !
    > > interface FastEthernet0/9
    > > shutdown
    > > !
    > > interface FastEthernet0/10
    > > shutdown
    > > !
    > > interface FastEthernet0/11
    > > shutdown
    > > !
    > > interface FastEthernet0/12
    > > shutdown
    > > !
    > > interface FastEthernet0/13
    > > description IP Phone
    > > !
    > > interface FastEthernet0/14
    > > shutdown
    > > !
    > > interface FastEthernet0/15
    > > description hydrogen - internet link
    > > bandwidth 6000
    > > !
    > > interface FastEthernet0/16
    > > shutdown
    > > !
    > > interface FastEthernet0/17
    > > description calcium link
    > > !
    > > interface FastEthernet0/18
    > > shutdown
    > > !
    > > interface FastEthernet0/19
    > > description chlorine link
    > > !
    > > interface FastEthernet0/20
    > > description potassium link
    > > !
    > > interface FastEthernet0/21
    > > description 100 mbs to helium (back house)
    > > !
    > > interface FastEthernet0/22
    > > description Arsenic
    > > speed 100
    > > !
    > > interface FastEthernet0/23
    > > shutdown
    > > speed 100
    > > duplex full
    > > !
    > > interface FastEthernet0/24
    > > shutdown
    > > !
    > > interface GigabitEthernet0/1
    > > shutdown
    > > !
    > > interface GigabitEthernet0/2
    > > shutdown
    > > !
    > > interface Vlan1
    > > ip address 192.168.2.10 255.255.255.0
    > > no ip route-cache
    > > !
    > > ip default-gateway 192.168.2.1
    > > ip http server
    > > snmp-server community public RO
    > > snmp-server location Garage Rack
    > > snmp-server contact Jim Surles
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > line vty 0 4
    > > password testing
    > > login
    > > line vty 5 15
    > > password testing
    > > login
    > > !
    > > ntp clock-period 17179777
    > > ntp server 192.168.2.19
    > > !
    > > end

    >
    > > Here is the full router configuration:

    >
    > > my-rtr#sh run
    > > Building configuration...

    >
    > > Current configuration : 1281 bytes
    > > !
    > > version 12.3
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > service password-encryption
    > > !
    > > hostname my-rtr
    > > !
    > > boot-start-marker
    > > boot system flash
    > > boot-end-marker
    > > !
    > > logging buffered 4096 debugging
    > > enable secret 5 $secretstuff
    > > !
    > > username jsurles password 7 083643410D
    > > clock timezone CST -6
    > > clock summer-time CDT recurring
    > > aaa new-model
    > > !
    > > !
    > > aaa session-id common
    > > ip subnet-zero
    > > ip cef
    > > !
    > > !
    > > ip name-server 192.168.2.19
    > > !
    > > ip audit po max-events 100
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > interface Ethernet0/0
    > > no ip address
    > > no ip unreachables
    > > no ip proxy-arp
    > > full-duplex
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.1
    > > encapsulation dot1Q 1 native
    > > ip address 192.168.2.99 255.255.255.0
    > > no cdp enable
    > > !
    > > interface Ethernet0/0.2
    > > encapsulation dot1Q 2
    > > ip address 192.168.248.99 255.255.255.0
    > > no cdp enable
    > > !
    > > interface Serial0/0
    > > shutdown
    > > !
    > > ip default-gateway 192.168.2.1
    > > no ip http server
    > > no ip http secure-server
    > > ip classless
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > !
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > password 7 15061206477E72
    > > !
    > > ntp clock-period 17208303
    > > ntp server 192.168.2.19
    > > !
    > > end

    >
    > > Hopefully this will give people some insight, and hopefully I won't
    > > lose anymore hair than I already have. :p- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > I don't see an IP on interface FastEthernet0/1.
    > Are the 192.x.x.x networks communicating?


    I didn't put an IP on the fa 0/1 interface because it's "trunked", I
    didn't think I needed one. On the switch itself, there is an ip of
    192.168.2.10, just not an independant one one the interface itself.
    All of the other 192.168.2.xx devices which are connected to the
    switch are communicating, but the 192.168.2.99 interface (eth 0/0.1 on
    the router) can not seem to see anything except for other addresses I
    might put on the router, but it's not passing anything through the
    switch.
    Jimsu, Nov 13, 2007
    #10
  11. Jimsu

    Thrill5 Guest

    Ethernet interfaces (10 MB) on Cisco (like 2610, 2611 and 2500 series)
    devices do not support dot1q or ISL, because the hardware chipsets they use
    do not support this functionality. It is a bug in the IOS software that
    allows you to even configure this. Another common IOS "bug" is setting
    duplex to full on these same device's 10 MB interfaces. You can set it, and
    a "show interface" will show the interface in full duplex mode, but again
    full duplex is not supported on the hardware on these 10MB interfaces and
    you will get errors.

    "Jimsu" <> wrote in message
    news:...
    > Hello,
    >
    > I've done some cisco configurations in the past without much issue.
    > Usually, between books and the internet, I can figure just about any
    > of them out.. but this one is stumping me. Perhaps there's an IOS
    > issue (like I have the wrong one), or perhaps it's pebkac.
    >
    > I am trying to setup a sample network, or networks. I'm trying to
    > configure a Cisco 26xx router, with one ethernet interface, with 2 sub
    > interfaces on different networks (192.168.2.xx/24 and 192.168.248.xx/
    > 24). On each of the subinterfaces I've added the router ip addresses.
    >
    > On the switch (cisco 2950) I've put the port into trunk mode (same
    > with the main interface on the router). i've added the ports to the
    > appropriate vlans, but I'm getting no connectivity.
    >
    > If anyone can please advise, and/or provide a link to further
    > resources, I would appreciate it. Here are the devices and configs:
    >
    > Cisco 2950:
    >
    > eanut_sw1#sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE
    > SOFTWARE (fc1)
    > Copyright (c) 1986-2005 by cisco Systems, Inc.
    > Compiled Wed 23-Mar-05 15:33 by yenanh
    > Image text-base: 0x80010000, data-base: 0x80562000
    >
    > ROM: Bootstrap program is C2950 boot loader
    >
    > eanut_sw1 uptime is 22 minutes
    > System returned to ROM by power-on
    > System restarted at 07:43:26 CDT Mon Nov 12 2007
    > System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"
    >
    > cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    > bytes of memory.
    > Processor board ID FOC0937Z6KN
    > Last reset from system-reset
    > Running Enhanced Image
    > 24 FastEthernet/IEEE 802.3 interface(s)
    > 2 Gigabit Ethernet/IEEE 802.3 interface(s)
    >
    > 32K bytes of flash-simulated non-volatile configuration memory.
    > Base ethernet MAC Address: 00:15:63:73:1B:40
    > Motherboard assembly number: 73-7280-05
    > Power supply part number: 34-0965-01
    > Motherboard serial number: FOC09371F6S
    > Power supply serial number: PHI0931C2MW
    > Model revision number: L0
    > Motherboard revision number: A0
    > Model number: WS-C2950G-24-EI
    > System serial number: FOC0937Z6KN
    > Configuration register is 0xF
    >
    > Cisco 2610:
    >
    > #sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    > SOFTWARE (fc3)
    > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > Compiled Tue 17-Aug-04 05:11 by kellythw
    > Image text-base: 0x80008098, data-base: 0x819E9FE4
    >
    > ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
    >
    > uptime is 54 minutes
    > System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    > System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"
    >
    >
    > This product contains cryptographic features and is subject to United
    > States and local country laws governing import, export, transfer and
    > use. Delivery of Cisco cryptographic products does not imply
    > third-party authority to import, export, distribute or use encryption.
    > Importers, exporters, distributors and users are responsible for
    > compliance with U.S. and local country laws. By using this product you
    > agree to comply with applicable laws and regulations. If you are
    > unable
    > to comply with U.S. and local laws, return this product immediately.
    >
    > A summary of U.S. laws governing Cisco cryptographic products may be
    > found at:
    > http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >
    > If you require further assistance please contact us by sending email
    > to
    > .
    >
    > cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K bytes
    > of memory.
    > Processor board ID JAD041007W7 (1350106988)
    > M860 processor: part number 0, mask 49
    > Bridging software.
    > X.25 software, Version 3.0.0.
    > 1 Ethernet/IEEE 802.3 interface(s)
    > 1 Serial network interface(s)
    > 32K bytes of non-volatile configuration memory.
    > 16384K bytes of processor board System flash (Read/Write)
    >
    > Configuration register is 0x2102
    >
    > Now onto the applicable configs:
    >
    > 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    > there):
    >
    > Current configuration : 2055 bytes
    > !
    > ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    > !
    > version 12.1
    > no service pad
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > !
    > hostname eanut_sw1
    > !
    > clock timezone CDT -6
    > ip subnet-zero
    > !
    > !
    > spanning-tree mode pvst
    > no spanning-tree optimize bpdu transmission
    > spanning-tree extend system-id
    > !
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport mode trunk
    > !
    >
    > Cisco 2510 config:
    >
    > !
    > interface Ethernet0/0
    > no ip address
    > no ip unreachables
    > no ip proxy-arp
    > full-duplex
    > no cdp enable
    > !
    > interface Ethernet0/0.1
    > encapsulation dot1Q 1 native
    > ip address 192.168.2.99 255.255.255.0
    > no cdp enable
    > !
    > interface Ethernet0/0.2
    > encapsulation dot1Q 2
    > ip address 192.168.248.99 255.255.255.0
    > no cdp enable
    > !
    >
    > with this setup, I cannot ping any devices on either network, and the
    > network cannot ping the .99 addresses assigned on the router. Please
    > advise. Hopefully, I'm just missing something obvious.
    >
    > Thank you,
    >
    > Jim Surles
    >
    Thrill5, Nov 13, 2007
    #11
  12. Jimsu

    guillermo.ralil

    Joined:
    Nov 12, 2007
    Messages:
    3
    WHAT???
    SWITCH LAYER 2 (CISCO 2950) WITH IP ADDRES CONFIGURED IN PHYSICAL INTERFACE??
    "I think you're wrong"
    :???:

    IF THIS IS IOS BUG....
    WHY THE COMMAND IS PERMITED??

    > interface Ethernet0/0.2
    > encapsulation dot1Q 2

    :hmmmm:

    CHECK YOUR DEFAULT GATEWAY FOR YOUR 2950.... (MOST BE interface Ethernet0/0.1 IP.... 192.168.2.99
    AND CREATE CORRECTLY VLANS IN YOUR SWITCH 2950...
    THE PROBLEM IS THE CONFIGURATION

    CONF T
    VLAN 2
    NAME VLAN2NAME

    OR

    VLAN DATABASE
    VLAN 2 NAME VLAN2NAME
    APPLY EXIT
    guillermo.ralil, Nov 13, 2007
    #12
  13. Jimsu

    Chris Marva Guest

    "Thrill5" <> wrote in
    news::

    > Ethernet interfaces (10 MB) on Cisco (like 2610, 2611 and 2500 series)
    > devices do not support dot1q or ISL, because the hardware chipsets
    > they use do not support this functionality. It is a bug in the IOS
    > software that allows you to even configure this. Another common IOS
    > "bug" is setting duplex to full on these same device's 10 MB
    > interfaces. You can set it, and a "show interface" will show the
    > interface in full duplex mode, but again full duplex is not supported
    > on the hardware on these 10MB interfaces and you will get errors.
    >
    > "Jimsu" <> wrote in message
    > news:...
    >> Hello,
    >>
    >> I've done some cisco configurations in the past without much issue.
    >> Usually, between books and the internet, I can figure just about any
    >> of them out.. but this one is stumping me. Perhaps there's an IOS
    >> issue (like I have the wrong one), or perhaps it's pebkac.
    >>
    >> I am trying to setup a sample network, or networks. I'm trying to
    >> configure a Cisco 26xx router, with one ethernet interface, with 2
    >> sub interfaces on different networks (192.168.2.xx/24 and
    >> 192.168.248.xx/ 24). On each of the subinterfaces I've added the
    >> router ip addresses.
    >>
    >> On the switch (cisco 2950) I've put the port into trunk mode (same
    >> with the main interface on the router). i've added the ports to the
    >> appropriate vlans, but I'm getting no connectivity.
    >>
    >> If anyone can please advise, and/or provide a link to further
    >> resources, I would appreciate it. Here are the devices and configs:
    >>
    >> Cisco 2950:
    >>
    >> eanut_sw1#sh ver
    >> Cisco Internetwork Operating System Software
    >> IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4,
    >> RELEASE SOFTWARE (fc1)
    >> Copyright (c) 1986-2005 by cisco Systems, Inc.
    >> Compiled Wed 23-Mar-05 15:33 by yenanh
    >> Image text-base: 0x80010000, data-base: 0x80562000
    >>
    >> ROM: Bootstrap program is C2950 boot loader
    >>
    >> eanut_sw1 uptime is 22 minutes
    >> System returned to ROM by power-on
    >> System restarted at 07:43:26 CDT Mon Nov 12 2007
    >> System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"
    >>
    >> cisco WS-C2950G-24-EI (RC32300) processor (revision L0) with 21039K
    >> bytes of memory.
    >> Processor board ID FOC0937Z6KN
    >> Last reset from system-reset
    >> Running Enhanced Image
    >> 24 FastEthernet/IEEE 802.3 interface(s)
    >> 2 Gigabit Ethernet/IEEE 802.3 interface(s)
    >>
    >> 32K bytes of flash-simulated non-volatile configuration memory.
    >> Base ethernet MAC Address: 00:15:63:73:1B:40
    >> Motherboard assembly number: 73-7280-05
    >> Power supply part number: 34-0965-01
    >> Motherboard serial number: FOC09371F6S
    >> Power supply serial number: PHI0931C2MW
    >> Model revision number: L0
    >> Motherboard revision number: A0
    >> Model number: WS-C2950G-24-EI
    >> System serial number: FOC0937Z6KN
    >> Configuration register is 0xF
    >>
    >> Cisco 2610:
    >>
    >> #sh ver
    >> Cisco Internetwork Operating System Software
    >> IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(10), RELEASE
    >> SOFTWARE (fc3)
    >> Copyright (c) 1986-2004 by cisco Systems, Inc.
    >> Compiled Tue 17-Aug-04 05:11 by kellythw
    >> Image text-base: 0x80008098, data-base: 0x819E9FE4
    >>
    >> ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
    >>
    >> uptime is 54 minutes
    >> System returned to ROM by reload at 11:57:15 CST Tue Mar 2 1993
    >> System image file is "flash:c2600-ik9o3s3-mz.123-10.bin"
    >>
    >>
    >> This product contains cryptographic features and is subject to United
    >> States and local country laws governing import, export, transfer and
    >> use. Delivery of Cisco cryptographic products does not imply
    >> third-party authority to import, export, distribute or use
    >> encryption. Importers, exporters, distributors and users are
    >> responsible for compliance with U.S. and local country laws. By using
    >> this product you agree to comply with applicable laws and
    >> regulations. If you are unable
    >> to comply with U.S. and local laws, return this product immediately.
    >>
    >> A summary of U.S. laws governing Cisco cryptographic products may be
    >> found at:
    >> http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    >>
    >> If you require further assistance please contact us by sending email
    >> to
    >> .
    >>
    >> cisco 2610 (MPC860) processor (revision 0x202) with 61440K/4096K
    >> bytes of memory.
    >> Processor board ID JAD041007W7 (1350106988)
    >> M860 processor: part number 0, mask 49
    >> Bridging software.
    >> X.25 software, Version 3.0.0.
    >> 1 Ethernet/IEEE 802.3 interface(s)
    >> 1 Serial network interface(s)
    >> 32K bytes of non-volatile configuration memory.
    >> 16384K bytes of processor board System flash (Read/Write)
    >>
    >> Configuration register is 0x2102
    >>
    >> Now onto the applicable configs:
    >>
    >> 2950 (the port Im plugging the switch into is fa0/1, so I stopped
    >> there):
    >>
    >> Current configuration : 2055 bytes
    >> !
    >> ! Last configuration change at 08:33:33 CDT Mon Nov 12 2007
    >> !
    >> version 12.1
    >> no service pad
    >> service timestamps debug datetime localtime
    >> service timestamps log datetime localtime
    >> !
    >> hostname eanut_sw1
    >> !
    >> clock timezone CDT -6
    >> ip subnet-zero
    >> !
    >> !
    >> spanning-tree mode pvst
    >> no spanning-tree optimize bpdu transmission
    >> spanning-tree extend system-id
    >> !
    >> !
    >> !
    >> !
    >> interface FastEthernet0/1
    >> switchport mode trunk
    >> !
    >>
    >> Cisco 2510 config:
    >>
    >> !
    >> interface Ethernet0/0
    >> no ip address
    >> no ip unreachables
    >> no ip proxy-arp
    >> full-duplex
    >> no cdp enable
    >> !
    >> interface Ethernet0/0.1
    >> encapsulation dot1Q 1 native
    >> ip address 192.168.2.99 255.255.255.0
    >> no cdp enable
    >> !
    >> interface Ethernet0/0.2
    >> encapsulation dot1Q 2
    >> ip address 192.168.248.99 255.255.255.0
    >> no cdp enable
    >> !
    >>
    >> with this setup, I cannot ping any devices on either network, and the
    >> network cannot ping the .99 addresses assigned on the router. Please
    >> advise. Hopefully, I'm just missing something obvious.
    >>
    >> Thank you,
    >>
    >> Jim Surles
    >>

    >
    >
    >


    There was an older T train version where dot1q was supported, it did the
    tagging in SW. We used in on quite a few 2611s after memory upgrades. But
    seems like I recall an issue with untagged traffic (native vlan).
    You could try leaving vlan 1 the native, and move the ip from vlan 1 to a
    new vlan (vlan 3) so that the traffic gets tagged and see if that works.

    c
    Chris Marva, Nov 13, 2007
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dmitry
    Replies:
    4
    Views:
    11,008
    Pete Mainwaring
    Feb 10, 2004
  2. Replies:
    8
    Views:
    7,354
    Bob the Builder
    Jan 6, 2005
  3. neo@theone
    Replies:
    1
    Views:
    7,058
    Martin Bilgrav
    Feb 7, 2005
  4. jester
    Replies:
    1
    Views:
    1,747
    Vivek
    Dec 20, 2005
  5. John Strow
    Replies:
    2
    Views:
    645
    John Strow
    Mar 1, 2008
Loading...

Share This Page