Cisco router - vlans and bridge.

Discussion in 'Cisco' started by Jarek Jarzebowski, Sep 25, 2006.

  1. Hello,

    I have cisco router connected to 2 hosts. On fastethernet interface I
    have two subinterfaces: one on 802.1q VLAN 100 and other one on VLAN
    200. I have bridge 2 (protocol ieee). The subinterfaces are bridged
    using bridge-group 2. I have also BVI 2 using IP with the same IP class
    192.168.100.0/24 then hosts. The problem is that I can ping BVI-Host#1,
    I can ping BVI-Host#2 but can't ping Host#1-Host#2, like subinterfaces
    never have been bridged. Moreover in 'show bridge 2 verbose' output I
    can see Host#1 and Host#2 macaddresses.

    I have to setup bridge of this two subinterfaces so Host#1 and Host#2
    belonging to different VLANS can contact each other.

    Below this is my cisco router config:

    Current configuration : 1059 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    aaa new-model
    enable password havana
    !
    username zdalny password 0 havana
    ip subnet-zero
    !
    !
    !
    bridge irb
    !
    !
    interface FastEthernet0
    ip address 192.168.3.33 255.255.255.0
    no keepalive
    half-duplex
    no cdp enable
    !
    interface FastEthernet0.100
    encapsulation dot1Q 100
    no cdp enable
    bridge-group 2
    !
    interface FastEthernet0.200
    encapsulation dot1Q 200
    no cdp enable
    bridge-group 2
    !
    interface BVI2
    ip address 192.168.100.100 255.255.255.0
    !
    ip classless
    no ip http server
    !
    !
    bridge 2 protocol ieee
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end

    Please point me where is the error.

    Regards,
    Jarek
     
    Jarek Jarzebowski, Sep 25, 2006
    #1
    1. Advertising

  2. In article <ef956q$13qb$>,
    Jarek Jarzebowski <> wrote:

    >I have cisco router connected to 2 hosts. On fastethernet interface I
    >have two subinterfaces: one on 802.1q VLAN 100 and other one on VLAN
    >200. I have bridge 2 (protocol ieee). The subinterfaces are bridged
    >using bridge-group 2.


    Bridging VLANs would put them into the same broadcast domain,
    but the point of VLANs is that they are *not* in the same broadcast
    domain. You are trying to do something contradictory.

    If you have two interfaces in different subnets in different VLANs,
    you would normally put them in different BVI and establish routing
    between them.

    If you have two interfaces in the same subnet but in different VLANs
    then you are making problems for yourself!
     
    Walter Roberson, Sep 25, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    596
  2. Chris_D
    Replies:
    6
    Views:
    3,125
    Uli Link
    Aug 5, 2005
  3. lyle
    Replies:
    0
    Views:
    657
  4. Jack Taugher
    Replies:
    2
    Views:
    4,618
  5. punisher
    Replies:
    2
    Views:
    2,113
    Charles Deling
    Nov 17, 2005
Loading...

Share This Page