Cisco Router Config

Discussion in 'Cisco' started by PC Docter, Dec 29, 2004.

  1. PC Docter

    PC Docter Guest

    Hi All,

    A cisco 1721 router with 4 port WIC card has been installed on our
    network. Having a looking a the configuration and trying to figure
    out all that is going on. Did some work on router sims at uni. Most of
    the config shown below im not sure what it does and would appreciate
    any help you can give. Ive made additional notes next on the parts i
    need help with are marked with a '#' sign.


    When I type show running-config the first few lines show this,

    ip name-server 219.10.236.130
    ip name-server 219.10.236.194
    ip name-server 219.10.236.131
    ip name-server 219.10.236.33

    Are the IP name server detected automatically or do they have to be
    entered manually? If so what command is used?

    The Ethernet port is configured:

    interface FastEthernet0
    ip address 84.19.229.33 255.255.255.240
    speed auto #is the speed always set to auto, what other parameters can
    be used?
    no cdp enable

    interface FastEthernet1 #this is the first port on the WIC card
    description Connected to VoIP switch
    switchport access vlan 11
    no ip address
    duplex full
    speed 100
    vlan-id dot1q 11 #**why is the vlan refered to in this way 'dot1q'?
    exit-vlan-config
    no cdp enable

    interface Serial0
    ip address 84.29.239.142 255.255.255.252
    ip broadcast-address 0.0.0.0 #Why is this set to 0?
    ip nat outside
    ip virtual-reassembly #What does this line mean?
    encapsulation ppp #Why is this line used

    interface Vlan11 #There is no reference in this script to 'dot1q'
    description VoIP VLAN
    ip address 10.0.250.101 255.255.255.0
    ip nat inside
    ip virtual-reassembly

    ip classless #What is meant by ip classless? Is this a global
    settingor is it only used on the S0 adapter?
    ip route 0.0.0.0 0.0.0.0 84.29.239.141 #Why are the first two IP's at
    0?
    no ip http server
    ip nat inside source list 1 interface Serial0 overload

    access-list 1 permit 10.0.250.0 0.0.0.255
    access-list 2 permit 10.0.250.0 0.0.0.255
    no cdp run

    I have been looking through the cisco site and find that i can access
    the info I need but there is so much techno garb to go through. I just
    need to get a better understanding of what going on just now then I
    can progress further with the project. If anyone can help or even
    point me toward a good info source on the net would be a great help.

    Thanks all,
    The Doc.
     
    PC Docter, Dec 29, 2004
    #1
    1. Advertising

  2. PC Docter

    Guest

    Are the IP name server detected automatically or do they have to be
    entered manually? If so what command is used?
    enter manually and the command is
    conf t
    ip name-server x.x.x.x
    exit
    wri mem

    ip virtual-reassembly #What does this line mean?

    used to prtect against fragment attack if Cisco IOS firewall feature is
    being used

    encapsulation ppp #Why is this line used
    On a serial link use can use encapulstion hdlc or encapusltion ppp; ppp
    standing for point-to-point protcol



    ip classless #What is meant by ip classless? Is this a global
    settingor is it only used on the S0 adapter?

    in classful routing, if a subnet is not found within a majro network,
    then the packet is dropped the assumption being that all subnets should
    be known withing a mjor network. With Classless this restriction is
    removed and if a subnet for a major network is not in the routing
    table, the rotuer will use default. Typically all routers are now
    configured with the "ip classles" command and it is a global command
     
    , Dec 29, 2004
    #2
    1. Advertising

  3. In article <>,
    PC Docter <> wrote:
    :A cisco 1721 router with 4 port WIC card has been installed on our
    :network. Having a looking a the configuration and trying to figure
    :eek:ut all that is going on.

    :The Ethernet port is configured:

    :interface FastEthernet0

    :speed auto #is the speed always set to auto, what other parameters can
    :be used?

    10 or 100 . Be careful: if you set the speed manually then autonegotiation
    is turned off, and if the other end is expecting autonegotiation then
    the other end will end up at 10 Mb/s half duplex.


    :vlan-id dot1q 11 #**why is the vlan refered to in this way 'dot1q'?

    It's a short form of the standard number that defines the vlan
    encapsulation, IEEE 802.1Q

    :interface Serial0
    :ip broadcast-address 0.0.0.0 #Why is this set to 0?

    I'm not sure. It is one of the four valid values at that point,
    0.0.0.0, 84.29.239.140, 84.29.239.144, or 255.255.255.255
    but I do not know why 0.0.0.0 would be preferred . There is an RFC
    that has to do with IP conservation on point-to-point links, but
    that really only applies to /31's, and it wouldn't be 0.0.0.0
    that was chosen for the broadcast address.

    Perhaps it has something to do with conventions on serial links
    as opposed to ethernet links ?

    :interface Vlan11 #There is no reference in this script to 'dot1q'

    There doesn't have to be. Encapsulation is set per interface, not
    per vlan, so it would be valid for there to be an interface set for
    ISL encapsulation that was carrying traffic for the same vlan as
    a dot1q encapsulated interface.

    :ip route 0.0.0.0 0.0.0.0 84.29.239.141 #Why are the first two IP's at
    :0?

    That's a default route. The first is the base IP address of the
    route, and the second is the netmask of the route. A bit which is
    1 in a netmask marks a bit in the IP address which must be the same
    as the target IP, and conversely a bit which is 0 in a netmask marks
    a bit in the IP address which does NOT have to be the same as the target IP.
    As every bit in the netmask is 0, then there are no fixed bits at all:
    it matches ever possible IP address destination, from 0.0.0.0 to
    255.255.255.255 . The base IP, the lowest IP in that series, is 0.0.0.0
    so that provides the first parameter.
    --
    Most Windows users will run any old attachment you send them, so if
    you want to implicate someone you can just send them a Trojan
    -- Adam Langley
     
    Walter Roberson, Dec 29, 2004
    #3
  4. PC Docter

    Peter Guest

    Greetings...

    > ip name-server 219.10.236.130
    > ip name-server 219.10.236.194
    > ip name-server 219.10.236.131
    > ip name-server 219.10.236.33
    >
    > Are the IP name server detected automatically or do they have to be
    > entered manually? If so what command is used?


    They are specified manually, exactly as listed above.

    > speed auto #is the speed always set to auto, what other parameters can
    > be used?


    Valid settings are speed auto, speed 10, speed 100. Use of anything
    other than auto implies a MANUAL setting and can cause problems if the
    other end of this link expects auto, when you can end up with a
    possible mis-match between the 2 ends.

    > vlan-id dot1q 11 #**why is the vlan refered to in this way 'dot1q'?


    VLANS are passed on an interface using 2 possible forms of
    encapsulation, ISL (which is proprietary to Cisco) or the 802.1Q
    international standard. The above statement says that VLAN 11 uses the
    802.1Q standard on that interface.

    > ip broadcast-address 0.0.0.0 #Why is this set to 0?


    An older form of broadcast was to use the (sub)net address, rather
    than the last address of the (sub)net. Its some times used these days
    to assist with IP address space conservation.

    > ip virtual-reassembly #What does this line mean?


    I think its to do with the Firewall Feature set and relates to
    allowing CBAC to see inside IP frames allowing the catching of certain
    content specific issues.

    > encapsulation ppp #Why is this line used


    This particular interface is using PPP encapsulation. The other end of
    this connection will also be using PPP encapsulation. For Serial
    links, the Cisco default encapsulation is a form of SDLC, and this
    statement modifies that default to use PPP, which eases compatibility
    with other manufactures Network H/W.

    > ip classless #What is meant by ip classless? Is this a global
    > settingor is it only used on the S0 adapter?


    It is a global statement, and means the Router is NOT operating in a
    Classfull Routing environment.

    > ip route 0.0.0.0 0.0.0.0 84.29.239.141 #Why are the first two IP's at
    > 0?


    Consider this to be similar to the line -
    ip route <any network> <any mask> 84.29.239.141
    which in other words means its a default route.

    Cheers...............pk.
     
    Peter, Dec 30, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Marshall

    Default Config Files or Basic Config

    Steve Marshall, Nov 5, 2003, in forum: Cisco
    Replies:
    2
    Views:
    538
    Chris
    Nov 5, 2003
  2. Preston Gallwas

    router OSPF 1 - not entering router config

    Preston Gallwas, Jun 30, 2004, in forum: Cisco
    Replies:
    3
    Views:
    903
    Gordon Smith
    Jul 1, 2004
  3. Replies:
    4
    Views:
    9,275
    Hansang Bae
    Mar 10, 2005
  4. AM
    Replies:
    2
    Views:
    8,045
  5. Someone

    Router to Router Config

    Someone, May 8, 2006, in forum: Cisco
    Replies:
    1
    Views:
    506
Loading...

Share This Page