Cisco Rommon confreg

Discussion in 'Cisco' started by Jeroen, Aug 12, 2004.

  1. Jeroen

    Jeroen Guest

    Before downloading a new image on a 3620 router, I changed with the
    confreg command the baud rate at the rommon prompt. After rebooting,
    this is the text that appears on my screen (unreadable) and I get the
    same when entering new characters.

    ËŸëëëËëËËËËËëËëýËÿÿËëË«‹ëËëËëËËÏÏË‹ËË‹ëëÏÏÿËëëÏŸ‹ÏÏëËËëëËŸËËëË

    Is there way to reset the rommon confreg, since the router is now
    totally unusable.

    Thx
    Jeroe
    Jeroen, Aug 12, 2004
    #1
    1. Advertising

  2. Jeroen

    VolatileAcid Guest

    you changed the baud rate? What did you change it to !

    Your terminal emulator needs to reflect the baud rate you set the router at,
    so if the router is set at 9600, then so should the terminal emulator be set
    at that.

    If you can't remember, your best bet is to just try them all ! although you
    can reset it by opening up the router, I think it's easier via trial and
    error using the terminal emulator.

    Oh and another thing... if you set the baud rate on the terminal emulator at
    9600... and it dosent work ! don't think that the speed has got to be
    lower... it hasn't.. it can be higher also !!!

    I'm speaking from hard learnt frustration and experience!
    VolatileAcid, Aug 13, 2004
    #2
    1. Advertising

  3. Jeroen

    Tosh Guest

    > Is there way to reset the rommon confreg, since the router is now
    > totally unusable.
    >

    See the 3620 installation manual, there you find the position of a little
    jumper in the motherboard that resets the console speed to factory.
    Bye,
    Tosh.
    Tosh, Aug 13, 2004
    #3
  4. Jeroen

    Jeroen Guest

    I changed the baud rate of SecureCRT to 115200 as well, and it works
    fine now. All text is readable. Is there also a way to reset the
    entire bootrom/rommon on the board with for example a jumper?

    Thx
    Jeroen
    Jeroen, Aug 13, 2004
    #4
  5. The console speed is set in bit 12/11 in the configuration register.
    The possible values are:

    00 - 9600 baud
    01 - 4800 baud
    10 - 1200 baud
    11 - 2400 baud

    To restore your console, change the baud rate in your virtual terminal
    program one at a time until the output returns to normal.

    This article contains all the config-register settings for reference:

    http://cco/en/US/products/hw/router...note09186a008022493f.shtml#config-reg-meaning

    (Jeroen) wrote in message news:<>...
    > Before downloading a new image on a 3620 router, I changed with the
    > confreg command the baud rate at the rommon prompt. After rebooting,
    > this is the text that appears on my screen (unreadable) and I get the
    > same when entering new characters.
    >
    > Ë?ëëëËëËËËËËëËëýËÿÿËëË«?ëËëËëËËÏÏË?ËË?ëëÏÏÿËëëÏ??ÏÏëËËëëË?ËËëË
    >
    > Is there way to reset the rommon confreg, since the router is now
    > totally unusable.
    >
    > Thx
    > Jeroe
    Anthony Swanson, Aug 13, 2004
    #5
  6. Jeroen

    Jeroen Guest

    That one now works fine, characters are readable. I have configured
    the 3620 with NM-2FE-2W, a WIC-1adsl and the c3620-is-mz.123-6a IOS
    with the running-config below. It does not seem to be able to connect
    to the internet. Any thoughts what could be wrong?

    jeroen#show running-config
    Building configuration...

    Current configuration : 1464 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname jeroen
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$9Cwt$K0FjxleKTL7gixdUflHCE/
    enable password abcdef
    !
    no aaa new-model
    ip subnet-zero
    no ip routing
    !
    no ip cef
    !
    vpdn enable
    !
    vpdn-group ppeo
    request-dialin
    protocol pppoe
    !
    interface ATM0/0
    no ip address
    no ip route-cache
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0/0
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    no ip route-cache
    speed auto
    half-duplex
    !
    interface FastEthernet0/1
    no ip address
    no ip route-cache
    shutdown
    duplex auto
    speed auto
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp pap sent-username abcdef password 0 adcdef
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    dialer pool 1
    !
    ip nat inside source list 1 interface Dialer0 overload
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    access-list 1 permit 10.10.10.0 0.0.0.255
    access-list 1 permit 10.10.0.0 0.0.255.255
    access-list 1 permit 10.10.0.0 0.0.0.255
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    line con 0
    line aux 0
    line vty 0 4
    password abcdef
    login
    !
    end
    Jeroen, Aug 14, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Martijn Koopsen

    Re: Cisco 803 ROMMON password

    Martijn Koopsen, Jul 21, 2003, in forum: Cisco
    Replies:
    1
    Views:
    659
    Kevin Pierce
    Jul 22, 2003
  2. an
    Replies:
    11
    Views:
    4,089
    Hansang Bae
    Jun 30, 2004
  3. Christian Lungwitz

    Cisco newbie: Cisco 1721 in rommon.

    Christian Lungwitz, Jan 25, 2005, in forum: Cisco
    Replies:
    4
    Views:
    4,046
    Christian Lungwitz
    Jan 26, 2005
  4. JC

    Cisco 6509 and rommon.

    JC, Mar 6, 2005, in forum: Cisco
    Replies:
    1
    Views:
    811
  5. LAGUY88

    2621XM confreg problem

    LAGUY88, Nov 6, 2010, in forum: Hardware
    Replies:
    2
    Views:
    1,419
    LAGUY88
    Nov 20, 2010
Loading...

Share This Page