Cisco QoS to use spare capacity

Discussion in 'General Computer Support' started by jonathan21, Jun 15, 2012.

  1. jonathan21

    jonathan21

    Joined:
    Jun 14, 2012
    Messages:
    1
    Hi,
    I'm working on a qos config for a cisco. The scenario is as follows:

    We provide a 100Mb service into a premises.
    Several IP networks are routed to the premises.
    We'd like to allocate 90% of the bandwidth to 192.168.50.0 /24 & the remainder to the following network - 10.10.10.0/24

    I have the following config so far, which is limiting the 192.168.150.0/24 network to about 90% and also applying the limit to the 10.10.10.0/24 network, but it doesn't appear that the 10.1.1.0/24 network can utilize the 'spare' bandwidth when it isn't being used by 192.168.50.0/24

    Can anyone offer some suggestions or better ways to achieve the same outcome?
    btw the below config is being applied to the customer's upstream router on a sub-interface (our router) :)

    class-map match-any customer-1
    match access-group 100
    class-map match-all data
    match access-group 150

    policy-map bw-reserve
    class customer-1
    priority percent 90
    class data
    priority percent 10

    policy-map qos-voip-parent
    class class-default
    shape average 20000000
    service-policy bw-reserve


    interface FastEthernet0/0.10
    description link to the customer QoS applied here
    bandwidth 100000
    encapsulation dot1Q 10
    ip address 172.16.20.1 255.255.255.252
    service-policy output qos-voip-parent

    access-list 150 remark Normal ip data traffic to all other hosts
    access-list 150 permit ip any any
    access-list 100 remark Allow up to 90% or bandwidth for customer-1
    access-list 100 permit ip any192.168.50.0 0.0.0.255

    Thanks in advance,
    Jonathan
     
    Last edited: Jun 19, 2012
    jonathan21, Jun 15, 2012
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,570
  2. Rene Kuhn
    Replies:
    0
    Views:
    967
    Rene Kuhn
    Dec 28, 2005
  3. ftran999
    Replies:
    5
    Views:
    1,961
    Barry OGrady
    Nov 23, 2004
  4. Ken

    Storing Spare CF cards next to Spare Battery

    Ken, Jul 5, 2006, in forum: Digital Photography
    Replies:
    5
    Views:
    458
  5. dominix
    Replies:
    2
    Views:
    503
    dominix
    Feb 6, 2007
Loading...

Share This Page