Cisco OER without BGP on 2851

Discussion in 'Cisco' started by grpangea, Feb 19, 2008.

  1. grpangea

    grpangea

    Joined:
    Feb 19, 2008
    Messages:
    4
    Location:
    Virginia
    Sorry, posted this earlier but labeled it wrong!

    Any help appreciated!


    Looking for a little help. Trying to implement OER on a 2851 as a means to perform multi-homing in a non-BGP environment with two static links. I have put together the following and hoping for some feedback before live implementation! Any help GREATLY appreciated!

    Here is the sample config (IP addresses have been changed to protect the innocent!)

    Sample config:

    Current configuration : 6641 bytes

    version 12.4
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    service password-encryption
    !
    hostname SAMPLE
    !
    ip cef
    !
    no ip domain lookup
    ip domain name sampledomain.com
    ip name-server x.x.x.x
    !
    multilink bundle-name both
    !
    controller T1 0/2/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    description Qwest Bonded T1-1
    !
    controller T1 0/2/1
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    description Qwest Bonded T1-2
    !
    ! Insert commands for Cisco Performance Routing to optimize traffic flow on internal
    ! and external links which will enact multi-homing and optimization of outbound links
    ! based on network latency, packet loss, jitter, link capacity and availability.
    !
    key chain key1
    key 1
    key-string oer
    oer master !Configure Master Controller
    logging !Enable logging
    mode router control !Enforce Routing changes
    max prefix total 100
    backoff 90 3000 300
    border 65.207.72.97 key-chain key1 !Require authentication key
    interface GigabitEthernet0/0 internal
    interface GigabitEthernet0/1 external
    max-xmit-utilization absolute 3000 !Limit GigE0/1 throughput
    interface Serial0/0/0 external
    max-xmit-utilization absolute 1536 !Limit Serial0/0/0 throughput
    learn
    throughput ------------------------| !Learn Delay and
    delay ------------------------| !Throughput
    monitor period 1 ------------------------| !Prefixes every Minute
    periodic-interval 3
    oer border !Configure Border Controller
    logging
    local GigabitEthernet0/0
    master 65.207.72.97 key chain key1
    !
    interface Multilink1
    description Bonded link of multiple T1’s
    ip address 192.168.1.1 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    ppp multilink
    ppp multilink group 1
    ppp multilink fragment disable
    !
    interface GigabitEthernet0/0
    description GigE connection facing the inside network
    description This is actually an inside network interface to an ISA server
    ip address 10.1.1.1 255.255.255.0
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly
    ip policy route-map web-browsing
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description GigE connection for two Bonded Qwest T1’s
    ip address 192.168.1.2 255.255.255.0
    ip policy route-map QwestBundles
    load-interval 30 !Used for load statistics in seconds
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    description To Worldcom
    bandwidth 1536
    ip address 198.6.1.1 255.255.255.0
    ip flow ingress
    ip flow egress
    ip nat outside
    encapsulation frame-relay IETF
    load-interval 30
    no fair-queue
    frame-relay lmi-type ansi
    !

    interface Serial0/1/0
    no ip address
    load-interval 30
    no fair-queue
    !
    interface Serial0/2/0:0
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/2/1:0
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1
    !
    ip route 0.0.0.0 0.0.0.0 198.6.1.1
    ip route 10.1.1.1 255.255.255.255 10.1.1.2 permanent
    !
    ip flow-top-talkers
    top 10
    sort-by bytes
    !
    ip nat inside source list nat-only interface Multilink1 overload

    !
    ip access-list extended nat-only
    permit tcp host 10.1.1.80 any eq www
    permit tcp host 10.1.1.443 any eq 443
    permit udp any any eq domain
    !
    route-map QwestBundles permit 10
    match ip address 150
    !
    route-map web-browsing permit 10
    match ip address nat-only
    !
     
    grpangea, Feb 19, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. kenny

    Cisco OER and NAT

    kenny, Oct 13, 2005, in forum: Cisco
    Replies:
    0
    Views:
    825
    kenny
    Oct 13, 2005
  2. TexasMirty@gmail.com

    Cisco 2851 CME Echo Cancellation

    TexasMirty@gmail.com, Apr 21, 2006, in forum: VOIP
    Replies:
    1
    Views:
    1,041
    Jonathan
    May 14, 2006
  3. Barney
    Replies:
    0
    Views:
    578
    Barney
    Oct 18, 2006
  4. hkyejian02
    Replies:
    0
    Views:
    696
    hkyejian02
    Nov 27, 2007
  5. rzirzi

    Cisco OER

    rzirzi, Feb 14, 2008, in forum: Cisco
    Replies:
    1
    Views:
    1,163
    Yandy Ramirez
    Feb 14, 2008
Loading...

Share This Page