cisco dhcp & nat

Discussion in 'Cisco' started by Lorre, May 14, 2005.

  1. Lorre

    Lorre Guest

    Hi all,

    I'm trying to setup my cisco 3620 router as a broadband router.
    For this i've set eth0/0 to dhcp and this interface receives an ip
    address without any problems from my isp.


    Internet<->[eth0/0]3620router[eth1/0]<->2950switch<->laptop

    I've setup nat overloading and a dhcp pool.

    Eth1/0 has an ip-address(192.168.0.1) and is connected to a 2950
    switch.
    On this switch my laptop is attached and gets an ip address
    (192.168.0.100)

    >From my router i can ping everything (also www.google.com)
    >From my laptop i can ping all interfaces on my router but not

    www.google.com. Resulting in that i can't reach the internet.

    Can someone please take a look at my running-config and hopefully tell
    me what's wrong.

    Thxs in advance guy's

    here's my show run:
    c3600#sh run
    Building configuration...

    Current configuration : 1021 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c3600
    !
    logging queue-limit 100
    !
    ip subnet-zero
    !
    !
    no ip dhcp conflict logging
    ip dhcp excluded-address 192.168.0.1 192.168.0.99
    !
    ip dhcp pool intranet
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    !
    frame-relay switching
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    bandwidth 1500
    ip address dhcp
    ip nat outside
    half-duplex
    fair-queue
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface Serial0/1
    no ip address
    dce-terminal-timing-enable
    no cdp enable
    !
    interface BRI1/0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface Ethernet1/0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    half-duplex
    fair-queue
    hold-queue 32 in
    !
    ip default-gateway 81.164.92.91
    ip nat inside source list 1 interface Ethernet1/0 overload
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end

    c3600#

    Lorre
     
    Lorre, May 14, 2005
    #1
    1. Advertising

  2. Lorre

    Wayne Guest


    > ip nat inside source list 1 interface Ethernet1/0 overload


    What does "sorce list 1" refer to? You need to add an access list...

    access-list 1 permit 192.168.0.0 0.0.0.255
     
    Wayne, May 14, 2005
    #2
    1. Advertising

  3. Lorre

    Peter Guest

    Hi Lorre,

    > ip default-gateway 81.164.92.91


    This should be a default route, not a default gateway. IE
    ip route 0.0.0.0 0.0.0.0 81.164.92.91
    Default gateway is for Router management (why the router can get
    outside), Default route is for Routing traffic passing through the
    Router.

    > ip nat inside source list 1 interface Ethernet1/0 overload


    I can't find your source list 1 ACL - that should be the inside
    network you wish to translate using NAT.

    Cheers.....................pk.

    ---
    Peter from Auckland.
     
    Peter, May 14, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SGVpbkQ=?=

    Wireless DHCP clients cannot obtain an IP address from the DHCP se

    =?Utf-8?B?SGVpbkQ=?=, Jan 8, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    2,843
    =?Utf-8?B?SGVpbkQ=?=
    Jan 8, 2006
  2. Enrico
    Replies:
    0
    Views:
    572
    Enrico
    Jul 21, 2005
  3. Ingo Hauf

    if Active Directory no DHCP? or: Where ist my DHCP

    Ingo Hauf, Oct 17, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    524
    Ralph Wade Phillips
    Oct 18, 2003
  4. Fayza
    Replies:
    3
    Views:
    12,760
    Dan Shea
    May 12, 2004
  5. Vimokh
    Replies:
    3
    Views:
    5,709
    Vimokh
    Sep 6, 2006
Loading...

Share This Page