cisco Configuration

Discussion in 'Cisco' started by John, Aug 14, 2007.

  1. John

    John Guest

    Hello,

    Soon, I will need to setup a t1 line between 2 sites. I have purchased 2
    Cisco 1841 routers with the T1 DSU/CSU card in slot 0 (WIC 1DSU-T1 V2).

    Anyway, I think I have everything working properly back to back, but I'm
    running into a weird problem where one side (config A) can only ping the
    other side 60% of the time, and the other side (config B) can not ping
    config A at all. Below are my configurations. Can anybody tell me what I'm
    doing wrong? This is going to be my first T1 deployment, and it has to work.
    Thanks:

    Config A:

    yourname#show run

    Building configuration...

    Current configuration : 2044 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname yourname

    !

    boot-start-marker

    boot-end-marker

    !

    logging buffered 51200 warnings

    !

    no aaa new-model

    !

    resource policy

    !

    mmi polling-interval 60

    no mmi auto-configure

    no mmi pvc

    mmi snmp-timeout 180

    ip subnet-zero

    ip cef

    !

    !

    no ip dhcp use vrf connected

    !

    !

    ip domain name yourdomain.com

    !

    username cisco privilege 15 secret 5 $1$uF6w$fMy7xMIp2BRaJMSi214EM/

    !

    !

    !

    interface FastEthernet0/0

    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

    ip address 10.10.0.1 255.255.0.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    no ip address

    shutdown

    duplex auto

    speed auto

    !

    interface Serial0/0/0

    ip unnumbered FastEthernet0/0

    encapsulation ppp

    !

    ip classless

    !

    ip http server

    ip http access-class 23

    ip http authentication local

    ip http timeout-policy idle 60 life 86400 requests 10000

    !

    access-list 23 permit 10.10.10.0 0.0.0.7

    !

    control-plane

    !

    banner login ^C

    -----------------------------------------------------------------------

    Cisco Router and Security Device Manager (SDM) is installed on this device.

    This feature requires the one-time use of the username "cisco"

    with the password "cisco". The default username and password have a
    privilege le

    vel of 15.

    Please change these publicly known initial credentials using SDM or the IOS
    CLI.

    Here are the Cisco IOS commands.

    username <myuser> privilege 15 secret 0 <mypassword>

    no username cisco

    Replace <myuser> and <mypassword> with the username and password you want to
    use

    ..

    For more information about SDM please follow the instructions in the QUICK
    START

    GUIDE for your router or go to http://www.cisco.com/go/sdm

    -----------------------------------------------------------------------

    ^C

    !

    line con 0

    exec-timeout 0 0

    login local

    line aux 0

    line vty 0 4

    access-class 23 in

    privilege level 15

    login local

    transport input telnet

    line vty 5 15

    access-class 23 in

    privilege level 15

    login local

    transport input telnet

    !

    end





    config B:

    yourname#show run

    Building configuration...

    Current configuration : 2093 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname yourname

    !

    boot-start-marker

    boot-end-marker

    !

    logging buffered 51200 warnings

    !

    no aaa new-model

    !

    resource policy

    !

    mmi polling-inter

    no mmi auto-configure

    no mmi pvc

    mmi snmp-timeout 180

    ip subnet-zero

    ip cef

    !

    !

    no ip dhcp use vrf connected

    !

    !

    ip domain name yourdomain.com

    !

    username p1admins privilege 15 secret 5 $1$nAL8$hheCXtA4rN6.RosXTheFz0

    !

    !

    !

    interface FastEthernet0/0

    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

    ip address 10.10.10.2 255.255.255.248

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    no ip address

    shutdown

    duplex auto

    speed auto

    !

    interface Serial0/0/0

    ip unnumbered FastEthernet0/0

    encapsulation ppp

    service-module t1 clock source internal

    !

    ip classless

    !

    ip http server

    ip http access-class 23

    ip http authentication local

    ip http timeout-policy idle 60 life 86400 requests 10000

    !

    access-list 23 permit 10.10.10.0 0.0.0.7

    !

    control-plane

    !

    banner login ^C

    -----------------------------------------------------------------------

    Cisco Router and Security Device Manager (SDM) is installed on this device.

    This feature requires the one-time use of the username "cisco"

    with the password "cisco". The default username an

    vel of 15.----------

    Please change these publicly known initial credentials using SDM or the IOS
    CLI.

    Cisco Router and Security Device Manag

    Here are the Cisco IOS commands.ce.

    username <myuser> privilege 15 secret 0 <mypassword>ture requires the
    one-time use of the username "cisco

    no username cisco

    Replace <myuser> and <mypassword> with the username and password you want to
    useassword have a privilege le

    ..

    For more information about SDM please follow the instructions in the QUICK
    START

    GUIDE for your router or go to http://www.cisco.com/go/sdm

    -----------------------------------------------------------------------

    ^C

    !

    line con 0

    exec-timeout 0 0

    login local

    line aux 0

    line vty 0 4

    access-class 23 in

    privilege level 15

    login local

    transport input telnet

    line vty 5 15

    access-class 23 in

    privilege level 15

    login local

    transport input telnet

    !

    end

    Right now both routers are configured back to back. Thanks.

    -- John
     
    John, Aug 14, 2007
    #1
    1. Advertising

  2. John

    KDawg44 Guest

    On Aug 14, 11:55 am, "John" <> wrote:
    > Hello,
    >
    > Soon, I will need to setup a t1 line between 2 sites. I have purchased 2
    > Cisco 1841 routers with the T1 DSU/CSU card in slot 0 (WIC 1DSU-T1 V2).
    >
    > Anyway, I think I have everything working properly back to back, but I'm
    > running into a weird problem where one side (config A) can only ping the
    > other side 60% of the time, and the other side (config B) can not ping
    > config A at all. Below are my configurations. Can anybody tell me what I'm
    > doing wrong? This is going to be my first T1 deployment, and it has to work.
    > Thanks:
    >
    > Config A:
    >
    > yourname#show run
    >
    > Building configuration...
    >
    > Current configuration : 2044 bytes
    >
    > !
    >
    > version 12.4
    >
    > service timestamps debug datetime msec
    >
    > service timestamps log datetime msec
    >
    > no service password-encryption
    >
    > !
    >
    > hostname yourname
    >
    > !
    >
    > boot-start-marker
    >
    > boot-end-marker
    >
    > !
    >
    > logging buffered 51200 warnings
    >
    > !
    >
    > no aaa new-model
    >
    > !
    >
    > resource policy
    >
    > !
    >
    > mmi polling-interval 60
    >
    > no mmi auto-configure
    >
    > no mmi pvc
    >
    > mmi snmp-timeout 180
    >
    > ip subnet-zero
    >
    > ip cef
    >
    > !
    >
    > !
    >
    > no ip dhcp use vrf connected
    >
    > !
    >
    > !
    >
    > ip domain name yourdomain.com
    >
    > !
    >
    > username cisco privilege 15 secret 5 $1$uF6w$fMy7xMIp2BRaJMSi214EM/
    >
    > !
    >
    > !
    >
    > !
    >
    > interface FastEthernet0/0
    >
    > description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    >
    > ip address 10.10.0.1 255.255.0.0
    >
    > duplex auto
    >
    > speed auto
    >
    > !
    >
    > interface FastEthernet0/1
    >
    > no ip address
    >
    > shutdown
    >
    > duplex auto
    >
    > speed auto
    >
    > !
    >
    > interface Serial0/0/0
    >
    > ip unnumbered FastEthernet0/0
    >
    > encapsulation ppp
    >
    > !
    >
    > ip classless
    >
    > !
    >
    > ip http server
    >
    > ip http access-class 23
    >
    > ip http authentication local
    >
    > ip http timeout-policy idle 60 life 86400 requests 10000
    >
    > !
    >
    > access-list 23 permit 10.10.10.0 0.0.0.7
    >
    > !
    >
    > control-plane
    >
    > !
    >
    > banner login ^C
    >
    > -----------------------------------------------------------------------
    >
    > Cisco Router and Security Device Manager (SDM) is installed on this device.
    >
    > This feature requires the one-time use of the username "cisco"
    >
    > with the password "cisco". The default username and password have a
    > privilege le
    >
    > vel of 15.
    >
    > Please change these publicly known initial credentials using SDM or the IOS
    > CLI.
    >
    > Here are the Cisco IOS commands.
    >
    > username <myuser> privilege 15 secret 0 <mypassword>
    >
    > no username cisco
    >
    > Replace <myuser> and <mypassword> with the username and password you want to
    > use
    >
    > .
    >
    > For more information about SDM please follow the instructions in the QUICK
    > START
    >
    > GUIDE for your router or go tohttp://www.cisco.com/go/sdm
    >
    > -----------------------------------------------------------------------
    >
    > ^C
    >
    > !
    >
    > line con 0
    >
    > exec-timeout 0 0
    >
    > login local
    >
    > line aux 0
    >
    > line vty 0 4
    >
    > access-class 23 in
    >
    > privilege level 15
    >
    > login local
    >
    > transport input telnet
    >
    > line vty 5 15
    >
    > access-class 23 in
    >
    > privilege level 15
    >
    > login local
    >
    > transport input telnet
    >
    > !
    >
    > end
    >
    > config B:
    >
    > yourname#show run
    >
    > Building configuration...
    >
    > Current configuration : 2093 bytes
    >
    > !
    >
    > version 12.4
    >
    > service timestamps debug datetime msec
    >
    > service timestamps log datetime msec
    >
    > no service password-encryption
    >
    > !
    >
    > hostname yourname
    >
    > !
    >
    > boot-start-marker
    >
    > boot-end-marker
    >
    > !
    >
    > logging buffered 51200 warnings
    >
    > !
    >
    > no aaa new-model
    >
    > !
    >
    > resource policy
    >
    > !
    >
    > mmi polling-inter
    >
    > no mmi auto-configure
    >
    > no mmi pvc
    >
    > mmi snmp-timeout 180
    >
    > ip subnet-zero
    >
    > ip cef
    >
    > !
    >
    > !
    >
    > no ip dhcp use vrf connected
    >
    > !
    >
    > !
    >
    > ip domain name yourdomain.com
    >
    > !
    >
    > username p1admins privilege 15 secret 5 $1$nAL8$hheCXtA4rN6.RosXTheFz0
    >
    > !
    >
    > !
    >
    > !
    >
    > interface FastEthernet0/0
    >
    > description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    >
    > ip address 10.10.10.2 255.255.255.248
    >
    > duplex auto
    >
    > speed auto
    >
    > !
    >
    > interface FastEthernet0/1
    >
    > no ip address
    >
    > shutdown
    >
    > duplex auto
    >
    > speed auto
    >
    > !
    >
    > interface Serial0/0/0
    >
    > ip unnumbered FastEthernet0/0
    >
    > encapsulation ppp
    >
    > service-module t1 clock source internal
    >
    > !
    >
    > ip classless
    >
    > !
    >
    > ip http server
    >
    > ip http access-class 23
    >
    > ip http authentication local
    >
    > ip http timeout-policy idle 60 life 86400 requests 10000
    >
    > !
    >
    > access-list 23 permit 10.10.10.0 0.0.0.7
    >
    > !
    >
    > control-plane
    >
    > !
    >
    > banner login ^C
    >
    > -----------------------------------------------------------------------
    >
    > Cisco Router and Security Device Manager (SDM) is installed on this device.
    >
    > This feature requires the one-time use of the username "cisco"
    >
    > with the password "cisco". The default username an
    >
    > vel of 15.----------
    >
    > Please change these publicly known initial credentials using SDM or the IOS
    > CLI.
    >
    > Cisco Router and Security Device Manag
    >
    > Here are the Cisco IOS commands.ce.
    >
    > username <myuser> privilege 15 secret 0 <mypassword>ture requires the
    > one-time use of the username "cisco
    >
    > no username cisco
    >
    > Replace <myuser> and <mypassword> with the username and password you want to
    > useassword have a privilege le
    >
    > .
    >
    > For more information about SDM please follow the instructions in the QUICK
    > START
    >
    > GUIDE for your router or go tohttp://www.cisco.com/go/sdm
    >
    > -----------------------------------------------------------------------
    >
    > ^C
    >
    > !
    >
    > line con 0
    >
    > exec-timeout 0 0
    >
    > login local
    >
    > line aux 0
    >
    > line vty 0 4
    >
    > access-class 23 in
    >
    > privilege level 15
    >
    > login local
    >
    > transport input telnet
    >
    > line vty 5 15
    >
    > access-class 23 in
    >
    > privilege level 15
    >
    > login local
    >
    > transport input telnet
    >
    > !
    >
    > end
    >
    > Right now both routers are configured back to back. Thanks.
    >
    > -- John


    I am not 100% sure, but I believe with ip unnumbered you have to have
    some routing protocol running. Do you have a routing protocol
    configured?
     
    KDawg44, Aug 14, 2007
    #2
    1. Advertising

  3. John

    Chris Guest


    > I am not 100% sure, but I believe with ip unnumbered you have to have
    > some routing protocol running. Do you have a routing protocol
    > configured?


    No, you don't need to run a routing protocol with ip unnumbered.

    Chris.
     
    Chris, Aug 14, 2007
    #3
  4. John

    J.Cottingim Guest

    On Aug 14, 10:55 am, "John" <> wrote:
    > Hello,
    >
    > Soon, I will need to setup a t1 line between 2 sites. I have purchased 2
    > Cisco 1841 routers with the T1 DSU/CSU card in slot 0 (WIC 1DSU-T1 V2).
    >
    > Anyway, I think I have everything working properly back to back, but I'm
    > running into a weird problem where one side (config A) can only ping the
    > other side 60% of the time, and the other side (config B) can not ping
    > config A at all. Below are my configurations. Can anybody tell me what I'm
    > doing wrong? This is going to be my first T1 deployment, and it has to work.
    > Thanks:
    >
    >=================================
    > Config A:


    > interface FastEthernet0/0
    > description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    > ip address 10.10.0.1 255.255.0.0
    > duplex auto
    > speed auto
    > !
    > interface Serial0/0/0
    > ip unnumbered FastEthernet0/0
    > encapsulation ppp
    > !
    > end
    >=================================
    > config B:
    >
    > interface FastEthernet0/0
    > description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    > ip address 10.10.10.2 255.255.255.248
    > duplex auto
    > speed auto
    > !
    > interface Serial0/0/0
    > ip unnumbered FastEthernet0/0
    > encapsulation ppp
    > service-module t1 clock source internal
    > !
    >=================================


    John,
    The problem you are having is an overlapping/mis-configured masks on
    the Fa0/0 interfaces.
    If you change the masks to something that is not over-lapping, it
    should work fine.
    Try configuring both of them with /24 masks (255.255.255.0)

    As KDawg44 mentions, you WILL need a routing protocol (sorry Chris).
    Any routing protocol will do - even static routes.
    Here's what you *could* use assuming:
    --- router A: fa0/0 --> 10.10.0.1 /24
    --- router B: fa0/0 --> 10.10.10.2 /24

    Add to router A's config:
    ip route 10.10.10.0 255.255.255.0 s0/0/0

    Add to router B's config:
    ip route 10.10.0.0 255.255.255.0 s0/0/0


    Good luck - Have fun
    JC
     
    J.Cottingim, Aug 14, 2007
    #4
  5. John

    Chris Guest


    > As KDawg44 mentions, you WILL need a routing protocol (sorry Chris).
    > Any routing protocol will do - even static routes.


    I wouldn't class static routing as a "routing protocol" I was simply saying
    that ip unnumbered doesn't require a routing protocol, which it doesn't.
    Static routes work fine. I have installed a couple of hundred routers in
    this manner!!
     
    Chris, Aug 14, 2007
    #5
  6. John

    J.Cottingim Guest

    On Aug 14, 4:31 pm, Chris <> wrote:
    > > As KDawg44 mentions, you WILL need a routing protocol (sorry Chris).
    > > Any routing protocol will do - even static routes.

    >
    > I wouldn't class static routing as a "routing protocol" I was simply saying
    > that ip unnumbered doesn't require a routing protocol, which it doesn't.
    > Static routes work fine. I have installed a couple of hundred routers in
    > this manner!!


    Chris,
    I know we're splitting hairs here - not to mention off-topic, but as a
    matter of classification, I would include static routing in the same
    class as any other routing protocol.
    If static routing isn't a "routing protocol", then what is it?

    I think what you mean is it's not a **dynamic** routing protocol.

    Let's check the definitions of the words...

    Routing:
    2. the arranging and scheduling of mail for delivery.
    http://dictionary.reference.com/browse/routing

    Protocol:
    3. code of correct conduct; "Saftey protocols"; "academic protocol"
    http://dictionary.reference.com/browse/protocol

    Static routes - is a method used to arrange delivery by a code of
    correct conduct [in our case - packets].

    If that doesn't convince you, Cisco lists it as one if it's Routing
    Protocols in it's table of administrative distances.
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt2/1cfindep.htm

    -JC
     
    J.Cottingim, Aug 15, 2007
    #6
  7. John

    John Guest

    Thanks guys. It works now with PPP & HDLC. I'm going to keep playing with
    it. I'm just using a default route now going through the serial interface
    on both routers. It seems to work fine. However, if I switch from PPP to
    HDLC, it seems to take a little while before the routers can ping each other
    (about 30-90 seconds). Maybe I'm going crazy.

    Anyway, the only problem I'm having now is that the connection seems to be
    slow. As you are aware, it is a back to back T1 connection. If I perform a
    "copy flash:myimage tftp", the image is downloaded through the connection,
    but it seems very slow. It takes me about 20 minutes to download the image.
    I'm going to check to see if there is some type of baudrate or speed command
    to increase this speed. If you guys have a suggestion, it would be greatly
    appreciated.

    Thanks again for the help thus far.
    -- John



    "J.Cottingim" <> wrote in message
    news:...
    > On Aug 14, 4:31 pm, Chris <> wrote:
    >> > As KDawg44 mentions, you WILL need a routing protocol (sorry Chris).
    >> > Any routing protocol will do - even static routes.

    >>
    >> I wouldn't class static routing as a "routing protocol" I was simply
    >> saying
    >> that ip unnumbered doesn't require a routing protocol, which it doesn't.
    >> Static routes work fine. I have installed a couple of hundred routers in
    >> this manner!!

    >
    > Chris,
    > I know we're splitting hairs here - not to mention off-topic, but as a
    > matter of classification, I would include static routing in the same
    > class as any other routing protocol.
    > If static routing isn't a "routing protocol", then what is it?
    >
    > I think what you mean is it's not a **dynamic** routing protocol.
    >
    > Let's check the definitions of the words...
    >
    > Routing:
    > 2. the arranging and scheduling of mail for delivery.
    > http://dictionary.reference.com/browse/routing
    >
    > Protocol:
    > 3. code of correct conduct; "Saftey protocols"; "academic protocol"
    > http://dictionary.reference.com/browse/protocol
    >
    > Static routes - is a method used to arrange delivery by a code of
    > correct conduct [in our case - packets].
    >
    > If that doesn't convince you, Cisco lists it as one if it's Routing
    > Protocols in it's table of administrative distances.
    > http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt2/1cfindep.htm
    >
    > -JC
    >
     
    John, Aug 15, 2007
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Moti
    Replies:
    1
    Views:
    1,184
    jonathan fernandes
    Jul 16, 2003
  2. javi
    Replies:
    1
    Views:
    642
    Ted Mittelstaedt
    Oct 16, 2003
  3. jester
    Replies:
    1
    Views:
    1,819
    Vivek
    Dec 20, 2005
  4. Replies:
    0
    Views:
    817
  5. Replies:
    2
    Views:
    3,156
    thort
    Sep 29, 2007
Loading...

Share This Page