Cisco CMTS QoS

Discussion in 'Cisco' started by Uffe S. Callesen, Aug 3, 2007.

  1. I'm working on a QoS solution for Ubr72xx and Ubr10k - I need to DSCP mark
    packets from/to eMTA's.

    I've tried to do this with a policy map :

    ..
    ..
    class-map match-any VoIP
    match access-group name VoIP-net
    ..
    ..
    ip access-list standard VoIP-net
    permit X.X.X.0 0.0.0.255
    ..
    ..
    policy-map VoIP-marking
    class VoIP
    set dscp ef
    ..
    ..
    cable1/2/3
    service-policy input VoIP-marking
    service-policy output VoIP-marking

    Unfortunately it results in:

    Service-policy input: VoIP-marking

    Class-map: VoIP (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any
    QoS Set
    dscp ef
    Packets marked 0

    Class-map: class-default (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any

    Service-policy output: VoIP-marking

    Class-map: VoIP (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any
    QoS Set
    dscp ef
    Packets marked 0

    Class-map: class-default (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any
    Output queue: 0/64; 2427871/126325894 packets/bytes output, 0 drops


    Any ideas as to what I'm doing wrong ??
     
    Uffe S. Callesen, Aug 3, 2007
    #1
    1. Advertising

  2. Uffe S. Callesen

    Guest

    On 3 Aug, 12:04, "Uffe S. Callesen" <> wrote:
    > I'm working on a QoS solution for Ubr72xx and Ubr10k - I need to DSCP mark
    > packets from/to eMTA's.
    >
    > I've tried to do this with a policy map :
    >
    > .
    > .
    > class-map match-any VoIP
    > match access-group name VoIP-net
    > .
    > .
    > ip access-list standard VoIP-net
    > permit X.X.X.0 0.0.0.255
    > .
    > .
    > policy-map VoIP-marking
    > class VoIP
    > set dscp ef
    > .
    > .
    > cable1/2/3
    > service-policy input VoIP-marking
    > service-policy output VoIP-marking
    >
    > Unfortunately it results in:
    >
    > Service-policy input: VoIP-marking
    >
    > Class-map: VoIP (match-any)
    > 0 packets, 0 bytes
    > 5 minute offered rate 0 bps, drop rate 0 bps
    > Match: any
    > QoS Set
    > dscp ef
    > Packets marked 0
    >
    > Class-map: class-default (match-any)
    > 0 packets, 0 bytes
    > 5 minute offered rate 0 bps, drop rate 0 bps
    > Match: any
    >
    > Service-policy output: VoIP-marking
    >
    > Class-map: VoIP (match-any)
    > 0 packets, 0 bytes
    > 5 minute offered rate 0 bps, drop rate 0 bps
    > Match: any
    > QoS Set
    > dscp ef
    > Packets marked 0
    >
    > Class-map: class-default (match-any)
    > 0 packets, 0 bytes
    > 5 minute offered rate 0 bps, drop rate 0 bps
    > Match: any
    > Output queue: 0/64; 2427871/126325894 packets/bytes output, 0 drops
    >
    > Any ideas as to what I'm doing wrong ??


    I have been tearing my hair out with cisco QoS. The behaviour
    seems to vary from platform to platform and I have seen cases
    where the commands seemed to be accepted but that nothing happened.

    You don't say of your interfaces are configured for IP? If not then
    maybe IP based policies are of no use?

    Otherwise, there looks to be nothing wrong with the config.

    Here is a working one:-

    ip access-list extended ACL.voice.udp
    permit udp any range 16384 32767 any range 16384 32767 !<- voice
    permit udp any any range 32000 34000 !<- test traffic - i.e.
    prioritise traceroute
    permit icmp any any port-unreachable !<-- test traffic - i.e.
    prioritise traceroute
    deny ip any any



    class-map match-any ClM.voice
    match dscp ef
    match dscp cs3
    match access-group name ACL.voice.udp



    policy-map PM.2M.to-internet.child
    class ClM.voice
    priority 700
    set dscp ef !<-- bit crude but does the job.

    policy-map PM.2M.to-internet.parent
    class class-default
    shape average 1800000
    service-policy PM.2M.to-internet.child



    interface GigabitEthernet0/0
    service-policy output PM.2M.to-internet.parent



    #sh policy-map in
    GigabitEthernet0/0

    Service-policy output: PM.2M.to-internet.parent

    Class-map: class-default (match-any)
    130929187 packets, 44836847927 bytes
    30 second offered rate 4000 bps, drop rate 0 bps
    Match: any
    Traffic Shaping
    Target/Average Byte Sustain Excess Interval
    Increment
    Rate Limit bits/int bits/int (ms)
    (bytes)
    1800000/1800000 11250 45000 45000 25 5625

    Adapt Queue Packets Bytes Packets Bytes
    Shaping
    Active Depth Delayed Delayed
    Active
    - 0 130748077 1863557570 22204988 389010887 no

    Service-policy : PM.2M.to-internet.child

    Class-map: ClM.voice (match-any)
    47118271 packets, 9367593607 bytes
    30 second offered rate 0 bps, drop rate 0 bps
    Match: dscp ef (46)
    41919155 packets, 8970698902 bytes
    30 second rate 0 bps
    Match: dscp cs3 (24)
    4307222 packets, 265278530 bytes
    30 second rate 0 bps
    Match: access-group name ACL.voice.udp
    891895 packets, 131616389 bytes
    30 second rate 0 bps
    Queueing
    Strict Priority
    Output Queue: Conversation 72
    Bandwidth 700 (kbps) Burst 17500 (Bytes)
    (pkts matched/bytes matched) 1255894/332541015
    (total drops/bytes drops) 0/0
    QoS Set
    dscp ef
    Packets marked 47118272

    Class-map: class-default (match-any)
    83810914 packets, 35469254052 bytes
    30 second offered rate 4000 bps, drop rate 0 bps
    Match: any


    Cisco 2821
    c2800nm-advipservicesk9-mz.124-8a.bin
     
    , Aug 3, 2007
    #2
    1. Advertising

  3. Figured it out - the QoS policy must be applied to a non-cable interface !
     
    Uffe S. Callesen, Aug 13, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,557
  2. Rene Kuhn
    Replies:
    0
    Views:
    949
    Rene Kuhn
    Dec 28, 2005
  3. dominix
    Replies:
    2
    Views:
    500
    dominix
    Feb 6, 2007
  4. scottp2626

    Cisco CMTS

    scottp2626, Apr 8, 2009, in forum: Cisco
    Replies:
    0
    Views:
    515
    scottp2626
    Apr 8, 2009
  5. JF Mezei
    Replies:
    0
    Views:
    748
    JF Mezei
    Feb 5, 2010
Loading...

Share This Page