Cisco Aironet and switch VLAN problem

Discussion in 'Cisco' started by BlackSheep, Sep 9, 2004.

  1. BlackSheep

    BlackSheep Guest

    Hi,

    I am having some strange problems with a Cisco Aironet 1200. I have set up 2
    VLANs
    (as config following). This is then connected by wire to a tagged (trunked
    etc.)
    port on a 3Com 4400 switch. The problem is that I cannot connect to the
    Access Point when
    connected to the tagged/trunked port. I can connect to the AP with an
    untagged port ok
    (on 10.10.10.5 as in config) but obviously I will not get VLAN functionality
    then.

    The 3com switch has one port (tagged) as a member of both VLAN 1 and 2, in
    which the AP
    would be plugged into.

    Im scratching my head on this, I have tried setting up the AP with GUI, CLI
    a few times
    after a complete reset. Still cannot work out, will look at again tommorow
    but any help
    or suggestions would be greatly appreciated.

    Dave.

    -------------------------------

    Cisco config:

    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Aironet1
    !
    enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    !
    username admin privilege 15 password 7
    1413110752577E
    ip subnet-zero
    !
    !
    bridge irb
    !
    !
    interface Dot11Radio0
    no ip address
    no ip route-cache
    !
    ssid MyWLAN_SSID_Lan1
    vlan 2
    !
    ssid MyWLAN_SSID_Lan2
    vlan 1
    !
    speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    rts threshold 2312
    station-role root
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    !
    interface Dot11Radio0.2
    encapsulation dot1Q 2
    no ip route-cache
    !
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    !
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    !
    interface FastEthernet0.2
    encapsulation dot1Q 2
    no ip route-cache
    !
    interface BVI1
    ip address 10.10.10.5 255.255.255.0
    no ip route-cache
    !
    ip http server
    ip http help-path
    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    ip radius source-interface BVI1
    bridge 1 route ip
    !
    !
    line con 0
    line vty 0 4
    login local
    line vty 5 15
    login
    !
    end

    ------
    BlackSheep, Sep 9, 2004
    #1
    1. Advertising

  2. Hello, BlackSheep!
    You wrote on Thu, 9 Sep 2004 22:42:02 +0100:

    B> interface FastEthernet0.1
    B> encapsulation dot1Q 1 native

    With best regards,
    Andrey.
    Andrey Tarasov, Sep 10, 2004
    #2
    1. Advertising

  3. BlackSheep

    mh Guest

    interface Dot11Radio0.2
    bridge-group 2
    exit
    interface FastEthernet0.2
    bridge-group 2
    exit
    mh, Sep 10, 2004
    #3
  4. BlackSheep

    BlackSheep Guest

    This adds VLAN 2 on Radio and Ethernet to bridge group 2. Is this bridge
    group anything to do with the Bridge Virtual Interface?

    Surely I should still be able to connect to the BVI as its in the Native
    VLAN 1 anyway?

    Have not tryed it yet as its weekend.

    > interface Dot11Radio0.2
    > bridge-group 2
    > exit
    > interface FastEthernet0.2
    > bridge-group 2
    > exit
    BlackSheep, Sep 11, 2004
    #4
  5. Noticed there is another blacksheep!! I have modded my name to help not mix
    me with him.


    "BlackSheep" <nospam@nowhere> wrote in message
    news:4140ce2b$0$22756$...
    > Hi,
    >
    > I am having some strange problems with a Cisco Aironet 1200. I have set up

    2
    > VLANs
    > (as config following). This is then connected by wire to a tagged (trunked
    > etc.)
    > port on a 3Com 4400 switch. The problem is that I cannot connect to the
    > Access Point when
    > connected to the tagged/trunked port. I can connect to the AP with an
    > untagged port ok
    > (on 10.10.10.5 as in config) but obviously I will not get VLAN

    functionality
    > then.
    >
    > The 3com switch has one port (tagged) as a member of both VLAN 1 and 2, in
    > which the AP
    > would be plugged into.
    >
    > Im scratching my head on this, I have tried setting up the AP with GUI,

    CLI
    > a few times
    > after a complete reset. Still cannot work out, will look at again tommorow
    > but any help
    > or suggestions would be greatly appreciated.
    >
    > Dave.
    >
    > -------------------------------
    >
    > Cisco config:
    >
    > !
    > version 12.2
    > no service pad
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname Aironet1
    > !
    > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    > !
    > username admin privilege 15 password 7
    > 1413110752577E
    > ip subnet-zero
    > !
    > !
    > bridge irb
    > !
    > !
    > interface Dot11Radio0
    > no ip address
    > no ip route-cache
    > !
    > ssid MyWLAN_SSID_Lan1
    > vlan 2
    > !
    > ssid MyWLAN_SSID_Lan2
    > vlan 1
    > !
    > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    > rts threshold 2312
    > station-role root
    > !
    > interface Dot11Radio0.1
    > encapsulation dot1Q 1 native
    > no ip route-cache
    > bridge-group 1
    > bridge-group 1 subscriber-loop-control
    > bridge-group 1 block-unknown-source
    > no bridge-group 1 source-learning
    > no bridge-group 1 unicast-flooding
    > bridge-group 1 spanning-disabled
    > !
    > interface Dot11Radio0.2
    > encapsulation dot1Q 2
    > no ip route-cache
    > !
    > interface FastEthernet0
    > no ip address
    > no ip route-cache
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0.1
    > encapsulation dot1Q 1 native
    > no ip route-cache
    > bridge-group 1
    > no bridge-group 1 source-learning
    > bridge-group 1 spanning-disabled
    > !
    > interface FastEthernet0.2
    > encapsulation dot1Q 2
    > no ip route-cache
    > !
    > interface BVI1
    > ip address 10.10.10.5 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > ip http help-path
    > http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    > ip radius source-interface BVI1
    > bridge 1 route ip
    > !
    > !
    > line con 0
    > line vty 0 4
    > login local
    > line vty 5 15
    > login
    > !
    > end
    >
    > ------
    >
    >
    BlackWoollySheep, Sep 11, 2004
    #5
  6. What are you saying :) This bit looks ok to me!

    "Andrey Tarasov" <> wrote in message
    news:chr6eu$1cmn$...
    > Hello, BlackSheep!
    > You wrote on Thu, 9 Sep 2004 22:42:02 +0100:
    >
    > B> interface FastEthernet0.1
    > B> encapsulation dot1Q 1 native
    >
    > With best regards,
    > Andrey.
    BlackWoollySheep, Sep 11, 2004
    #6
  7. BlackSheep

    White Sheep Guest

    Hi BlackSheep,

    Your Native VLAN (1) on the Aironet will be sending untagged traffic, while
    you non native VLAN (2) will be tagged. You need to configure VLAN 1 on the
    3COM to be the Native "ie untagged' VLAN. Here is the a config for a Cisco
    connected to an Aironet running Voice in VLAN 305 and data in VLAN 306:

    interface FastEthernet0/18
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 306
    switchport trunk allowed vlan 1,305,306,1002-1005
    switchport mode trunk
    spanning-tree portfast
    end

    Sorry but I don't know the equivilant in the 3Com world.
    "BlackSheep" <nospam@nowhere> wrote in message
    news:4140ce2b$0$22756$...
    > Hi,
    >
    > I am having some strange problems with a Cisco Aironet 1200. I have set up
    > 2
    > VLANs
    > (as config following). This is then connected by wire to a tagged (trunked
    > etc.)
    > port on a 3Com 4400 switch. The problem is that I cannot connect to the
    > Access Point when
    > connected to the tagged/trunked port. I can connect to the AP with an
    > untagged port ok
    > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    > functionality
    > then.
    >
    > The 3com switch has one port (tagged) as a member of both VLAN 1 and 2, in
    > which the AP
    > would be plugged into.
    >
    > Im scratching my head on this, I have tried setting up the AP with GUI,
    > CLI
    > a few times
    > after a complete reset. Still cannot work out, will look at again tommorow
    > but any help
    > or suggestions would be greatly appreciated.
    >
    > Dave.
    >
    > -------------------------------
    >
    > Cisco config:
    >
    > !
    > version 12.2
    > no service pad
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname Aironet1
    > !
    > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    > !
    > username admin privilege 15 password 7
    > 1413110752577E
    > ip subnet-zero
    > !
    > !
    > bridge irb
    > !
    > !
    > interface Dot11Radio0
    > no ip address
    > no ip route-cache
    > !
    > ssid MyWLAN_SSID_Lan1
    > vlan 2
    > !
    > ssid MyWLAN_SSID_Lan2
    > vlan 1
    > !
    > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    > rts threshold 2312
    > station-role root
    > !
    > interface Dot11Radio0.1
    > encapsulation dot1Q 1 native
    > no ip route-cache
    > bridge-group 1
    > bridge-group 1 subscriber-loop-control
    > bridge-group 1 block-unknown-source
    > no bridge-group 1 source-learning
    > no bridge-group 1 unicast-flooding
    > bridge-group 1 spanning-disabled
    > !
    > interface Dot11Radio0.2
    > encapsulation dot1Q 2
    > no ip route-cache
    > !
    > interface FastEthernet0
    > no ip address
    > no ip route-cache
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0.1
    > encapsulation dot1Q 1 native
    > no ip route-cache
    > bridge-group 1
    > no bridge-group 1 source-learning
    > bridge-group 1 spanning-disabled
    > !
    > interface FastEthernet0.2
    > encapsulation dot1Q 2
    > no ip route-cache
    > !
    > interface BVI1
    > ip address 10.10.10.5 255.255.255.0
    > no ip route-cache
    > !
    > ip http server
    > ip http help-path
    > http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    > ip radius source-interface BVI1
    > bridge 1 route ip
    > !
    > !
    > line con 0
    > line vty 0 4
    > login local
    > line vty 5 15
    > login
    > !
    > end
    >
    > ------
    >
    >
    White Sheep, Sep 11, 2004
    #7
  8. On the 3com its a matter of telnetting in and changing the config. There is
    no multi line boot up config like the Cisco.

    I will try this on monday and let you know, thanks!

    "White Sheep" <> wrote in message
    news:...
    > Hi BlackSheep,
    >
    > Your Native VLAN (1) on the Aironet will be sending untagged traffic,

    while
    > you non native VLAN (2) will be tagged. You need to configure VLAN 1 on

    the
    > 3COM to be the Native "ie untagged' VLAN. Here is the a config for a Cisco
    > connected to an Aironet running Voice in VLAN 305 and data in VLAN 306:
    >
    > interface FastEthernet0/18
    > switchport trunk encapsulation dot1q
    > switchport trunk native vlan 306
    > switchport trunk allowed vlan 1,305,306,1002-1005
    > switchport mode trunk
    > spanning-tree portfast
    > end
    >
    > Sorry but I don't know the equivilant in the 3Com world.
    > "BlackSheep" <nospam@nowhere> wrote in message
    > news:4140ce2b$0$22756$...
    > > Hi,
    > >
    > > I am having some strange problems with a Cisco Aironet 1200. I have set

    up
    > > 2
    > > VLANs
    > > (as config following). This is then connected by wire to a tagged

    (trunked
    > > etc.)
    > > port on a 3Com 4400 switch. The problem is that I cannot connect to the
    > > Access Point when
    > > connected to the tagged/trunked port. I can connect to the AP with an
    > > untagged port ok
    > > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    > > functionality
    > > then.
    > >
    > > The 3com switch has one port (tagged) as a member of both VLAN 1 and 2,

    in
    > > which the AP
    > > would be plugged into.
    > >
    > > Im scratching my head on this, I have tried setting up the AP with GUI,
    > > CLI
    > > a few times
    > > after a complete reset. Still cannot work out, will look at again

    tommorow
    > > but any help
    > > or suggestions would be greatly appreciated.
    > >
    > > Dave.
    > >
    > > -------------------------------
    > >
    > > Cisco config:
    > >
    > > !
    > > version 12.2
    > > no service pad
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > service password-encryption
    > > !
    > > hostname Aironet1
    > > !
    > > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    > > !
    > > username admin privilege 15 password 7
    > > 1413110752577E
    > > ip subnet-zero
    > > !
    > > !
    > > bridge irb
    > > !
    > > !
    > > interface Dot11Radio0
    > > no ip address
    > > no ip route-cache
    > > !
    > > ssid MyWLAN_SSID_Lan1
    > > vlan 2
    > > !
    > > ssid MyWLAN_SSID_Lan2
    > > vlan 1
    > > !
    > > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    > > rts threshold 2312
    > > station-role root
    > > !
    > > interface Dot11Radio0.1
    > > encapsulation dot1Q 1 native
    > > no ip route-cache
    > > bridge-group 1
    > > bridge-group 1 subscriber-loop-control
    > > bridge-group 1 block-unknown-source
    > > no bridge-group 1 source-learning
    > > no bridge-group 1 unicast-flooding
    > > bridge-group 1 spanning-disabled
    > > !
    > > interface Dot11Radio0.2
    > > encapsulation dot1Q 2
    > > no ip route-cache
    > > !
    > > interface FastEthernet0
    > > no ip address
    > > no ip route-cache
    > > duplex auto
    > > speed auto
    > > !
    > > interface FastEthernet0.1
    > > encapsulation dot1Q 1 native
    > > no ip route-cache
    > > bridge-group 1
    > > no bridge-group 1 source-learning
    > > bridge-group 1 spanning-disabled
    > > !
    > > interface FastEthernet0.2
    > > encapsulation dot1Q 2
    > > no ip route-cache
    > > !
    > > interface BVI1
    > > ip address 10.10.10.5 255.255.255.0
    > > no ip route-cache
    > > !
    > > ip http server
    > > ip http help-path
    > >

    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    > > ip radius source-interface BVI1
    > > bridge 1 route ip
    > > !
    > > !
    > > line con 0
    > > line vty 0 4
    > > login local
    > > line vty 5 15
    > > login
    > > !
    > > end
    > >
    > > ------
    > >
    > >

    >
    >
    BlackWoollySheep, Sep 12, 2004
    #8
  9. BlackSheep

    White Sheep Guest

    Any luck?


    "BlackWoollySheep" <nospam@nowhere> wrote in message
    news:41442a8c$0$22754$...
    > On the 3com its a matter of telnetting in and changing the config. There
    > is
    > no multi line boot up config like the Cisco.
    >
    > I will try this on monday and let you know, thanks!
    >
    > "White Sheep" <> wrote in message
    > news:...
    >> Hi BlackSheep,
    >>
    >> Your Native VLAN (1) on the Aironet will be sending untagged traffic,

    > while
    >> you non native VLAN (2) will be tagged. You need to configure VLAN 1 on

    > the
    >> 3COM to be the Native "ie untagged' VLAN. Here is the a config for a
    >> Cisco
    >> connected to an Aironet running Voice in VLAN 305 and data in VLAN 306:
    >>
    >> interface FastEthernet0/18
    >> switchport trunk encapsulation dot1q
    >> switchport trunk native vlan 306
    >> switchport trunk allowed vlan 1,305,306,1002-1005
    >> switchport mode trunk
    >> spanning-tree portfast
    >> end
    >>
    >> Sorry but I don't know the equivilant in the 3Com world.
    >> "BlackSheep" <nospam@nowhere> wrote in message
    >> news:4140ce2b$0$22756$...
    >> > Hi,
    >> >
    >> > I am having some strange problems with a Cisco Aironet 1200. I have set

    > up
    >> > 2
    >> > VLANs
    >> > (as config following). This is then connected by wire to a tagged

    > (trunked
    >> > etc.)
    >> > port on a 3Com 4400 switch. The problem is that I cannot connect to the
    >> > Access Point when
    >> > connected to the tagged/trunked port. I can connect to the AP with an
    >> > untagged port ok
    >> > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    >> > functionality
    >> > then.
    >> >
    >> > The 3com switch has one port (tagged) as a member of both VLAN 1 and 2,

    > in
    >> > which the AP
    >> > would be plugged into.
    >> >
    >> > Im scratching my head on this, I have tried setting up the AP with GUI,
    >> > CLI
    >> > a few times
    >> > after a complete reset. Still cannot work out, will look at again

    > tommorow
    >> > but any help
    >> > or suggestions would be greatly appreciated.
    >> >
    >> > Dave.
    >> >
    >> > -------------------------------
    >> >
    >> > Cisco config:
    >> >
    >> > !
    >> > version 12.2
    >> > no service pad
    >> > service timestamps debug datetime msec
    >> > service timestamps log datetime msec
    >> > service password-encryption
    >> > !
    >> > hostname Aironet1
    >> > !
    >> > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    >> > !
    >> > username admin privilege 15 password 7
    >> > 1413110752577E
    >> > ip subnet-zero
    >> > !
    >> > !
    >> > bridge irb
    >> > !
    >> > !
    >> > interface Dot11Radio0
    >> > no ip address
    >> > no ip route-cache
    >> > !
    >> > ssid MyWLAN_SSID_Lan1
    >> > vlan 2
    >> > !
    >> > ssid MyWLAN_SSID_Lan2
    >> > vlan 1
    >> > !
    >> > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    >> > rts threshold 2312
    >> > station-role root
    >> > !
    >> > interface Dot11Radio0.1
    >> > encapsulation dot1Q 1 native
    >> > no ip route-cache
    >> > bridge-group 1
    >> > bridge-group 1 subscriber-loop-control
    >> > bridge-group 1 block-unknown-source
    >> > no bridge-group 1 source-learning
    >> > no bridge-group 1 unicast-flooding
    >> > bridge-group 1 spanning-disabled
    >> > !
    >> > interface Dot11Radio0.2
    >> > encapsulation dot1Q 2
    >> > no ip route-cache
    >> > !
    >> > interface FastEthernet0
    >> > no ip address
    >> > no ip route-cache
    >> > duplex auto
    >> > speed auto
    >> > !
    >> > interface FastEthernet0.1
    >> > encapsulation dot1Q 1 native
    >> > no ip route-cache
    >> > bridge-group 1
    >> > no bridge-group 1 source-learning
    >> > bridge-group 1 spanning-disabled
    >> > !
    >> > interface FastEthernet0.2
    >> > encapsulation dot1Q 2
    >> > no ip route-cache
    >> > !
    >> > interface BVI1
    >> > ip address 10.10.10.5 255.255.255.0
    >> > no ip route-cache
    >> > !
    >> > ip http server
    >> > ip http help-path
    >> >

    > http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    >> > ip radius source-interface BVI1
    >> > bridge 1 route ip
    >> > !
    >> > !
    >> > line con 0
    >> > line vty 0 4
    >> > login local
    >> > line vty 5 15
    >> > login
    >> > !
    >> > end
    >> >
    >> > ------
    >> >
    >> >

    >>
    >>

    >
    >
    White Sheep, Sep 13, 2004
    #9
  10. Tryed it today and success!!!

    Now according to my thinking, if a packet is tagged for a VLAN then it
    should
    go to the correct one as the Cisco has both VLANs 802.1q tagged and so did
    the 3com that "you would of thought" (or at least me!) that would of been
    ok!

    So I dropped the VLAN1 native port out of the tagged state and VLAN2 is
    still tagged.

    Anyway it works great now. As it was holding my AP side (3 of them) of the
    XP rollout
    behind and its not easy to explain the managment here about these things,
    especially my line manager.

    Thanks loads as I have not got any other support elsewhere
    "White Sheep" <> wrote in message
    news:...
    > Any luck?
    >
    >
    > "BlackWoollySheep" <nospam@nowhere> wrote in message
    > news:41442a8c$0$22754$...
    > > On the 3com its a matter of telnetting in and changing the config. There
    > > is
    > > no multi line boot up config like the Cisco.
    > >
    > > I will try this on monday and let you know, thanks!
    > >
    > > "White Sheep" <> wrote in message
    > > news:...
    > >> Hi BlackSheep,
    > >>
    > >> Your Native VLAN (1) on the Aironet will be sending untagged traffic,

    > > while
    > >> you non native VLAN (2) will be tagged. You need to configure VLAN 1 on

    > > the
    > >> 3COM to be the Native "ie untagged' VLAN. Here is the a config for a
    > >> Cisco
    > >> connected to an Aironet running Voice in VLAN 305 and data in VLAN 306:
    > >>
    > >> interface FastEthernet0/18
    > >> switchport trunk encapsulation dot1q
    > >> switchport trunk native vlan 306
    > >> switchport trunk allowed vlan 1,305,306,1002-1005
    > >> switchport mode trunk
    > >> spanning-tree portfast
    > >> end
    > >>
    > >> Sorry but I don't know the equivilant in the 3Com world.
    > >> "BlackSheep" <nospam@nowhere> wrote in message
    > >> news:4140ce2b$0$22756$...
    > >> > Hi,
    > >> >
    > >> > I am having some strange problems with a Cisco Aironet 1200. I have

    set
    > > up
    > >> > 2
    > >> > VLANs
    > >> > (as config following). This is then connected by wire to a tagged

    > > (trunked
    > >> > etc.)
    > >> > port on a 3Com 4400 switch. The problem is that I cannot connect to

    the
    > >> > Access Point when
    > >> > connected to the tagged/trunked port. I can connect to the AP with an
    > >> > untagged port ok
    > >> > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    > >> > functionality
    > >> > then.
    > >> >
    > >> > The 3com switch has one port (tagged) as a member of both VLAN 1 and

    2,
    > > in
    > >> > which the AP
    > >> > would be plugged into.
    > >> >
    > >> > Im scratching my head on this, I have tried setting up the AP with

    GUI,
    > >> > CLI
    > >> > a few times
    > >> > after a complete reset. Still cannot work out, will look at again

    > > tommorow
    > >> > but any help
    > >> > or suggestions would be greatly appreciated.
    > >> >
    > >> > Dave.
    > >> >
    > >> > -------------------------------
    > >> >
    > >> > Cisco config:
    > >> >
    > >> > !
    > >> > version 12.2
    > >> > no service pad
    > >> > service timestamps debug datetime msec
    > >> > service timestamps log datetime msec
    > >> > service password-encryption
    > >> > !
    > >> > hostname Aironet1
    > >> > !
    > >> > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    > >> > !
    > >> > username admin privilege 15 password 7
    > >> > 1413110752577E
    > >> > ip subnet-zero
    > >> > !
    > >> > !
    > >> > bridge irb
    > >> > !
    > >> > !
    > >> > interface Dot11Radio0
    > >> > no ip address
    > >> > no ip route-cache
    > >> > !
    > >> > ssid MyWLAN_SSID_Lan1
    > >> > vlan 2
    > >> > !
    > >> > ssid MyWLAN_SSID_Lan2
    > >> > vlan 1
    > >> > !
    > >> > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    > >> > rts threshold 2312
    > >> > station-role root
    > >> > !
    > >> > interface Dot11Radio0.1
    > >> > encapsulation dot1Q 1 native
    > >> > no ip route-cache
    > >> > bridge-group 1
    > >> > bridge-group 1 subscriber-loop-control
    > >> > bridge-group 1 block-unknown-source
    > >> > no bridge-group 1 source-learning
    > >> > no bridge-group 1 unicast-flooding
    > >> > bridge-group 1 spanning-disabled
    > >> > !
    > >> > interface Dot11Radio0.2
    > >> > encapsulation dot1Q 2
    > >> > no ip route-cache
    > >> > !
    > >> > interface FastEthernet0
    > >> > no ip address
    > >> > no ip route-cache
    > >> > duplex auto
    > >> > speed auto
    > >> > !
    > >> > interface FastEthernet0.1
    > >> > encapsulation dot1Q 1 native
    > >> > no ip route-cache
    > >> > bridge-group 1
    > >> > no bridge-group 1 source-learning
    > >> > bridge-group 1 spanning-disabled
    > >> > !
    > >> > interface FastEthernet0.2
    > >> > encapsulation dot1Q 2
    > >> > no ip route-cache
    > >> > !
    > >> > interface BVI1
    > >> > ip address 10.10.10.5 255.255.255.0
    > >> > no ip route-cache
    > >> > !
    > >> > ip http server
    > >> > ip http help-path
    > >> >

    > >

    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    > >> > ip radius source-interface BVI1
    > >> > bridge 1 route ip
    > >> > !
    > >> > !
    > >> > line con 0
    > >> > line vty 0 4
    > >> > login local
    > >> > line vty 5 15
    > >> > login
    > >> > !
    > >> > end
    > >> >
    > >> > ------
    > >> >
    > >> >
    > >>
    > >>

    > >
    > >

    >
    >
    BlackWoollySheep, Sep 13, 2004
    #10
  11. BlackSheep

    White Sheep Guest

    Glad to help.

    It important to remember that Cisco deems the native vlan a non-trunk vlan.
    In other words there is no 802.1Q header placed onto packets in the native
    vlan so if the switch is expecting traffic in vlan 1 to be tagged it would
    never see it.

    Cheers,

    Greg.


    "BlackWoollySheep" <nospam@nowhere> wrote in message
    news:4145d1d8$0$22748$...
    > Tryed it today and success!!!
    >
    > Now according to my thinking, if a packet is tagged for a VLAN then it
    > should
    > go to the correct one as the Cisco has both VLANs 802.1q tagged and so did
    > the 3com that "you would of thought" (or at least me!) that would of been
    > ok!
    >
    > So I dropped the VLAN1 native port out of the tagged state and VLAN2 is
    > still tagged.
    >
    > Anyway it works great now. As it was holding my AP side (3 of them) of the
    > XP rollout
    > behind and its not easy to explain the managment here about these things,
    > especially my line manager.
    >
    > Thanks loads as I have not got any other support elsewhere
    > "White Sheep" <> wrote in message
    > news:...
    >> Any luck?
    >>
    >>
    >> "BlackWoollySheep" <nospam@nowhere> wrote in message
    >> news:41442a8c$0$22754$...
    >> > On the 3com its a matter of telnetting in and changing the config.
    >> > There
    >> > is
    >> > no multi line boot up config like the Cisco.
    >> >
    >> > I will try this on monday and let you know, thanks!
    >> >
    >> > "White Sheep" <> wrote in message
    >> > news:...
    >> >> Hi BlackSheep,
    >> >>
    >> >> Your Native VLAN (1) on the Aironet will be sending untagged traffic,
    >> > while
    >> >> you non native VLAN (2) will be tagged. You need to configure VLAN 1
    >> >> on
    >> > the
    >> >> 3COM to be the Native "ie untagged' VLAN. Here is the a config for a
    >> >> Cisco
    >> >> connected to an Aironet running Voice in VLAN 305 and data in VLAN
    >> >> 306:
    >> >>
    >> >> interface FastEthernet0/18
    >> >> switchport trunk encapsulation dot1q
    >> >> switchport trunk native vlan 306
    >> >> switchport trunk allowed vlan 1,305,306,1002-1005
    >> >> switchport mode trunk
    >> >> spanning-tree portfast
    >> >> end
    >> >>
    >> >> Sorry but I don't know the equivilant in the 3Com world.
    >> >> "BlackSheep" <nospam@nowhere> wrote in message
    >> >> news:4140ce2b$0$22756$...
    >> >> > Hi,
    >> >> >
    >> >> > I am having some strange problems with a Cisco Aironet 1200. I have

    > set
    >> > up
    >> >> > 2
    >> >> > VLANs
    >> >> > (as config following). This is then connected by wire to a tagged
    >> > (trunked
    >> >> > etc.)
    >> >> > port on a 3Com 4400 switch. The problem is that I cannot connect to

    > the
    >> >> > Access Point when
    >> >> > connected to the tagged/trunked port. I can connect to the AP with
    >> >> > an
    >> >> > untagged port ok
    >> >> > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    >> >> > functionality
    >> >> > then.
    >> >> >
    >> >> > The 3com switch has one port (tagged) as a member of both VLAN 1 and

    > 2,
    >> > in
    >> >> > which the AP
    >> >> > would be plugged into.
    >> >> >
    >> >> > Im scratching my head on this, I have tried setting up the AP with

    > GUI,
    >> >> > CLI
    >> >> > a few times
    >> >> > after a complete reset. Still cannot work out, will look at again
    >> > tommorow
    >> >> > but any help
    >> >> > or suggestions would be greatly appreciated.
    >> >> >
    >> >> > Dave.
    >> >> >
    >> >> > -------------------------------
    >> >> >
    >> >> > Cisco config:
    >> >> >
    >> >> > !
    >> >> > version 12.2
    >> >> > no service pad
    >> >> > service timestamps debug datetime msec
    >> >> > service timestamps log datetime msec
    >> >> > service password-encryption
    >> >> > !
    >> >> > hostname Aironet1
    >> >> > !
    >> >> > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    >> >> > !
    >> >> > username admin privilege 15 password 7
    >> >> > 1413110752577E
    >> >> > ip subnet-zero
    >> >> > !
    >> >> > !
    >> >> > bridge irb
    >> >> > !
    >> >> > !
    >> >> > interface Dot11Radio0
    >> >> > no ip address
    >> >> > no ip route-cache
    >> >> > !
    >> >> > ssid MyWLAN_SSID_Lan1
    >> >> > vlan 2
    >> >> > !
    >> >> > ssid MyWLAN_SSID_Lan2
    >> >> > vlan 1
    >> >> > !
    >> >> > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    >> >> > rts threshold 2312
    >> >> > station-role root
    >> >> > !
    >> >> > interface Dot11Radio0.1
    >> >> > encapsulation dot1Q 1 native
    >> >> > no ip route-cache
    >> >> > bridge-group 1
    >> >> > bridge-group 1 subscriber-loop-control
    >> >> > bridge-group 1 block-unknown-source
    >> >> > no bridge-group 1 source-learning
    >> >> > no bridge-group 1 unicast-flooding
    >> >> > bridge-group 1 spanning-disabled
    >> >> > !
    >> >> > interface Dot11Radio0.2
    >> >> > encapsulation dot1Q 2
    >> >> > no ip route-cache
    >> >> > !
    >> >> > interface FastEthernet0
    >> >> > no ip address
    >> >> > no ip route-cache
    >> >> > duplex auto
    >> >> > speed auto
    >> >> > !
    >> >> > interface FastEthernet0.1
    >> >> > encapsulation dot1Q 1 native
    >> >> > no ip route-cache
    >> >> > bridge-group 1
    >> >> > no bridge-group 1 source-learning
    >> >> > bridge-group 1 spanning-disabled
    >> >> > !
    >> >> > interface FastEthernet0.2
    >> >> > encapsulation dot1Q 2
    >> >> > no ip route-cache
    >> >> > !
    >> >> > interface BVI1
    >> >> > ip address 10.10.10.5 255.255.255.0
    >> >> > no ip route-cache
    >> >> > !
    >> >> > ip http server
    >> >> > ip http help-path
    >> >> >
    >> >

    > http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    >> >> > ip radius source-interface BVI1
    >> >> > bridge 1 route ip
    >> >> > !
    >> >> > !
    >> >> > line con 0
    >> >> > line vty 0 4
    >> >> > login local
    >> >> > line vty 5 15
    >> >> > login
    >> >> > !
    >> >> > end
    >> >> >
    >> >> > ------
    >> >> >
    >> >> >
    >> >>
    >> >>
    >> >
    >> >

    >>
    >>

    >
    >
    White Sheep, Sep 13, 2004
    #11
  12. To be honest I do not have much experience with Segmenting devices with
    VLANs. Up to now I have
    only used switch to switch configs (3com) and they are happy to go tagged to
    tagged. This is
    what threw me!! I have setup a few Cisco devices but not VLANs. Nothing in
    the CCNA about this
    I remember either. So I learned something new! Thanks again :)


    "White Sheep" <> wrote in message
    news:...
    > Glad to help.
    >
    > It important to remember that Cisco deems the native vlan a non-trunk

    vlan.
    > In other words there is no 802.1Q header placed onto packets in the native
    > vlan so if the switch is expecting traffic in vlan 1 to be tagged it would
    > never see it.
    >
    > Cheers,
    >
    > Greg.
    >
    >
    > "BlackWoollySheep" <nospam@nowhere> wrote in message
    > news:4145d1d8$0$22748$...
    > > Tryed it today and success!!!
    > >
    > > Now according to my thinking, if a packet is tagged for a VLAN then it
    > > should
    > > go to the correct one as the Cisco has both VLANs 802.1q tagged and so

    did
    > > the 3com that "you would of thought" (or at least me!) that would of

    been
    > > ok!
    > >
    > > So I dropped the VLAN1 native port out of the tagged state and VLAN2 is
    > > still tagged.
    > >
    > > Anyway it works great now. As it was holding my AP side (3 of them) of

    the
    > > XP rollout
    > > behind and its not easy to explain the managment here about these

    things,
    > > especially my line manager.
    > >
    > > Thanks loads as I have not got any other support elsewhere
    > > "White Sheep" <> wrote in message
    > > news:...
    > >> Any luck?
    > >>
    > >>
    > >> "BlackWoollySheep" <nospam@nowhere> wrote in message
    > >> news:41442a8c$0$22754$...
    > >> > On the 3com its a matter of telnetting in and changing the config.
    > >> > There
    > >> > is
    > >> > no multi line boot up config like the Cisco.
    > >> >
    > >> > I will try this on monday and let you know, thanks!
    > >> >
    > >> > "White Sheep" <> wrote in message
    > >> > news:...
    > >> >> Hi BlackSheep,
    > >> >>
    > >> >> Your Native VLAN (1) on the Aironet will be sending untagged

    traffic,
    > >> > while
    > >> >> you non native VLAN (2) will be tagged. You need to configure VLAN 1
    > >> >> on
    > >> > the
    > >> >> 3COM to be the Native "ie untagged' VLAN. Here is the a config for a
    > >> >> Cisco
    > >> >> connected to an Aironet running Voice in VLAN 305 and data in VLAN
    > >> >> 306:
    > >> >>
    > >> >> interface FastEthernet0/18
    > >> >> switchport trunk encapsulation dot1q
    > >> >> switchport trunk native vlan 306
    > >> >> switchport trunk allowed vlan 1,305,306,1002-1005
    > >> >> switchport mode trunk
    > >> >> spanning-tree portfast
    > >> >> end
    > >> >>
    > >> >> Sorry but I don't know the equivilant in the 3Com world.
    > >> >> "BlackSheep" <nospam@nowhere> wrote in message
    > >> >> news:4140ce2b$0$22756$...
    > >> >> > Hi,
    > >> >> >
    > >> >> > I am having some strange problems with a Cisco Aironet 1200. I

    have
    > > set
    > >> > up
    > >> >> > 2
    > >> >> > VLANs
    > >> >> > (as config following). This is then connected by wire to a tagged
    > >> > (trunked
    > >> >> > etc.)
    > >> >> > port on a 3Com 4400 switch. The problem is that I cannot connect

    to
    > > the
    > >> >> > Access Point when
    > >> >> > connected to the tagged/trunked port. I can connect to the AP with
    > >> >> > an
    > >> >> > untagged port ok
    > >> >> > (on 10.10.10.5 as in config) but obviously I will not get VLAN
    > >> >> > functionality
    > >> >> > then.
    > >> >> >
    > >> >> > The 3com switch has one port (tagged) as a member of both VLAN 1

    and
    > > 2,
    > >> > in
    > >> >> > which the AP
    > >> >> > would be plugged into.
    > >> >> >
    > >> >> > Im scratching my head on this, I have tried setting up the AP with

    > > GUI,
    > >> >> > CLI
    > >> >> > a few times
    > >> >> > after a complete reset. Still cannot work out, will look at again
    > >> > tommorow
    > >> >> > but any help
    > >> >> > or suggestions would be greatly appreciated.
    > >> >> >
    > >> >> > Dave.
    > >> >> >
    > >> >> > -------------------------------
    > >> >> >
    > >> >> > Cisco config:
    > >> >> >
    > >> >> > !
    > >> >> > version 12.2
    > >> >> > no service pad
    > >> >> > service timestamps debug datetime msec
    > >> >> > service timestamps log datetime msec
    > >> >> > service password-encryption
    > >> >> > !
    > >> >> > hostname Aironet1
    > >> >> > !
    > >> >> > enable secret 5 $1$RkOp$fmNdiNpBz1VUFeOxAzpyY1
    > >> >> > !
    > >> >> > username admin privilege 15 password 7
    > >> >> > 1413110752577E
    > >> >> > ip subnet-zero
    > >> >> > !
    > >> >> > !
    > >> >> > bridge irb
    > >> >> > !
    > >> >> > !
    > >> >> > interface Dot11Radio0
    > >> >> > no ip address
    > >> >> > no ip route-cache
    > >> >> > !
    > >> >> > ssid MyWLAN_SSID_Lan1
    > >> >> > vlan 2
    > >> >> > !
    > >> >> > ssid MyWLAN_SSID_Lan2
    > >> >> > vlan 1
    > >> >> > !
    > >> >> > speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    > >> >> > rts threshold 2312
    > >> >> > station-role root
    > >> >> > !
    > >> >> > interface Dot11Radio0.1
    > >> >> > encapsulation dot1Q 1 native
    > >> >> > no ip route-cache
    > >> >> > bridge-group 1
    > >> >> > bridge-group 1 subscriber-loop-control
    > >> >> > bridge-group 1 block-unknown-source
    > >> >> > no bridge-group 1 source-learning
    > >> >> > no bridge-group 1 unicast-flooding
    > >> >> > bridge-group 1 spanning-disabled
    > >> >> > !
    > >> >> > interface Dot11Radio0.2
    > >> >> > encapsulation dot1Q 2
    > >> >> > no ip route-cache
    > >> >> > !
    > >> >> > interface FastEthernet0
    > >> >> > no ip address
    > >> >> > no ip route-cache
    > >> >> > duplex auto
    > >> >> > speed auto
    > >> >> > !
    > >> >> > interface FastEthernet0.1
    > >> >> > encapsulation dot1Q 1 native
    > >> >> > no ip route-cache
    > >> >> > bridge-group 1
    > >> >> > no bridge-group 1 source-learning
    > >> >> > bridge-group 1 spanning-disabled
    > >> >> > !
    > >> >> > interface FastEthernet0.2
    > >> >> > encapsulation dot1Q 2
    > >> >> > no ip route-cache
    > >> >> > !
    > >> >> > interface BVI1
    > >> >> > ip address 10.10.10.5 255.255.255.0
    > >> >> > no ip route-cache
    > >> >> > !
    > >> >> > ip http server
    > >> >> > ip http help-path
    > >> >> >
    > >> >

    > >

    http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    > >> >> > ip radius source-interface BVI1
    > >> >> > bridge 1 route ip
    > >> >> > !
    > >> >> > !
    > >> >> > line con 0
    > >> >> > line vty 0 4
    > >> >> > login local
    > >> >> > line vty 5 15
    > >> >> > login
    > >> >> > !
    > >> >> > end
    > >> >> >
    > >> >> > ------
    > >> >> >
    > >> >> >
    > >> >>
    > >> >>
    > >> >
    > >> >
    > >>
    > >>

    > >
    > >

    >
    >
    BlackWoollySheep, Sep 14, 2004
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andre Paetzold

    Aironet 1200 and Aironet 1300 compatible?

    Andre Paetzold, Dec 8, 2004, in forum: Cisco
    Replies:
    2
    Views:
    859
    Andre Paetzold
    Dec 9, 2004
  2. Sven Juergensen

    aironet <-> aironet bridging?

    Sven Juergensen, Dec 15, 2004, in forum: Cisco
    Replies:
    1
    Views:
    451
    Walter Roberson
    Dec 16, 2004
  3. Replies:
    2
    Views:
    939
  4. Phil Schuman
    Replies:
    3
    Views:
    909
    stephen
    Sep 4, 2006
  5. Phil Schuman
    Replies:
    3
    Views:
    5,400
    stephen
    Sep 4, 2006
Loading...

Share This Page