Cisco 877W and Demon

Discussion in 'Cisco' started by paulbrownservices@googlemail.com, Nov 22, 2008.

  1. Guest

    Hello

    I have purchased a Cisco 877W, but i cant get the router online at
    all, we have a static ip and have enter all the information for the
    router, but nothing, my isp is demon, i have asked them and they wont
    help.

    Does any one have any ideas?

    Paul
    , Nov 22, 2008
    #1
    1. Advertising

  2. bod43 Guest

    On Nov 22, 2:39 pm, wrote:
    > Hello
    >
    > I have purchased a Cisco 877W, but i cant get the router online at
    > all, we have a static ip and have enter all the information for the
    > router, but nothing, my isp is demon, i have asked them and they wont
    > help.
    >
    > Does any one have any ideas?
    >
    > Paul


    what is the software version?
    What is happening?

    Is the ATM interface UP.
    Are you getting an IP address on the dialer -
    oh you use static - just let it negotiate.

    If it is workign the CD light and PPP lights on the front
    should be steady.

    flashing CD means ATM not done.

    there have been isues with 850 and 870 ADSL
    software, It was available as a free download but
    las time I looked it was not accessible. You may
    need to change the IOS now.
    Worth a try as it is and also to manually try all of the
    allowed " dsl operating-mode" options if you have trouble
    at the CD light level.

    Here is a reasonable conifg for the UK.
    If demon doesnt like CHAP then you will need to
    change it to PPP (or add it too)
    BT like CHAP and most or all UK ISPs do.

    ! You can paste commands in in a terminal session
    ! avoid doing too many at once.

    ! There is something odd about the order of these
    ! I dont understand it and just put the three
    ! in twice and then its happy.
    bridge 1 protocol ieee
    bridge 1 route ip
    bridge irb



    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.18.25.1
    ip dhcp excluded-address 10.18.25.2
    !
    ip dhcp pool CLIENT
    import all
    network 10.18.25.0 255.255.255.0
    default-router 10.18.25.1
    domain-name whatever.com
    dns-server 1.1.1.1 1.1.1.2 ! put your own here
    !
    !
    ip cef
    !
    !
    bridge irb
    !
    !
    !
    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    !
    interface Dot11Radio0
    no ip address
    !
    encryption mode ciphers tkip
    !
    ssid your-ssid
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 your-wpa-key
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0
    36.0 48.0 54.0
    station-role root
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    bridge-group 1
    !
    interface Dialer0
    ! # I recommend that you negotiated IP
    ! even for fixed one.
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin

    ! ## YOUR ##
    ! # ADSL user and password MUST go here.
    ppp chap hostname ! e.g.
    ppp chap password your-adsl-password
    !
    interface BVI1
    ip address 10.18.25.1 255.255.255.0
    ip nat inside
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ip nat inside source route-map nonat interface Dialer0 overload
    !
    access-list 110 permit ip 10.18.25.0 0.0.0.255 any

    dialer-list 1 protocol ip permit


    route-map nonat permit 10
    match ip address 110
    !
    !
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0

    line vty 0 4
    login
    password fred
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    bod43, Nov 23, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alun Bell

    Cisco 837 and Demon ADSL 2000

    Alun Bell, Nov 26, 2003, in forum: Cisco
    Replies:
    1
    Views:
    628
    Richard Antony Burton
    Nov 27, 2003
  2. DVD Verdict
    Replies:
    0
    Views:
    444
    DVD Verdict
    May 3, 2004
  3. Matthias Scheler

    Bridging Ethernet and WLAN with a Cisco 877W

    Matthias Scheler, Oct 29, 2006, in forum: Cisco
    Replies:
    3
    Views:
    1,929
  4. Colin Heseltine

    Cisco 877 with Demon Broadband - Help

    Colin Heseltine, Mar 29, 2007, in forum: Cisco
    Replies:
    2
    Views:
    1,349
    Ian Wilson
    Mar 30, 2007
  5. Galerio
    Replies:
    11
    Views:
    4,197
    Galerio
    Mar 9, 2009
Loading...

Share This Page