Cisco 877 with Demon Broadband - Help

Discussion in 'Cisco' started by Colin Heseltine, Mar 29, 2007.

  1. I am trying toget a Cisco 877 router working on my Demon B'band connection.
    The Broadband works when I use a BT Voyager 220V so I know the service
    itself is OK. The configuration on the router works quite happily when
    attached to a standard BT B'band connection at another site.

    The ATM0 link comes up and then drops a few moments later. The CD led lights
    up followed by a limited amount of activity on both RXD and TXD leds and
    then the whole cycle appears to repeat itself,

    I am not au fait with debugging as ar as the adsl link goes.

    Can anyone help/advise.

    Many Thanks,


    Config is shown below


    version 12.4

    no service pad

    service timestamps debug uptime

    service timestamps log uptime

    service password-encryption

    !

    hostname nnnnnnnn

    !

    boot-start-marker

    boot-end-marker

    !

    logging buffered 40960 debugging

    enable password password

    !

    no aaa new-model

    !

    resource policy

    !

    ip subnet-zero

    ip cef

    !

    interface ATM0

    no ip address

    no atm ilmi-keepalive

    pvc 0/38

    encapsulation aal5mux ppp dialer

    dialer pool-member 1

    !

    dsl operating-mode auto

    !

    interface FastEthernet0

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface Vlan1

    description #Connection to Home LAN#

    ip address 192.168.n.n 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    ip tcp adjust-mss 1452

    !

    interface Dialer1

    ip address negotiated

    ip nat outside

    ip virtual-reassembly

    encapsulation ppp

    dialer pool 1

    ppp chap hostname

    ppp chap password nnnnnnnn

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 Dialer1

    !

    no ip http server

    no ip http secure-server

    ip nat inside source list 1 interface Dialer1 overload

    !

    access-list 1 permit 192.168.0.0 0.0.0.255

    !

    control-plane

    !

    line con 0

    no modem enable

    line aux 0

    line vty 0

    password nnnnnnn

    login

    line vty 1 4

    login

    !

    scheduler max-task-time 5000

    end
    Colin Heseltine, Mar 29, 2007
    #1
    1. Advertising

  2. Colin Heseltine

    Guest

    On 29 Mar, 23:06, "Colin Heseltine" <> wrote:
    > I am trying toget a Cisco 877 router working on my Demon B'band connection.
    > The Broadband works when I use a BT Voyager 220V so I know the service
    > itself is OK. The configuration on the router works quite happily when
    > attached to a standard BT B'band connection at another site.
    >
    > The ATM0 link comes up and then drops a few moments later. The CD led lights
    > up followed by a limited amount of activity on both RXD and TXD leds and
    > then the whole cycle appears to repeat itself,
    >
    > I am not au fait with debugging as ar as the adsl link goes.
    > interface ATM0
    > no ip address
    > no atm ilmi-keepalive
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > dsl operating-mode auto


    On 877 I have seen various DSL issues (but not
    your one). Worth trying

    int atm 0
    dsl operating-mode {all possibilities one by one}
    ! There are only a few:)

    Worth an IOS software upgrade too if you have
    support.

    Otherwise you may consider:-
    DSL firmware can be downloaded from
    ftp://ftp.cisco.com/pub/access/800/
    Don't worry too much where it says
    the firmware release only supports
    a particular IOS - give it a try anyway.
    , Mar 30, 2007
    #2
    1. Advertising

  3. Colin Heseltine

    Ian Wilson Guest

    Colin Heseltine wrote:
    > I am trying toget a Cisco 877 router working on my Demon B'band connection.
    > The Broadband works when I use a BT Voyager 220V so I know the service
    > itself is OK. The configuration on the router works quite happily when
    > attached to a standard BT B'band connection at another site.
    >
    > The ATM0 link comes up and then drops a few moments later. The CD led lights
    > up followed by a limited amount of activity on both RXD and TXD leds and
    > then the whole cycle appears to repeat itself,
    >
    > I am not au fait with debugging as ar as the adsl link goes.


    Neither am I but this might help, if you haven't already read it.
    <http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a8da.shtml>

    >
    >
    > Config is shown below
    >

    ....
    >
    > interface ATM0
    > no ip address
    > no atm ilmi-keepalive
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > dsl operating-mode auto
    > !

    ....
    > !
    > interface Dialer1
    > ip address negotiated
    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > dialer pool 1
    > ppp chap hostname
    > ppp chap password nnnnnnnn
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1


    I'm not using Demon but my 877 has a slightly different configuration. I
    have an ATM0.1 (sub) interface. I'd guess it isn't a significant
    difference but you might try it

    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !

    ....

    interface Dialer0
    ip address negotiated
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip inspect DEFAULT100 out
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname xxxxxxxxxxxxxxxx
    ppp chap password 7 xxxxxxxxxxxxxxxxxxxx
    !

    You'd obviously need to prune out the ACL references.
    The only other significant difference might be the omission of the 'ppp
    authentication chap callin' line?

    You could also try saving your current config somewhere safe (e.g. TFTP
    server) and using SDM to generate a new config.

    Caveat: I'm new to Cisco and not an expert.
    Ian Wilson, Mar 30, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alun Bell

    Cisco 837 and Demon ADSL 2000

    Alun Bell, Nov 26, 2003, in forum: Cisco
    Replies:
    1
    Views:
    635
    Richard Antony Burton
    Nov 27, 2003
  2. Adam Richards

    Accessing demon newsgroups with NTL Broadband???

    Adam Richards, Jan 6, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    614
    Spider
    Jan 7, 2004
  3. kls4861

    Need Help z-demon adware trojan removal!!

    kls4861, Jan 31, 2005, in forum: Computer Support
    Replies:
    7
    Views:
    545
    owldo @ PAX
    Feb 3, 2005
  4. kls4861

    Need Help z-demon adware trojan removal!!

    kls4861, Jan 31, 2005, in forum: Computer Support
    Replies:
    1
    Views:
    401
    kls4861
    Jan 31, 2005
  5. Cisco 877W and Demon

    , Nov 22, 2008, in forum: Cisco
    Replies:
    1
    Views:
    684
    bod43
    Nov 23, 2008
Loading...

Share This Page