Cisco 877 with 2 PVC's Data and voice but no internet from voice network

Discussion in 'Cisco' started by messaana, Apr 26, 2012.

  1. messaana

    messaana

    Joined:
    Apr 26, 2012
    Messages:
    3
    I have been trying to get this to work but for some reason I am unable to make this work.


    I have 2 PVC's 1 for internet use and 1 for a voice network.

    The first pvc with internet connection works and the second pvc for voice works. This is no problem.

    I have made 2 vlans 1 for internet and 1 for voice. This also works just fine.


    The problem that I am facing is that I need to have a route from vlan2 to vlan1 to gain access to DNS and a dhcp option 66 to load the config from 46.44.163.254 for the voip phones.

    There is no way to route this trough the voice pvc due to the fact that this pvc is only hooked up to the voice network an has no external gateway to connect to the internet to do dns lookup ect.

    So I have to make a route from vlan 2 over vlan 1 to gain acces to the internet.

    But I can see where I am going wrong.


    IOS version : Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(15)T15


    Extra vlan info from vlan database :
    VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500
    Translational Bridged VLAN: 1002
    Translational Bridged VLAN: 1003

    VLAN ISL Id: 2
    Name: VLAN0002
    Media Type: Ethernet
    VLAN 802.10 Id: 100002
    State: Operational
    MTU: 1500



    Config :


    Current configuration : 5349 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service sequence-numbers
    !
    hostname a router
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200
    logging console critical
    !
    no aaa new-model
    clock timezone GMT 1
    clock summer-time GMT date Apr 26 2012 1:00 Oct 26 2035 10:37
    !
    !
    dot11 syslog
    no ip source-route
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.6.1 192.168.6.49
    ip dhcp excluded-address 192.168.101.1 192.168.101.49
    !
    ip dhcp pool DATA
    network 192.168.101.0 255.255.255.0
    default-router 192.168.101.254
    dns-server 213.144.235.254
    !
    ip dhcp pool VOICE
    network 192.168.6.0 255.255.255.0
    default-router 192.168.6.254
    dns-server 213.144.235.1
    option 66 ascii "http://46.44.163.254/dms/aastra"
    !
    !
    ip vrf data
    rd 65535:1
    route-target export 65535:1
    route-target import 65535:1
    !
    ip vrf voice
    rd 65535:2
    route-target export 65535:2
    route-target import 65535:2
    !
    no ip bootp server
    no ip domain lookup
    ip domain name terberg.eu
    ip name-server 213.144.235.1
    ip name-server 213.144.235.2
    !
    multilink bundle-name authenticated
    !
    !
    username justme privilege 15 secret 010101010101010101

    !
    !
    archive
    log config
    hidekeys
    !
    !
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description PVC1
    pvc 0/33
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface ATM0.2 point-to-point
    description PVC2
    pvc 0/34
    vbr-rt 192 192 1
    encapsulation aal5mux ppp dialer
    dialer pool-member 2
    !
    !
    interface FastEthernet0
    ip vrf forwarding data
    !
    interface FastEthernet1
    switchport access vlan 2
    !
    interface FastEthernet2
    switchport mode trunk
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    shutdown
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    !
    interface Vlan1
    description DATA_VLAN
    ip vrf forwarding data
    ip address 192.168.101.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    interface Vlan2
    description VOICE_VLAN
    ip vrf forwarding voice
    ip address 192.168.6.254 255.255.255.0
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    interface Dialer1
    ip vrf forwarding data
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username blabla password 7 01010101010101010
    !
    interface Dialer2
    ip vrf forwarding voice
    ip unnumbered Vlan2
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 2
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username blabla password 01010101010101010
    !
    ip forward-protocol nd
    ip route vrf data 0.0.0.0 0.0.0.0 Dialer1
    ip route vrf voice 0.0.0.0 0.0.0.0 Dialer2
    ip route vrf voice 46.44.163.0 255.255.255.0 Dialer1 :trytofly:
    !
    !
    no ip http server
    ip http access-class 23
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip dns view vrf data default
    no ip nat service sip tcp port 5060
    no ip nat service sip udp port 5060
    ip nat inside source list 101 interface Dialer1 vrf data overload
    ip nat inside source static tcp 192.168.101.40 3389 interface Dialer1 3389
    !
    logging trap debugging
    access-list 23 permit 192.168.101.0 0.0.0.X
    access-list 23 permit 192.168.6.0 0.0.0.X
    access-list 23 permit 83.X.X.X 0.0.0.X
    access-list 23 permit 82.X.X.X 0.0.0.X
    access-list 23 permit 84.X.X.0 0.0.0.X
    access-list 23 permit 172.X.X.0.X.0.0.X
    access-list 23 permit 213.X.X.X 0.0.X.X
    access-list 23 permit 92.X.X.X 0.0.0.X
    access-list 101 permit ip 192.168.101.0 0.0.0.255 any
    access-list 102 permit tcp any host 192.168.101.40 eq 3389
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    no cdp run
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    login local
    no modem enable
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    !
    scheduler max-task-time 5000
    end
     
    messaana, Apr 26, 2012
    #1
    1. Advertising

  2. messaana

    messaana

    Joined:
    Apr 26, 2012
    Messages:
    3
    Wow no one has any idea ?
     
    messaana, May 4, 2012
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sven Holm
    Replies:
    0
    Views:
    1,531
    Sven Holm
    Sep 7, 2003
  2. Sven Holm
    Replies:
    0
    Views:
    1,447
    Sven Holm
    Sep 9, 2003
  3. Sven Holm
    Replies:
    5
    Views:
    4,527
    Arnold Ligtvoet
    Sep 12, 2003
  4. Peter Danes
    Replies:
    1
    Views:
    993
  5. GT
    Replies:
    0
    Views:
    1,570
Loading...

Share This Page