Cisco 877 ADSL problem connecting

Discussion in 'Hardware' started by gastonp50, Mar 30, 2008.

  1. gastonp50

    gastonp50

    Joined:
    Mar 30, 2008
    Messages:
    1
    Hello,

    I’ve been trying to configure the Cisco 877 ADSL for access to Internet . The fact is that, although I’ve been able to connect it to my ISP, the router cannot connect after it is rebooted. I haven’t configured a Cisco router before and so I would be grateful if someone could help me find out what I’ve been doing wrong.

    The problem is the following. The only way I’m able to connect to Internet is starting with a blank startup-config and using the Security Device Manager (SDM). However, when I copy the configuration into the NVRAM using the command-line "write memory" or "copy running-config nvram:" in a Hyper Terminal session and I reboot, the router appears to be unable to establish a physical connection to my ISP. The router keeps hanging-up and trying again while the ADSL CD led keeps blinking. There is also an intermittent beep sound indicating the router hanging-up.

    Specifically what I do is the following. I start a Hyper Terminal session with a blank startup-config. At the prompt “Router>” I use the command-lines "enable", "configure terminal" and "ip http server" to be able to access the SDM in the router. And finally, I give the router an IP address in the same subnet or LAN where my computer is connected by using the command-line "interface vlan1 192.168.01 255.255.255.0". Now I’m able to configure the router by using the http protocol following the menu in the SDM. The following is the output obtained by the command-line show running-config:

    Building configuration...

    Current configuration : 1387 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxxxxxxxx@xxxxxxxx.xxx
    ppp chap password 0 xxxxxxxx
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.0.0 0.0.0.255
    dialer-list 1 protocol ip permit
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    !
    scheduler max-task-time 5000
    !
    webvpn context Default_context
    ssl authenticate verify all
    !
    no inservice
    !
    end

    This works fine as long as I don’t reboot the router as explained above.

    On the other hand, when I enter all the above commands manually using the command-line in a Hyper Terminal session instead of using the SDM, there is an error that it didn’t appear before. Each time I enter the command-line "ip nat inside" and "ip nat outside" for the interfaces "vlan1" and "dialer0" respectively, there is the following error: “NAT: Error activating CNBAR on the interface vlan1” and “NAT: Error activating CNBAR on the interface dialer0" corresponding to the interfaces "vlan1" and "dialer0” respectively. This error appears when rebooting the router as well. However I’ve noticed that it doesn’t appear when using the SDM and checking the output obtained in the Hyper Terminal session. I wonder whether this error is relevant or can give any clue to resolve the problem.

    In conclusion, the fact is that the router works since it is able to connect to my broadband account …at least when using the SDM and starting from a blank startup-config. This suggests this could just be a trivial problem of configuration. Therefore I hope somebody could help me to find out a solution for the rebooting-internet-connection problem.

    Best regards,
    gapadi
     
    gastonp50, Mar 30, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jamie

    877 adsl capacity

    jamie, Apr 2, 2006, in forum: Cisco
    Replies:
    2
    Views:
    625
    jamie
    Apr 3, 2006
  2. nordberg

    Cisco 877 ADSL/Wifi

    nordberg, May 16, 2006, in forum: Cisco
    Replies:
    1
    Views:
    2,302
    nordberg
    May 17, 2006
  3. nordberg

    Cisco 877 ADSL Router/WiFi

    nordberg, Jun 6, 2006, in forum: Cisco
    Replies:
    1
    Views:
    1,107
    MCScrapE
    Jun 6, 2006
  4. MK
    Replies:
    2
    Views:
    6,891
  5. Supersleuth

    877 ADSL

    Supersleuth, Oct 6, 2011, in forum: Cisco
    Replies:
    3
    Views:
    1,675
    Stephen Worthington
    Oct 10, 2011
Loading...

Share This Page