cisco 871 as pptp client

Discussion in 'Cisco' started by ceedjay, Sep 1, 2013.

  1. ceedjay

    ceedjay

    Joined:
    Sep 1, 2013
    Messages:
    1
    Hi i am a newbi on cisco and IOS. I have managed to set up a pptp client in my cisco 871 and the connection works, i can ping from the serial terminal.

    How can i make the dialer interface to be routed to physical ports FE0-3? I want to connect a computer to the cisco router in any free port and be able to access adresses on my local network behind the pptp server. The server works fine, i can connect to it from internet side with my windows 7 computer.

    Here is my conf:

    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service internal
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    aaa new-model
    !
    !
    aaa authentication login default none
    aaa authentication enable default none
    !
    !
    aaa session-id common
    !
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    !
    vpdn enable
    !
    vpdn-group 10
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip pptpserveraddress
    ip pmtu
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    ip address dhcp
    duplex auto
    speed auto
    !
    interface Vlan1
    ip address 192.168.1.10 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1400
    ip nat outside
    no ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1350
    ip policy route-map clear-df-bit
    load-interval 30
    dialer in-band
    dialer idle-timeout 0
    dialer string 123321
    dialer vpdn
    dialer-group 10
    no keepalive
    no cdp enable
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp chap hostname pptp-username
    ppp chap password 0 pptp-password
    !
    interface Dialer1
    no ip address
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 0.0.0.0 0.0.0.0 Dialer1 220
    ip route pptpserveraddress 255.255.255.255 Dialer1
    no ip http server
    no ip http secure-server
    !
    !
    ip access-list extended PAT-LIST
    deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
    permit ip 10.0.0.0 0.255.255.255 any
    ip access-list extended clear-df-bit
    permit ip any any
    !
    dialer-list 10 protocol ip permit
    !
    !
    !
    route-map clear-df-bit permit 10
    match ip address clear-df-bit
    set ip df 0
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    !
    scheduler max-task-time 5000
    end

    please help :)
    ceedjay, Sep 1, 2013
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Caruso
    Replies:
    0
    Views:
    542
    John Caruso
    Apr 7, 2004
  2. John Caruso
    Replies:
    0
    Views:
    652
    John Caruso
    Apr 7, 2004
  3. Matthew
    Replies:
    0
    Views:
    3,950
    Matthew
    May 19, 2004
  4. Charles de Lorena

    Newbie: Cisco 2801 as PPTP CLient

    Charles de Lorena, Jan 24, 2005, in forum: Cisco
    Replies:
    5
    Views:
    11,117
    Daniel Prinsloo - www.CherryFive.com
    Jan 26, 2005
  5. Elia Spadoni
    Replies:
    15
    Views:
    2,844
Loading...

Share This Page