cisco 837, static ip's, and routing.

Discussion in 'Cisco' started by junior, Aug 18, 2005.

  1. junior

    junior Guest

    Hey guys,

    Can someone help me with a quick cisco 837 problem i'm having with my 837?

    My isp has given me an 8 ip block. For arguments sake we say this is the :
    80.229.1.8 network. (real ip's not shown for security)

    I've assigned 80.229.1.9 to the 837 router and ethernet port using the the
    'ip unnumbered' command to allow the dialer interface to "borrow" the IP
    address of the ethernet already configured on the router.

    I've got my PC on the network with the IP: 80.229.1.10, however, whilst I
    can surf the net, I cannot access the PC from across the internet.

    I guess I may be required to implement an access list, or add some static
    routes to the router?

    Can someone please advise me.

    I've pasted my configuration below:

    Any help appreciated, thanks in advance.


    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    enable password topsecret
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip ips po max-events 100
    no ftp-server write-enable
    !
    interface Ethernet0
    ip address 80.229.1.9 255.255.255.248
    no ip mroute-cache
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip mroute-cache
    atm vc-per-vp 64
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    interface Dialer1
    ip unnumbered Ethernet0
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname
    ppp chap password 0 plaintextpassword
    ppp ipcp dns request
    ppp ipcp wins request
    no routing dynamic
    hold-queue 224 in
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    no ip http secure-server
    !

    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    line con 0
    exec-timeout 120 0
    no modem enable
    transport preferred all
    transport output all
    stopbits 1
    line aux 0
    transport preferred all
    transport output none
    line vty 0 4
    exec-timeout 120 0
    password topsecret
    login
    transport preferred all
    transport input all
    transport output all
    !
    scheduler max-task-time 5000
    end
     
    junior, Aug 18, 2005
    #1
    1. Advertising

  2. junior

    Guest

    I don't have any experience with the 837 series, but from a routing
    perspective I would say you are OK. As long as you have a static route
    to your provider and they are advertising your block to the Internet
    (which they must be doing since you can surf), you should be OK. One
    question I have though is about the dialer interface. Have you already
    established the Internet connection with your PC when you are trying to
    access it? If not, traffic from the Internet is probably not going to
    bring up the interface. Just a thought. HTH.

    Robert
     
    , Aug 19, 2005
    #2
    1. Advertising

  3. junior

    Guest

    I'm posting from another account, however can I say that the problem
    remains as was, and that is that I am unable to connect to anything
    past the router, i.e. my PC which has a real IP address. The PC has
    full internet connectivity!
     
    , Aug 19, 2005
    #3
  4. junior

    Chris Guest

    "junior" <> wrote in message
    news:430511aa$0$22922$...
    > Hey guys,
    >
    > Can someone help me with a quick cisco 837 problem i'm having with my 837?
    >
    > My isp has given me an 8 ip block. For arguments sake we say this is the :
    > 80.229.1.8 network. (real ip's not shown for security)
    >
    > I've assigned 80.229.1.9 to the 837 router and ethernet port using the the
    > 'ip unnumbered' command to allow the dialer interface to "borrow" the IP
    > address of the ethernet already configured on the router.
    >
    > I've got my PC on the network with the IP: 80.229.1.10, however, whilst I
    > can surf the net, I cannot access the PC from across the internet.
    >
    > I guess I may be required to implement an access list, or add some static
    > routes to the router?


    The config looks okay and must be if you can access the internet from the PC
    behind the router. I doubt that the problem lies with the router and is more
    likely to be the PC behind it. I preume that you are running a firewall of
    some kind? How are you trying to access the PC? What services?

    Chris.
     
    Chris, Aug 19, 2005
    #4
  5. junior

    junior Guest

    My apologies Rob and Chris.

    Thanks for verifying my configuration! I booted into linux instead, and it
    was pingable from the net - and after investigating what could be causing
    the problem, I finally diagnosed my 'Cisco VPN client' as the problem...
    it's stateful firewall was on!.

    ps. for those who don't know, the cisco vpn client is a piece of software
    used to connected to a vpn server/router - you don't need any hardware
    locally for this to work.

    Cheers guys :)
     
    junior, Aug 19, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Confused

    Cisco 837-837 VPN

    Confused, Jul 9, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,834
    Confused
    Jul 9, 2003
  2. Suppa Lamah
    Replies:
    8
    Views:
    1,687
  3. Anthony
    Replies:
    7
    Views:
    973
  4. Alistair Young
    Replies:
    2
    Views:
    4,591
  5. Replies:
    4
    Views:
    4,251
Loading...

Share This Page