Cisco 837 Router

Discussion in 'Cisco' started by Wobble Wobble, Apr 6, 2006.

  1. I have a Cisco 837 Router that is second hand and for the last 2 weeks
    I've been beating myself to death trying to comprehend how to setup
    this router. I have a Adsl line with a working SMC, I know all my
    settings to get the router to talk to the net etc, but as to how I
    actually get to talk to the thing I'm lost.

    I have a console cable and regurlary take trips into the world of Cisco
    IOS or whatever its called. Typing in instructions as per Cisco site,
    manuals, pdf's and anything else I can find, but to get the thing to
    answer to 192.168.2.200, or even return a ping let alone connect to the
    net!

    Help please someone. I'm looking for help in understanding where I've
    gone wrong. I have reset it several times, I'm fairly ok on getting
    around its menus, layers, but am damned if I can get a sucessfull
    result!

    Anyone there help it will be much appriciated.

    Wobble
     
    Wobble Wobble, Apr 6, 2006
    #1
    1. Advertising

  2. Wobble Wobble

    Merv Guest

    the first step is to get Ethernet interface and DHCP server working


    So assuming an IP subnet of 192.168.1.0/24 the required config would
    be:


    ip dhcp excluded-address 192.168.1.1 192.168.1.1

    ip dhcp pool CLIENT_DHCP_POOL
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1

    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    no shut

    Your PC should then be able to acquire an IP address via DHCP and you
    should be able to ping the router's IP address 192.168.1.1
     
    Merv, Apr 6, 2006
    #2
    1. Advertising

  3. First off, thanks for the reply, about some things I know but this has
    me pulling out my hair as I'm afraid I have a little knowledge about
    not a lot on this subject.


    Not yet I'm afraid.

    First off a few ips are fixed in my network.
    SMC is 192.168.2.250
    main pc is 192.168.2.25
    Server 1 is 192.168.2.2
    Server 2 is 192.168.2.3 ( home network for playing/ learning on)

    I tried the setup as in your reply but didn't get a dhcp working, tried
    after a reboot of router and again same thing. I've deleted/ reset the
    router a few times,

    What follows is from reboot of router and a running-config from the
    router, and I thought Microsoft IPSec was tough.

    Wobble

    System Bootstrap, Version 12.2(8r)YN,
    (c) of the Commercial Computer Software - Restricted###################
    [OK]
    TAC Support: http://w
    Rights clause at FAR sec. 52.227-19 and subparagraph
    Copyright (c) 2002 by cisco Systems, Inc.
    (c) (1) (ii) of the Rights in Technical Data and Computer: 23-127)
    platform with 49152 Kbytes of main memory
    Software clause at DFARS sec. 252.227-7013.forth in subparagraph

    program load c

    cisco Systems, Inc., size: 0x5e428ccial Computer
    170 West Tasman Drive

    San Jose, C

    TAC Support: http://www.cisco.com/tacn, or disclosure by the Government
    is
    Copyright (c) 1986-2003 by cisco Systems, Inc.
    subject to restrictions as set forth in
    Compiled Thu 25-Sep-03 10:33 by ealyon
    (c) of the C
    Image text-base: 0x800131E8, data-base: 0x80B928E0

    Rights c


    This product contains cryptographic features and is subject to United

    (c) (1) (ii) of the Rights in Technical Data
    States and local country laws governing import, export, transfer and
    Software clause at DFARS sec. 252.227-7013.

    A summary of U.S. laws governing Cisco cryptographic products may be
    found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    .

    CISCO C837 (MPC857DSL) processor (revision 0x400) with 44237K/4915K
    bytes of mem
    ory.
    Processor board ID AMB08070N2N (63668408), with hardware revision 0000
    CPU rev number 7
    Bridging software.
    1 Ethernet/IEEE 802.3 interface(s)
    4 FastEthernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    10240K bytes of processor board System flash partition 1 (Read/Write)
    2048K bytes of processor board System flash partition 2 (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)


    --- System Configuration Dialog ---

    Would you like to enter the initial configuration dialog? [yes/no]:

    After a reboot this is what I see.


    And this is from a Show running-config

    show running-config
    Building configuration...

    Current configuration : 920 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    --More--  partition flash 2 10 2
    !
    !
    !
    !
    interface Ethernet0
    no ip address
    shutdown
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface FastEthernet1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet2
    --More--   no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip classless
    no ip http server
    no ip http secure-server
    !
    !
    line con 0
    --More--   no modem enable
    line aux 0
    line vty 0 4
    !
    scheduler max-task-time 5000
    !
    end

    Router#
     
    Wobble Wobble, Apr 6, 2006
    #3
  4. Wobble Wobble

    Merv Guest

    you might also want to try giving the Cisco SDM (web-based) config
    tools a spin - see www.cisco.com/go/sdm
     
    Merv, Apr 6, 2006
    #4
  5. Wobble Wobble

    Alni Guest

    Bonjour,

    Dans son message précédent, Merv a écrit :
    > you might also want to try giving the Cisco SDM (web-based) config
    > tools a spin - see www.cisco.com/go/sdm


    I'm afraid that the SDM doesn't work with 827 series.
    (I got a 827)

    <copy>
    Cisco SDM supports a wide range of Cisco IOS Software releases and is
    available free of charge on Cisco router models from Cisco 830 Series
    to Cisco 7301. It ships preinstalled on all new Cisco 850 Series, Cisco
    870 Series, Cisco 1800 Series, Cisco 2800 Series, and Cisco 3800 Series
    integrated services routers.
    </copy>

    --
    Alni
     
    Alni, Apr 6, 2006
    #5
  6. I've tried that once or twice as well!

    I'll relate what I've done, maybe you can see a flaw in that and tell
    me where I'm wrong? Already found the Cat 5 cable has popped out and
    though I was cured!

    I've done this

    Erase Startup-config

    Reload

    and also the following

    Step 1 If break is enabled, go to Step 2. If break is disabled, turn
    the router off ( O ), wait 5 seconds, and turn it on ( | ) again.
    Within 60 seconds, press the Break key. The terminal displays the ROM
    monitor prompt. Go to Step 3.



    --------------------------------------------------------------------------------
    Note Some terminal keyboards have a key labeled Break. If your
    keyboard does not have a Break key, see the documentation that came
    with the terminal for instructions on how to send a break.

    --------------------------------------------------------------------------------

    Step 2 Press break. The terminal displays the following prompt:

    rommon 2>


    Step 3 Enter confreg 0x142 to reset the configuration register:

    rommon 2> confreg 0x142


    Step 4 Initialize the router by entering the reset command:

    rommon 2> reset


    The router cycles its power, and the configuration register is set to
    0x142. The router uses the boot ROM system image, indicated by the
    system configuration dialog:

    --- System Configuration Dialog ---


    Step 5 Enter no in response to the prompts until the following
    message is displayed:

    Press RETURN to get started!


    Step 6 Press Return. The following prompt appears:

    Router>


    Step 7 Enter the enable command to enter enable mode. Configuration
    changes can be made only in enable mode:

    Router> enable


    The prompt changes to the privileged EXEC prompt:

    Router#


    Step 8 Enter the show startup-config command to display an enable
    password in the configuration file:

    Router# show startup-config

    and used various settings from different Cisco manual pages in an
    effort to try and figure it out myself. Now I'm just at the point where
    I need help, but would to know why!

    Thanks

    Wobble
     
    Wobble Wobble, Apr 6, 2006
    #6
  7. Wobble Wobble

    Merv Guest

    try the following and capture and post the output when you paste this
    config into your terminal session


    conf t

    ip dhcp excluded-address 192.168.2.1 192.168.2.10

    ip dhcp pool POOL1
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.250
    exit

    interface Ethernet0
    ip address 192.168.2.250 255.255.255.0
    no shut
    exit

    int fa 1
    no shut

    int fa 2
    no shut

    int fa 3
    no shut

    int fa 4
    no shut

    end

    wri mem
     
    Merv, Apr 6, 2006
    #7
  8. I'd use some language that is a bit stronger than this group would
    allow, but by golly I've got a ping reply from my router!

    Thanks, thank you a lot. you'll be the reason I can now have a warm
    head again. Of course not that I can talk to it, I'll break it again,
    but I'll copy out the config ( however I do that) and save ot on CD.

    Again thanks, and if you wanna see how well I do on this expidition
    I'll keep posting!

    Wobble
     
    Wobble Wobble, Apr 7, 2006
    #8
  9. I even found, from previous research the commands to allow me to view
    the setup through the Web interface.

    Thanks again.

    Wobble Wobble
     
    Wobble Wobble, Apr 7, 2006
    #9
  10. Wobble Wobble

    Guest

    > 837 Initial config issues

    You will need:-

    interface ATM0
    no shutdown

    to get the ADSL going.


    Also you have the config register set to:-

    0x142.

    IIRC this causes the router NOT to read the saved configuration.
    The "startup-config". The normal use for your present seting is
    password recovery.

    The default which works for most circumstances is 0x2102.

    CORE1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    CORE1(config)#config-register 0x2102
    CORE1(config)#end

    http://groups.google.com/group/comp...body43 837 adsl&rnum=2&hl=en#ec47b0fd4dd4be3a

    Has a fairly complete 837 config.
     
    , Apr 7, 2006
    #10
  11. Wobble Wobble

    Merv Guest

    Is your connection to the Internet working now ?

    Can you post your current working config ?
     
    Merv, Apr 7, 2006
    #11
  12. !
    interface FastEthernet1 to abort.uplex autoern
    no ip address
    duplex auto
    speed autoely down
    !
    interface FastEthernet247: %LINK-3-UPDOWN: Int
    no ip addressanged state to
    duplex autoonds:terface
    speed autot4dialog? [
    !s
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    ip classless
    no ip http server
    no ip http secure-server
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    !
    scheduler max-task-time 5000
    !
    end

    Router#

    I have used
    write memory

    to write data to NV ram


    Internet not working yet, but at least I can talk to the router and
    play with it. I'll find out the rest of the info as I go. Best way to
    learn.
     
    Wobble Wobble, Apr 7, 2006
    #12
  13. Wobble Wobble

    Merv Guest

    I would suggest:

    1. get the ADSL link up next

    2. then do NAT

    3. then do FW (i.e. CBAC)
     
    Merv, Apr 7, 2006
    #13
  14. I will be back and will let you know how I get on, but thanks for the
    help and the steer.

    Also thanks to other people for their interest.

    Quick question, whats FW? ( Cisco based access control?)

    WW
     
    Wobble Wobble, Apr 7, 2006
    #14
  15. Wobble Wobble

    Merv Guest

    Sorry - FW is the IOS firewall features - CBAC - inspect commands and
    inbound and outbound access lists
     
    Merv, Apr 7, 2006
    #15
  16. well thats a whole new world, and what fun I will have, but for now a
    router routing to the internet is cool

    its friday night and bed calls
    later
     
    Wobble Wobble, Apr 7, 2006
    #16
  17. Merv, quick few questions, you cisco qualified? certified? if did it
    help? and was it difficulf?

    WW
     
    Wobble Wobble, Apr 8, 2006
    #17
  18. Shouldn't the router save its configuration when I use the command

    Write memory

    It seems to need the info if I reboot the router.

    WW
     
    Wobble Wobble, Apr 8, 2006
    #18
  19. Wobble Wobble

    Merv Guest

    Yes, yes and YES
     
    Merv, Apr 8, 2006
    #19
  20. Wobble Wobble

    Merv Guest

    The write memory or copy running-config startup-config saves the
    running-config to NVRAM so that it will be available should the router
    be reloaded or be powere cycled.
     
    Merv, Apr 8, 2006
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Confused

    Cisco 837-837 VPN

    Confused, Jul 9, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,800
    Confused
    Jul 9, 2003
  2. Suppa Lamah
    Replies:
    8
    Views:
    1,667
  3. Jason

    Cisco 837 Router

    Jason, Dec 31, 2003, in forum: Cisco
    Replies:
    0
    Views:
    484
    Jason
    Dec 31, 2003
  4. Richard Antony Burton
    Replies:
    0
    Views:
    6,291
    Richard Antony Burton
    Jan 5, 2004
  5. Replies:
    4
    Views:
    4,223
Loading...

Share This Page