Cisco 837 - Port fowarding question - Remote desktop

Discussion in 'Cisco' started by Marc, Apr 23, 2007.

  1. Marc

    Marc Guest

    Here's my situation: At work I'm using remote desktop (port 3389) to get to
    home PC. My work firewall has most ports blocked on inside to outside. My
    827 has the following commands:
    ip nat inside source static tcp 192.168.1.7 3389 interface Dialer1 3389
    access-list 111 permit tcp any any eq 3389

    My only security is my username and password and the fact I'm using DynDNS
    which helps a little. Obviously I want to change the port to something
    obscure.

    Here's the solution (that won't work in my case.)

    From work; dynDNSname:34600

    From home: ip nat inside source static tcp 192.168.1.7 3389 interface
    Dialer1 34600 (unless I changed my remote desktop port at home to something
    other than 3389)

    Yet this won't work because Dialer1 has to be at 3389 since the firewall at
    work blocks other ports and will only allow me to get out on 3389.

    Aside from using secureCRT or something like that. Any ideas for a Cisco
    solution to this? Thanks.
     
    Marc, Apr 23, 2007
    #1
    1. Advertising

  2. Marc

    Trendkill Guest

    On Apr 23, 3:12 pm, "Marc" <> wrote:
    > Here's my situation: At work I'm using remote desktop (port 3389) to get to
    > home PC. My work firewall has most ports blocked on inside to outside. My
    > 827 has the following commands:
    > ip nat inside source static tcp 192.168.1.7 3389 interface Dialer1 3389
    > access-list 111 permit tcp any any eq 3389
    >
    > My only security is my username and password and the fact I'm using DynDNS
    > which helps a little. Obviously I want to change the port to something
    > obscure.
    >
    > Here's the solution (that won't work in my case.)
    >
    > From work; dynDNSname:34600
    >
    > From home: ip nat inside source static tcp 192.168.1.7 3389 interface
    > Dialer1 34600 (unless I changed my remote desktop port at home to something
    > other than 3389)
    >
    > Yet this won't work because Dialer1 has to be at 3389 since the firewall at
    > work blocks other ports and will only allow me to get out on 3389.
    >
    > Aside from using secureCRT or something like that. Any ideas for a Cisco
    > solution to this? Thanks.


    How about 5190 (AIM), 1863 (MSN), or ports like that? If any of those
    services work from your office, you can use one of those ports, and
    I'd avoid the 'translation' and just move your Remote Desktop to the
    port via the registry change (I think I remember thats how you can
    change RD's port). That way you just connect on the port, and your RD
    accepts it. Otherwise, I'm not a guru on translating one port to a
    different port, and because the destination port is what your work
    firewall is blocking, you can't send it out to one port and receive it
    at home on a different port.
     
    Trendkill, Apr 23, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Suppa Lamah
    Replies:
    8
    Views:
    1,682
  2. Replies:
    4
    Views:
    4,247
  3. Replies:
    3
    Views:
    4,050
  4. xn51
    Replies:
    0
    Views:
    553
  5. chun4kp
    Replies:
    0
    Views:
    562
    chun4kp
    Aug 9, 2010
Loading...

Share This Page