Cisco 837 multiple IP addresses.

Discussion in 'Hardware' started by seanbranagh, Mar 29, 2009.

  1. seanbranagh

    seanbranagh

    Joined:
    Mar 29, 2009
    Messages:
    3
    I recently changed from a Netgear DG834 to a Cisco 837. I done this because I have 2 servers, one running Windows XP Pro and one Linux CentOS 4.7. When running bittorrent on the Windows machine (even with speed limited) friends and family were experiencing difficulty establishing ftp connections to the Linux server. I worked out that the Netgear router was struggling with the number of connections and was advised to replace it with a Cisco 837.
    After a few days I had the Cisco up and running using the CLI but was experiencing a new problem. With the netgear I was able to connect from behind the router to the external addresses of the ftp and web server so I could properly test and experience the problems my friends were having. The Cisco will not allow me to do this. I am unable to access virtual hosts on my webserver from within my network and can only access the default servers on the local machine address.
    I thought using a different IP would solve the problem so I contacted my ISP who kindly gave me a block of 4 IPs. I set up 2 of the ips in the router to put my servers on one and everything else on another. This does work and the servers are working on a different address but I am still unable to access the servers through their external domains from within the network despite being on a different IP. I have included my config below which was basically made up as I went along:


    837#sh run
    Building configuration...

    Current configuration : 2418 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 837
    !
    logging queue-limit 100
    enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXX
    !
    username XXXXXXXXXX privilege 15 password 0 XXXXXXXXXX
    no ip subnet-zero
    ip name-server 212.159.6.9
    ip name-server 212.159.6.10
    ip dhcp excluded-address 192.168.10.1 192.168.10.40
    ip dhcp excluded-address 192.168.10.50 192.168.10.255
    !
    ip dhcp pool DPA
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.31
    dns-server 192.168.10.31
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.10.31 255.255.255.0
    ip nat inside
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    snmp ifindex persist
    hold-queue 224 in
    !
    interface Dialer1
    ip address 212.159.24.241 255.255.255.252
    ip mtu 1420
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    snmp ifindex persist
    ppp authentication chap callin
    ppp chap hostname XXXXXXXXXXX
    ppp chap password 0 XXXXXXXX
    !
    interface Dialer2
    ip address 212.159.24.242 255.255.255.252
    ip mtu 1420
    ip nat outside
    encapsulation ppp
    dialer pool 2
    dialer-group 2
    snmp ifindex persist
    ppp authentication chap callin
    ppp chap hostname XXXXXXXXXXXX
    ppp chap password 0 XXXXXXXX
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source list 2 interface Dialer2 overload
    ip nat inside source static tcp 192.168.10.39 80 interface Dialer2 80
    ip nat inside source static tcp 192.168.10.39 20 interface Dialer2 20
    ip nat inside source static tcp 192.168.10.39 21 interface Dialer2 21
    ip nat inside source static tcp 192.168.10.38 2020 interface Dialer2 2020
    ip nat inside source static tcp 192.168.10.38 75 interface Dialer2 75
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    no ip http secure-server
    ip dns server
    !
    access-list 1 deny 192.168.10.38
    access-list 1 deny 192.168.10.39
    access-list 1 permit 192.168.10.0 0.0.0.255
    access-list 2 permit 192.168.10.38
    access-list 2 permit 192.168.10.39
    access-list 2 deny 192.168.10.0 0.0.0.255
    !
    line con 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    !
    end
    seanbranagh, Mar 29, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Confused

    Cisco 837-837 VPN

    Confused, Jul 9, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,637
    Confused
    Jul 9, 2003
  2. Erik Tamminga
    Replies:
    0
    Views:
    466
    Erik Tamminga
    Jul 25, 2003
  3. Suppa Lamah
    Replies:
    8
    Views:
    1,596
  4. Alistair Young
    Replies:
    2
    Views:
    4,457
  5. lyvicro@hotmail.com
    Replies:
    4
    Views:
    4,119
    lyvicro@hotmail.com
    Dec 15, 2005
Loading...

Share This Page