Cisco 837 Ethernet2 Nat

Discussion in 'Cisco' started by seanbranagh, Jul 27, 2010.

  1. seanbranagh

    seanbranagh

    Joined:
    Mar 29, 2009
    Messages:
    3
    I have a block of 8 IP'S with my ISP. I want to use one or more servers on the public network but also use NAT for desktops etc. I currently use a Cisco 837 but I want to use a Netgear Dg834 I have as the modem as it provides much greater speed on the line. I assumed I could use Ethernet2 to basicly replace Dialer1 on the Cisco and connect that to the Netgear (Netgear in No Nat). I have successfully get the Netgear running in no nat but the Cisco just wont work. Is this even possible with an 837 or would I need something like a 2600?

    The config I am trying is below:

    interface Ethernet0
    ip address 10.19.7.31 255.0.0.0 (this is the internal router address that the cisco had when I was successfully using its internal modem)
    ip nat inside
    ip virtual-reassembly
    hold-queue 100 out
    !
    interface Ethernet2
    ip address 84.X.X.34 255.255.255.248 (This is the second of my usable public addresses, The Netgear has the first)
    ip nat outside
    ip virtual-reassembly
    no snmp ifindex persist
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    shutdown
    snmp ifindex persist
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    duplex auto
    speed auto
    !
    interface FastEthernet2
    duplex auto
    speed auto
    !
    interface FastEthernet3
    duplex auto
    speed auto
    !
    interface FastEthernet4
    duplex auto
    speed auto
    !
    ip route 0.0.0.0 0.0.0.0 Ethernet2
    !
    no ip http server
    no ip http secure-server
    !
    ip nat inside source list 1 interface Ethernet2 overload
    !
    access-list 1 permit 10.0.0.0 0.255.255.255
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    end
     
    seanbranagh, Jul 27, 2010
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Suppa Lamah
    Replies:
    8
    Views:
    1,632
  2. Richard Antony Burton
    Replies:
    0
    Views:
    6,172
    Richard Antony Burton
    Jan 5, 2004
  3. lyvicro@hotmail.com
    Replies:
    4
    Views:
    4,170
    lyvicro@hotmail.com
    Dec 15, 2005
  4. Mikey
    Replies:
    3
    Views:
    980
    Bod43@hotmail.co.uk
    Oct 15, 2006
  5. HangaS
    Replies:
    5
    Views:
    1,825
    seanbranagh
    Jul 27, 2010
Loading...

Share This Page