Cisco 837 ethernet0 half-duplex

Discussion in 'Cisco' started by wxu3000@yahoo.com, Apr 18, 2006.

  1. Guest

    Hi, all,
    When I plug in a Cisco837 router into the swich, it gives me a
    warning message: CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on
    Ethe
    rnet0 (not half duplex).

    When I do a "sh interface ethernet0", it shows: "Full-duplex,
    10Mb/s".

    The IOS is: 12.3(8). Is there anyway to change it to half duplex?

    Thanks.
    , Apr 18, 2006
    #1
    1. Advertising

  2. Merv Guest

    what switch are you plugging the router into and how is the port
    configured ?
    Merv, Apr 18, 2006
    #2
    1. Advertising

  3. Merv Guest

    find out if the switch is capable of 100-full or 10-full and set it
    accordingly

    otherwise on the 837 try

    ethernet 0
    speed 10
    duplex half
    exit
    Merv, Apr 18, 2006
    #3
  4. Guest

    I had the same problem on an 837 and 2950 switch. IIRC, setting the
    duplex to half and speed to 10, still resulted in CDP duplex mismatch
    error, or collisions. I remember reading something about a CDP bug, so
    I just disabled CDP on that port.

    ie (on 837)
    ethernet 0
    no cdp enable
    exit

    or (on switch)
    fastethernet 0/24
    no cdp enable
    exit
    , Apr 18, 2006
    #4
  5. Guest

    under interface ethernet 0, I could not set it to half duplex. have to
    disable cdp. it worked. thank you very much guys.
    , Apr 18, 2006
    #5
  6. Guest

    > Hi, all,
    > When I plug in a Cisco837 router into the swich, it gives me a
    > warning message: CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on
    > Ethe
    > rnet0 (not half duplex).
    >
    > When I do a "sh interface ethernet0", it shows: "Full-duplex,
    > 10Mb/s".
    >
    > The IOS is: 12.3(8). Is there anyway to change it to half duplex?
    >
    > Thanks.


    Rather than disable CDP completely, you can issue the command:

    no cdp log mismatch duplex

    which just prevents the router reporting these errors.
    , Apr 19, 2006
    #6
  7. the_Muttster Guest

    wrote:
    > Hi, all,
    > When I plug in a Cisco837 router into the swich, it gives me a
    > warning message: CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on
    > Ethe
    > rnet0 (not half duplex).
    >
    > When I do a "sh interface ethernet0", it shows: "Full-duplex,
    > 10Mb/s".
    >
    > The IOS is: 12.3(8). Is there anyway to change it to half duplex?
    >
    > Thanks.


    I had the same issue. I fixed the speed on the 2950 end to 10Mbit/HD
    and it went away. A bit of reading on the Cisco site at the time led me
    to believe that the E0 port isn't full-duplex which is the bug. Rather,
    it's a virtual interface of the 4 Fa ports which aren't proper
    switchports unlike the 1800 series. Therefore, for simplicity, I treat
    it as a hub.
    the_Muttster, Apr 19, 2006
    #7
  8. none Guest

    On Tue, 18 Apr 2006 03:54:03 -0700, bhalicki wrote:

    > I had the same problem on an 837 and 2950 switch. IIRC, setting the
    > duplex to half and speed to 10, still resulted in CDP duplex mismatch
    > error, or collisions.


    At half duplex collisions are OK and normal - if you see frame or other
    errors then you have a duplex mismatch.

    none
    none, Apr 22, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. JOE CAMPOS
    Replies:
    0
    Views:
    436
    JOE CAMPOS
    Nov 10, 2003
  2. AM
    Replies:
    0
    Views:
    406
  3. Replies:
    2
    Views:
    575
  4. Some Guy At Work

    Half - Full Duplex

    Some Guy At Work, Jul 18, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    553
    Some Guy At Work
    Jul 18, 2003
  5. DigitalSierra

    ECP Half-duplex or Full-Duplex?

    DigitalSierra, Oct 18, 2004, in forum: A+ Certification
    Replies:
    0
    Views:
    636
    DigitalSierra
    Oct 18, 2004
Loading...

Share This Page