Cisco 837 Config

Discussion in 'Cisco' started by Mark Hodge, Apr 27, 2006.

  1. Mark Hodge

    Mark Hodge Guest

    Does anyone have a Cisco 837 config which i can use to setup Nildram UK?

    They have assigned me with all the settings but i have no clue as to how i
    setup.

    username
    Password mypassword
    Static IP 62.3.X.X
    Mutliple Static IP 82.133.X.X/29

    PPPOA (PPP over ATM)
    VPI 0
    VCI 38
    Framing VC-MUX
    Modulation/Mode G.DMT

    Thanks,
    Hudson
    Mark Hodge, Apr 27, 2006
    #1
    1. Advertising

  2. Mark Hodge

    Merv Guest

    This should at least get you started:

    hostname MYROUTER


    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption


    enable secret <place your secret here> ! DO NOT FORGET

    username xxxx password xxxx ! for telnet access to router


    no aaa new-model
    ip subnet-zero
    ip classless
    no ip domain-lookup


    logging buffered 10000 debug
    no logging console



    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    hold-queue 100 out
    no shut


    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    dsl operating-mode auto
    no shut


    interface Dialer0
    encapsulation ppp
    ip address negotiated ! change this line if IP is static
    ip nat outside
    dialer pool 1
    dialer pool-member 1
    ppp authentication chap callin
    ppp chap hostname xxxx
    ppp chap password xxxx
    ppp ipcp dns request
    no shut


    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    no shut

    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    no shut

    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    no shut

    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    no shut




    ip nat inside source list 101 interface Dialer0 overload

    access-list 101 permit ip 192.168.1.0 0.0.0.255 any

    dialer-list 1 protocol ip permit


    ip route 0.0.0.0 0.0.0.0 Dialer0


    ip dhcp pool CLIENT
    network 192.168.1.0 255.255.255.0
    domain-name mydomain.com
    default-router 192.168.1.1
    dns-server 1.1.1.2
    lease 1 0 0
    exit


    ! to provide telnet access to router

    line vty 0 4
    login local
    Merv, Apr 28, 2006
    #2
    1. Advertising

  3. Mark Hodge

    Robert Guest

    > username
    > Password mypassword
    > Static IP 62.3.X.X
    > Mutliple Static IP 82.133.X.X/29
    >
    > PPPOA (PPP over ATM)
    > VPI 0
    > VCI 38
    > Framing VC-MUX
    > Modulation/Mode G.DMT


    no service pad

    service timestamps debug uptime

    service timestamps log uptime

    service password-encryption

    !

    hostname ROUTER (or another name)

    !

    boot-start-marker

    boot-end-marker

    !

    no logging buffered

    !

    username (someusername) password 7 (somepassword)

    username (some powerfull username) privilege 15 somepassword

    no aaa new-model

    ip subnet-zero

    !

    interface Ethernet0

    ip address external_ip external_subnet

    hold-queue 100 out

    !

    interface ATM0

    no ip address

    atm vc-per-vp 64

    no atm ilmi-keepalive

    dsl equipment-type CPE

    dsl operating-mode GSHDSL symmetric annex B

    dsl linerate AUTO

    pvc 0/38

    encapsulation aal5mux ppp dialer

    dialer pool-member 1

    !

    !

    interface Dialer1

    ip address negotiated

    encapsulation ppp

    dialer pool 1

    dialer-group 1

    ppp authentication chap pap callin

    ppp chap hostname

    ppp chap password 7 YOUR_ISP_PASSWORD

    ppp pap sent-username password 7 YOUR_ISP_PASSWORD

    ppp ipcp dns request

    ppp ipcp wins request

    hold-queue 224 in

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 Dialer1

    ip http server

    !

    dialer-list 1 protocol ip permit

    !

    line con 0

    exec-timeout 120 0

    password 7 SOME_PASSWORD

    transport preferred all

    transport output all

    stopbits 1

    line vty 0 4

    access-class 23 in

    exec-timeout 120 0

    login local

    length 0

    transport preferred all

    transport input all

    transport output all

    !

    scheduler max-task-time 5000

    !





    Any problems write me

    i can give you my config (working)



    Robert
    Robert, Apr 28, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Confused

    Cisco 837-837 VPN

    Confused, Jul 9, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,685
    Confused
    Jul 9, 2003
  2. Suppa Lamah
    Replies:
    8
    Views:
    1,617
  3. Replies:
    4
    Views:
    4,146
  4. r_blears

    Cisco 837 Config Check Please

    r_blears, Apr 3, 2007, in forum: Cisco
    Replies:
    0
    Views:
    1,263
    r_blears
    Apr 3, 2007
  5. robandyuk

    Cisco 837 Roter config help needed

    robandyuk, May 13, 2012, in forum: Cisco
    Replies:
    0
    Views:
    1,054
    robandyuk
    May 13, 2012
Loading...

Share This Page